mplayer-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. #% define with_ffmpeg 1
  5. %global name mplayer
  6. %global version 1.0
  7. #% define extver rc4
  8. %global svndate 20120525
  9. %global release 47%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
  10. #% define dvbappver 0.98
  11. %define codecdir %{_libdir}/codecs
  12. %global ttfontdir /usr/share/fonts
  13. %global ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  14. TrueType-sazanami-gothic/sazanami-gothic
  15. Summary: The Movie Player
  16. Summary(ja): 動画プレイヤー
  17. Name: %{name}
  18. Version: %{version}
  19. Release: %{release}
  20. #Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  21. Source0: mplayer-export-%{svndate}.tar.xz
  22. Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
  23. Source10: mplayer-snapshot-vine.sh
  24. # ## DVB app.
  25. # ## 0.9.8
  26. # Source100: http://2sen.dip.jp/cgi-bin/dtvup/source/up0799.zip
  27. # set defaults for Vine Linux
  28. #Patch2: %{name}-config.patch
  29. Patch2: %{name}-config-20120525-vine.patch
  30. # use roff include statements instead of symlinks
  31. Patch8: %{name}-manlinks.patch
  32. # erase any trace of libdvdcss
  33. Patch14: %{name}-nodvdcss.patch
  34. # use system FFmpeg libraries
  35. Patch18: %{name}-ffmpeg.patch
  36. ## Vine
  37. %if 0%{!?_without_amr:1}
  38. License: GPLv3+
  39. %else
  40. License: GPLv2+
  41. %endif
  42. Group: Applications/Multimedia
  43. URL: http://www.mplayerhq.hu/
  44. BuildRequires: SDL-devel
  45. BuildRequires: aalib-devel
  46. BuildRequires: alsa-lib-devel
  47. BuildRequires: cdparanoia-devel
  48. BuildRequires: desktop-file-utils
  49. ##!!BuildRequires: em8300-devel
  50. BuildRequires: libdvdnav-devel
  51. BuildRequires: enca-devel
  52. BuildRequires: fontconfig-devel
  53. BuildRequires: freetype2-devel >= 2.0.9
  54. BuildRequires: fribidi-devel
  55. BuildRequires: giflib-devel
  56. BuildRequires: gtk2-devel
  57. BuildRequires: mesa-libGL-devel
  58. BuildRequires: libXinerama-devel
  59. BuildRequires: libXScrnSaver-devel
  60. BuildRequires: libXv-devel
  61. BuildRequires: libXvMC-devel
  62. BuildRequires: libXxf86dga-devel
  63. BuildRequires: libXxf86vm-devel
  64. BuildRequires: libass-devel
  65. BuildRequires: libpng-devel
  66. BuildRequires: libjpeg-devel
  67. BuildRequires: libdvdread
  68. BuildRequires: libmpcdec-devel >= 1.2.1
  69. BuildRequires: librtmp-devel >= 2.3
  70. BuildRequires: speex-devel >= 1.1
  71. %{?with_vaapi:BuildRequires:libva-devel}
  72. BuildRequires: libvdpau-devel
  73. BuildRequires: libvorbis-devel
  74. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  75. BuildRequires: lzo-devel >= 2
  76. BuildRequires: pulseaudio-lib-devel
  77. BuildRequires: speex-devel >= 1.1
  78. BuildRequires: twolame-devel
  79. BuildRequires: xorg-x11-devel
  80. BuildRequires: yasm
  81. BuildRequires: zlib-devel
  82. # *-devel packages provided by other self-build-* should only be listed
  83. # in self-build-%{name}.spec as PreReq.
  84. ##Requires: self-build-mplayer-codecs
  85. ##BuildRequires: self-build-libdvdcss
  86. ##BuildRequires: self-build-lame
  87. ##BuildRequires: self-build-libdca
  88. ##BuildRequires: self-build-x264 >= 0.0.0-15.20110322
  89. ##BuildRequires: self-build-xvidcore >= 0.9.2
  90. ##BuildRequires: self-build-faad2 >= 2.6.1
  91. ##BuildRequires: self-build-libmpeg2
  92. Requires: TrueType-vlgothic
  93. Requires: mesa-libGL
  94. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  95. Obsoletes: mplayer < %{version}-%{release}
  96. %description
  97. MPlayer can play most standard video formats out of the box and almost
  98. all others with the help of external codecs.
  99. MPlayer currently works best from the command line, but visual feedback
  100. for many functions is available from its onscreen status display (OSD),
  101. which is also used for displaying subtitles.
  102. MPlayer also has a GUI with skin support and several unofficial alternative
  103. graphical frontends are available.
  104. MEncoder is a command line video encoder for advanced users that can
  105. be built from the MPlayer source tree. Unofficial graphical frontends
  106. exist but arenot included.
  107. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  108. support for some newer codecs are not yet inpmlemented.
  109. You should install mplayer-codecs package if you want to play videos
  110. using those new codecs.
  111. %description -l ja
  112. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  113. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  114. で再生できます。
  115. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  116. 多くの操作は字幕と同様に、
  117. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  118. MPlayer には スキンを変更できる GUI も用意されていますし、
  119. また複数の非公式なフロントエンドも利用できます。
  120. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  121. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  122. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  123. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  124. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  125. をインストールする必要があります。
  126. %prep
  127. #%setup -q -n MPlayer-%{version}%{extver}
  128. %setup -q -n mplayer-export-%{svndate}
  129. %patch2 -p1 -b .vine
  130. %patch8 -p1 -b .manlinks
  131. %patch14 -p1 -b .nodvdcss
  132. %{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
  133. # ## apply the DVB app. patches
  134. # unzip %{SOURCE100}
  135. # patch -p1 < mplayer-patches-%{dvbappver}/0014-check-the-decoded-result-of-PCE.patch || exit 1
  136. %build
  137. ./configure \
  138. --prefix=%{_prefix} \
  139. --bindir=%{_bindir} \
  140. --datadir=%{_datadir}/mplayer \
  141. --mandir=%{_mandir} \
  142. --confdir=%{_sysconfdir}/mplayer \
  143. --libdir=%{_libdir} \
  144. --codecsdir=%{codecdir} \
  145. \
  146. --extra-cflags="$RPM_OPT_FLAGS" \
  147. --language=ja,en \
  148. --enable-joystick \
  149. --enable-gui --enable-menu \
  150. --enable-radio --enable-radio-capture \
  151. --enable-runtime-cpudetection \
  152. --enable-unrarexec \
  153. \
  154. --disable-dvdread-internal \
  155. --disable-libdvdcss-internal \
  156. --disable-nemesi \
  157. \
  158. %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
  159. %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
  160. %{!?with_faac:--disable-faac} \
  161. --disable-libmpeg2-internal \
  162. --disable-libopenjpeg \
  163. \
  164. --disable-bitmap-font \
  165. --disable-dga1 --disable-dga2 \
  166. --disable-directfb \
  167. --disable-svga \
  168. --disable-termcap \
  169. --enable-xvmc \
  170. --with-xvmclib=XvMCW \
  171. \
  172. --disable-arts --disable-esd --disable-jack --disable-openal \
  173. --disable-live \
  174. ;
  175. %{__make} V=1 %{?_smp_mflags}
  176. %install
  177. %{__rm} -rf ${RPM_BUILD_ROOT}
  178. %{__make} install INSTALLSTRIP= \
  179. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  180. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  181. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  182. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  183. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  184. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  185. ;
  186. ## install some default config files
  187. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  188. %{__install} -pm 644 etc/example.conf \
  189. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  190. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  191. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  192. # # Icons
  193. # for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
  194. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
  195. # install -pm 644 etc/mplayer$iconsize.png \
  196. # $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
  197. # done
  198. # install default skin
  199. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  200. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  201. %{__tar} xjf %{SOURCE1}
  202. %{__ln_s} Blue default
  203. popd
  204. # make sybolic link to ttf font for subtitle
  205. for i in %{ttfontlist}; do
  206. if [ -e %{ttfontdir}/$i.ttf ];then
  207. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  208. break;
  209. fi;
  210. done
  211. ## install TOOLS
  212. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  213. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  214. done
  215. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  216. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  217. done
  218. for file in vobshift.py ; do
  219. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  220. done
  221. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  222. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  223. %clean
  224. %{__rm} -rf ${RPM_BUILD_ROOT}
  225. %post
  226. touch --no-create %{_datadir}/icons/hicolor
  227. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  228. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  229. fi
  230. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  231. %postun
  232. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  233. touch --no-create %{_datadir}/icons/hicolor
  234. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  235. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  236. fi || :
  237. %files
  238. %defattr(-,root,root)
  239. #%doc AUTHORS Changelog Copyright LICENSE README
  240. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  241. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  242. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  243. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  244. %{_bindir}/mplayer
  245. %{_bindir}/gmplayer
  246. %{_bindir}/mencoder
  247. %{_datadir}/mplayer/skins/Blue
  248. %{_datadir}/mplayer/skins/default
  249. %{_datadir}/mplayer/subfont.ttf
  250. %{_datadir}/applications/mplayer.desktop
  251. %{_datadir}/icons/hicolor/*/apps/mplayer.png
  252. %{_mandir}/man1/mplayer.1*
  253. %{_mandir}/man1/mencoder.1*
  254. ## TOOLS
  255. %{_bindir}/aconvert
  256. %{_bindir}/calcbpp
  257. %{_bindir}/countquant
  258. %{_bindir}/divx2svcd
  259. %{_bindir}/dvd2divxscript
  260. %{_bindir}/mencvcd
  261. %{_bindir}/midentify
  262. %{_bindir}/mpconsole
  263. %{_bindir}/qepdvcd
  264. %{_bindir}/subsearch
  265. %{_bindir}/vobshift
  266. %{_datadir}/mplayer/*.fp
  267. %changelog
  268. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
  269. - updated snapshot 20120525 with ffmpeg 0.11
  270. * Tue Jan 3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-46.20120102
  271. - updated snapshot 20120102
  272. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111210
  273. - updated snapshot 20111217 (with ffmpeg 0.9)
  274. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  275. - s/self-build-libdvdnav/libdvdnav/
  276. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  277. - updated %%SOURCE1
  278. - update to 1.8
  279. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  280. - dropped BuildRequires: esound-devel
  281. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  282. - new upstream release
  283. - ready for Vine Linux 6
  284. - revived support for Vine Linux 5
  285. - added BuildRequires:
  286. - libass-devel
  287. - librtmp-devel >= 2.3
  288. - speex-devel >= 1.1
  289. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  290. - added BuildRequires:
  291. - aalib-devel
  292. - enca-devel
  293. - lzo-devel
  294. - speex-devel
  295. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  296. - updated fixed %{name}-config.patch
  297. - applied %{name}-config-20100709-vine.patch
  298. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  299. - change release to sync with self-build-mplayer
  300. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  301. - updated source snapshot 20100709
  302. - renamed %%Source10 to mplayer-snapshot-vine.sh
  303. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  304. - added BuildRequires: libvpx-devel >= 0.9.1
  305. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  306. - updated source snapshot 20100621
  307. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  308. - updated source snapshot 20100615
  309. - added BuildRequires: libXinerama-devel
  310. - dropped vl4 support
  311. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  312. - updated source snapshot 20100410
  313. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  314. - updated source snapshot 20100401
  315. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  316. - updated source snapshot 20100326
  317. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  318. - updated source snapshot 20100317
  319. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  320. - updated source snapshot 20100216
  321. - moved scripts from TOOLS
  322. - added --disable-libopenjpeg in configure options
  323. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  324. - updated source snapshot 20100201
  325. - dropped obsolete patches
  326. - added BuildRequires:
  327. - libvdpau-devel
  328. - libXScrnSaver-devel
  329. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  330. - update mplayer-config-20091215-vine.patch
  331. - update mplayer-20091215-x86_32-compile.patch
  332. - added --enable-runtime-cpudetection in configure options
  333. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  334. - source snapshot 20091031
  335. - updated mplayer-20091031-x86_32-compile.patch
  336. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  337. - source snapshot 20091003
  338. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  339. - change release to sync with self-build-mplayer
  340. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  341. - source snapshot 20090905
  342. - added settings for vl6
  343. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  344. - source snapshot 20090821
  345. - replaced BR: libungif-devel with BR: giflib-devel
  346. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  347. - source snapshot 20090722
  348. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  349. - source snapshot 20090702
  350. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  351. - source snapshot 20090611
  352. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  353. - added Requires: TrueType-vlgothic
  354. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  355. - source snapshot 20090522
  356. - build with x264 >= 0.0.0-9.20090522
  357. - updated mplayer-20090522-nodvdcss.patch
  358. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  359. - change release to sync with self-build-mplayer
  360. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  361. - source snapshot 20090502
  362. - updated mplayer-20090503-x86_32-compile.patch
  363. - updated mplayer-20090502-nodvdcss.patch
  364. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  365. - applied mplayer-config-vine.patch
  366. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  367. - source snapshot 20090327
  368. - updated mplayer-20090327-x86_32-compile.patch
  369. - updated mplayer-20090325-nodvdcss.patch
  370. - dropped gmplayer-about-vine.patch
  371. - install some default config files
  372. - added configure options:
  373. - --disable-termcap
  374. - --enable-xvmc
  375. - --with-xvmclib=XvMCW
  376. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  377. - fixed %%files for *.conf
  378. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  379. - source snapshot 20090305
  380. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  381. - source snapshot 20090227
  382. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  383. - source snapshot 20090216
  384. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  385. - source snapshot 20090206
  386. - dropped mplayer-man-zh_CN.patch
  387. - updated mplayer-20090206-nodvdcss.patch
  388. - changed to PreReq: self-build-faad2 from faad2-devel
  389. - added PreReq: self-build-libmad
  390. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  391. - source snapshot 20090131
  392. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  393. - change release to sync with self-build-mplayer
  394. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  395. - source snapshot
  396. - update mplayer-20090122-nodvdcss.patch
  397. - added BuildRequires:
  398. - faad2-devel
  399. - libmpcdec-devel
  400. - twolame-devel
  401. - yasm
  402. - faac-devel (as PreReq in self-build-%{name})
  403. - lame-devel (as PreReq in self-build-%{name})
  404. - libdca-devel (as PreReq in self-build-%{name})
  405. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  406. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  407. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  408. - source snapshot
  409. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  410. --disable-faad-internal in configure options
  411. - dropped gmplayer-add-flv-extension.patch
  412. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  413. - source snapshot
  414. - fixed License
  415. - added some patches from RPM Fusion
  416. - updated gmplayer-about-vine.patch for 20081001 snapshot
  417. - added BuildRequires: libdvdread
  418. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  419. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  420. in configure options
  421. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  422. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  423. - fixed License
  424. - added some devel packages to support OpenGL
  425. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  426. - spec in utf8
  427. - fix sybolic link of subfont for vl5
  428. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  429. - add "Patch105: CVE-2008-1558.patch".
  430. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  431. - build with new versioning policy.
  432. - fix Source[01] URLs.
  433. - add "Patch200: gmplayer-about-vine.patch".
  434. - add "Patch201: gmplayer-add-flv-extension.patch".
  435. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  436. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  437. CVE-2008-0629, CVE-2008-0630)
  438. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  439. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  440. - change source download URL. <BTS:VineLinux:603>
  441. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  442. - fix CONFDIR for make install. <BTS:wishes:33>
  443. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  444. - initial build for Vine Linux