rocs-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. Name: rocs
  2. Summary: Graph theory IDE
  3. Summary(ja): グラフ理論向け IDE
  4. Version: 4.14.3
  5. Release: 2%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/Edutainment
  8. URL: http://edu.kde.org/rocs/
  9. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
  10. ## upstream patches
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: desktop-file-utils
  13. BuildRequires: kdelibs-devel >= %{version}
  14. BuildRequires: libboost-devel
  15. BuildRequires: libboost-graph
  16. BuildRequires: soprano-devel
  17. BuildRequires: grantlee-devel
  18. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  19. Requires: kwrite
  20. Conflicts: kdeedu4 < 4.6.50
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Rocs aims to be a Graph Theory IDE for helping professors to show
  25. the results of a graph algorithm and also helping students to do
  26. the algorithms.
  27. Rocs has a scripting module, done in Qt Script, that interacts with
  28. the drawn graph and every change in the graph with the script is
  29. reflected on the drawn one.
  30. This package is part of the KDE education module.
  31. %package libs
  32. Summary: Runtime libraries for %{name}
  33. Summary(ja): %{name} のランタイムライブラリ
  34. Group: System Environment/Libraries
  35. Conflicts: kdeedu4-math-libs < 4.6.50
  36. %description libs
  37. %{summary}.
  38. %package devel
  39. Summary: Development files for %{name}
  40. Summary(ja): %{name} の開発用ファイル
  41. Group: Development/Libraries
  42. Requires: %{name}-libs = %{version}-%{release}
  43. Conflicts: kdeedu4-devel < 4.6.50
  44. %description devel
  45. Header files for developing applications using %{name}.
  46. %prep
  47. %setup -q
  48. %build
  49. # uniform_int_distribution error
  50. sed -i "s|add_subdirectory(GenerateGraph)|#add_subdirectory(GenerateGraph)|" VisualEditor/Tools/CMakeLists.txt
  51. mkdir -p %{_target_platform}
  52. pushd %{_target_platform}
  53. %cmake \
  54. -DCMAKE_BUILD_TYPE=release \
  55. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  56. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  57. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  58. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  59. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  60. ..
  61. popd
  62. make %{?_smp_mflags} -C %{_target_platform}
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %check
  69. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  70. desktop-file-validate $f
  71. done
  72. %posttrans
  73. update-desktop-database -q &> /dev/null ||:
  74. %postun
  75. if [ $1 -eq 0 ] ; then
  76. update-desktop-database -q &> /dev/null ||:
  77. fi
  78. %post libs -p /sbin/ldconfig
  79. %postun libs -p /sbin/ldconfig
  80. %files
  81. %defattr(-,root,root)
  82. %doc COPYING COPYING.DOC
  83. %{_bindir}/rocs
  84. %{_libdir}/kde4/rocs_*.so
  85. %{_datadir}/appdata/rocs.appdata.xml
  86. %{_datadir}/applications/kde4/rocs.desktop
  87. %{_datadir}/config/rocs.knsrc
  88. %{_datadir}/config.kcfg/rocs.kcfg
  89. %{_datadir}/icons/hicolor/*/*/*
  90. %{_datadir}/kde4/apps/rocs
  91. %{_datadir}/kde4/apps/rocs_rootedtree
  92. %{_datadir}/kde4/services/rocs_*.desktop
  93. %{_datadir}/kde4/servicetypes/Rocs*.desktop
  94. %doc %{_docdir}/HTML/en/rocs/
  95. %files libs
  96. %defattr(-,root,root)
  97. %{_libdir}/librocscore.so.*
  98. %{_libdir}/librocsvisualeditor.so.*
  99. %files devel
  100. %defattr(-,root,root)
  101. %{_includedir}/kde4/rocs
  102. %{_libdir}/librocscore.so
  103. %{_libdir}/librocsvisualeditor.so
  104. %changelog
  105. * Fri Jul 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
  106. - rebuild with gcc-5.4.0
  107. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
  108. - new upstream release
  109. * Wed May 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
  110. - new upstream release
  111. * Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
  112. - new upstream release
  113. * Wed Dec 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
  114. - new upstream release
  115. * Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
  116. - new upstream release
  117. - add BuildRequires: grantlee-devel
  118. * Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
  119. - new upstream release
  120. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
  121. - new upstream release
  122. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
  123. - new upstream release
  124. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
  125. - new upstream release
  126. * Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
  127. - new upstream release
  128. * Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
  129. - new upstream release
  130. - add BuildRequires: libboost-graph
  131. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
  132. - split from kdeedu