cmake-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. # Set to bcond_without or use --with bootstrap if bootstrapping a new release
  2. # or architecture
  3. %bcond_with bootstrap
  4. # Set to bcond_with or use --without gui to disable qt4 gui build
  5. %bcond_with gui
  6. Name: cmake
  7. Summary: Cross-platform make system
  8. Summary(ja): クロスプラットフォームな Make システム
  9. Version: 3.19.6
  10. Release: 1%{?_dist_release}
  11. Group: programming
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: BSD
  15. URL: https://www.cmake.org/
  16. Source0: https://github.com/Kitware/CMake/releases/download/v%{version}/cmake-%{version}.tar.gz
  17. Source1: macros.cmake
  18. Source3: %{name}.attr
  19. Source4: %{name}.prov
  20. Source5: %{name}.req
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: curl-devel
  23. BuildRequires: expat-devel
  24. BuildRequires: gcc-gfortran
  25. BuildRequires: libarchive-devel
  26. #BuildRequires: libidn-devel
  27. BuildRequires: ncurses-devel
  28. BuildRequires: openssl-devel
  29. BuildRequires: zlib-devel
  30. BuildRequires: xz-devel
  31. BuildRequires: jsoncpp-devel
  32. %if %{with gui}
  33. BuildRequires: qt4-devel, desktop-file-utils
  34. %define qt_gui --qt-gui
  35. %else
  36. %define qt_gui --no-qt-gui
  37. %endif
  38. Provides: %{name}-filesystem%{?_isa} = %{version}-%{release}
  39. %global major_version %(echo %{version} | cut -d . -f 1)
  40. %global minor_version %(echo %{version} | cut -d . -f 2)
  41. %description
  42. CMake is used to control the software compilation process using simple
  43. platform and compiler independent configuration files. CMake generates
  44. native makefiles and workspaces that can be used in the compiler
  45. environment of your choice. CMake is quite sophisticated: it is possible
  46. to support complex environments requiring system configuration, pre-processor
  47. generation, code generation, and template instantiation.
  48. %package gui
  49. Summary: Qt GUI for %{name}
  50. Group: programming
  51. Requires: %{name} = %{version}-%{release}
  52. Requires(post): desktop-file-utils, shared-mime-info
  53. Requires(postun): desktop-file-utils, shared-mime-info
  54. %description gui
  55. The %{name}-gui package contains the Qt based GUI for CMake.
  56. %debug_package
  57. %prep
  58. %setup -q
  59. %build
  60. ./bootstrap \
  61. --prefix=%{_prefix} \
  62. --datadir=/share/%{name} \
  63. --docdir=/share/doc/%{name} \
  64. --mandir=/share/man \
  65. %if 0%{?with_bootstrap}
  66. --no-system-libs \
  67. %else
  68. --system-curl \
  69. --system-expat \
  70. --system-jsoncpp \
  71. --system-zlib \
  72. --system-bzip2 \
  73. --system-liblzma \
  74. --system-libarchive \
  75. --no-system-librhash \
  76. %endif
  77. --parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
  78. %{?qt_gui} \
  79. -- -DCMAKE_USE_SYSTEM_LIBUV=OFF
  80. # sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
  81. make VERBOSE=1 %{?_smp_mflags}
  82. %install
  83. rm -rf %{buildroot}
  84. make install DESTDIR=%{buildroot}
  85. find %{buildroot}/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  86. rm -rf %{buildroot}/usr/doc
  87. # RPM macros
  88. install -p -m0644 -D %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.cmake
  89. sed -i -e "s|@@CMAKE_MAJOR_VERSION@@|%{major_version}|" %{buildroot}%{_rpmmacrodir}/macros.cmake
  90. touch -r %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.cmake
  91. # RPM auto provides
  92. install -p -m0644 -D %{SOURCE3} %{buildroot}%{_prefix}/lib/rpm/fileattrs/%{name}.attr
  93. install -p -m0755 -D %{SOURCE4} %{buildroot}%{_prefix}/lib/rpm/%{name}.prov
  94. install -p -m0755 -D %{SOURCE5} %{buildroot}%{_prefix}/lib/rpm/%{name}.req
  95. %if %{with gui}
  96. # Desktop file
  97. desktop-file-install --delete-original \
  98. --dir=%{buildroot}%{_datadir}/applications \
  99. %{buildroot}/%{_datadir}/applications/CMake.desktop
  100. %endif
  101. rm -rf doc
  102. mv -f %{buildroot}%{_docdir}/%{name} ./doc
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %if %{with gui}
  106. %post gui
  107. update-desktop-database &> /dev/null || :
  108. update-mime-database %{_datadir}/mime &> /dev/null || :
  109. %postun gui
  110. update-desktop-database &> /dev/null || :
  111. update-mime-database %{_datadir}/mime &> /dev/null || :
  112. %endif
  113. %files
  114. %defattr(-,root,root)
  115. %doc CMakeLogo.gif README.* doc
  116. %doc Help
  117. %license Copyright.txt Licenses/*
  118. %config(noreplace) %{_rpmmacrodir}/macros.cmake
  119. %{_rpmconfigdir}/fileattrs/%{name}.attr
  120. %{_rpmconfigdir}/%{name}.prov
  121. %{_rpmconfigdir}/%{name}.req
  122. %{_bindir}/ccmake
  123. %{_bindir}/cmake
  124. %{_bindir}/cpack
  125. %{_bindir}/ctest
  126. %{_datadir}/%{name}/
  127. %{_datadir}/aclocal/cmake.m4
  128. %dir %{_datadir}/bash-completion
  129. %dir %{_datadir}/bash-completion/completions
  130. %{_datadir}/bash-completion/completions/*
  131. %exclude /usr/share/vim
  132. %exclude /usr/share/emacs
  133. %if %{with gui}
  134. %files gui
  135. %defattr(-,root,root,-)
  136. %{_bindir}/cmake-gui
  137. %{_datadir}/applications/CMake.desktop
  138. %{_datadir}/mime/packages/cmakecache.xml
  139. %{_datadir}/icons/hicolor/*/*/*
  140. %endif
  141. %changelog
  142. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.19.6-1
  143. - updated to 3.19.6.
  144. - updated macros.cmake.
  145. * Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.18.0-1
  146. - updated to 3.18.0.
  147. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.15.3-1
  148. - updated to 3.15.3.
  149. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10.1-1
  150. - updated to 3.10.1.
  151. - updated macros.cmake.
  152. - disabled gui.
  153. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-2
  154. - rebuild with gcc-5.4.0
  155. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  156. - update to 3.5.2
  157. - add BuildRequires: xz-devel, jsoncpp-devel
  158. - remove old patches
  159. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  160. - update to 2.8.12.2
  161. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  162. - update to 2.8.12.2
  163. - add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
  164. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
  165. - rebuild with libarchive-3.1.2
  166. * Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
  167. - new upstream release
  168. - add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
  169. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
  170. - new upstream release
  171. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
  172. - new upstream release
  173. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
  174. - new upstream release
  175. - fixed desktop file warning
  176. * Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  177. - rebuild with libarchive-3.0.4
  178. * Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
  179. - new upstream release
  180. - forced to link with libtinfo.so (ccmake)
  181. - used --system-libs again
  182. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  183. - new upstream release
  184. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  185. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  186. - fixed typo (not --with-system-libs, but --system-libs)
  187. - added BR: curl-devel, expat-devel, zlib-devel
  188. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  189. - add BuildRequires: ncurses-devel
  190. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  191. - generate gui package
  192. - renamed module directory
  193. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  194. - new upstream release
  195. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  196. - rebuilt with new toolchain
  197. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  198. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  199. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  200. - new upstream release
  201. - added Vendor/Distribution tag
  202. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  203. - new upstream release
  204. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  205. - new upstream release
  206. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  207. - new upstream release
  208. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  209. - new upstream release
  210. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  211. - new upstream release
  212. - drop Patch100
  213. - use bootstrap script instead of configure
  214. - delete caches from %%doc
  215. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  216. - rebuilt with new toolchain
  217. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  218. - new upstream release
  219. - delete duped docs
  220. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  221. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  222. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  223. - source version up
  224. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  225. - initial build for Vine Linux