double-conversion-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. %undefine __cmake_in_source_build
  2. %bcond_without static_libs # don't build static libraries
  3. Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
  4. Name: double-conversion
  5. Version: 3.1.5
  6. Release: 5%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. Source0: https://github.com/google/double-conversion/archive/v%{version}/%{name}-%{version}.tar.gz
  12. URL: https://github.com/google/double-conversion
  13. BuildRequires: gcc
  14. BuildRequires: gcc-c++
  15. BuildRequires: cmake
  16. %description
  17. Provides binary-decimal and decimal-binary routines for IEEE doubles.
  18. The library consists of efficient conversion routines that have been
  19. extracted from the V8 JavaScript engine. The code has been re-factored
  20. and improved so that it can be used more easily in other projects.
  21. %package devel
  22. Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
  23. Group: programming
  24. Requires: %{name}%{?_isa} = %{version}-%{release}
  25. %description devel
  26. Contains header files for developing applications that use the %{name}
  27. library.
  28. There is extensive documentation in src/double-conversion.h. Other
  29. examples can be found in test/cctest/test-conversions.cc.
  30. %package static
  31. Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
  32. Group: programming
  33. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  34. %description static
  35. Static %{name} library.
  36. %debug_package
  37. %prep
  38. %setup -q
  39. %build
  40. %global _vpath_builddir build-shared
  41. %cmake -DBUILD_TESTING=ON
  42. %cmake_build
  43. %if %{with static_libs}
  44. %global _vpath_builddir build-static
  45. CXXFLAGS="%{optflags} -fPIC" %cmake -DBUILD_SHARED_LIBS=NO
  46. %cmake_build
  47. %endif
  48. %install
  49. %if %{with static_libs}
  50. %global _vpath_builddir build-static
  51. %cmake_install
  52. %endif
  53. %global _vpath_builddir build-shared
  54. %cmake_install
  55. %if 0
  56. %check
  57. %ctest
  58. %endif
  59. %ldconfig_scriptlets
  60. %files
  61. %doc LICENSE README.md AUTHORS Changelog
  62. %{_libdir}/libdouble-conversion.so.3*
  63. %files devel
  64. %{_libdir}/libdouble-conversion.so
  65. %{_libdir}/cmake/%{name}
  66. %{_includedir}/%{name}
  67. %if %{with static_libs}
  68. %files static
  69. %{_libdir}/libdouble-conversion.a
  70. %endif
  71. %changelog
  72. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.5-5
  73. - initial build for Vine Linux.
  74. * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.5-4
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  76. * Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.5-3
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  78. * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.5-2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  80. * Sun Sep 22 2019 Orion Poplawski <orion@nwra.com> - 3.1.5-1
  81. - Update to 3.1.5
  82. * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-5
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  84. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-4
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  86. * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-3
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  88. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-2
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  90. * Mon Sep 4 2017 Milan Bouchet-Valat <nalimilan@club.fr> - 3.0.0-1
  91. - New upstream release.
  92. * Sun Aug 06 2017 Björn Esser <besser82@fedoraproject.org> - 2.0.1-11
  93. - Rebuilt for AutoReq cmake-filesystem
  94. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-10
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  96. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-9
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  98. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-8
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  100. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-7
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  102. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-6
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  104. * Fri Mar 13 2015 Orion Poplawski <orion@cora.nwra.com> - 2.0.1-5
  105. - Use github source
  106. * Wed Mar 11 2015 Orion Poplawski <orion@cora.nwra.com> - 2.0.1-4
  107. - Build with cmake
  108. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-3
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  110. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  112. * Sat Feb 8 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 2.0.1-1
  113. - New upstream version.
  114. - Drop no longer needed custom SConstruct file and use new upstream SONAME.
  115. * Tue Dec 17 2013 Milan Bouchet-Valat <nalimilan@club.fr> - 2.0.0-4
  116. - Drop libstdc++-devel from BuildRequires.
  117. - Move %%check after %%install.
  118. * Sat Dec 14 2013 Milan Bouchet-Valat <nalimilan@club.fr> - 2.0.0-3
  119. - Remove gcc-c++ from BuildRequires as it is an exception.
  120. - Fix command in %%check and pass CXXFLAGS to scons.
  121. - Use %%global instead of %%define.
  122. * Thu Dec 12 2013 Milan Bouchet-Valat <nalimilan@club.fr> - 2.0.0-2
  123. - Fix building when "--without static_libs" is passed.
  124. - Remove %%ghost with libdouble-conversion.so.2.
  125. - Drop BuildRoot.
  126. - Use rm instead of %%{__rm} for consistency
  127. - Use %%{?dist} in Release.
  128. * Wed Dec 11 2013 Milan Bouchet-Valat <nalimilan@club.fr> - 2.0.0-1
  129. - Initial Fedora package based on a PLD Linux RPM by Elan Ruusamäe <glen@delfi.ee>:
  130. http://git.pld-linux.org/gitweb.cgi?p=packages/double-conversion.git