inkscape-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338
  1. %global page_id 23820
  2. %global src_suffix 2021-01-15_e86c870879
  3. Name: inkscape
  4. Summary: A Vector Drawing Application
  5. Summary(ja): ベクター描画アプリケーション
  6. Version: 1.0.2
  7. Release: 1%{?_dist_release}
  8. Group: graphics
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv2+
  12. URL: https://inkscape.org/
  13. Source0: https://inkscape.org/ja/gallery/item/%{page_id}/inkscape-%{version}.tar.xz
  14. # # to fix compile error with poppler>=0.58
  15. # Patch1000: poppler-0.58.x.patch
  16. # Patch1001: poppler-0.58.x-autotools.patch
  17. # # to fix compile error with poppler>=0.76.0
  18. # https://gitlab.com/inkscape/inkscape/issues/220
  19. #Patch1002: poppler-0.76.x.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: cairo-devel
  22. BuildRequires: cmake
  23. BuildRequires: dos2unix
  24. BuildRequires: dbus-glib-devel
  25. BuildRequires: double-conversion-devel
  26. BuildRequires: gc-devel >= 6.4
  27. BuildRequires: gdl-devel
  28. BuildRequires: gsl-devel
  29. BuildRequires: gtkmm3-devel
  30. BuildRequires: ImageMagick-c++-devel
  31. BuildRequires: lcms2-devel
  32. BuildRequires: libboost-devel
  33. BuildRequires: libexif-devel
  34. BuildRequires: libjpeg-turbo-devel
  35. BuildRequires: libpng-devel >= 1.2.0
  36. BuildRequires: libsigc++-devel >= 2.0.12
  37. BuildRequires: libsoup-devel
  38. BuildRequires: libxml2-devel >= 2.6.11
  39. BuildRequires: libxslt-devel >= 1.0.15
  40. BuildRequires: libwpg-devel
  41. BuildRequires: pango-devel
  42. BuildRequires: perl-XML-Parser
  43. BuildRequires: poppler-devel >= 0.14.2
  44. BuildRequires: popt-devel
  45. BuildRequires: potrace-devel
  46. BuildRequires: python3-devel
  47. BuildRequires: python3-setuptools
  48. Requires: python3
  49. Requires: python3-lxml
  50. Requires: python3-numpy
  51. #Requires: python3-scour
  52. %description
  53. Inkscape is a SVG based generic vector-drawing program for
  54. Linux/Unix/Windows/Mac.
  55. %description -l ja
  56. Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
  57. Linux/Unix/Windows/Mac で動作します。
  58. %debug_package
  59. %prep
  60. %setup -q -n %{name}-%{version}_%{src_suffix}
  61. # %patch1000 -p1
  62. # %patch1001 -p1
  63. #patch1002 -p1 -b .poppler0.76.x
  64. # https://bugs.launchpad.net/inkscape/+bug/314381
  65. # A couple of files have executable bits set,
  66. # despite not being executable
  67. find . -name '*.cpp' | xargs chmod -x
  68. find . -name '*.h' | xargs chmod -x
  69. find share/extensions -name '*.py' | xargs chmod -x
  70. # Fix end of line encodings
  71. dos2unix -k -q share/extensions/*.py
  72. %build
  73. cmake \
  74. -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
  75. -DCMAKE_CXX_FLAGS_RELEASE:STRING="-DNDEBUG" \
  76. -DCMAKE_Fortran_FLAGS_RELEASE:STRING="-DNDEBUG" \
  77. -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
  78. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  79. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
  80. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  81. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  82. -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
  83. %if "%{_lib}" == "lib64"
  84. -DLIB_SUFFIX=64 \
  85. %endif
  86. -DBUILD_SHARED_LIBS:BOOL=OFF .
  87. make %{?_smp_mflags}
  88. %install
  89. rm -rf %{buildroot}
  90. make install DESTDIR=%{buildroot}
  91. find %{buildroot} -type f -name 'lib*.a' -delete
  92. rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  93. %find_lang %{name} --with-man
  94. %find_lang inkview --with-man
  95. rm -rf $RPM_BUILD_ROOT%{_datadir}/inkscape/doc
  96. rm -f $RPM_BUILD_ROOT%{_datadir}/doc/inkscape/copyright
  97. %clean
  98. rm -rf %{buildroot}
  99. %post
  100. /sbin/ldconfig
  101. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  102. %postun
  103. if [ $1 -eq 0 ] ; then
  104. update-desktop-database -q &> /dev/null
  105. touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
  106. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  107. fi
  108. %posttrans
  109. update-desktop-database -q &> /dev/null
  110. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  111. %files -f %{name}.lang -f inkview.lang
  112. %defattr(-, root, root)
  113. %license COPYING
  114. %doc AUTHORS NEWS* README*
  115. %{_bindir}/inkscape
  116. %{_bindir}/inkview
  117. %{_datadir}/inkscape
  118. %{_datadir}/metainfo/org.inkscape.Inkscape.appdata.xml
  119. %{_datadir}/applications/org.inkscape.Inkscape.desktop
  120. %{_datadir}/icons/hicolor/*/*/*.png
  121. %{_mandir}/man1/*
  122. %dir %{_datadir}/bash-completion
  123. %dir %{_datadir}/bash-completion/completions
  124. %{_datadir}/bash-completion/completions/inkscape
  125. %changelog
  126. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.2-1
  127. - new upstream release.
  128. * Sun Oct 27 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-3
  129. - rebuild with OpenEXR-libs-2.4.0 (required by ImageMagick)
  130. * Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-2
  131. - rebuild with poppler-0.81.0 and gsl-2.6
  132. - add Patch1002 for poppler >= 0.76.0
  133. * Mon May 20 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-1
  134. - update to 0.92.4
  135. - drop unrecognized options: --with-python, --enable-lcms2
  136. * Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
  137. - updated to 0.92.3
  138. - drop Patch1000,1001
  139. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
  140. - updated to 0.92.2
  141. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
  142. - rebuild with gcc-5.4.0
  143. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
  144. - rebuild with poppler-0.43.0
  145. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
  146. - update to 0.91
  147. - remove old patches
  148. - add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
  149. * Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
  150. - rebuild with ImageMagick-6.9.1.1
  151. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
  152. - rebuilt with libwpd 0.3.0
  153. - added Patch14 to build with libwpd 0.3.0
  154. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
  155. - rebuild with poppler-0.26.2
  156. * Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
  157. - new upstream release
  158. - add BuildRequires: libwpg-devel
  159. - remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  160. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
  161. - rebuild with poppler-0.24.5
  162. - add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  163. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
  164. - rebuild with ImageMagick-6.8.7.5
  165. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
  166. - rebuild with poppler-0.24.2
  167. * Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
  168. - rebuild with ImageMagick-6.8.6.8
  169. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
  170. - new upstream release
  171. - remove Patch0 (inkscape-0.48.2-poppler_020.patch)
  172. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
  173. - rebuild with poppler-0.20.4
  174. - add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
  175. - change BuildRequires: lcms2-devel instead of lcms-devel
  176. * Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
  177. - new upstream release
  178. * Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
  179. - rebuild with ImageMagick-6.7.5.10
  180. * Sat Feb 4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
  181. - new upstream release
  182. * Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
  183. - add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
  184. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
  185. - new upstream release
  186. - built with poppler-0.16.3
  187. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
  188. - rebuild with poppler-0.14.2
  189. - add BuildRequires: popt-devel, ImageMagick-c++-devel
  190. * Sun Oct 3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
  191. - new upstream release
  192. - rebuilt with ImageMagick-6.6.4.8
  193. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
  194. - added Patch0 for building with poppler-0.12.2+
  195. - rebuilt with new toolchain and ImageMagick-6.6.1.5
  196. - removed BR: libgnomeprint-devel, libgnomeprintui-devel
  197. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
  198. - rebuild with poppler-0.12.1
  199. * Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
  200. - new upstream release
  201. - add BR: libboost-devel
  202. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
  203. - update to 0.47pre2
  204. - drop obsolete patches
  205. - add BR: gsl-devel
  206. * Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
  207. - rebuild with poppler-0.10.2
  208. * Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
  209. - add Patch[1-6]
  210. * Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
  211. - added inkscape-0.46-poppler-0.8.3.patch
  212. - spec in utf-8
  213. - added option %%{?_smp_mflags} at make
  214. * Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
  215. - new upstream release
  216. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
  217. - rebuild with new environment/toolchain
  218. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
  219. - new upstream release
  220. * Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
  221. - add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
  222. - update required version of gtk2-devel
  223. * Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
  224. - new upstream release
  225. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
  226. - new upstream release
  227. * Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
  228. - new upstream release
  229. * Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
  230. - new upstream release
  231. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
  232. - new upstream release
  233. * Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
  234. - new upstream release
  235. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
  236. - new upstream release
  237. - add Japanese summary and description
  238. - fixed dependancy of libsigc++12 to libsigc++ >= 2.0
  239. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
  240. - fixed dependancy of libsigc++ to libsigc++12
  241. - fixed %files section
  242. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
  243. - rebuild for Vine Linux
  244. - s/Copyright/License/
  245. - added Requires and BuildRequires
  246. * Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
  247. - Removing _libdir and TODO, updating description
  248. * Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
  249. - Fix up the spec file for current release
  250. * Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
  251. - Update to 0.2.6
  252. * Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
  253. - Update to 0.2.5
  254. - Changed SPEC to benefit from macros