golang-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560
  1. # temporalily ignore test failures
  2. %ifarch %{ix86} x86_64
  3. %bcond_without ignore_tests
  4. %else
  5. %bcond_with ignore_tests
  6. %endif
  7. # Define arches for PA and SA
  8. %global golang_arches %{ix86} x86_64
  9. %global go_arches %{golang_arches}
  10. # Where to set GOPATH for builds
  11. %global gopath %{_datadir}/gocode
  12. # build ids are not currently generated:
  13. # https://code.google.com/p/go/issues/detail?id=5238
  14. #
  15. # also, debuginfo extraction currently fails with
  16. # "Failed to write file: invalid section alignment"
  17. %global debug_package %{nil}
  18. # we are shipping the full contents of src in the data subpackage, which
  19. # contains binary-like things (ELF data for tests, etc)
  20. %global _binaries_in_noarch_packages_terminate_build 0
  21. # Do not check any files in doc or src for requires
  22. #global __requires_exclude_from ^(%{_datadir}|/usr/lib)/%{name}/(doc|src)/.*$
  23. # Don't alter timestamps of especially the .a files (or else go will rebuild later)
  24. # Actually, don't strip at all since we are not even building debug packages and this corrupts the dwarf testdata
  25. %global __strip /bin/true
  26. # rpmbuild magic to keep from having meta dependency on libc.so.6
  27. %global __requires_exclude_from ^.*$
  28. %global __spec_install_post /usr/lib/rpm/check-rpaths \
  29. /usr/lib/rpm/check-buildroot \
  30. /usr/lib/rpm/brp-compress
  31. # Golang build options.
  32. # Buid golang using external/internal(close to cgo disabled) linking.
  33. %global external_linker 1
  34. # Build golang with cgo enabled/disabled(later equals more or less to internal linking).
  35. %global cgo_enabled 1
  36. # Use golang/gcc-go as bootstrap compiler
  37. %global golang_bootstrap 1
  38. # boostrap(with internal linking) using gcc-go fails due to bug in tests(https://github.com/golang/go/issues/12629)
  39. # make check not to fail due to it
  40. # Controls what ever we fail on failed tests
  41. %if %{with ignore_tests}
  42. %global fail_on_tests 0
  43. %else
  44. %global fail_on_tests 1
  45. %endif
  46. # TODO get more support for shared objects
  47. # Build golang shared objects for stdlib
  48. %ifarch x86_64
  49. %global shared 1
  50. %else
  51. %global shared 0
  52. %endif
  53. # Fedora GOROOT
  54. %global goroot /usr/lib/%{name}
  55. %ifarch x86_64
  56. %global gohostarch amd64
  57. %endif
  58. %ifarch %{ix86}
  59. %global gohostarch 386
  60. %endif
  61. %global go_version 1.15.7
  62. %global go_api %(echo "%{version}" | cut -d . -f 1,2)
  63. Summary: The Go Programming Language
  64. Summary(ja): プログラミング言語 Go
  65. Name: golang
  66. Version: %{go_version}
  67. Release: 1%{?_dist_release}
  68. Group: programming
  69. Vendor: Project Vine
  70. Distribution: Vine Linux
  71. # source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
  72. License: BSD and Public Domain
  73. URL: https://golang.org/
  74. # pre-processed by source.sh to make Mark.Twain-Tom.Sawyer.txt free again
  75. Source0: https://dl.google.com/go/go%{go_version}.src.tar.gz
  76. Source100: golang-gdbinit
  77. Source101: golang-prelink.conf
  78. Source102: macros.golang
  79. # These are the only RHEL/Fedora architectures that we compile this package for
  80. ExclusiveArch: %{golang_arches}
  81. # The compiler is written in Go. Needs go(1.4+) compiler for build.
  82. BuildRequires: golang > 1.4
  83. BuildRequires: net-tools
  84. # for tests
  85. BuildRequires: pcre-devel, glibc-static
  86. Provides: go = %{version}-%{release}
  87. Requires: %{name}-bin
  88. Requires: %{name}-src = %{version}-%{release}
  89. %description
  90. %{summary}.
  91. %package docs
  92. Summary: Golang compiler docs
  93. Group: documentation
  94. Requires: %{name} = %{version}-%{release}
  95. #BuildArch: noarch
  96. Obsoletes: %{name}-docs < 1.1-4
  97. %description docs
  98. %{summary}.
  99. %package misc
  100. Summary: Golang compiler miscellaneous sources
  101. Group: programming
  102. Requires: %{name} = %{version}-%{release}
  103. #BuildArch: noarch
  104. %description misc
  105. %{summary}.
  106. %package tests
  107. Summary: Golang compiler tests for stdlib
  108. Group: programming
  109. Requires: %{name} = %{version}-%{release}
  110. #BuildArch: noarch
  111. %description tests
  112. %{summary}.
  113. %package src
  114. Summary: Golang compiler source tree
  115. Group: programming
  116. #BuildArch: noarch
  117. %description src
  118. %{summary}
  119. %package bin
  120. Summary: Golang core compiler tools
  121. Group: programming
  122. Requires: go = %{version}-%{release}
  123. Requires(post): %{_sbindir}/update-alternatives
  124. Requires(postun): %{_sbindir}/update-alternatives
  125. # We strip the meta dependency, but go does require glibc.
  126. # This is an odd issue, still looking for a better fix.
  127. Requires: glibc
  128. Requires: gcc
  129. %description bin
  130. %{summary}
  131. # Workaround old RPM bug of symlink-replaced-with-dir failure
  132. %pretrans -p <lua>
  133. for _,d in pairs({"api", "doc", "include", "lib", "src"}) do
  134. path = "%{goroot}/" .. d
  135. if posix.stat(path, "type") == "link" then
  136. os.remove(path)
  137. posix.mkdir(path)
  138. end
  139. end
  140. %if %{shared}
  141. %package shared
  142. Summary: Golang shared object libraries
  143. Group: system
  144. %description shared
  145. %{summary}.
  146. %endif
  147. %debug_package
  148. %prep
  149. %setup -q -n go
  150. %build
  151. # bootstrap compiler GOROOT
  152. %if !%{golang_bootstrap}
  153. export GOROOT_BOOTSTRAP=/
  154. %else
  155. export GOROOT_BOOTSTRAP=%{goroot}
  156. %endif
  157. # set up final install location
  158. export GOROOT_FINAL=%{goroot}
  159. export GOHOSTOS=linux
  160. export GOHOSTARCH=%{gohostarch}
  161. pushd src
  162. # use our gcc options for this build, but store gcc as default for compiler
  163. export CFLAGS="$RPM_OPT_FLAGS"
  164. export LDFLAGS="$RPM_LD_FLAGS"
  165. export CC="gcc"
  166. export CC_FOR_TARGET="gcc"
  167. export GOOS=linux
  168. export GOARCH=%{gohostarch}
  169. %if !%{external_linker}
  170. export GO_LDFLAGS="-linkmode internal"
  171. %endif
  172. %if !%{cgo_enabled}
  173. export CGO_ENABLED=0
  174. %endif
  175. ./make.bash --no-clean
  176. popd
  177. # build shared std lib
  178. %if %{shared}
  179. GOROOT=$(pwd) PATH=$(pwd)/bin:$PATH go install -buildmode=shared std
  180. %endif
  181. %install
  182. rm -rf $RPM_BUILD_ROOT
  183. # create the top level directories
  184. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  185. mkdir -p $RPM_BUILD_ROOT%{goroot}
  186. # install everything into libdir (until symlink problems are fixed)
  187. # https://code.google.com/p/go/issues/detail?id=5830
  188. cp -apv api bin doc favicon.ico lib pkg robots.txt src misc test VERSION \
  189. $RPM_BUILD_ROOT%{goroot}
  190. # bz1099206
  191. find $RPM_BUILD_ROOT%{goroot}/src -exec touch -r $RPM_BUILD_ROOT%{goroot}/VERSION "{}" \;
  192. # and level out all the built archives
  193. touch $RPM_BUILD_ROOT%{goroot}/pkg
  194. find $RPM_BUILD_ROOT%{goroot}/pkg -exec touch -r $RPM_BUILD_ROOT%{goroot}/pkg "{}" \;
  195. # generate the spec file ownership of this source tree and packages
  196. cwd=$(pwd)
  197. src_list=$cwd/go-src.list
  198. pkg_list=$cwd/go-pkg.list
  199. shared_list=$cwd/go-shared.list
  200. misc_list=$cwd/go-misc.list
  201. docs_list=$cwd/go-docs.list
  202. tests_list=$cwd/go-tests.list
  203. rm -f $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list
  204. touch $src_list $pkg_list $docs_list $misc_list $tests_list $shared_list
  205. pushd $RPM_BUILD_ROOT%{goroot}
  206. find src/ -type d -a \( ! -name testdata -a ! -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $src_list
  207. find src/ ! -type d -a \( ! -ipath '*/testdata/*' -a ! -name '*_test*.go' \) -printf '%{goroot}/%p\n' >> $src_list
  208. find bin/ pkg/ -type d -a ! -path '*_dynlink/*' -printf '%%%dir %{goroot}/%p\n' >> $pkg_list
  209. find bin/ pkg/ ! -type d -a ! -path '*_dynlink/*' -printf '%{goroot}/%p\n' >> $pkg_list
  210. find doc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $docs_list
  211. find doc/ ! -type d -printf '%{goroot}/%p\n' >> $docs_list
  212. find misc/ -type d -printf '%%%dir %{goroot}/%p\n' >> $misc_list
  213. find misc/ ! -type d -printf '%{goroot}/%p\n' >> $misc_list
  214. %if %{shared}
  215. find pkg/*_dynlink/ -type d -printf '%%%dir %{goroot}/%p\n' >> $shared_list
  216. find pkg/*_dynlink/ ! -type d -printf '%{goroot}/%p\n' >> $shared_list
  217. %endif
  218. find test/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  219. find test/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
  220. find src/ -type d -a \( -name testdata -o -ipath '*/testdata/*' \) -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  221. find src/ ! -type d -a \( -ipath '*/testdata/*' -o -name '*_test*.go' \) -printf '%{goroot}/%p\n' >> $tests_list
  222. # this is only the zoneinfo.zip
  223. find lib/ -type d -printf '%%%dir %{goroot}/%p\n' >> $tests_list
  224. find lib/ ! -type d -printf '%{goroot}/%p\n' >> $tests_list
  225. popd
  226. # remove the doc Makefile
  227. rm -rfv $RPM_BUILD_ROOT%{goroot}/doc/Makefile
  228. # put binaries to bindir, linked to the arch we're building,
  229. # leave the arch independent pieces in %{goroot}
  230. mkdir -p $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}
  231. ln -sf %{goroot}/bin/go $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}/go
  232. ln -sf %{goroot}/bin/gofmt $RPM_BUILD_ROOT%{goroot}/bin/linux_%{gohostarch}/gofmt
  233. # ensure these exist and are owned
  234. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/github.com
  235. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/bitbucket.org
  236. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/code.google.com/p
  237. mkdir -p $RPM_BUILD_ROOT%{gopath}/src/golang.org/x
  238. # make sure these files exist and point to alternatives
  239. rm -f $RPM_BUILD_ROOT%{_bindir}/go
  240. ln -sf /etc/alternatives/go $RPM_BUILD_ROOT%{_bindir}/go
  241. rm -f $RPM_BUILD_ROOT%{_bindir}/gofmt
  242. ln -sf /etc/alternatives/gofmt $RPM_BUILD_ROOT%{_bindir}/gofmt
  243. # gdbinit
  244. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d
  245. cp -av %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d/golang.gdb
  246. # prelink blacklist
  247. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d
  248. cp -av %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d/golang.conf
  249. # rpm macros
  250. mkdir -p %{buildroot}
  251. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
  252. cp -av %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.golang
  253. %check
  254. export GOROOT=$(pwd -P)
  255. export PATH="$GOROOT"/bin:"$PATH"
  256. cd src
  257. export CC="gcc"
  258. export CFLAGS="$RPM_OPT_FLAGS"
  259. export LDFLAGS="$RPM_LD_FLAGS"
  260. %if !%{external_linker}
  261. export GO_LDFLAGS="-linkmode internal"
  262. %endif
  263. %if !%{cgo_enabled} || !%{external_linker}
  264. export CGO_ENABLED=0
  265. %endif
  266. # make sure to not timeout
  267. export GO_TEST_TIMEOUT_SCALE=2
  268. %if %{fail_on_tests}
  269. ./run.bash --no-rebuild -v -v -v -k
  270. %else
  271. ./run.bash --no-rebuild -v -v -v -k || :
  272. %endif
  273. cd ..
  274. %post bin
  275. %{_sbindir}/update-alternatives --install %{_bindir}/go \
  276. go %{goroot}/bin/go 90 \
  277. --slave %{_bindir}/gofmt gofmt %{goroot}/bin/gofmt
  278. %preun bin
  279. if [ $1 = 0 ]; then
  280. %{_sbindir}/update-alternatives --remove go %{goroot}/bin/go
  281. fi
  282. %files
  283. %license LICENSE
  284. %doc AUTHORS CONTRIBUTORS PATENTS
  285. # VERSION has to be present in the GOROOT, for `go install std` to work
  286. %doc %{goroot}/VERSION
  287. %dir %{goroot}/doc
  288. %doc %{goroot}/doc/*
  289. # go files
  290. %dir %{goroot}
  291. %exclude %{goroot}/bin/
  292. %exclude %{goroot}/pkg/
  293. %exclude %{goroot}/src/
  294. %exclude %{goroot}/doc/
  295. %exclude %{goroot}/misc/
  296. %{goroot}/*
  297. # ensure directory ownership, so they are cleaned up if empty
  298. %dir %{gopath}
  299. %dir %{gopath}/src
  300. %dir %{gopath}/src/github.com/
  301. %dir %{gopath}/src/bitbucket.org/
  302. %dir %{gopath}/src/code.google.com/
  303. %dir %{gopath}/src/code.google.com/p/
  304. %dir %{gopath}/src/golang.org
  305. %dir %{gopath}/src/golang.org/x
  306. # gdbinit (for gdb debugging)
  307. %{_sysconfdir}/gdbinit.d
  308. # prelink blacklist
  309. %{_sysconfdir}/prelink.conf.d
  310. %{_sysconfdir}/rpm/macros.golang
  311. %files -f go-src.list src
  312. %files -f go-docs.list docs
  313. %files -f go-misc.list misc
  314. %files -f go-tests.list tests
  315. %files -f go-pkg.list bin
  316. %{_bindir}/go
  317. %{_bindir}/gofmt
  318. %if %{shared}
  319. %files -f go-shared.list shared
  320. %endif
  321. %changelog
  322. * Wed Feb 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.7-1
  323. - new upstream release.
  324. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.6-1
  325. - new upstream release.
  326. * Thu Nov 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
  327. - new upstream release.
  328. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.1-1
  329. - new upstream release.
  330. * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15-1
  331. - new upstream release.
  332. * Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.6-1
  333. - new upstream release.
  334. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-1
  335. - new upstream release.
  336. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.5-1
  337. - new upstream release.
  338. * Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.4-1
  339. - new upstream release.
  340. * Tue Jun 26 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.10.3-1
  341. - update to 1.10.3
  342. - drop patches (Patch0, 212, 215)
  343. - export 'GO_TEST_TIMEOUT_SCALE=2' in %%check
  344. - add bcond for tests
  345. * Tue Jun 06 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.3-1
  346. - update to 1.8.3
  347. * Mon Jun 5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.1-1
  348. - update to 1.8.1
  349. - remove BuildArch tags
  350. - drop Source1
  351. - drop patches
  352. - remove ECC p224 patch (Patch1)
  353. - X.509 patch (Patch2): upstream merged
  354. - disable TestGdbPython patch (Patch213)
  355. - disable TestCloneNEWUSERAndRemapNoRootDisableSetgroups patch (Patch214)
  356. - drop Patch216: upstream fixed
  357. - update bootstrap binary path patch (Patch212)
  358. * Mon Dec 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
  359. - new upstream release.
  360. * Sun Mar 8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.2-1
  361. - new upstream release.
  362. * Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2-2
  363. - added Group tag
  364. * Sat Feb 1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.2
  365. - initial build for Vine Linux
  366. - drop emacs and vim package
  367. * Fri Jan 24 2014 Vincent Batts <vbatts@redhat.com> 1.2-4
  368. - skip a flaky test that is sporadically failing on the build server
  369. * Thu Jan 16 2014 Vincent Batts <vbatts@redhat.com> 1.2-3
  370. - remove golang-godoc dependency. cyclic dependency on compiling godoc
  371. * Wed Dec 18 2013 Vincent Batts <vbatts@redhat.com> - 1.2-2
  372. - removing P224 ECC curve
  373. * Mon Dec 2 2013 Vincent Batts <vbatts@fedoraproject.org> - 1.2-1
  374. - Update to upstream 1.2 release
  375. - remove the pax tar patches
  376. * Tue Nov 26 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-8
  377. - fix the rpmspec conditional for rhel and fedora
  378. * Thu Nov 21 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-7
  379. - patch tests for testing on rawhide
  380. - let the same spec work for rhel and fedora
  381. * Wed Nov 20 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-6
  382. - don't symlink /usr/bin out to ../lib..., move the file
  383. - seperate out godoc, to accomodate the go.tools godoc
  384. * Fri Sep 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-5
  385. - Pull upstream patches for BZ#1010271
  386. - Add glibc requirement that got dropped because of meta dep fix
  387. * Fri Aug 30 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-4
  388. - fix the libc meta dependency (thanks to vbatts [at] redhat.com for the fix)
  389. * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-3
  390. - Revert incorrect merged changelog
  391. * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-2
  392. - This was reverted, just a placeholder changelog entry for bad merge
  393. * Tue Aug 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-1
  394. - Update to latest upstream
  395. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-7
  396. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  397. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.1.1-6
  398. - Perl 5.18 rebuild
  399. * Wed Jul 10 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-5
  400. - Blacklist testdata files from prelink
  401. - Again try to fix #973842
  402. * Fri Jul 5 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-4
  403. - Move src to libdir for now (#973842) (upstream issue https://code.google.com/p/go/issues/detail?id=5830)
  404. - Eliminate noarch data package to work around RPM bug (#975909)
  405. - Try to add runtime-gdb.py to the gdb safe-path (#981356)
  406. * Wed Jun 19 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-3
  407. - Use lua for pretrans (http://fedoraproject.org/wiki/Packaging:Guidelines#The_.25pretrans_scriptlet)
  408. * Mon Jun 17 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-2
  409. - Hopefully really fix #973842
  410. - Fix update from pre-1.1.1 (#974840)
  411. * Thu Jun 13 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-1
  412. - Update to 1.1.1
  413. - Fix basically useless package (#973842)
  414. * Sat May 25 2013 Dan Horák <dan[at]danny.cz> - 1.1-3
  415. - set ExclusiveArch
  416. * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-2
  417. - Fix noarch package discrepancies
  418. * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-1
  419. - Initial Fedora release.
  420. - Update to 1.1
  421. * Thu May 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.3.rc3
  422. - Update to rc3
  423. * Thu Apr 11 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.2.beta2
  424. - Update to beta2
  425. * Tue Apr 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.1.beta1
  426. - Initial packaging.