slang-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The shared library for the S-Lang extension language
  3. Summary(ja): S-Lang 拡張言語ライブラリ
  4. Name: slang
  5. Version: 2.3.2
  6. Release: 2%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: https://www.jedsoft.org/slang/
  12. Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
  13. # don't use memcpy() on overlapping buffers
  14. Patch1: slang-getkey-memmove.patch
  15. # disable test that fails with SIGHUP ignored (e.g. in koji)
  16. Patch2: slang-sighuptest.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: libpng-devel
  19. BuildRequires: oniguruma-devel
  20. BuildRequires: pcre-devel
  21. BuildRequires: zlib-devel
  22. %description
  23. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  24. that supports a C-like syntax. It has been designed from the beginning
  25. to be easily embedded into a program to make it extensible. Slang also
  26. provides a way to quickly develop and debug the application embedding it
  27. in a safe and efficient manner. Since slang resembles C, it is easy to
  28. recode slang procedures in C if the need arises.
  29. %description -l ja
  30. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  31. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  32. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  33. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  34. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  35. %package slsh
  36. Summary: Interpreter for S-Lang scripts
  37. Summary(ja): S-Lang スクリプトインタプリタ
  38. Group: programming
  39. Requires: %{name} = %{version}-%{release}
  40. %description slsh
  41. slsh (slang-shell) is a program for interpreting S-Lang scripts.
  42. It supports dynamic loading of S-Lang modules and includes a readline
  43. interface for interactive use.
  44. This package also includes S-Lang modules that are distributed with
  45. the S-Lang distribution.
  46. %package devel
  47. Summary: Development package for %{name}
  48. Summary(ja): %{name} の開発パッケージ
  49. Group: programming
  50. Requires: %{name} = %{version}-%{release}
  51. %description devel
  52. This package contains files which you'll need if you want to
  53. develop S-Lang based applications. Documentation which may help
  54. you write S-Lang based applications is also included.
  55. Install the slang-devel package if you want to develop applications
  56. based on the S-Lang extension language.
  57. #'
  58. %description devel -l ja
  59. このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
  60. ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
  61. なるようなドキュメントも含まれています。
  62. もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
  63. インストールしてください。
  64. ## to build compat32 for x86_64 architecture support
  65. %package -n compat32-%{name}
  66. Summary: The shared library for the S-Lang extension language
  67. Summary(ja): S-Lang 拡張言語ライブラリ
  68. Group: system,legacy
  69. Requires: %{name} = %{version}-%{release}
  70. %description -n compat32-%{name}
  71. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  72. that supports a C-like syntax. It has been designed from the beginning
  73. to be easily embedded into a program to make it extensible. Slang also
  74. provides a way to quickly develop and debug the application embedding it
  75. in a safe and efficient manner. Since slang resembles C, it is easy to
  76. recode slang procedures in C if the need arises.
  77. %description -n compat32-%{name} -l ja
  78. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  79. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  80. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  81. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  82. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  83. %package -n compat32-%{name}-devel
  84. Summary: Development package for %{name}
  85. Summary(ja): %{name} の開発パッケージ
  86. Group: programming,legacy
  87. Requires: compat32-%{name} = %{version}-%{release}
  88. Requires: %{name}-devel = %{version}-%{release}
  89. %description -n compat32-%{name}-devel
  90. This package contains files which you'll need if you want to
  91. develop S-Lang based applications. Documentation which may help
  92. you write S-Lang based applications is also included.
  93. Install the slang-devel package if you want to develop applications
  94. based on the S-Lang extension language.
  95. #'
  96. %debug_package
  97. %prep
  98. %setup -q
  99. %patch1 -p1 -b .getkey-memmove
  100. %patch2 -p1 -b .sighuptest
  101. # fix permissions of installed modules
  102. sed -i '/^INSTALL_MODULE=/s/_DATA//' configure
  103. # disable test failing on 32-bit archs
  104. sed -i '/TEST_SCRIPTS_SLC = /s/array //' src/test/Makefile
  105. %build
  106. %configure \
  107. --includedir=%{_includedir}/slang \
  108. --with-{pcre,png,z,onig}lib=%{_libdir} \
  109. --with-{pcre,png,z,onig}inc=%{_includedir} \
  110. %{nil}
  111. make RPATH="" install_doc_dir=%{_pkgdocdir} all
  112. %install
  113. rm -rf ${RPM_BUILD_ROOT}
  114. make install-all INSTALL="install -p" RPATH="" DESTDIR=$RPM_BUILD_ROOT
  115. rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
  116. %clean
  117. rm -rf ${RPM_BUILD_ROOT}
  118. %files
  119. %defattr(-,root,root)
  120. %doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
  121. %{_libdir}/libslang*.so.*
  122. %files slsh
  123. %defattr(-,root,root)
  124. %doc slsh/doc/html/slsh*.html
  125. %config(noreplace) %{_sysconfdir}/slsh.rc
  126. %{_bindir}/slsh
  127. %{_libdir}/slang
  128. %{_mandir}/man1/slsh.1*
  129. %{_datadir}/slsh
  130. %files devel
  131. %defattr(-,root,root)
  132. %doc doc/*/cslang*.txt doc/*/cref.txt
  133. %{_libdir}/libslang*.so
  134. %{_libdir}/pkgconfig/slang.pc
  135. %{_libdir}/libslang*.a
  136. %{_includedir}/slang
  137. %if %{build_compat32}
  138. %files -n compat32-%{name}
  139. %defattr(- , root, root)
  140. %{_libdir}/libslang.so.*
  141. %files -n compat32-%{name}-devel
  142. %defattr(- , root, root)
  143. %{_libdir}/libslang.a
  144. %{_libdir}/libslang.so
  145. %endif
  146. %changelog
  147. * Tue Aug 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-2
  148. - rebuilt with current environment.
  149. - dropped ldconfig scriptlets.
  150. * Sun Sep 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  151. - new upstream release.
  152. - dropped Patch1 and 2.
  153. - imported Patch1 and 2 from rawhide.
  154. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.4-5
  155. - rebuild with VineSeed environment
  156. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.4-4
  157. - rebuilt with new toolchains
  158. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
  159. - removed unneccesary %if !%{build_compat32} case condition
  160. * Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
  161. - rebuilt with oniguruma-5.9.1
  162. * Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
  163. - new upstream release
  164. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
  165. - new upstream release
  166. - drop slang_jp patch
  167. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
  168. - update to slang-1.4.9
  169. - rediffed slang_jp patch
  170. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
  171. - change ./configure to %%configure
  172. - uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
  173. - added compat32-* packages for x86_64 architecture support
  174. * Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
  175. - rebuild with new toolchains
  176. - s/Copyright/License/
  177. * Sat Feb 9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
  178. - bug fixed canna input for jed
  179. - change patch: bug fixed slsng-console.patch
  180. * Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
  181. - rebuild with glibc-2.2.4
  182. * Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
  183. - update to 1.4.4
  184. - use jp0 patch
  185. - use better macros
  186. - use Release No for Vine Linux
  187. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  188. [1.2.2_jp-7]
  189. - Japanese summary and description
  190. - change group
  191. * Sun Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
  192. - rebuild for new environment.
  193. * Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  194. [1.2.2_jp-5]
  195. - Updated to 1.2.2j056
  196. * Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
  197. [1.2.2_jp-4]
  198. - fix box bug with KANJI
  199. * Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  200. [1.2.2_jp-2]
  201. - Updated to 1.2.2j054
  202. * Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
  203. [1.2.2j052-2]
  204. - patch for linux console and kon
  205. - bug fix for no-kanji version
  206. - separate devel
  207. * Sat Jul 4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  208. [1.2.1j-1]
  209. - Updated to 1.2.2 (j052)
  210. * Fri Jun 5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  211. [1.2.1j-1]
  212. - japanize patch added
  213. * Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
  214. [1.2.1-1]
  215. - Updated to 1.2.1
  216. * Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
  217. [1.2.0-1]
  218. - Updated to 1.2.0, the first 1.x non-beta version
  219. * Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
  220. [1.0.3-1]
  221. - Updated to 1.0.3
  222. - Minor fixes
  223. * Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
  224. - Earlier changes were lost, because of misplacement of RPM:
  225. - BuildRoot
  226. - RPM_OPT_FLAGS
  227. - %clean section
  228. - other minor spec file changes
  229. - Should be buildable by non-root now
  230. - Included untic, a very cool terminfo interpreter (this probably out to be
  231. split out eventually)
  232. - Added bug fix from JED
  233. * Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
  234. - upgraded to 1.0.2
  235. * Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
  236. - Apparently so, Donnie. :)
  237. - upgraded to 1.0.0beta
  238. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  239. - spec file cleanups
  240. * Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
  241. - upgraded to 0.99.38 (will it EVER go 1.0???)
  242. - all patches removed (all appear to be in this version)
  243. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  244. - built against glibc