clutter-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354
  1. %define clutter_version 1.14.2
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.14/%{name}-%{version}.tar.xz
  12. Patch0: clutter-fixdso.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: gdk-pixbuf2-devel
  20. BuildRequires: atk-devel
  21. BuildRequires: pkgconfig
  22. BuildRequires: pango-devel
  23. BuildRequires: libXdamage-devel
  24. BuildRequires: libXcomposite-devel
  25. BuildRequires: libXi-devel
  26. BuildRequires: gettext
  27. BuildRequires: gtk-doc
  28. BuildRequires: gobject-introspection-devel >= 0.9.5
  29. BuildRequires: json-glib-devel
  30. BuildRequires: cogl-devel >= 1.12.0
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: Takemikaduchi
  34. %description
  35. Clutter is an open source software library for creating fast,
  36. visually rich graphical user interfaces. The most obvious example
  37. of potential usage is in media center type applications.
  38. We hope however it can be used for a lot more.
  39. %description -l ja
  40. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  41. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  42. しかしながら、我々はいろいろな分野で使用されることを願っています。
  43. %package devel
  44. Summary: Clutter development environment
  45. Summary(ja): Clutterの開発環境
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  49. Requires: mesa-libGL-devel
  50. Requires: gobject-introspection-devel
  51. Requires: json-glib-devel
  52. Requires: libXcomposite-devel
  53. Requires: libXi-devel
  54. %description devel
  55. Header files and libraries for building a extension library for the
  56. clutter
  57. %package doc
  58. Summary: Documentation for %{name}
  59. Summary(ja): %{name}用のドキュメント
  60. Group: Documentation
  61. Requires: %{name} = %{version}-%{release}
  62. BuildArch: noarch
  63. %description doc
  64. Clutter is an open source software library for creating fast,
  65. visually rich graphical user interfaces. The most obvious example
  66. of potential usage is in media center type applications.
  67. We hope however it can be used for a lot more.
  68. This package contains documentation for clutter.
  69. %prep
  70. %setup -q
  71. %patch0 -p1 -b .dso
  72. %build
  73. #%configure --enable-gtk-doc \
  74. # --enable-introspection=yes \
  75. # --disable-silent-rules \
  76. # --enable-xinput \
  77. # --disable-static
  78. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  79. %configure $CONFIGFLAGS \
  80. --enable-introspection=yes \
  81. --disable-silent-rules \
  82. --enable-xinput \
  83. --disable-static
  84. # clutter git ships with some magic to put the git log in shipped tarballs
  85. # which gets listed in files; don't blow up if it's missing
  86. if ! test -f ChangeLog; then
  87. echo "Created from snapshot" > ChangeLog
  88. fi
  89. )
  90. make V=0
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. #make DESTDIR=$RPM_BUILD_ROOT install
  94. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  96. %find_lang %{name}-1.0
  97. %clean
  98. rm -rf $RPM_BUILD_ROOT
  99. %post -p /sbin/ldconfig
  100. %postun -p /sbin/ldconfig
  101. %files -f %{name}-1.0.lang
  102. %defattr(-,root,root,-)
  103. %doc AUTHORS COPYING NEWS README
  104. %{_libdir}/*.so.*
  105. %{_libdir}/girepository-1.0/*.typelib
  106. %files devel
  107. %defattr(-, root, root)
  108. %doc ChangeLog
  109. %{_includedir}/clutter-1.0
  110. %{_libdir}/*.so
  111. %{_libdir}/pkgconfig/*.pc
  112. %{_datadir}/gir-1.0/*.gir
  113. %files doc
  114. %defattr(-, root, root)
  115. %{_datadir}/gtk-doc/html/clutter
  116. %{_datadir}/gtk-doc/html/cally
  117. %changelog
  118. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  119. - new upstream release
  120. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  121. - new upstream release
  122. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  123. - new upstream release
  124. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  125. - new upstream release
  126. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  127. - new upstream release
  128. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  129. - new upstream release
  130. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  131. - new upstream release
  132. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
  133. - new upstream release
  134. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  135. - new upstream release
  136. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  137. - new upstream release
  138. - add Requires: libXcomposite-devel, libXi-devel (-devel package)
  139. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  140. - new upstream release
  141. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  142. - new upstream release
  143. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  144. - new upstream release
  145. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  146. - new upstream release
  147. - add BuildRequires: cogl-devel
  148. - add "BuildArch: noarch" to doc sub package
  149. - add Patch0 (clutter-fixdso.patch)
  150. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  151. - new upstream release
  152. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  153. - new upstream release
  154. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  155. - new upstream release
  156. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  157. - new upstream release
  158. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  159. - new upstream release
  160. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  161. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  162. - drop Patch0
  163. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  164. - new upstream release
  165. - drop Patch1
  166. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  167. - new upstream release
  168. - add BuildRequires: json-glib-devel
  169. - delete Requires: gir-repository
  170. - delete BuildRequires: gir-repository-devel
  171. - add Requires: json-glib-devel (devel package)
  172. - add Patch0, Patch1
  173. - fix %build
  174. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  175. - rebuild with rpm-4.8.1 for pkg-config file
  176. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  177. - new upstream release
  178. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  179. - new upstream release
  180. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  181. - new upstream release
  182. - add configure option (--enable-xinput)
  183. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  184. - new upstream release
  185. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  186. - new upstream release
  187. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  188. - new upstream release
  189. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  190. - new upstream release
  191. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  192. - new upstream release
  193. - build for Vine Linux
  194. - add Summary(ja)
  195. - fix BuildRoot
  196. - remove Obsolete and Provides
  197. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  198. - Update to 1.0.6
  199. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  200. - Update to 1.0.4, update gobject-introspection requirement
  201. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  202. - Update to 1.0.2
  203. * Sat Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  204. - Move ChangeLog to -devel to save some space
  205. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  206. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  207. onto the live cd
  208. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  209. - Update to 1.0.0
  210. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  211. - fix bz #507389
  212. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  213. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  214. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  215. - Update to 0.9.8
  216. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  217. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  218. introspection support to clutter (#512260)
  219. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  220. - Update to 0.9.6
  221. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  222. - Update to 0.9.4
  223. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  224. - Update to 0.9.2
  225. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  226. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  227. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  228. - Remove noarch from doc subpackage
  229. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  230. - Added gtk-doc for cogl
  231. - Created doc subpackage
  232. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  233. - Update to 0.8.6
  234. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  235. - Update to 0.8.2
  236. - Removed clutter-0.8.0-clutter-fixed.patch
  237. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  238. - Update to 0.8.0
  239. - Added clutter-0.8.0-clutter-fixed.patch
  240. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  241. - Update to 0.6.4
  242. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  243. - Update to 0.6.2
  244. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  245. - Update to 0.6.0
  246. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  247. - Autorebuild for GCC 4.3
  248. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  249. - Update to 0.4.2
  250. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  251. - Update to 0.4.1
  252. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  253. - Update to 0.3.1
  254. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  255. - Update to 0.2.3
  256. * Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  257. - Changed buildrequires and requires
  258. * Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  259. - Fix .spec
  260. * Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  261. - Fix .spec
  262. * Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  263. - Initial RPM release