evolution-data-server-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809
  1. %define use_nss 1
  2. %define ldap_support 1
  3. %define static_ldap 1
  4. %define krb5_support 1
  5. %define nntp_support 1
  6. %define glib2_version 2.34.0
  7. %define gtk3_version 3.6.0
  8. %define gtk_doc_version 1.18
  9. %define intltool_version 0.35.5
  10. %define orbit2_version 2.14.19
  11. %define soup_version 2.36.0
  12. %define libgweather_version 3.2.0
  13. %define libical_version 0.44
  14. %define libgdata_version 0.10.1
  15. %define eds_base_version 3.8
  16. %define eds_api_version 1.2
  17. %define use_gnome_keyring 1
  18. %define support_imap4_provider 0
  19. %define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
  20. %define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
  21. %define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
  22. %define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
  23. ### Abstract ###
  24. Summary: Backend data server for evolution
  25. Summary(ja): Evolution バックエンドデータサーバ
  26. Name: evolution-data-server
  27. Version: 3.8.1
  28. Release: 1%{?_dist_release}
  29. License: LGPL
  30. Group: System Environment/Libraries
  31. URL: http://www.gnome.org/projects/evolution/
  32. Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.8/%{name}-%{version}.tar.xz
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. ### Patches ###
  35. # RH bug #243296
  36. Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
  37. ### Dependencies ###
  38. #Requires: ORBit2 >= %{orbit2_version}
  39. Requires: libsoup >= %{soup_version}
  40. ### Build Dependencies ###
  41. #BuildRequires: ORBit2-devel >= %{orbit2_version}
  42. BuildRequires: bison
  43. BuildRequires: db4-devel
  44. BuildRequires: flex
  45. BuildRequires: gettext
  46. BuildRequires: glib2-devel
  47. BuildRequires: gtk3-devel
  48. BuildRequires: dbus-glib-devel
  49. BuildRequires: gnutls-devel
  50. BuildRequires: intltool >= %{intltool_version}
  51. BuildRequires: libsoup-devel >= %{soup_version}
  52. BuildRequires: libtool
  53. BuildRequires: libgnome-keyring-devel
  54. BuildRequires: gtk-doc >= 1.14
  55. BuildRequires: sqlite3-devel
  56. BuildRequires: libgweather-devel >= %{libgweather_version}
  57. BuildRequires: libical-devel >= %{libical_version}
  58. BuildRequires: gperf
  59. BuildRequires: krb5-devel
  60. BuildRequires: libgdata-devel >= %{libgdata_version}
  61. BuildRequires: gnome-online-accounts-devel
  62. BuildRequires: liboauth-devel
  63. BuildRequires: libsecret-devel
  64. BuildRequires: gnome-common
  65. BuildRequires: vala
  66. BuildRequires: vala-tools
  67. %if %{use_nss}
  68. BuildRequires: nspr-devel
  69. BuildRequires: nss-devel
  70. %else
  71. BuildRequires: openssl-devel
  72. %endif
  73. %if %{ldap_support}
  74. %if %{static_ldap}
  75. BuildRequires: openldap-evolution-devel
  76. BuildRequires: openssl-devel
  77. %else
  78. BuildRequires: openldap-devel >= 2.0.11
  79. %endif
  80. %endif
  81. %if %{krb5_support}
  82. BuildRequires: krb5-devel
  83. # tweak for krb5 1.2 vs 1.3
  84. %define krb5dir /usr/kerberos
  85. #define krb5dir `pwd`/krb5-fakeprefix
  86. %endif
  87. Vendor: Project Vine
  88. Distribution: Vine Linux
  89. %description
  90. The evolution-data-server package provides a unified backend for
  91. programs that work with contacts, tasks, and calendar information.
  92. It was originally developed for Evolution (hence the name), but
  93. is now used by other packages.
  94. %package devel
  95. Summary: Development files for building against evolution-data-server
  96. Group: Development/Libraries
  97. Requires: %{name} = %{version}-%{release}
  98. Requires: pkgconfig
  99. Requires: sqlite3-devel
  100. Requires: libgnome-keyring-devel
  101. %description devel
  102. Development files needed for building things which link against
  103. evolution-data-server.
  104. %package doc
  105. Summary: Documentation for %{name}
  106. Summary(ja): %{name} 用のドキュメント
  107. Group: Documentation
  108. Requires: %{name} = %{version}-%{release}
  109. BuildArch: noarch
  110. %description doc
  111. This package contains documentation for %{name}.
  112. %package vala
  113. Summary: Vala bindings for %{name}
  114. Summary(ja): %{name} の Vala バインディング
  115. Group: Development/Libraries
  116. Requires: %{name} = %{version}-%{release}
  117. Requires: vala
  118. %description vala
  119. Vala bindings for %{name}.
  120. %prep
  121. %setup -q
  122. %patch12 -p1 -b .fix-64bit-acinclude
  123. mkdir -p krb5-fakeprefix/include
  124. mkdir -p krb5-fakeprefix/lib
  125. mkdir -p krb5-fakeprefix/%{_lib}
  126. %build
  127. %if %{ldap_support}
  128. %if %{static_ldap}
  129. %define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
  130. # Set LIBS so that configure will be able to link with static LDAP libraries,
  131. # which depend on Cyrus SASL and OpenSSL. XXX Is the "else" clause necessary?
  132. if pkg-config libssl ; then
  133. export LIBS="-lsasl2 `pkg-config --libs libssl`"
  134. else
  135. export LIBS="-lsasl2 -lssl -lcrypto"
  136. fi
  137. %else
  138. %define ldap_flags --with-openldap=yes
  139. %endif
  140. %else
  141. %define ldap_flags --without-openldap
  142. %endif
  143. %if %{krb5_support}
  144. %define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
  145. %else
  146. %define krb5_flags --without-krb5
  147. %endif
  148. %if %{nntp_support}
  149. %define nntp_flags --enable-nntp=yes
  150. %else
  151. %define nntp_flags --enable-nntp=no
  152. %endif
  153. %if %{use_nss}
  154. %define ssl_flags --enable-nss=yes --enable-smime=yes
  155. %else
  156. %define ssl_flags --enable-openssl=yes
  157. %endif
  158. %if %{use_nss}
  159. if ! pkg-config --exists nss; then
  160. echo "Unable to find suitable version of nss to use!"
  161. exit 1
  162. fi
  163. %endif
  164. %if %{use_gnome_keyring}
  165. %define keyring_flags --enable-gnome-keyring
  166. %else
  167. %define keyring flags --disable-gnome-keyring
  168. %endif
  169. %if %{support_imap4_provider}
  170. %define imap4_flags --enable-imap4=yes
  171. %else
  172. %define imap4_flags --enable-imap4=no
  173. %endif
  174. export CPPFLAGS="-I%{_includedir}/et"
  175. export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
  176. # Regenerate configure to pick up configure.in and acinclude.m4 changes.
  177. aclocal -I m4
  178. autoheader
  179. automake
  180. libtoolize
  181. intltoolize --force
  182. autoconf
  183. # See Ross Burton's blog entry for why we want --with-libdb.
  184. # http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
  185. %configure \
  186. --with-libdb=/usr \
  187. --disable-uoa \
  188. --enable-file-locking=fcntl \
  189. --enable-dot-locking=no \
  190. --enable-gtk-doc \
  191. --enable-introspection=yes \
  192. --enable-vala-bindings \
  193. %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
  194. %keyring_flags
  195. export tagname=CC
  196. #make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
  197. make LIBTOOL=/usr/bin/libtool
  198. %install
  199. rm -rf $RPM_BUILD_ROOT
  200. export tagname=CC
  201. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
  202. # remove libtool archives for importers and the like
  203. find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
  204. find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
  205. # give the libraries some executable bits
  206. find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
  207. %find_lang %{name}-%{eds_base_version}
  208. %clean
  209. rm -rf $RPM_BUILD_ROOT
  210. %post -p /sbin/ldconfig
  211. %postun
  212. /sbin/ldconfig
  213. if [ $1 -eq 0 ]; then
  214. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  215. fi
  216. %posttrans
  217. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  218. %files -f %{name}-%{eds_base_version}.lang
  219. %defattr(-,root,root,-)
  220. %doc README COPYING ChangeLog NEWS AUTHORS
  221. %{_libdir}/*.so.*
  222. %{_libdir}/girepository-1.0/*.typelib
  223. %{_libexecdir}/evolution-addressbook-factory
  224. %{_libexecdir}/evolution-calendar-factory
  225. %{_libexecdir}/evolution-source-registry
  226. %{_libexecdir}/evolution-user-prompter
  227. %{_libexecdir}/camel-index-control-%{eds_api_version}
  228. %{_libexecdir}/camel-lock-helper-%{eds_api_version}
  229. %{_datadir}/GConf/gsettings/evolution-data-server.convert
  230. %{_datadir}/GConf/gsettings/libedataserver.convert
  231. %{_datadir}/dbus-1/services/*
  232. %{_datadir}/%{name}/evolutionperson.schema
  233. %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
  234. %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
  235. %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
  236. %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
  237. %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
  238. %{_datadir}/pixmaps/evolution-data-server
  239. %dir %{_libdir}/evolution-data-server
  240. %dir %{camel_provider_dir}
  241. %dir %{ebook_backends_dir}
  242. %dir %{ecal_backends_dir}
  243. %dir %{registry_modules_dir}
  244. # Camel providers:
  245. #%{camel_provider_dir}/libcamelimap.so
  246. #%{camel_provider_dir}/libcamelimap.urls
  247. %{camel_provider_dir}/libcamelimapx.so
  248. %{camel_provider_dir}/libcamelimapx.urls
  249. %{camel_provider_dir}/libcamellocal.so
  250. %{camel_provider_dir}/libcamellocal.urls
  251. %{camel_provider_dir}/libcamelnntp.so
  252. %{camel_provider_dir}/libcamelnntp.urls
  253. %{camel_provider_dir}/libcamelpop3.so
  254. %{camel_provider_dir}/libcamelpop3.urls
  255. %{camel_provider_dir}/libcamelsendmail.so
  256. %{camel_provider_dir}/libcamelsendmail.urls
  257. %{camel_provider_dir}/libcamelsmtp.so
  258. %{camel_provider_dir}/libcamelsmtp.urls
  259. # e-d-s extensions:
  260. %{ebook_backends_dir}/libebookbackendfile.so
  261. %{ebook_backends_dir}/libebookbackendgoogle.so
  262. %{ebook_backends_dir}/libebookbackendldap.so
  263. %{ebook_backends_dir}/module-data-book-factory-goa.so
  264. %{ebook_backends_dir}/libebookbackendwebdav.so
  265. %{ecal_backends_dir}/libecalbackendcaldav.so
  266. %{ecal_backends_dir}/libecalbackendcontacts.so
  267. %{ecal_backends_dir}/libecalbackendfile.so
  268. %{ecal_backends_dir}/libecalbackendhttp.so
  269. %{ecal_backends_dir}/libecalbackendweather.so
  270. %{ecal_backends_dir}/module-data-cal-factory-goa.so
  271. %{registry_modules_dir}/module-cache-reaper.so
  272. %{registry_modules_dir}/module-google-backend.so
  273. %{registry_modules_dir}/module-gnome-online-accounts.so
  274. %{registry_modules_dir}/module-owncloud-backend.so
  275. %{registry_modules_dir}/module-trust-prompt.so
  276. %{registry_modules_dir}/module-yahoo-backend.so
  277. %files devel
  278. %defattr(-,root,root,-)
  279. %{_includedir}/%{name}
  280. %{_libdir}/*.so
  281. %{_libdir}/pkgconfig/*.pc
  282. %{_datadir}/gir-1.0/*.gir
  283. %files doc
  284. %defattr(-,root,root,-)
  285. %{_datadir}/gtk-doc/html/camel
  286. %{_datadir}/gtk-doc/html/libebackend
  287. %{_datadir}/gtk-doc/html/libebook
  288. %{_datadir}/gtk-doc/html/libebook-contacts
  289. %{_datadir}/gtk-doc/html/libecal
  290. %{_datadir}/gtk-doc/html/libedata-book
  291. %{_datadir}/gtk-doc/html/libedata-cal
  292. %{_datadir}/gtk-doc/html/libedataserver
  293. %files vala
  294. %defattr(-,root,root,-)
  295. %{_datadir}/vala/vapi/libebook-1.2.deps
  296. %{_datadir}/vala/vapi/libebook-1.2.vapi
  297. %{_datadir}/vala/vapi/libebook-contacts-1.2.deps
  298. %{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
  299. %{_datadir}/vala/vapi/libedataserver-1.2.deps
  300. %{_datadir}/vala/vapi/libedataserver-1.2.vapi
  301. %changelog
  302. * Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  303. - new upstream release
  304. - add configure option (--disable-uoa)
  305. - add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
  306. - create %%{name}-vala subpackage
  307. * Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
  308. - new upstream release
  309. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  310. - new upstream release
  311. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  312. - new upstream release
  313. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  314. - new upstream release
  315. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  316. - new upstream release
  317. * Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  318. - new upstream release
  319. * Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  320. - new upstream release
  321. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  322. - new upstream release
  323. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  324. - new upstream release
  325. - add BuildRequires: dbus-glib-devel
  326. * Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
  327. - new upstream release
  328. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  329. - new upstream release
  330. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  331. - new upstream release
  332. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  333. - new upstream release
  334. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  335. - new upstream release
  336. - remove Patch101
  337. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  338. - new upstream release
  339. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  340. - new upstream release
  341. - change BuildRequires: gtk3-devel instead of gtk2-devel
  342. - BuildRequires: gnome-online-accounts-devel
  343. - add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
  344. - fix %%files
  345. * Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  346. - new upstream release
  347. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
  348. - rebuild with openssl-1.0.0c
  349. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  350. - new upstream release
  351. - remove Requires: gnome-vfs2, libglade2, libgnomeui
  352. - remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
  353. - add BuildRequires: libgdata
  354. - add Requires: nspr-devel, nss-devel (devel package)
  355. - drop Patch11
  356. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
  357. - rebuild with rpm-4.8.1 for pkg-config file
  358. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  359. - new upstream release
  360. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  361. - new upstream release
  362. * Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  363. - new upstream release
  364. - remove BuildRequires: libbonobo-devel
  365. - remove Requires: libbonobo
  366. - drop Patch10
  367. - add configure option (--with-krb5-libs, --with-krb5-includes)
  368. * Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
  369. - rebuilt with db4-4.8
  370. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  371. - new upstream release
  372. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  373. - new upstream release
  374. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  375. - new upstream release
  376. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
  377. - new upstream release
  378. * Sat Apr 4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
  379. - added Requires: libical-devel >= 0.43 to devel package
  380. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  381. - new upstream release
  382. - add BR: libgweather-devel >= 2.26.0
  383. - add BR: libical-devel >= 0.43
  384. * Sat Mar 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
  385. - new upstream release
  386. - added BuildRequires: sqlite3-devel
  387. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
  388. - enabled krb5 support
  389. * Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
  390. - new upstream release
  391. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  392. - new upstream release
  393. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  394. - new upstream release
  395. * Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
  396. - new upstream release
  397. * Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
  398. - rebuilt with db4-4.6.21
  399. * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
  400. - new upstream release
  401. * Sun May 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  402. - new upstream release
  403. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  404. - new upstream release
  405. * Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  406. - new upstream release based on Fedora package 2.20.0-3.fc9
  407. * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
  408. - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
  409. * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
  410. - Add patch for RH bug #296671 (GC servers may not support NTLM).
  411. * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
  412. - Try removing the ancient "ldap-x86_64-hack" patch.
  413. * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
  414. - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
  415. - split doc subpackage
  416. * Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
  417. - fixed dependancy
  418. * Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
  419. - updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
  420. * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
  421. - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
  422. * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
  423. - Make the new ESourceComboBox widget work properly (RH bug #234760).
  424. * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
  425. - Link to static evolution-openldap library (RH bug #210126).
  426. - Require openssl-devel when statically linking against openldap.
  427. - Add -Wdeclaration-after-statement to strict build settings.
  428. * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
  429. - Modify patch for GNOME bug #376991 to fix RH bug #231994.
  430. - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
  431. * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
  432. - Update to 1.10.0
  433. * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
  434. - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
  435. - Patch by Kenny Root.
  436. - rebuilt with nss-devel and nspr-devel
  437. * Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
  438. - rebuilt with new toolchain and db4-4.3.x
  439. * Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  440. - new upstream release
  441. * Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
  442. - new upstream release
  443. - dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
  444. * Sat Oct 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
  445. - new upstream release
  446. - rebuilt with openssl instead of mozilla-nss
  447. * Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
  448. - rebuilt with openldap-2.3.24-0vl4
  449. * Thu Dec 1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
  450. - new upstream release
  451. - build with libsoap-2.2.7
  452. * Tue Nov 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
  453. - new upstream release
  454. * Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
  455. - new upstream release
  456. - added/removed Patches based on Fedora packages
  457. * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
  458. - Updated patch 102 to fix further implicit function declarations
  459. * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
  460. - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
  461. tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
  462. * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
  463. - Removed upstreamed patch:
  464. evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
  465. * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
  466. - added patch to calendar/libecal/e-cal.c to fix missing declaration
  467. of open_calendar
  468. - rebuilt with mozilla-1.7.12
  469. * Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
  470. - rebuilt with mozilla-1.7.7
  471. * Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  472. - initial build for Vine Linux based on FC package
  473. - disable krb5 support
  474. * Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
  475. - 1.2.1
  476. * Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
  477. - Removed explicit run-time spec-file requirement on mozilla.
  478. The Mozilla NSS API/ABI stabilised by version 1.7.3
  479. The libraries are always located in the libdir
  480. However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
  481. and so they move each time the mozilla version changes.
  482. So we no longer have an explicit mozilla run-time requirement in the specfile;
  483. a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
  484. We have an explicit, exact build-time version, so that we can find the headers (without
  485. invoking an RPM query from the spec file; to do so is considered bad practice)
  486. - Introduced mozilla_build_version, to replace mozilla_version
  487. - Set mozilla_build_version to 1.7.6 to reflect current state of tree
  488. * Tue Mar 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
  489. - Added a patch to deal with glibc defining a macro called "read"
  490. * Tue Mar 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
  491. - 1.2.0
  492. - Removed patch for GCC 4 as this is now in upstream tarball
  493. * Wed Mar 2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
  494. - rebuild to fix library linking silliness
  495. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
  496. - disabling gtk-doc on ia64 and s390x
  497. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
  498. - added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
  499. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
  500. - extended patch to deal with camel-groupwise-store-summary.c
  501. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
  502. - added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
  503. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
  504. - 1.1.6
  505. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
  506. - rebuild
  507. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
  508. - forgot to fix sources
  509. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
  510. - 1.1.5
  511. * Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
  512. - Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
  513. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
  514. - disable gtk-doc generation on ia64 for now
  515. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
  516. - Exclude ppc64 due to missing mozilla dependency
  517. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
  518. - Update from 1.0.3 to 1.1.4.1
  519. - Updated eds_major from 1.0 to 1.2; fixed translation search path.
  520. - Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
  521. - Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
  522. - Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
  523. - Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
  524. - Camel code from evolution is now in evolution-data-server:
  525. - Added camel-index-control and camel-lock-helper to packaged files
  526. - Added mozilla dependency code from the evolution package
  527. - Ditto for LDAP
  528. - Ditto for krb5
  529. - Ditto for NNTP support handling
  530. - Ditto for --enable-file-locking and --enable-dot-locking
  531. - Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
  532. - Updated libsoup requirement from 2.2.1 to 2.2.2
  533. - Enabled gtk-doc
  534. * Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
  535. - fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
  536. * Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
  537. - update from upstream 1.0.2 to 1.0.3:
  538. * Address Book
  539. - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
  540. - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
  541. * Calendar
  542. #XB59904 - Speed up calendar queries (Rodrigo)
  543. #XB69624 - make changes in evo corresponding to soap schema changes (Siva)
  544. - fix libical build for automake 1.9 (Rodney)
  545. - fix putenv usage for portability (Julio M. Merino Vidal)
  546. * Updated Translations:
  547. - sv (Christian Rose)
  548. - Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
  549. * Tue Dec 7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
  550. - Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
  551. http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
  552. (The groupwise part of that patch did not cleanly apply, so I removed it).
  553. * Thu Dec 2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
  554. - Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
  555. optimisation patch posted to upstream development mailing list here:
  556. http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
  557. * Wed Nov 3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
  558. - Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64 (#136914)
  559. * Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
  560. - added workaround for a backend leak that causes the "contacts" calendar
  561. backend to hold open an EBook for the local contacts (filed upstream at:
  562. http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
  563. never lose its last addressbook, and hence never quit. We workaround this by
  564. detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
  565. * Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
  566. - added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
  567. * Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
  568. - update from 1.0.1 to 1.0.2
  569. - increased libsoup requirement to 2.2.1 to match configuration script
  570. * Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
  571. - update from 1.0.0 to 1.0.1
  572. - removed patch that fixed warnings in calendar code (now in upstream tarball)
  573. * Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
  574. - fixed various warnings in the calendar code
  575. (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
  576. * Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
  577. - update from 0.0.99 to 1.0.0
  578. - changed path in FTP source location from 0.0 to 1.0
  579. * Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
  580. - update from 0.0.98 to 0.0.99
  581. - increased libsoup requirement to 2.2.0 to match configuration script
  582. * Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
  583. - updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
  584. * Thu Aug 5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
  585. - pkgconfig -devel Requires libbonobo-devel, libgnome-devel
  586. * Wed Aug 4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
  587. - upgraded to 0.0.97; rewrote the package's description
  588. * Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
  589. - rebuilt
  590. * Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
  591. - added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
  592. * Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
  593. - 0.0.96; libsoup required is now 2.1.12
  594. * Thu Jul 8 2004 David Malcolm <dmalcolm@redhat.com>
  595. - rebuilt
  596. * Wed Jul 7 2004 David Malcolm <dmalcolm@redhat.com>
  597. - rebuilt
  598. * Tue Jul 6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
  599. - 0.0.95
  600. * Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
  601. - 0.0.94.1
  602. * Mon Jun 7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
  603. - rebuilt
  604. * Mon Jun 7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
  605. - 0.0.94
  606. * Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
  607. - added ORBit2 requirement
  608. * Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
  609. - rebuild again
  610. * Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
  611. - rebuilt
  612. * Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
  613. - 0.0.93; libsoup required is now 2.1.10
  614. * Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
  615. - Update to 0.0.92; added a define and a requirement on the libsoup version
  616. * Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
  617. - 0.0.90
  618. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  619. - rebuilt
  620. * Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
  621. - 0.0.6
  622. * Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
  623. - better fix by using system libtool
  624. * Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
  625. - add some libdb linkage to make the build on x86_64 happy
  626. * Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
  627. - update to 0.0.5
  628. * Sat Jan 3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
  629. - Initial build.