xnoise-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. %define XNOISE_BIN %{_libexecdir}/%{name}
  2. Name: xnoise
  3. Version: 0.2.15
  4. Release: 1%{?_dist_release}
  5. Summary: Tracklist-centric Media Player
  6. Summary(ja): トラックリストを中心とするメディアプレーヤー
  7. Group: Applications/Multimedia
  8. License: GPLv2+ with exceptions
  9. URL: http://www.xnoise-media-player.com/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.bz2
  12. Source1: xnoise_ja.po
  13. Source10: xnoise.sh
  14. BuildRequires: pkgconfig
  15. BuildRequires: gettext
  16. BuildRequires: glib2-devel >= 2.30.0
  17. BuildRequires: gtk3-devel
  18. BuildRequires: gstreamer-plugins-base-devel >= 0.10.23
  19. BuildRequires: intltool
  20. BuildRequires: libxml2-devel >= 2.6.32
  21. #BuildRequires: libnotify-devel >= 0.7.0
  22. BuildRequires: libsoup-devel >= 2.26.0
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: sqlite3-devel >= 3.6
  25. BuildRequires: taglib-devel >= 1.6.0
  26. BuildRequires: unique-devel
  27. BuildRequires: vala-devel >= 0.16.0
  28. BuildRequires: desktop-file-utils gettext intltool
  29. Requires: hicolor-icon-theme
  30. # xnoise >= 0.1.14 bundles the plug-ins
  31. Provides: xnoise-plugins-core = %{version}-%{release}
  32. %description
  33. Xnoise is a Gtk+ media player with a tracklist-centric design. The
  34. tracklist is a list of video or music tracks that are played one by
  35. one without being removed (right side of window). This gives you the
  36. possibility to enqueue any track in any order, regardless if they are
  37. on the same album or not. The tracks can be reordered at any time by
  38. using drag and drop.
  39. %package devel
  40. Summary: Development files for %{name}
  41. Summary(ja): %{name} の開発ファイル
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. %description devel
  45. The %{name}-devel package contains libraries and header files for
  46. developing applications that use %{name}.
  47. %prep
  48. %setup -q
  49. %{__cp} -f %{SOURCE1} po/ja.po
  50. #sed -i s/hu/hu\\nja/g po/LINGUAS
  51. %build
  52. %configure --enable-soundmenu2=no --disable-ubuntuone
  53. make %{?_smp_mflags}
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install DESTDIR=$RPM_BUILD_ROOT
  57. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  58. # remove invalid locale file
  59. rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
  60. ## wrapper install
  61. %__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
  62. %__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
  63. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  64. %find_lang %{name}
  65. %check
  66. make check
  67. desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
  68. %post
  69. /sbin/ldconfig
  70. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  71. update-desktop-database &> /dev/null || :
  72. %postun
  73. /sbin/ldconfig
  74. if [ $1 -eq 0 ] ; then
  75. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  76. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  77. fi
  78. update-desktop-database &> /dev/null || :
  79. %posttrans
  80. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  81. %files -f %{name}.lang
  82. %defattr(-,root,root,-)
  83. %doc AUTHORS COPYING README
  84. %{XNOISE_BIN}
  85. %{_bindir}/xnoise
  86. # libxnoise.so *needs* to be in main package
  87. # otherwise plugins currently don't work
  88. %exclude %{_libdir}/xnoise/libxnoisetest.so
  89. %{_libdir}/xnoise
  90. %{_libdir}/libtaginfo*
  91. %{_libdir}/libxnoise.so*
  92. %{_mandir}/man1/xnoise.1*
  93. %{_datadir}/xnoise
  94. %{_datadir}/applications/xnoise.desktop
  95. %{_datadir}/icons/hicolor/*
  96. %files devel
  97. %defattr(-,root,root,-)
  98. %{_includedir}/xnoise
  99. %{_includedir}/taginfo/
  100. %{_libdir}/xnoise/libxnoise*.so*
  101. %{_libdir}/taginfo/include
  102. %{_libdir}/pkgconfig/xnoise-1.0.pc
  103. %{_libdir}/pkgconfig/taginfo.pc
  104. %{_libdir}/pkgconfig/taginfo_c.pc
  105. # make package own the vala API dir:
  106. # xnoise plugins don't have to be written in vala
  107. %dir %{_datadir}/vala
  108. %dir %{_datadir}/vala/vapi
  109. %{_datadir}/vala/vapi/xnoise-1.0.*
  110. %{_datadir}/vala/vapi/taginfo_c.*
  111. %changelog
  112. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
  113. - new upstream release
  114. - updated Source1
  115. * Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
  116. - new upstream release
  117. - updated Source1
  118. * Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
  119. - new upstream release
  120. - updated Source1
  121. * Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
  122. - new upstream release
  123. - updated Source1
  124. - deleted BuildRequires: libnotify-devel >= 0.7.0
  125. - changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
  126. * Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
  127. - new upstream release
  128. - updated Source1
  129. - deleted %%configure option: --disable-magnatune
  130. * Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
  131. - new upstream release
  132. - updated Source1
  133. * Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
  134. - new upstream release
  135. - updated Source1
  136. - added %%configure option: --disable-magnatune
  137. * Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
  138. - new upstream release
  139. - updated Source1
  140. - added %%configure option: --disable-ubuntuone
  141. * Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
  142. - initial build for VineSeed
  143. * Wed Oct 5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
  144. - Update to 0.1.29
  145. * Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
  146. - Update to 0.1.28
  147. * Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
  148. - Update to 0.1.27
  149. * Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
  150. - Update to 0.1.26
  151. - Enable tests
  152. * Mon Apr 4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
  153. - Update to 0.1.18
  154. * Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
  155. - Update to 0.1.16
  156. - Now bundles the plugins, obsoleting xnoise-plugins-core
  157. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  159. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
  160. - Own %%{_libdir}/xnoise for plugins
  161. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
  162. - invoke ldconfig on (un)install
  163. - remove %%clean section; only targeting F-14+
  164. - re-enable deletion of invalid locale dir
  165. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
  166. - Update to 0.1.12
  167. - Specify the correct location for Vala API files in *.pc
  168. * Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
  169. - Make xnoise-devel co-own Vala's VAPI dir
  170. - Remove invalid locale file
  171. * Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  172. - Update to final 0.1.6 release
  173. * Sat Apr 3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
  174. - Initial package