123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282 |
- # Copyright (c) 2000-2005, JPackage Project
- # All rights reserved.
- #
- # Redistribution and use in source and binary forms, with or without
- # modification, are permitted provided that the following conditions
- # are met:
- #
- # 1. Redistributions of source code must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- # 2. Redistribution1s in binary form must reproduce the above copyright
- # notice, this list of conditions and the following disclaimer in the
- # documentation and/or other materials provided with the
- # distribution.
- # 3. Neither the name of the JPackage Project nor the names of its
- # contributors may be used to endorse or promote products derived
- # from this software without specific prior written permission.
- #
- # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
- # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
- # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
- # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
- # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
- # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
- # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
- # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- #
- %define scm_version 1_7R4
- Name: rhino
- Version: 1.7
- Release: 0.r4.1%{?_dist_release}
- Summary: JavaScript for Java
- Summary(ja): Java で記述された JavaScript
- Group: Development/Libraries
- License: MPLv2.0
- URL: http://www.mozilla.org/rhino/
- Source0: https://github.com/mozilla/rhino/archive/Rhino%{scm_version}_RELEASE.zip
- Source2: %{name}.script
- Patch0: %{name}-build.patch
- # Add OSGi metadata from Eclipse Orbit project
- # Rip out of MANIFEST.MF included in this JAR:
- # http://www.eclipse.org/downloads/download.php?r=1&file=/tools/orbit/downloads/drops/R20110523182458/repository/plugins/org.mozilla.javascript_1.7.2.v201005080400.jar
- Patch1: %{name}-addOrbitManifest.patch
- Patch2: %{name}-shell-manpage.patch
- # Originally from https://github.com/mozilla/rhino/commit\
- # /52e25f784cd1b927d44383aa9afb358191df97e4.patch
- # See RHBZ# 1011947
- Patch3: %{name}-overflow-detection.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- BuildRequires: ant
- BuildRequires: java-devel
- Requires: jpackage-utils
- Requires: jline
- # Disable xmlbeans until we can get it into Fedora
- #Requires: xmlbeans
- #BuildRequires: xmlbeans
- %description
- Rhino is an open-source implementation of JavaScript written entirely
- in Java. It is typically embedded into Java applications to provide
- scripting to end users.
- %description -l ja
- Rhino はすべてが Java で記述された JavaScript のオープンソースな実装です.
- 一般的には Java アプリケーションに組み込まれることで、エンドユーザーによる
- スクリプトの記述が可能になります.
- %package demo
- Summary: Examples for %{name}
- Summary(ja): %{name} のデモプログラム
- Group: Development/Libraries
- %description demo
- Examples for %{name}.
- #%package manual
- #Summary: Manual for %{name}
- #Group: Documentation
- #
- #%description manual
- #Documentation for %{name}.
- %prep
- %setup -q -n %{name}-Rhino%{scm_version}_RELEASE
- %patch0 -p1 -b .build
- %patch1 -p1 -b .fixManifest
- %patch2 -p1 -b .manpage
- %patch3 -p1 -b .overflow
- # Fix build
- sed -i -e '/.*<get.*src=.*>$/d' build.xml testsrc/build.xml \
- toolsrc/org/mozilla/javascript/tools/debugger/build.xml xmlimplsrc/build.xml
- # Fix manifest
- sed -i -e '/^Class-Path:.*$/d' src/manifest
- # Add jpp release info to version
- sed -i -e 's|^implementation.version: Rhino .* release .* \${implementation.date}|implementation.version: Rhino %{version} release %{release} \${implementation.date}|' build.properties
- %build
- ant deepclean jar copy-all -Dno-xmlbeans=1
- pushd examples
- export CLASSPATH=../build/%{name}%{scm_version}/js.jar:$(build-classpath xmlbeans/xbean 2>/dev/null)
- %{javac} *.java
- %{jar} cvf ../build/%{name}%{scm_version}/%{name}-examples.jar *.class
- popd
- %install
- rm -rf $RPM_BUILD_ROOT
- # jars
- mkdir -p $RPM_BUILD_ROOT%{_javadir}
- cp -a build/%{name}%{scm_version}/js.jar $RPM_BUILD_ROOT%{_javadir}
- ln -s js.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
- cp -a build/%{name}%{scm_version}/%{name}-examples.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-examples.jar
- # man page
- mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
- install -m 644 build/%{name}%{scm_version}/man/%{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
- ## script
- mkdir -p $RPM_BUILD_ROOT%{_bindir}
- install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
- # examples
- mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
- cp -a examples/* $RPM_BUILD_ROOT%{_datadir}/%{name}
- find $RPM_BUILD_ROOT%{_datadir}/%{name} -name '*.build' -delete
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(0644,root,root,0755)
- %doc LICENSE.txt
- %attr(0755,root,root) %{_bindir}/*
- %{_javadir}/*
- %{_mandir}/man1/%{name}.1*
- %files demo
- %defattr(0644,root,root,0755)
- %{_datadir}/%{name}
- #%files manual
- #%defattr(0644,root,root,0755)
- #%if 0
- #%doc build/%{name}%{scm_version}/docs/*
- #%endif
- %changelog
- * Fri Jan 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.7-0.r4.1
- - new upstream release
- * Sat Jun 2 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-0.r3.1
- - new upstream release
- * Wed Sep 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-0.r2.1
- - Initial build for VineLinux
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.7.r2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Sun May 31 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0:1.7-0.6.r2
- - Update to rhino1_7R2
- - Add patch from Steven Elliott to fix exception in the interpreter shell.
- * Mon Apr 20 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.4.r2pre.1.1
- - Added jpackage-utils requirement.
- - Resolves: rhbz#496435
- * Thu Mar 26 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.3.r2pre.1.1
- - Updated rhino-build.patch
- - License for treetable has been fixed. Re-included this code, and removed patch.
- - Resolves: rhbz#457336
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.2.r2pre.1.1
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Fri Feb 13 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.1.r2pre.1.1
- - Upgraded to 1.7r2pre.
- - Resolves: rhbz#485135
- * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.6-0.1.r5.1.3
- - drop repotag
- - fix license tag
- * Thu Mar 15 2007 Matt Wringe <mwringe@redhat.com> 0:1.6-0.1.r5.1jpp.2
- - Remove script from build as the debugging tool is disabled due to it
- containing proprietary code from Sun.
- * Wed Mar 07 2007 Deepak Bhole <dbhole@redhat.com> 0:1.6-0.1.r5.1jpp.1
- - Upgrade to 1.6r5
- - Change release per Fedora guidelines
- - Disable dependency on xmlbeans (optional component, not in Fedora yet)
- - Disable building of debugger tool, as it needs confidential code from Sun
- - Remove post/postuns for javadoc and add the two dirs as %%doc
- * Wed Jun 14 2006 Ralph Apel <r.apel@r-apel.de> 0:1.6-0.r2.2jpp
- - Add bea-stax-api in order to build xmlimpl classes
- * Tue May 31 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r2.1jpp
- - Upgrade to RC2
- * Mon Apr 24 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r1.2jpp
- - First JPP 1.7 build
- * Thu Dec 02 2004 David Walluck <david@jpackage.org> 0:1.6-0.r1.1jpp
- - 1_6R1
- - add demo subpackage containing example code
- - add jpp release info to implementation version
- - add script to launch js shell
- - build E4X implementation (Requires: xmlbeans)
- - remove `Class-Path' from manifest
- * Tue Aug 24 2004 Fernando Nasser <fnasser@redhat.com> - 0:1.5-1.R5.1jpp
- - Update to 1.5R5.
- - Rebuild with Ant 1.6.2
- * Sat Jul 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.5-1.R4.1.1jpp
- - Update to 1.5R4.1.
- - Non-versioned javadoc dir symlink.
- * Fri Apr 11 2003 David Walluck <davdi@anti-microsoft.org> 0:1.5-0.R4.2jpp
- - remove build patches in favor of perl
- - add epoch
- * Sun Mar 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.r4.1jpp
- - Update to 1.5R4.
- - Rebuild for JPackage 1.5.
- * Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R3.1jpp
- - 1.5R3
- - versioned dir for javadoc
- * Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.9jpp
- - versioned compatibility symlink
- * Mon Jan 21 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.8jpp
- - section macro
- - new release scheme
- * Thu Jan 17 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-7jpp
- - spec cleanup
- - changelog corrections
- * Fri Jan 11 2002 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-6jpp
- - backward compatibility js.jar symlink
- - used original swing exemples archive
- - fixed javadoc empty package-list file
- - no dependencies for manual and javadoc packages
- * Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-5jpp
- - javadoc in javadoc package
- - fixed offline build
- * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 1.5R2-4jpp
- - changed extension --> jpp
- * Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-3jpp
- - first unified release
- - s/jPackage/JPackage
- - corrected license to MPL
- * Sat Sep 15 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-2mdk
- - spec cleanup
- - standardized cvs references
- * Thu Aug 31 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-1mdk
- - first Mandrake release
|