wine-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838
  1. %define pkg_major_version 1.7.54
  2. %define pkg_name wine
  3. %define pkg_release 1%{?_dist_release}
  4. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  5. # spec file for package wine.. # base (SUSE10 and fedora core 9)
  6. Summary: Allows running Windows 16/32/64 bit programs on Unix.
  7. Summary(ja): Unix で 16/32/64ビットWindoowsプログラムを実行させます
  8. Name: %{pkg_name}
  9. Version: %{pkg_major_version}
  10. Release: %{pkg_release}
  11. URL: http://www.winehq.org/
  12. License: LGPLv2+
  13. Group: Applications/System
  14. #--------------------------------------------------------------------
  15. Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
  16. #--------------------------------------------------------------------
  17. Source1: wine.init
  18. Source3: wine-README-Fedora
  19. Source4: wine-32.conf
  20. # desktop stuff
  21. Source100: wine-notepad.desktop
  22. Source101: wine-regedit.desktop
  23. Source102: wine-uninstaller.desktop
  24. Source103: wine-winecfg.desktop
  25. Source104: wine-winefile.desktop
  26. Source105: wine-winemine.desktop
  27. Source106: wine-winhelp.desktop
  28. Source107: wine-wineboot.desktop
  29. # desktop dir
  30. Source200: wine.menu
  31. Source201: wine.directory
  32. # mime types
  33. Source300: wine-mime-msi.desktop
  34. # explain how to use wine with pulseaudio
  35. Source402: README-FEDORA-PULSEAUDIO
  36. Patch400: http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
  37. Patch401: http://art.ified.ca/downloads/winepulse-0.30.patch
  38. Patch402: http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
  39. Patch0: wine-prefixfonts.patch
  40. Patch1: wine-1.1.28-rpath.patch
  41. Patch2: wine-1.7.40-x86_64_gstreamer.patch
  42. # ADD ja
  43. Source801: wine_README.ja
  44. Source802: README-FEDORA-PULSEAUDIO.ja
  45. Source803: wine-README-Fedora.ja
  46. Source804: wine_README_add.ja
  47. Source805: fonts-replace-list.txt
  48. Source806: ja_fonts_replace-js2ipa.reg
  49. Source807: ja_fonts_replace-js2vl.reg
  50. Source808: ja_fonts_replace-ms2ipa.reg
  51. Source809: ja_fonts_replace-ms2vl.reg
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: daisuke, Takemikaduchi
  55. ExclusiveArch: %{ix86} x86_64
  56. #--------------------------------------------------------------------
  57. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  58. #--------------------------------------------------------------------
  59. ## FedoraCore ##
  60. BuildRequires: bison, flex
  61. BuildRequires: audiofile, audiofile-devel
  62. BuildRequires: alsa-lib-devel
  63. BuildRequires: freeglut-devel, lcms-devel
  64. ## BuildRequires: libieee1284-devel
  65. BuildRequires: libjpeg-devel, libpng-devel
  66. BuildRequires: libstdc++-devel
  67. BuildRequires: libusb-devel
  68. BuildRequires: libxml2-devel, libxslt-devel
  69. BuildRequires: openldap-devel, ncurses-devel
  70. BuildRequires: unixODBC-devel, openssl-devel
  71. # BuildRequires: sane-devel
  72. BuildRequires: zlib-devel
  73. BuildRequires: desktop-file-utils
  74. BuildRequires: fontforge
  75. ## BuildRequires: gphoto2, gphoto2-devel
  76. ## BuildRequires: jack-audio-connection-kit-devel
  77. ## BuildRequires: isdn4k-utils-devel
  78. BuildRequires: cups-devel
  79. BuildRequires: dbus-devel
  80. BuildRequires: gstreamer-plugins-base-devel
  81. ## Requires: %{_bindir}/xmessage
  82. ## X modular(fc) > X 7.2
  83. BuildRequires: libX11-devel
  84. BuildRequires: mesa-libGL-devel
  85. BuildRequires: mesa-libGLU-devel
  86. BuildRequires: mesa-libOSMesa-devel
  87. BuildRequires: libXxf86dga-devel, libXxf86vm-devel
  88. BuildRequires: libXrandr-devel
  89. BuildRequires: libXrender-devel
  90. BuildRequires: libXext-devel
  91. BuildRequires: libXinerama-devel
  92. BuildRequires: libXcomposite-devel
  93. BuildRequires: libXmu-devel
  94. BuildRequires: libXi-devel
  95. BuildRequires: libXcursor-devel
  96. BuildRequires: fontconfig-devel
  97. BuildRequires: giflib-devel
  98. BuildRequires: libtiff-devel
  99. BuildRequires: pkgconfig
  100. BuildRequires: libicu-devel
  101. BuildRequires: freetype2-devel
  102. BuildRequires: lcms2-devel
  103. BuildRequires: gsm-devel
  104. %ifarch x86_64
  105. BuildRequires: compat32-glibc-devel
  106. BuildRequires: compat32-glibc-devel
  107. BuildRequires: compat32-libX11-devel
  108. BuildRequires: compat32-libxcb-devel
  109. BuildRequires: compat32-freetype2-devel
  110. BuildRequires: compat32-libSM-devel
  111. BuildRequires: compat32-libXext-devel
  112. BuildRequires: compat32-libXrender-devel
  113. BuildRequires: compat32-mesa-libGL-devel
  114. BuildRequires: compat32-mesa-libGLU-devel
  115. BuildRequires: compat32-mesa-libOSMesa-devel
  116. BuildRequires: compat32-libxml2-devel
  117. BuildRequires: compat32-libxslt-devel
  118. BuildRequires: compat32-openssl-devel
  119. BuildRequires: compat32-libjpeg-devel
  120. BuildRequires: compat32-libpng-devel
  121. BuildRequires: compat32-zlib-devel
  122. BuildRequires: compat32-alsa-lib-devel
  123. BuildRequires: compat32-dbus-devel
  124. BuildRequires: compat32-lcms2-devel
  125. BuildRequires: compat32-cups-devel
  126. BuildRequires: compat32-gnutls-devel
  127. BuildRequires: compat32-gstreamer-devel
  128. BuildRequires: compat32-gstreamer-plugins-base-devel
  129. BuildRequires: compat32-gsm-devel
  130. ## extension
  131. BuildRequires: compat32-libXcursor-devel
  132. BuildRequires: compat32-libXi-devel
  133. BuildRequires: compat32-libXxf86vm-devel
  134. BuildRequires: compat32-libXrandr-devel
  135. BuildRequires: compat32-libXinerama-devel
  136. BuildRequires: compat32-libXcomposite-devel
  137. BuildRequires: compat32-ncurses-devel
  138. BuildRequires: compat32-fontconfig-devel
  139. BuildRequires: compat32-libtiff-devel
  140. BuildRequires: compat32-openldap-devel
  141. Requires: compat32-freetype2
  142. Requires: compat32-ncurses
  143. %endif
  144. Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
  145. Requires(post): desktop-file-utils >= 0.8
  146. Requires(preun): /sbin/chkconfig, /sbin/service
  147. Requires(postun): /sbin/ldconfig
  148. Requires(postun): desktop-file-utils >= 0.8
  149. #--------------------------------------------------------------------
  150. %description
  151. (WINE Is Not an Emulator)
  152. While Wine is usually thought of as a Windows(TM) emulator,
  153. the Wine developers would prefer that users thought of
  154. Wine as a Windows compatibility layer for UNIX.
  155. This package includes a program loader, which allows
  156. unmodified Windows 3.x/9x/NT binaries to run on x86 and
  157. x86_64 Unixes.
  158. Wine does not require MS Windows, but it can use native
  159. system .dll files if they are available.
  160. %description -l ja
  161. (WINE Is Not an Emulator)
  162. WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
  163. 開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
  164. 互換レイヤー」と考えてくれる事を好むでしょう。
  165. このパッケージはプログラムローダーを含み、これは未修正の
  166. Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
  167. させます。
  168. WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
  169. Windows システムの .dll ファイルが存在するのならば、それを使用する
  170. 事もできます
  171. #--------------------------------------------------------------------
  172. %package devel
  173. Summary: Wine development environment
  174. Summary(ja): WINE の開発ファイルです
  175. Group: System Environment/Libraries
  176. Requires: wine = %{version}-%{release}
  177. %description devel
  178. This RPM contains the header files and development tools
  179. for the WINE libraries.
  180. %description devel -l ja
  181. WINEの開発用ライブラリやヘッダーファイル、そして開発用の
  182. アプリケーション(例:winebuild)のパッケージです
  183. (development packages)
  184. #--------------------------------------------------------------------
  185. %package init
  186. Summary: WINE binfmt_misc kernel function used for init file.
  187. Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
  188. Group: System Environment/Libraries
  189. Requires: wine = %{version}-%{release}
  190. %description init
  191. WINE binfmt_misc kernel function used for init file.
  192. WIN32-binary attribute run with a Linux-binary run the same way as possible.
  193. (init.d packages)
  194. ** example **
  195. Until now, "$ wine /file/to/path/arege.exe" and then you were running
  196. from the usual binary Linux as "$ /file/to/path/arege.exe"
  197. and just be able to run.
  198. Of course, please be mindful of security.
  199. %description init -l ja
  200. カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
  201. 実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
  202. ようにします。
  203. (init.d packages)
  204. ※ 例 ※
  205. これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
  206. が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
  207. だけで実行できるようになります。
  208. 無論、セキュリティに留意して下さい。
  209. #--------------------------------------------------------------------
  210. %prep
  211. %setup -q -n %{name}-%{version}
  212. %ifarch x86_64
  213. %patch2 -p1
  214. %endif
  215. %patch401 -p1
  216. # fix typo
  217. sed -i "s|Thamoa|Tahoma|" po/ja.po
  218. %build
  219. autoreconf -if
  220. %ifarch x86_64
  221. export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
  222. ./configure \
  223. --prefix=%{_prefix} \
  224. --libdir=%{_libdir} \
  225. --with-x \
  226. --without-jack \
  227. --without-capi \
  228. --without-gphoto \
  229. --without-hal \
  230. --without-mpg123 \
  231. --without-sane
  232. %else
  233. export CFLAGS="$RPM_OPT_FLAGS"
  234. %{configure} \
  235. --prefix=%{_prefix} \
  236. --with-x \
  237. --without-jack \
  238. --without-capi \
  239. --without-gphoto \
  240. --without-hal \
  241. --without-mpg123 \
  242. --without-sane
  243. %endif
  244. grep "have_x=yes" config.log || exit 1
  245. %{__make} depend
  246. %{__make} %{?_smp_mflags}
  247. %install
  248. rm -rf ${RPM_BUILD_ROOT}
  249. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  250. #-----------------------------------------------------------FC9
  251. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
  252. # Allow users to launch Windows programs by just clicking on the .exe file...
  253. mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
  254. install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
  255. # add wine dir to desktop
  256. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
  257. install -p -m 644 %{SOURCE200} \
  258. ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  259. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
  260. install -p -m 644 %{SOURCE201} \
  261. ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
  262. ## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  263. ## %%{_datadir}/applications
  264. # install desktop files
  265. desktop-file-install \
  266. --vendor=vine \
  267. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  268. %{SOURCE100}
  269. desktop-file-install \
  270. --vendor=vine \
  271. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  272. %{SOURCE101}
  273. desktop-file-install \
  274. --vendor=vine \
  275. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  276. %{SOURCE102}
  277. desktop-file-install \
  278. --vendor=vine \
  279. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  280. %{SOURCE103}
  281. desktop-file-install \
  282. --vendor=vine \
  283. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  284. %{SOURCE104}
  285. desktop-file-install \
  286. --vendor=vine \
  287. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  288. %{SOURCE105}
  289. desktop-file-install \
  290. --vendor=vine \
  291. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  292. %{SOURCE106}
  293. desktop-file-install \
  294. --vendor=vine \
  295. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  296. %{SOURCE107}
  297. desktop-file-install \
  298. --vendor=vine \
  299. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  300. --delete-original \
  301. ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
  302. #mime-types
  303. desktop-file-install \
  304. --vendor=vine \
  305. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  306. %{SOURCE300}
  307. ## other files
  308. cp %{SOURCE3} README-Fedora
  309. cp %{SOURCE803} README-Fedora.ja
  310. cp %{SOURCE801} documentation/README.ja
  311. cp %{SOURCE804} documentation/README_add.ja
  312. cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
  313. mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
  314. install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  315. # deploy pulseaudio readme (802jp)
  316. cp %{SOURCE402} .
  317. cp %{SOURCE802} .
  318. # check desktop files
  319. %check
  320. desktop-file-validate \
  321. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
  322. desktop-file-validate \
  323. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
  324. desktop-file-validate \
  325. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
  326. desktop-file-validate \
  327. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
  328. desktop-file-validate \
  329. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
  330. desktop-file-validate \
  331. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
  332. desktop-file-validate \
  333. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
  334. desktop-file-validate \
  335. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
  336. desktop-file-validate \
  337. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
  338. #--------------------------------------------------------------------
  339. %clean
  340. rm -rf ${RPM_BUILD_ROOT}
  341. %post
  342. /sbin/ldconfig
  343. update-desktop-database &>/dev/null || :
  344. ### add vinelinux
  345. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  346. echo "WINEのシステムフォントをリプレースするには"
  347. echo " fonts-replace-list.txt をお読み下さい。"
  348. else
  349. echo "You need to Japanese fonts name replace, "
  350. echo "See fonts-replace-list.txt ."
  351. fi
  352. %postun
  353. /sbin/ldconfig
  354. update-desktop-database &>/dev/null || :
  355. %post init
  356. if [ $1 = 1 ]; then
  357. /sbin/chkconfig --add wine
  358. /sbin/chkconfig --level 2345 wine on
  359. /sbin/service wine start &>/dev/null || :
  360. fi
  361. ### add vinelinux
  362. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  363. echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
  364. echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
  365. echo "(ファイル名は /etc/init.d/wine です)"
  366. echo "起動時にファイルシステムのマウントが必要です。"
  367. echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
  368. echo "(削除も手動でお願いします)"
  369. echo ""
  370. echo "# cp /etc/fstab /etc/fstab.before ##バックアップの作成"
  371. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  372. echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
  373. else
  374. echo "WINE binfmt_misc feature from the boot files "
  375. echo "to be installed and enabled 2,3,4,5 runlevel."
  376. echo "(File name in the /etc/init.d/wine )"
  377. echo "Filesystem mounted at boot time is required."
  378. echo "Root privileges using the following command in the /etc/fstab"
  379. echo "please Addenda.(Please delete manually.)"
  380. echo ""
  381. echo "# cp /etc/fstab /etc/fstab.before ##(Create backup)"
  382. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  383. echo "See also(en)http://www.linux.com/articles/56032 "
  384. fi
  385. %preun init
  386. if [ $1 = 0 ]; then
  387. /sbin/service wine stop >/dev/null 2>&1
  388. /sbin/chkconfig --del wine
  389. fi
  390. #--------------------------------------------------------------------
  391. ## deleted /usr/share/applications/wine.desktop
  392. %files
  393. %defattr(-,root,root,-)
  394. %doc ANNOUNCE AUTHORS COPYING.LIB LICENSE LICENSE.OLD
  395. %doc README VERSION
  396. %doc README-FEDORA-PULSEAUDIO
  397. %doc README-FEDORA-PULSEAUDIO.ja
  398. %doc README-Fedora
  399. %doc README-Fedora.ja
  400. %doc documentation/README* documentation/ChangeLog*
  401. %doc documentation/ja_fonts_replace*
  402. %doc documentation/fonts-replace-list.txt
  403. ### %{_bindir}/*
  404. %{_bindir}/msiexec
  405. %{_bindir}/regedit
  406. %{_bindir}/regsvr32
  407. %{_bindir}/wine
  408. %{_bindir}/wineboot
  409. %{_bindir}/wineconsole
  410. ## %{_bindir}/wineprefixcreate
  411. %{_bindir}/winecfg
  412. %{_bindir}/wine-preloader
  413. # winelauncher --> Remove
  414. %{_bindir}/wineserver
  415. %{_bindir}/notepad
  416. %{_bindir}/winedbg
  417. %{_bindir}/winedump
  418. %{_bindir}/winefile
  419. %{_bindir}/winemaker
  420. %{_bindir}/winemine
  421. %{_bindir}/winepath
  422. ## winhelp -> renamed winhlp32.exe
  423. %{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  424. %{_sysconfdir}/ld.so.conf.d/wine-32.conf
  425. %{_libdir}/libwine.so.1*
  426. %dir %{_libdir}/wine
  427. %{_libdir}/wine/*.cpl.so
  428. %{_libdir}/wine/*.exe.so
  429. %{_libdir}/wine/*.exe16.so
  430. %{_libdir}/wine/*.dll.so
  431. %{_libdir}/wine/*.dll16.so
  432. %{_libdir}/wine/*.drv.so
  433. %{_libdir}/wine/*.drv16.so
  434. %{_libdir}/wine/*.mod16.so
  435. ## %{_libdir}/wine/*.*16
  436. %{_libdir}/wine/*.ds.so
  437. %{_libdir}/wine/*.ocx.so
  438. %{_libdir}/wine/*.vxd.so
  439. %{_libdir}/wine/*.acm.so
  440. %{_libdir}/wine/*.sys.so
  441. %{_libdir}/wine/*.tlb.so
  442. %dir %{_libdir}/wine/fakedlls
  443. %{_libdir}/wine/fakedlls/*
  444. %dir %{_datadir}/wine
  445. %{_datadir}/wine/*
  446. %{_datadir}/applications/vine-wine-mime-msi.desktop
  447. %{_datadir}/applications/vine-wine.desktop
  448. %{_datadir}/applications/vine-wine-regedit.desktop
  449. %{_datadir}/applications/vine-wine-uninstaller.desktop
  450. %{_datadir}/applications/vine-wine-winecfg.desktop
  451. %{_datadir}/applications/vine-wine-wineboot.desktop
  452. %{_datadir}/applications/vine-wine-notepad.desktop
  453. %{_datadir}/applications/vine-wine-winefile.desktop
  454. %{_datadir}/applications/vine-wine-winemine.desktop
  455. %{_datadir}/applications/vine-wine-winhelp.desktop
  456. %{_datadir}/desktop-directories/Wine.directory
  457. %{_mandir}/man1/wine.1.*
  458. %{_mandir}/man1/wineserver.1*
  459. %{_mandir}/man1/msiexec.1*
  460. %{_mandir}/man1/notepad.1*
  461. %{_mandir}/man1/regedit.1*
  462. %{_mandir}/man1/regsvr32.1*
  463. %{_mandir}/man1/wineboot.1*
  464. %{_mandir}/man1/winecfg.1*
  465. %{_mandir}/man1/wineconsole.1*
  466. %{_mandir}/man1/winefile.1*
  467. %{_mandir}/man1/winemine.1*
  468. %{_mandir}/man1/winepath.1*
  469. ## %{_mandir}/man1/wineprefixcreate.1*
  470. %lang(de) %{_mandir}/de.UTF-8/man1/*.1*
  471. %lang(fr) %{_mandir}/fr.UTF-8/man1/*
  472. %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
  473. #--------------------------------------------------------------------
  474. %files devel
  475. %defattr(-,root,root,-)
  476. %{_bindir}/function_grep.pl
  477. %{_bindir}/widl
  478. %{_bindir}/winebuild
  479. %{_bindir}/winecpp
  480. %{_bindir}/winedump
  481. %{_bindir}/wineg++
  482. %{_bindir}/winegcc
  483. %{_bindir}/winemaker
  484. %{_bindir}/wmc
  485. %{_bindir}/wrc
  486. %{_includedir}/wine
  487. %{_libdir}/*.so
  488. %{_libdir}/wine/*.a
  489. %{_libdir}/wine/*.def
  490. %{_mandir}/man1/widl.1*
  491. %{_mandir}/man1/winebuild.1*
  492. %{_mandir}/man1/winecpp.1*
  493. %{_mandir}/man1/winedump.1*
  494. %{_mandir}/man1/winegcc.1*
  495. %{_mandir}/man1/winemaker.1*
  496. %{_mandir}/man1/wmc.1*
  497. %{_mandir}/man1/wrc.1*
  498. %{_mandir}/man1/winedbg.1*
  499. %{_mandir}/man1/wineg++.1*
  500. #--------------------------------------------------------------------
  501. %files init
  502. %defattr(-,root,root,-)
  503. %{_initrddir}/wine
  504. %doc documentation/README_add.ja
  505. #--------------------------------------------------------------------
  506. %changelog
  507. * Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.54-1
  508. - update to 1.7.54
  509. * Sat Oct 24 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.53-1
  510. - update to 1.7.53
  511. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.52-1
  512. - update to 1.7.52
  513. * Sun Sep 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.51-1
  514. - update to 1.7.51
  515. * Sun Aug 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.50-1
  516. - update to 1.7.50
  517. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.49-1
  518. - update to 1.7.49
  519. * Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.48-1
  520. - update to 1.7.48
  521. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.44-1
  522. - update to 1.7.44
  523. * Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.42-1
  524. - update to 1.7.42
  525. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.40-1
  526. - update to 1.7.40
  527. - update Patch2 (wine-1.7.40-x86_64_gstreamer.patch)
  528. - add BuildRequires: compat32-mesa-libOSMesa-devel, compat32-lcms2-devel, compat32-gsm-devel (x86_64 only)
  529. - add BuildRequires: mesa-libOSMesa-devel, lcms2-devel, gsm-devel
  530. * Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
  531. - new upstream release
  532. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  533. - new upstream release
  534. * Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
  535. - new upstream release
  536. - remove Patch1000 (wine-1.4.1-vine.patch)
  537. - update Patch2 (wine-1.6-x86_64_gstreamer.patch)
  538. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
  539. - update to 1.5.17
  540. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  541. - new upstream release
  542. - update Patch1000 (wine-1.4.1-vine.patch)
  543. * Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
  544. - new upstream release
  545. - add Patch2 (wine-1.4-x86_64_gstreamer.patch)
  546. - add BuildRequires: gstreamer-plugins-base-devel
  547. * Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  548. - update to 1.2.3
  549. - add Requires: compat32-freetype2 (x86_64 only)
  550. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
  551. - new upstream release
  552. * Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  553. - new upstream release
  554. - drop Patch1
  555. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
  556. - new upstream release
  557. - fix %configure (add configu:e and gcc option of x86_64)
  558. - fix %install (remove wine.desktop and change make install option)
  559. - add ExclusiveArch: %{ix86} x86_64
  560. - add BuildRequires for x86_64 (compat32 packages)
  561. * Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
  562. - update to 1.2-rc2
  563. - fix spec file
  564. - if [ "$LANG" = "ja_JP.eucJP" ];
  565. + if [ "$LANG" = "ja_JP.UTF-8" ];
  566. - convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
  567. - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
  568. - fix %files
  569. - drop patches (Patch0, Patch400, Patch402)
  570. * Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
  571. - update BRs
  572. - remove freetype-devel
  573. - remove libungif-devel, add giflib-devel
  574. - remove gphoto2-devel, add libgphoto2-devel
  575. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
  576. - update to 1.1.29
  577. * Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
  578. - update to 1.1.28
  579. - update winepulse patches
  580. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
  581. - update to 1.1.23
  582. - spec in utf-8
  583. - add patch1000 to enable FontSmoothing by deafult.
  584. - update pulseaudio patches
  585. - remove invalid Provides: Wine HQ
  586. - remove unneeded patches
  587. * Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
  588. - Wine development release 1.1.0.
  589. - Updated specfile (for VineSeed)
  590. #--------------------------------------------------------------------
  591. * Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
  592. - added "ja_fonts_replace-*.reg" files.
  593. - Updated specfile
  594. * Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
  595. - version upgrade
  596. - Updated specfile
  597. - Update to 1.0
  598. - fix wine.desktop mime types (fc)
  599. - add desktop package including desktop files and binary handler (fc)
  600. - pull in some wine alsa/pulseaudio patches (fc)
  601. -- NEWS "June 17, 2008: Wine 1.0 Released"
  602. -- read http://www.winehq.org/?issue=348
  603. * Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
  604. - Updated specfile
  605. - Update to 1.0-rc4
  606. - NEWS "June 6, 2008: Wine 1.0-rc4 Released"
  607. -- ntdll: Add local defines for VIF and VIP flags.
  608. -- wininet: Include openssl/ssl.h before Windows headers.
  609. -- shell32: Fixed the French about box.
  610. -- ChangeLog: Moved to documentation/ChangeLog.BETA.
  611. -- fonts: Add a non-breaking space glyph to the Tahoma fonts.
  612. -- ....others , read ChangeLog
  613. --- Bug fixes only, we are in code freeze.
  614. * Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
  615. - Updated specfile
  616. - Update to 1.0-rc3
  617. - NEWS "May 30, 2008: Wine 1.0-rc3 Released"
  618. -- The default version is now Windows XP.
  619. -- Many Richedit improvements.
  620. -- Beginning of jscript dll support.
  621. -- Shell folders now respect XDG directory configuration.
  622. -- Many translation updates.
  623. -- Lots of bug fixes.
  624. -- * Bug fixes only, we are in code freeze.
  625. --- kernel32: Add a builtin 16-bit winhelp.exe.
  626. --- This should be moved to winhlp32.exe once we support 16-bit modules in
  627. --- executables.
  628. ---- winhelp -> renamed winhlp32.exe
  629. ---- programs: Remove winelauncher from install rules.
  630. * Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
  631. - Updated specfile
  632. - Update to 0.9.59
  633. - NEWS.. "April 4, 2008: Wine 0.9.59 Released"
  634. -- * Improved support for the .NET framework.
  635. -- * Better services handling through a separate services.exe process.
  636. -- * Support for ATI fragment shader.
  637. -- * Better support for http proxies.
  638. -- * Window management fixes.
  639. -- * Pre-compiled fonts are now available in the source tree.
  640. -- * Lots of bug fixes.
  641. * Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
  642. - Updated specfile (split wine-init package)
  643. - Update to 0.9.58
  644. - NEWS.. "March 21, 2008: Wine 0.9.58 Released"
  645. -- * The default version is now Windows XP.
  646. -- * Many Richedit improvements.
  647. -- * Beginning of jscript dll support.
  648. -- * Shell folders now respect XDG directory configuration.
  649. -- * Many translation updates.
  650. -- * Lots of bug fixes.
  651. * Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
  652. - Updated specfile (*.desktop file %check .)
  653. - Update to 0.9.57
  654. - NEWS.. "March 7, 2008: Wine 0.9.57 Released"
  655. -- * Support for multiple OpenGL pixel formats.
  656. -- * Improved support for color profiles.
  657. -- * Many window management fixes.
  658. -- * Better fullscreen support.
  659. -- * Lots of bug fixes.
  660. * Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
  661. - Updated specfile
  662. - ("Build Tool" from the wine-package to move to devel-packages)
  663. - Update to 0.9.56
  664. - NEWS.. "February 22, 2008: Wine 0.9.56 Released"
  665. -- * Proper handling of OpenGL/Direct3D windows with menu bars.
  666. -- * Stubs for all the d3dx9_xx dlls.
  667. -- * Several graphics optimizations.
  668. -- * Many installer fixes.
  669. -- * Improved MIME message support.
  670. -- * Lots of bug fixes.
  671. * Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
  672. - Updated specfile (cf. VineLinux .spec file format)
  673. - Add Installed messages for "binfmt_misc" .
  674. - *.desktop file "Name" change to japanese. (UTF8)
  675. * Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
  676. - Import WINE - Packager: Babasaki
  677. - Updated specfile (SUSE base + FC9 cfg)
  678. - Update to 0.9.55
  679. - Update to 0.9.54 from FC9
  680. - Update to 0.9.53 from Private package
  681. # FC9 ------------------------------------------------------------- FC9
  682. * Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  683. - 0.9.55-1
  684. - version upgrade
  685. * Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  686. - 0.9.54-1
  687. - version upgrade
  688. - remove default pulseaudio workaround (#429420,#428745)
  689. - improve pulseaudio readme
  690. * Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  691. - 0.9.53-2
  692. - add some missing BR
  693. * Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  694. - 0.9.53-1
  695. - version upgrade
  696. * Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  697. - 0.9.52-2
  698. - fix menu bug (#393641)
  699. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  700. - 0.9.52-1
  701. - version upgrade
  702. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  703. - 0.9.51-3
  704. - add -n Wine to pulseaudio workaround
  705. - try to fix menu bug #393641
  706. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  707. - 0.9.51-2
  708. - add fix for #344281 pulseaudio workaround
  709. - fix #253474: wine-jack should require jack-audio-connection-kit
  710. * Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  711. - 0.9.51-1
  712. - version upgrade
  713. # ---- abbreviatio ----------------------------------------------------#
  714. # ----------and suse.
  715. # * Fri Mar 17 2006 - meissner@suse.de
  716. # - Avoid ulimit leading to out of memory situations by using
  717. # the compat address space layout personality. #152115