pandoc-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212
  1. %define pkg_name pandoc
  2. %define pkg_version 2.2.2
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: general markup converter
  5. Summary(ja): 汎用マークアップ変換ツール
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2+
  10. Group: Applications/Text
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. Source11: pandoc-2.2.2.tar.gz
  14. Source12: pandoc.cabal
  15. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  16. BuildRequires: ghc haskell-platform
  17. BuildRequires: libffi-devel gmp-devel zlib-devel
  18. BuildRequires: libghc-data-default-class
  19. BuildRequires: libghc-dlist
  20. BuildRequires: libghc-old-locale
  21. BuildRequires: libghc-aeson
  22. BuildRequires: libghc-semigroups
  23. BuildRequires: yaml
  24. BuildRequires: libghc-http-client-tls
  25. BuildRequires: libghc-haddock-library
  26. BuildRequires: libghc-build-pandoc
  27. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  28. Requires: libffi
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Packager: ara_t
  32. %description
  33. Pandoc is a Haskell library for converting from one markup format to another,
  34. and a command-line tool that uses this library.
  35. It can read markdown and (subsets of) HTML, reStructuredText, LaTeX, DocBook,
  36. MediaWiki markup, Haddock markup, OPML, Emacs Org-mode, and Textile,
  37. and it can write markdown, reStructuredText, HTML,
  38. LaTeX (including rendering as plain PDF or beamer slide shows),
  39. ConTeXt, DocBook, OPML, OpenDocument, ODT, Word docx, RTF, MediaWiki, Textile,
  40. groff man pages, GNU Texinfo, plain text, Emacs Org-Mode, AsciiDoc, InDesign
  41. ICML, EPUB (v2 or v3), FictionBook2, and several kinds of HTML/javascript
  42. slide shows (S5, Slidy, Slideous, DZSlides, reveal.js).
  43. Pandoc extends standard markdown syntax with footnotes, embedded LaTeX,
  44. definition lists, tables, and other features.
  45. A compatibility mode is provided for those who need a drop-in replacement for
  46. Markdown.pl.
  47. In contrast to existing tools for converting markdown to HTML,
  48. which use regex substitutions, pandoc has a modular design:
  49. it consists of a set of readers, which parse text in a given format
  50. and produce a native representation of the document,
  51. and a set of writers, which convert this native representation into a target
  52. format.
  53. Thus, adding an input or output format requires only adding a reader or writer.
  54. %description -l ja
  55. Pandoc はあるマークアップ形式から別の形式に変換するHaskellライブラリで、
  56. また、このライブラリを使ったコマンドラインツールです。
  57. markdown、HTML (のサブセット)、reStructuredText、 LaTeX、DocBook、
  58. MediaWikiマークアップ、Haddockマークアップ、OPML、Emacs Org-mode、
  59. およびTextileを読み取り、
  60. markdown、reStructuredText、HTML、LaTeX (プレインPDFまたはbeamerスライドショー
  61. での描画を含む)、ConTeXt、DocBook、OPML、OpenDocument、ODT、Word docx、RTF、
  62. MediaWiki、Textile、groff manページ、GNU Texinfo、プレーンテキスト、
  63. Emacs Org-Mode、AsciiDoc、InDesign ICML、EPUB (v2 または v3)、FictionBook2、
  64. およびいくつかの種類のHTML/javascriptスライドショー
  65. (S5, Slidy, Slideous, DZSlides, reveal.js) に書き出せます。
  66. Pandocは標準的なmarkdownの文法に脚注、組み込み LaTeX、定義リスト、表、
  67. およびその他の機能を拡張しています。
  68. Markdown.plの気軽な置き換えを希望する方向けに互換モードを提供しています。
  69. markdownからHTMLに変換する既存のツールは正規表現で置換していますが、
  70. これらとは異なり、pandoc はモジュール式の設計になっています:
  71. テキストを指定された形式でパースし、文書のネイティブ表現を生成するリーダ一式、
  72. および、このネイティブ表現を対象とする形式に変換するライタ一式で構成されて
  73. います。したがって、入力または出力形式を追加するにはリーダやライタを追加する
  74. ことだけが必要です。
  75. %package libs
  76. Summary: Library of pandoc
  77. Group: Development/Libraries
  78. Requires: haskell-platform-dep
  79. Requires: libghc-data-default-class
  80. Requires: libghc-dlist
  81. Requires: libghc-old-locale
  82. Requires: libghc-aeson
  83. Requires: libghc-semigroups
  84. Requires: yaml
  85. Requires: libghc-http-client-tls
  86. Requires: libghc-haddock-library
  87. Requires: libghc-build-pandoc
  88. %description libs
  89. Librariy of pandoc for building pandoc-citeproc and pandoc-crossref
  90. %prep
  91. %{__rm} -rf ${RPM_BUILD_ROOT}
  92. %build
  93. %ghc_pkg_init
  94. cd %{_builddir}
  95. for pkg in `cat %{SOURCE0}`; do
  96. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  97. pushd ${pkg}
  98. %ghc_fix_dependencies ${pkg}
  99. %cabal_configure1 ${pkg}
  100. %cabal_build
  101. %cabal_haddock
  102. %cabal_copy_resister ${pkg}
  103. popd
  104. done
  105. %install
  106. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
  107. # copy documents and mannual
  108. pushd %{_builddir}/%{name}-%{version}
  109. %{__cp} \
  110. BUGS changelog CONTRIBUTING.md COPYING.md COPYRIGHT \
  111. MANUAL.txt README.md \
  112. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  113. %{__cp} man/pandoc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/
  114. popd
  115. %clean
  116. %{__rm} -rf ${RPM_BUILD_ROOT}
  117. %post libs
  118. %ghc_pkg_recache
  119. %postun libs
  120. %ghc_pkg_recache
  121. %files
  122. %defattr(-, root, root)
  123. %{_bindir}/pandoc
  124. %{_datadir}/%{name}-%{version}/
  125. %{_docdir}/%{name}-%{version}/
  126. %{_mandir}/man1/
  127. %files libs
  128. %defattr(-, root, root)
  129. %{_libdir}/ghc-%{ghc_version}/
  130. %{_libdir}/ghc-lib/%{name}-%{version}/
  131. %changelog
  132. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 2.2.2-1
  133. - update to 2.2.2
  134. - build using ghc-8.4.3
  135. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-1
  136. - update to 2.2.1
  137. - rebuild using ghc-8.4.2
  138. - rewrite using macro
  139. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 2.0.6-1
  140. - update to 2.0.6
  141. - build using ghc-8.2.2
  142. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 1.19.2.1-2
  143. - update to 1.19.2.1
  144. - build using ghc-8.0.2
  145. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-2
  146. - rebuild using ghc-8.0.1
  147. * Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
  148. - update to 1.17.1
  149. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-5
  150. - update to 1.17.0.3
  151. - add BuildRequires: libghc-build-pandoc
  152. - provide pandoc-libs for building pandoc-citeproc and pacdoc-crossref
  153. - delete subpackages: pandoc-citeproc and pacdoc-crossref
  154. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-5
  155. - correct SPEC file
  156. * Mon Mar 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-4
  157. - correct pandoc-citeproc error
  158. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
  159. - rebuild under dependent rpm packages
  160. * Sun Feb 21 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
  161. - rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
  162. * Sun Feb 07 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-1
  163. - new package