libXp-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276
  1. # libXp will be removed from future release.
  2. %define without_devel 0
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. Summary: X.Org X11 libXp runtime library
  5. Summary(ja): X.Org X11 libXp ランタイムライブラリ
  6. Name: libXp
  7. Version: 1.0.0
  8. Release: 4%{?_dist_release}
  9. License: MIT/X11
  10. Group: System Environment/Libraries
  11. URL: http://www.x.org
  12. Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
  13. Patch0: add-proto-files.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: xorg-x11-util-macros
  17. BuildRequires: xorg-x11-proto-devel
  18. BuildRequires: libX11-devel
  19. BuildRequires: libXext-devel
  20. BuildRequires: libXau-devel
  21. BuildRequires: libtool automake autoconf gettext
  22. Obsoletes: XFree86-libs, XOrg-libs
  23. %description
  24. X.Org X11 libXp runtime library
  25. %package devel
  26. Summary: X.Org X11 libXp development package
  27. Summary(ja): X.Org X11 libXp 開発パッケージ
  28. Group: Development/Libraries
  29. Requires(pre): xorg-x11-filesystem
  30. Requires: libXau-devel
  31. Requires: %{name} = %{version}-%{release}
  32. BuildRequires: xorg-x11-proto-devel
  33. Obsoletes: XFree86-devel, XOrg-devel
  34. %description devel
  35. X.Org X11 libXp development package
  36. # compat32
  37. %package -n compat32-%{name}
  38. Summary: X.Org X11 libXp runtime library
  39. Summary(ja): X.Org X11 libXp ランタイムライブラリ
  40. Group: System Environment/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. %description -n compat32-%{name}
  43. X.Org X11 libXp runtime library
  44. %package -n compat32-%{name}-devel
  45. Summary: X.Org X11 libXp development package
  46. Summary(ja): X.Org X11 libXp 開発パッケージ
  47. Group: Development/Libraries
  48. Requires(pre): xorg-x11-filesystem
  49. Requires: %{name}-devel = %{version}-%{release}
  50. Requires: compat32-%{name} = %{version}-%{release}
  51. Requires: compat32-libXau-devel
  52. %description -n compat32-%{name}-devel
  53. X.Org X11 libXp development package
  54. %prep
  55. %setup -q
  56. %patch0 -p1 -b .add-proto-files
  57. # Disable static library creation by default.
  58. %define with_static 0
  59. %build
  60. # There is a patch that changes configure.ac, so we have
  61. # run autoreconf
  62. CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
  63. export CPPFLAGS
  64. autoreconf -v --install
  65. %configure \
  66. %if ! %{with_static}
  67. --disable-static
  68. %endif
  69. make
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make install DESTDIR=$RPM_BUILD_ROOT
  73. %if %{without_devel}
  74. {
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.a
  76. rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.so
  77. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  78. rm -rf $RPM_BUILD_ROOT%{_mandir}
  79. }
  80. %endif
  81. # Don't encourage people to use the deprecated Xprint APIs.
  82. rm -rf $RPM_BUILD_ROOT%{_mandir}
  83. # We intentionally don't ship *.la files
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %post -p /sbin/ldconfig
  88. %postun -p /sbin/ldconfig
  89. %post -n compat32-%{name} -p /sbin/ldconfig
  90. %postun -n compat32-%{name} -p /sbin/ldconfig
  91. %files
  92. %defattr(-,root,root,-)
  93. %doc AUTHORS COPYING README INSTALL ChangeLog
  94. %{_libdir}/libXp.so.6
  95. %{_libdir}/libXp.so.6.2.0
  96. %if ! %{without_devel}
  97. %files devel
  98. %defattr(-,root,root,-)
  99. %if %{with_static}
  100. %{_libdir}/libXp.a
  101. %endif
  102. %{_includedir}/X11/extensions/Print.h
  103. %{_includedir}/X11/extensions/Printstr.h
  104. %{_libdir}/pkgconfig/printproto.pc
  105. # FIXME: Should we remove the shared lib during deprecation, so that things
  106. # that keep linking to libXp, will always get the static lib and not break
  107. # when we eventually drop libXp?
  108. %{_libdir}/libXp.so
  109. %{_libdir}/pkgconfig/xp.pc
  110. #%dir %{_mandir}/man3x
  111. #%{_mandir}/man3/*.3x*
  112. %endif
  113. # compat32
  114. %if %{build_compat32}
  115. %files -n compat32-%{name}
  116. %defattr(-,root,root,-)
  117. %{_libdir}/libXp.so.6
  118. %{_libdir}/libXp.so.6.2.0
  119. %if ! %{without_devel}
  120. %files -n compat32-%{name}-devel
  121. %defattr(-,root,root,-)
  122. %if %{with_static}
  123. %{_libdir}/libXp.a
  124. %endif
  125. %{_libdir}/pkgconfig/printproto.pc
  126. # FIXME: Should we remove the shared lib during deprecation, so that things
  127. # that keep linking to libXp, will always get the static lib and not break
  128. # when we eventually drop libXp?
  129. %{_libdir}/libXp.so
  130. %{_libdir}/pkgconfig/xp.pc
  131. %endif
  132. %endif
  133. %changelog
  134. * Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-4
  135. - rebuild with rpm-4.8.1 for pkg-config file
  136. * Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.0-3
  137. - added compat32 package for x86_64 arch support
  138. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  139. - spec in utf-8
  140. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  141. - new versioning policy
  142. * Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  143. - initial build for Vine Linux
  144. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.0-8
  145. - Rebuild for build id
  146. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-8
  147. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  148. * Wed Sep 20 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0.7
  149. - Add requires for the devel package on libXau-devel (173530)
  150. * Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
  151. - Add the proto files directly instead of attempting to build a separate
  152. tarball. Also remove last traces of printproto-1.0.3.tar.gz
  153. * Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com>
  154. - Remove printproto source.
  155. * Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
  156. - BuildRequire autoconf automake libtool gettext
  157. * Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
  158. - Run autoreconf to make sure changes to configure.ac take effect
  159. * Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
  160. - Add patch to not check for printproto.pc. (Since it's part of this
  161. package now, it isn't installed at the time libXp is configured).
  162. * Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-5
  163. - Moved Print.h, Printstr.h and printproto.pc into the devel package here
  164. (they used to be in xorg-x11-proto-devel).
  165. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
  166. - rebuild
  167. * Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-4
  168. - Renamed libXp_deprecated rpm macro to "with_devel" to avoid confusion. This
  169. library is still deprecated, we just decided to remove the word "deprecated"
  170. from the package name for library naming consistency.
  171. * Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
  172. - Replace "makeinstall" with "make install DESTDIR=..."
  173. - Added "Requires: xorg-x11-proto-devel" to devel for xp.pc
  174. - Remove package ownership of mandir/libdir/etc.
  175. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
  176. - bump again for double-long bug on ppc(64)
  177. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
  178. - rebuilt for new gcc4.1 snapshot and glibc changes
  179. * Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
  180. - Bumped and rebuilt
  181. * Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  182. - Updated libXp to version 1.0.0 from X11R7 RC4
  183. * Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  184. - Updated libXp to version 0.99.2 from X11R7 RC3
  185. - Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
  186. that /usr/lib/X11 and /usr/include/X11 pre-exist.
  187. - Removed 'x' suffix from manpage directories to match RC3 upstream.
  188. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  189. - rebuilt
  190. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
  191. - Added "Obsoletes: xorg-x11-deprecated-libs" to runtime package, and
  192. "Obsoletes: xorg-x11-deprecated-libs-devel" to devel package.
  193. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
  194. - Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
  195. - Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
  196. * Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
  197. - Updated libXp to version 0.99.1 from X11R7 RC1
  198. * Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
  199. - Renamed package to remove xorg-x11 from the name due to unanimous decision
  200. between developers.
  201. - Use Fedora Extras style BuildRoot tag.
  202. - Disable static library creation by default.
  203. - Add missing defattr to devel subpackage
  204. - Add missing documentation files to doc macro
  205. * Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
  206. - Renamed package to prepend "xorg-x11" to the name for consistency with
  207. the rest of the X11R7 packages.
  208. - Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
  209. subpackage to ensure the devel package matches the installed shared libs.
  210. - Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
  211. allow applications to use implementation agnostic dependencies.
  212. - Added post/postun scripts which call ldconfig.
  213. - Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
  214. and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
  215. * Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
  216. - Initial build.