wxPython-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. #%define buildflags WXPORT=gtk2 UNICODE=1
  4. %global py_setup_args WX_CONFIG=/usr/bin/wx-config-3.0 WXPORT=gtk3
  5. Name: wxPython
  6. Version: 3.0.2.0
  7. Release: 1%{?dist}
  8. Summary: GUI toolkit for the Python programming language
  9. Group: Development/Languages
  10. License: LGPLv2+ and wxWidgets
  11. URL: http://www.wxpython.org/
  12. Source0: http://downloads.sourceforge.net/wxpython/%{name}-src-%{version}.tar.bz2
  13. # Remove Editra - it doesn't work and is technically a bundle. Thanks to
  14. # Debian for the patch.
  15. Patch0: fix-editra-removal.patch
  16. Patch1: wxPython-3.0.0.0-format.patch
  17. # http://trac.wxwidgets.org/ticket/16765
  18. Patch2: wxPython-3.0.2.0-getxwindowcrash.patch
  19. # http://trac.wxwidgets.org/ticket/16767
  20. Patch3: wxPython-3.0.2.0-plot.patch
  21. # http://trac.wxwidgets.org/ticket/17160
  22. Patch4: wxPython-3.0.2.0-listctrl-mixin-edit.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. # make sure to keep this updated as appropriate
  25. BuildRequires: wxGTK3-devel
  26. BuildRequires: python-devel
  27. BuildRequires: gtk3-devel
  28. #BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. wxPython is a GUI toolkit for the Python programming language. It allows
  33. Python programmers to create programs with a robust, highly functional
  34. graphical user interface, simply and easily. It is implemented as a Python
  35. extension module (native code) that wraps the popular wxWindows cross
  36. platform GUI library, which is written in C++.
  37. %package devel
  38. Group: Development/Libraries
  39. Summary: Development files for wxPython add-on modules
  40. Requires: %{name} = %{version}-%{release}
  41. Requires: wxGTK3-devel
  42. %description devel
  43. This package includes C++ header files and SWIG files needed for developing
  44. add-on modules for wxPython. It is NOT needed for development of most
  45. programs which use the wxPython toolkit.
  46. %package docs
  47. Group: Documentation
  48. Summary: Documentation and samples for wxPython
  49. Requires: %{name} = %{version}-%{release}
  50. BuildArch: noarch
  51. %description docs
  52. Documentation, samples and demo application for wxPython.
  53. %prep
  54. %autosetup -p1 -n wxPython-src-%{version}
  55. # fix libdir otherwise additional wx libs cannot be found, fix default optimization flags
  56. sed -i -e 's|/usr/lib|%{_libdir}|' -e 's|-O3|-O2|' wxPython/config.py
  57. %build
  58. # Just build the wxPython part, not all of wxWindows which we already have
  59. # in Fedora
  60. cd wxPython
  61. # included distutils is not multilib aware; use normal
  62. %__rm -rf distutils
  63. python setup.py %{py_setup_args} build
  64. %install
  65. %__rm -rf $RPM_BUILD_ROOT
  66. cd wxPython
  67. python setup.py %{py_setup_args} install --root=$RPM_BUILD_ROOT
  68. # this is a kludge....
  69. %if "%{python_sitelib}" != "%{python_sitearch}"
  70. %__mv $RPM_BUILD_ROOT%{python_sitelib}/wx.pth $RPM_BUILD_ROOT%{python_sitearch}
  71. %__mv $RPM_BUILD_ROOT%{python_sitelib}/wxversion.py* $RPM_BUILD_ROOT%{python_sitearch}
  72. %endif
  73. %clean
  74. %__rm -rf $RPM_BUILD_ROOT
  75. %files
  76. %defattr(-,root,root,-)
  77. %license wxPython/licence/*
  78. %{_bindir}/*
  79. %{python_sitearch}/*
  80. %{python_sitelib}/*
  81. %files devel
  82. %defattr(-,root,root,-)
  83. %dir %{_includedir}/wx-3.0/wx/wxPython
  84. %{_includedir}/wx-3.0/wx/wxPython/*.h
  85. %dir %{_includedir}/wx-3.0/wx/wxPython/i_files
  86. %{_includedir}/wx-3.0/wx/wxPython/i_files/*.i
  87. %{_includedir}/wx-3.0/wx/wxPython/i_files/*.py*
  88. %{_includedir}/wx-3.0/wx/wxPython/i_files/*.swg
  89. %files docs
  90. %defattr(-,root,root,-)
  91. %doc wxPython/docs wxPython/demo wxPython/samples
  92. %changelog
  93. * Sat Jul 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2.0-1
  94. - new upstream release.
  95. * Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-3
  96. - s/wx-gtk2/wxGTK/g
  97. * Sun Jul 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-2
  98. - rebuilt with wx-gtk2-devel-2.8.12-2
  99. * Fri Apr 6 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-1
  100. - updated to 2.8.12.1
  101. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.0-2
  102. - rebuild with python-2.7.2
  103. * Sun May 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.0-1
  104. - initial build based on Fedora rawhide
  105. * Tue Apr 26 2011 Dan Horák <dan[at]danny.cz> - 2.8.12.0-1
  106. - update to 2.8.12.0 (#699207)
  107. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.11.0-5
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  109. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.8.11.0-4
  110. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  111. * Mon Jul 12 2010 Dan Horák <dan@danny.cz> - 2.8.11.0-3
  112. - rebuilt against wxGTK-2.8.11-2
  113. * Sun Jul 11 2010 Lubomir Rintel <lkundrak@v3.sk> - 2.8.11.0-2
  114. - Include egg-info when build on recent RHEL
  115. * Mon May 31 2010 Dan Horák <dan[at]danny.cz> - 2.8.11.0-1
  116. - update to 2.8.11.0 (#593837, #595936, #597639)
  117. * Sun May 2 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-3
  118. - rebuilt with wxGTK 2.8.11
  119. * Wed Mar 17 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-2
  120. - add missing module (#573961)
  121. * Sat Jan 16 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-1
  122. - update to 2.8.10.1
  123. - backport to wxGTK 2.8.10 API
  124. - cleaned up BRs
  125. * Thu Jan 7 2010 Hans de Goede <hdegoede@redhat.com> - 2.8.9.2-4
  126. - Change python_foo macros to use %%global as the new rpm will break
  127. using %%define here, see:
  128. https://www.redhat.com/archives/fedora-devel-list/2010-January/msg00093.html
  129. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.2-3
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  131. * Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-2
  132. - add patch to fix compile failure for contrib/gizmos/_treelist.i
  133. * Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-1
  134. - update to 2.8.9.2
  135. - create noarch docs subpackage
  136. * Thu Mar 5 2009 Lubomir Rintel <lkundrak@v3.sk> - 2.8.9.1-4
  137. - Rebuilt for newer wxgtk package
  138. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.1-3
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  140. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.8.9.1-2
  141. - Rebuild for Python 2.6
  142. * Tue Sep 30 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.1-1
  143. - update to 2.8.9.1
  144. - fix libdir for additional wx libraries (#306761)
  145. * Mon Sep 29 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.0-1
  146. - update to 2.8.9.0
  147. * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.8.8.0-2
  148. - fix license tag
  149. * Thu Jul 31 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.8.0-1
  150. - update to 2.8.8.0 (bug #457408)
  151. - a fix for bug #450073 is included in the upstream release, so
  152. dropping that patch.
  153. * Thu Jun 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> - 2.8.7.1-5
  154. - Fix an attribute error when importing wxPython (compat) module
  155. (redhat bugzilla 450073, 450074)
  156. * Fri Jun 6 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-4
  157. - gratuitously bump package release number to work around build system
  158. glitch. again, but it will work this time.
  159. * Wed Jun 4 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-3
  160. - gratuitously bump package release number to work around build system
  161. glitch
  162. * Thu Feb 21 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-2
  163. - include egg-info files for fedora 9 or greater
  164. * Wed Feb 20 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-1
  165. - update to 2.8.7.1
  166. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.8.4.0-3
  167. - Autorebuild for GCC 4.3
  168. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.8.4.0-2
  169. - Rebuild for selinux ppc32 issue.
  170. * Wed Jul 11 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.4.0-1
  171. - update to 2.8.4.0
  172. - obsolete compat-wxPythonGTK
  173. * Sun Apr 15 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.3.0-1
  174. - update to 2.8.3.0
  175. * Fri Dec 15 2006 Matthew Miller <mattdm@mattdm.org> - 2.8.0.1-1
  176. - update to 2.8.0.1
  177. - make buildrequire wxGTK of version-wxpythonsubrelease
  178. - add wxaddons to filelist
  179. * Mon Dec 11 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-3
  180. - bump release for rebuild against python 2.5.
  181. * Mon Aug 28 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-2
  182. - bump release for FC6 rebuild
  183. * Thu Apr 13 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-1
  184. - version 2.6.3.2
  185. - move wxversion.py _into_ lib64. Apparently that's the right thing to do. :)
  186. - upstream tarball no longer includes embedded.o (since I finally got around
  187. to pointing that out to the developers instead of just kludging it away.)
  188. - buildrequires to just libGLU-devel instead of mesa-libGL-devel
  189. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-4
  190. - grr. bump relnumber.
  191. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-3
  192. - oh yeah -- wxversion.py not lib64.
  193. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-2
  194. - buildrequires mesa-libGLU-devel
  195. * Thu Mar 30 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-1
  196. - update to 2.6.3.0
  197. - wxGTK and wxPython versions are inexorably linked; make BuildRequires
  198. be exact, rather than >=.
  199. - make devel subpackage as per comment #7 in bug #163440.
  200. * Thu Nov 24 2005 Matthew Miller <mattdm@mattdm.org> - 2.6.1.0-1
  201. - update to 2.6.0.0
  202. - merge in changes from current extras 2.4.x package
  203. - Happy Thanksgiving
  204. - build animate extention again -- works now.
  205. * Thu Apr 28 2005 Matthew Miller <mattdm@bu.edu> - 2.6.0.0-bu45.1
  206. - get rid of accidental binaries in source tarball -- they generates
  207. spurious dependencies and serve no purpose
  208. - update to 2.6.0.0 and build for Velouria
  209. - switch to Fedora Extras base spec file
  210. - enable gtk2 and unicode and all the code stuff (as FE does)
  211. - disable BUILD_ANIMATE extension from contrib -- doesn't build
  212. - files are in a different location now -- adjust to that
  213. - zap include files (needed only for building wxPython 3rd-party modules),
  214. because I don't think this is likely to be very useful. Other option
  215. would be to create a -devel package, but I think that'd be confusing.
  216. * Tue Feb 08 2005 Thorsten Leemhuis <fedora at leemhuis dot info> 0:2.4.2.4-4
  217. - remove included disutils - it is not multilib aware; this
  218. fixes build on x86_64
  219. * Tue Jan 06 2004 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.3
  220. - rename package to wxPythonGTK2, provide wxPython (see bug 927)
  221. - dont ship binaries in /usr/share
  222. * Thu Nov 20 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.2
  223. - add missing buildrequires: python-devel, wxGTK2-gl
  224. * Sun Nov 02 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.1
  225. - Initial RPM release.
  226. ~