OpenIPMI-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540
  1. # TODO: uses private copy of libedit, should be modified to use system one
  2. %bcond_without python3
  3. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  4. Summary: IPMI (Intelligent Platform Management Interface) library and tools
  5. Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
  6. Name: OpenIPMI
  7. Version: 2.0.27
  8. Release: 1%{?_dist_release}
  9. License: LGPLv2+ and GPLv2+ or BSD
  10. Group: System Environment/Base
  11. URL: http://sourceforge.net/projects/openipmi/
  12. Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
  13. Source1: openipmi.sysconf
  14. Source2: openipmi.initscript
  15. Source3: openipmigui.desktop
  16. Source4: README.initscript
  17. #Patch3: 0003-Python3.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: desktop-file-utils
  20. BuildRequires: gdbm-devel
  21. BuildRequires: glib2-devel
  22. BuildRequires: libedit-devel
  23. BuildRequires: libxcrypt-devel
  24. BuildRequires: ncurses-devel
  25. BuildRequires: net-snmp-devel
  26. BuildRequires: openssl-devel
  27. BuildRequires: perl
  28. BuildRequires: popt-devel
  29. BuildRequires: swig
  30. BuildRequires: tcl
  31. %if %{with python3}
  32. BuildRequires: python3-devel
  33. BuildRequires: python3-rpm-macros
  34. BuildRequires: python3-tkinter
  35. %else
  36. BuildRequires: python-devel
  37. BuildRequires: python-rpm-macros
  38. BuildRequires: tkinter
  39. %endif
  40. Requires(post): chkconfig
  41. Requires(preun): chkconfig
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. %description
  45. The Open IPMI project aims to develop an open code base to allow access to
  46. platform information using Intelligent Platform Management Interface (IPMI).
  47. This package contains the tools of the OpenIPMI project.
  48. %package libs
  49. Summary: The OpenIPMI runtime libraries
  50. Summary(ja): OpenIPMI ランタイムライブラリ
  51. Group: System Environment/Libraries
  52. %description libs
  53. The OpenIPMI-libs package contains the runtime libraries for shared binaries
  54. and applications.
  55. %package perl
  56. Summary: IPMI Perl language bindings
  57. Summary(ja): IPMI Perl 言語バインディング
  58. Group: Development/Libraries
  59. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  60. %description perl
  61. The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
  62. %if %{with python3}
  63. %package -n python3-openipmi
  64. Group: Development/Libraries
  65. Summary: IPMI Python3 language bindings
  66. Summary(ja): IPMI Python3 言語バインディング
  67. Requires: python3
  68. Obsoletes: %{name}-python < %{version}-%{release}
  69. Provides: %{name}-python = %{version}-%{release}
  70. %description -n python3-openipmi
  71. The OpenIPMI-python3 package contains the Python3 language bindings for OpenIPMI.
  72. %else
  73. %package python
  74. Group: Development/Libraries
  75. Summary: IPMI Python language bindings
  76. Summary(ja): IPMI Python 言語バインディング
  77. Requires: python
  78. %description python
  79. The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
  80. %endif
  81. %package devel
  82. Summary: The development environment for the OpenIPMI project
  83. Summary(ja): OpenIPMI の開発キット
  84. Group: Development/Libraries
  85. Requires: %{name} = %{version}-%{release}
  86. Requires: pkgconfig
  87. %description devel
  88. The OpenIPMI-devel package contains the development libraries and header files
  89. of the OpenIPMI project.
  90. %package gui
  91. Summary: IPMI graphical user interface tool
  92. Summary(ja): IPMI GUI ツール
  93. Group: System Environment/Base
  94. Requires: tix
  95. Requires: tkinter
  96. %if %{with python3}
  97. Requires: python3-openipmi = %{version}-%{release}
  98. %else
  99. Requires: %{name}-python = %{version}-%{release}
  100. %endif
  101. %description gui
  102. The OpenIPMI-gui package contains the graphical user interface to monitor
  103. and control IPMI-enabled devices.
  104. %prep
  105. %setup -q
  106. #%patch3 -p1
  107. rm -rf ./libedit
  108. %build
  109. export EDIT_CFLAGS=`pkg-config --cflags libedit`
  110. export EDIT_LIBS=`pkg-config --libs libedit`
  111. export CFLAGS="-fPIC $RPM_OPT_FLAGS"
  112. perl -pi -e 's|readline/readline\.h|editline/readline.h|' cmdlang/ipmish.c
  113. perl -pi -e 's|-lreadline|-ledit|' cmdlang/Makefile.am
  114. perl -pi -e 's|-lreadline|-ledit|' sample/Makefile.am
  115. %if %{with python3}
  116. perl -pi -e 's|python conftest|%{__python3} conftest|' configure.ac
  117. %endif
  118. autoreconf -vif
  119. %configure \
  120. CFLAGS="-fPIC %{optflags} -z now -fno-strict-aliasing" \
  121. LDFLAGS="%{?__global_ldflags} -Wl,--as-needed" \
  122. --disable-dependency-tracking \
  123. %if %{with python3}
  124. --with-python=%{__python3} \
  125. --with-pythoninstall=%{python3_sitearch} \
  126. %else
  127. --with-pythoninstall=%{python_sitearch} \
  128. %endif
  129. --with-tkinter=yes \
  130. --with-tcl=no \
  131. --with-glib12=no \
  132. --disable-static
  133. # get rid of rpath
  134. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  135. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  136. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  137. make # not %{?_smp_mflags} safe
  138. %install
  139. rm -rf $RPM_BUILD_ROOT
  140. make install DESTDIR=$RPM_BUILD_ROOT
  141. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  142. install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
  143. install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
  144. install -d ${RPM_BUILD_ROOT}%{_initrddir}
  145. install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
  146. desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
  147. install -m 644 %SOURCE4 .
  148. %post
  149. /sbin/chkconfig --add ipmi
  150. %preun
  151. if [ $1 = 0 ]; then
  152. service ipmi stop >/dev/null 2>&1
  153. /sbin/chkconfig --del ipmi
  154. fi
  155. %postun
  156. if [ "$1" -ge "1" ]; then
  157. service ipmi condrestart >/dev/null 2>&1 || :
  158. fi
  159. %post libs -p /sbin/ldconfig
  160. %postun libs -p /sbin/ldconfig
  161. %clean
  162. rm -rf $RPM_BUILD_ROOT
  163. %files
  164. %defattr(-,root,root)
  165. %license COPYING COPYING.BSD COPYING.LIB
  166. %doc CONFIGURING_FOR_LAN FAQ README README.Force README.MotorolaMXP README.initscript
  167. %config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
  168. %config(noreplace) %{_sysconfdir}/ipmi/lan.conf
  169. %config(noreplace) %{_sysconfdir}/sysconfig/ipmi
  170. %{_initrddir}/ipmi
  171. %{_bindir}/ipmicmd
  172. %{_bindir}/ipmilan
  173. %{_bindir}/ipmish
  174. %{_bindir}/ipmi_sim
  175. %{_bindir}/ipmi_ui
  176. %{_bindir}/openipmicmd
  177. %{_bindir}/openipmish
  178. %{_bindir}/rmcp_ping
  179. %{_bindir}/sdrcomp
  180. %{_bindir}/solterm
  181. %{_bindir}/openipmi_eventd
  182. %{_mandir}/man1/ipmi_*
  183. %{_mandir}/man1/openipmicmd*
  184. %{_mandir}/man1/openipmish*
  185. %{_mandir}/man1/rmcp_ping*
  186. %{_mandir}/man1/solterm*
  187. %{_mandir}/man5/ipmi_*
  188. %{_mandir}/man1/openipmi_eventd*
  189. %{_mandir}/man7/ipmi_cmdlang*
  190. %{_mandir}/man7/openipmi_conparms*
  191. %{_mandir}/man8/ipmilan*
  192. %files perl
  193. %defattr(-,root,root)
  194. %attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
  195. %{perl_vendorarch}/auto/OpenIPMI/
  196. %if %{with python3}
  197. %files -n python3-openipmi
  198. %defattr(-,root,root)
  199. %{python3_sitearch}/*OpenIPMI*
  200. %else
  201. %files python
  202. %defattr(-,root,root)
  203. %{python_sitearch}/*OpenIPMI*
  204. %endif
  205. %files libs
  206. %defattr(-,root,root)
  207. %{_libdir}/*.so.*
  208. %files devel
  209. %defattr(-,root,root)
  210. %{_includedir}/OpenIPMI
  211. %{_libdir}/*.so
  212. %{_libdir}/pkgconfig/*.pc
  213. %files gui
  214. %defattr(-,root,root)
  215. %{_bindir}/openipmigui
  216. %{_mandir}/man1/openipmigui*
  217. %if %{with python3}
  218. %{python3_sitearch}/openipmigui
  219. %else
  220. %{python_sitearch}/openipmigui
  221. %endif
  222. %{_datadir}/applications/fedora-openipmigui.desktop
  223. %changelog
  224. * Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.27-1
  225. - updated to 2.0.27.
  226. - dropped Patch2 (fixed in upstream).
  227. - added BR:libxcrypt-devel.
  228. - switched to python3.
  229. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.25-1
  230. - updated to 2.0.25.
  231. - dropped Patch1 (fixed in upstream).
  232. - imported Patch2 from rawhide.
  233. - added BR:libedit-devel.
  234. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-3
  235. - rebuild with openssl-1.0.2
  236. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
  237. - remove *.la files
  238. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
  239. - updated to 2.0.21
  240. - rebuilt with perl-5.16.3
  241. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
  242. - rebuild with net-snmp-5.7.1
  243. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
  244. - rebuild with python-2.7.2
  245. * Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
  246. - build with perl 5.12.3
  247. - add Vendor and Distribution tags
  248. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
  249. - rebuild with openssl-1.0.0d
  250. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
  251. - initial build for Vine Linux
  252. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
  253. - Mass rebuild with perl-5.12.0
  254. * Wed May 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
  255. - updated to OpenIPMI-2.0.18
  256. - fixed OpenIPMIpthread pkgconfig file (#468067)
  257. * Mon May 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
  258. - updated to OpenIPMI-2.0.17
  259. * Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
  260. - implemented mandatory 'force-reload' command in ipmi service
  261. * Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
  262. - rebuild against new gdbm
  263. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
  264. - add README.initscript describing /etc/init.d/ipmi initscript exit codes
  265. (#562151)
  266. * Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
  267. - fix package License: field, there *are* sources with BSD header
  268. - distribute README files and COPYING in package
  269. * Tue Jan 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
  270. - fix package License: field, there is no source with BSD header
  271. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
  272. - rebuild against perl 5.10.1
  273. * Tue Dec 1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
  274. - fix package compilation to remove rpmlint errors
  275. * Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
  276. - rebuilt with new net-snmp
  277. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
  278. - rebuilt with new openssl
  279. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
  280. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  281. * Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
  282. - fix compilation flags, debuginfo package is correctly generated now
  283. * Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
  284. - new upstream release
  285. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
  286. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  287. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
  288. - rebuild with new openssl
  289. * Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
  290. - fix linking without rpath, prelink won't screw up the libraries
  291. anymore (#475265)
  292. * Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
  293. - shorter probe interval is used in init script, making the service startup
  294. quicker in most situations (#475101)
  295. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
  296. - Rebuild for Python 2.6
  297. * Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
  298. - removed static libraries from the -devel subpackage
  299. - fixed openipmigui.desktop file
  300. * Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
  301. - fixed typos in the descriptions
  302. - added .desktop file for openipmigui tool
  303. * Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
  304. - fixed description of the package
  305. * Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
  306. - split ipmitool to separate package
  307. - added 'reload' functionality to init script
  308. - added seraparate -gui subpackage
  309. * Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
  310. - Fixed rpath problem in libOpenIPMIposix.so.0.0.1
  311. * Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
  312. - Fixed several specfile problems (#453751)
  313. - Update to OpenIPMI-2.0.14
  314. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
  315. - Autorebuild for GCC 4.3
  316. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
  317. - Updated to OpenIPMI-2.0.13
  318. - Rebuild due to new openssl
  319. * Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
  320. - Added missing perl-devel buildrequires
  321. * Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  322. - Added missing popt-devel buildrequires
  323. * Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  324. - Fix rebuild problems due to glibc change
  325. - License review and fixes
  326. * Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
  327. - Update to OpenIPMI-2.0.11
  328. * Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
  329. - Update for ipmitool-1.8.9
  330. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
  331. - rebuild for python 2.5
  332. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
  333. - Update due to new net-snmp-5.4
  334. - Some specfile updates
  335. * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
  336. - Fixed check for udev in initscript (#197956)
  337. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
  338. - rebuild
  339. * Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
  340. - don't include <linux/compiler.h>
  341. * Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
  342. - Fix a build requires (needs glibc-kernheaders)
  343. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
  344. - Bump for new glib2
  345. * Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
  346. - Fixed bug with type conversion in ipmitool (#191091)
  347. - Added python bindings
  348. - Split off perl and python bindings in separate subpackages
  349. - Dropped obsolete patches
  350. - Added missing buildprereq on readline-devel
  351. - Made it install the python bindings properly on 64bit archs
  352. * Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
  353. - Updated ipmitool to 1.8.8
  354. - Updated OpenIPMI to 2.0.6
  355. * Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
  356. - Added missing PreReq for chkconfig
  357. * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
  358. - rebump for build order issues during double-long bump
  359. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
  360. - bump again for double-long bug on ppc(64)
  361. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
  362. - rebuilt for new gcc4.1 snapshot and glibc changes
  363. * Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
  364. - Updated ipmitool to latest upstream version.
  365. - Removed 3 patches for already fixed bugs in latest ipmitool.
  366. - Adapted warning message fix for ipmitool for latest version.
  367. * Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
  368. - Fixed some minor things in initscripts.
  369. * Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
  370. - Included FRU fix for displaying FRUs with ipmitool
  371. - Included patch for new option to specify a BMC password for IPMI 2.0 sessions
  372. * Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
  373. - Rebuilt against new libnetsnmp
  374. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  375. - rebuilt
  376. * Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
  377. - Some more initscript and sysconfig updates from Dell.
  378. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
  379. - Rebuilt to link against latest openssl libs.
  380. - Fixed ipmitool not setting session privilege level (#172312)
  381. * Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
  382. - Rebuild to link against new net-snmp libs.
  383. * Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
  384. - Updated initscript to fix missing redhat-lsb bug (#169901)
  385. * Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
  386. - Another update to latest initscripts from Dell
  387. - Fixed some missing return statements for non-void functions (#164138)
  388. * Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
  389. - Updated initscript to latest version from Dell
  390. * Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
  391. - Fixed the unwanted output of failed module loading of the initscript. Behaves
  392. now like all our other initscripts (#165476)
  393. * Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
  394. - Fixed build problem on 64bit machines
  395. * Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
  396. - Fixed missing change to not autostart in the initscript
  397. * Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
  398. - Made the initscript a replacing configfile
  399. * Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
  400. - Updated versions of the initscripts and sysconf files
  401. - Fixed typo in preun script and changelog
  402. * Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
  403. - Updated to OpenIPMI-1.4.14
  404. - Split the main package into normal and libs package for multilib support
  405. - Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
  406. - Added sysconf and initscript (#158270)
  407. - Fixed oob subscripts (#149142)
  408. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
  409. - Correctly put libs in the proper packages
  410. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
  411. - gcc4 rebuild fixes
  412. - Added missing gdbm-devel buildprereq
  413. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
  414. - bump release and rebuild with gcc 4
  415. * Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
  416. - update
  417. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  418. - Initial version