SDL2-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. %define ver 2.0.5
  2. %define rel 1
  3. %bcond_with wayland
  4. Name: SDL2
  5. Version: %{ver}
  6. Release: %{rel}%{?_dist_release}
  7. Summary: A cross-platform multimedia library
  8. Group: System Environment/Libraries
  9. URL: http://www.libsdl.org/
  10. License: zlib and MIT
  11. Source0: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
  12. Source1: SDL_config.h
  13. Patch0: multilib.patch
  14. BuildRequires: alsa-lib-devel
  15. BuildRequires: audiofile-devel
  16. BuildRequires: mesa-libGL-devel
  17. BuildRequires: mesa-libGLU-devel
  18. BuildRequires: mesa-libEGL-devel
  19. BuildRequires: mesa-libGLES-devel
  20. BuildRequires: libXext-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: libXi-devel
  23. BuildRequires: libXrandr-devel
  24. BuildRequires: libXrender-devel
  25. BuildRequires: dbus-devel
  26. BuildRequires: libXScrnSaver-devel
  27. BuildRequires: libusb-devel
  28. BuildRequires: pulseaudio-libs-devel
  29. BuildRequires: libXinerama-devel
  30. BuildRequires: libXcursor-devel
  31. # Wayland
  32. %if %{with wayland}
  33. BuildRequires: libwayland-client-devel
  34. BuildRequires: libwayland-egl-devel
  35. BuildRequires: libwayland-cursor-devel
  36. %endif
  37. BuildRequires: libxkbcommon-devel
  38. %description
  39. Simple DirectMedia Layer (SDL) is a cross-platform multimedia library designed
  40. to provide fast access to the graphics frame buffer and audio device.
  41. %package devel
  42. Summary: Files needed to develop Simple DirectMedia Layer applications
  43. Group: Development/Libraries
  44. Requires: %{name}%{?_isa} = %{version}-%{release}
  45. Requires: alsa-lib-devel
  46. Requires: mesa-libGL-devel
  47. Requires: mesa-libGLU-devel
  48. Requires: mesa-libEGL-devel
  49. Requires: mesa-libGLES-devel
  50. Requires: libX11-devel
  51. Requires: libXi-devel
  52. Requires: libXext-devel
  53. Requires: libXrandr-devel
  54. Requires: libXrender-devel
  55. Requires: libXScrnSaver-devel
  56. Requires: libXinerama-devel
  57. Requires: libXcursor-devel
  58. %if %{with wayland}
  59. # Wayland
  60. Requires: libwayland-client-devel
  61. Requires: libwayland-egl-devel
  62. Requires: libwayland-cursor-devel
  63. %endif
  64. Requires: libxkbcommon-devel
  65. %description devel
  66. Simple DirectMedia Layer (SDL) is a cross-platform multimedia library designed
  67. to provide fast access to the graphics frame buffer and audio device. This
  68. package provides the libraries, include files, and other resources needed for
  69. developing SDL applications.
  70. Vendor: Project Vine
  71. Distribution: Vine Linux
  72. Packager: iwaim
  73. %prep
  74. %setup -q
  75. #%patch0 -p1 -b .multilib
  76. # Compilation without ESD
  77. sed -i -e 's/.*AM_PATH_ESD.*//' configure.in
  78. sed -i -e 's/\r//g' TODO.txt README.txt WhatsNew.txt BUGS.txt COPYING.txt CREDITS.txt README-SDL.txt
  79. %build
  80. %configure \
  81. --enable-sdl-dlopen \
  82. --disable-arts \
  83. --disable-esd \
  84. --disable-nas \
  85. --enable-pulseaudio-shared \
  86. --enable-alsa \
  87. %if %{with wayland}
  88. --enable-video-wayland \
  89. %endif
  90. --disable-rpath
  91. make %{?_smp_mflags}
  92. %install
  93. %make_install
  94. # Rename SDL_config.h to SDL_config-<arch>.h to avoid file conflicts on
  95. # multilib systems and install SDL_config.h wrapper
  96. mv %{buildroot}%{_includedir}/SDL2/SDL_config.h %{buildroot}%{_includedir}/SDL2/SDL_config-%{_arch}.h
  97. install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/SDL2/SDL_config.h
  98. # remove libtool .la file
  99. rm -f %{buildroot}%{_libdir}/*.la
  100. # remove static .a file
  101. rm -f %{buildroot}%{_libdir}/*.a
  102. %post -p /sbin/ldconfig
  103. %postun -p /sbin/ldconfig
  104. %files
  105. %doc BUGS.txt CREDITS.txt COPYING.txt README-SDL.txt
  106. %{_libdir}/lib*.so.*
  107. %files devel
  108. %doc README.txt TODO.txt WhatsNew.txt
  109. %{_bindir}/*-config
  110. %{_libdir}/lib*.so
  111. %{_libdir}/pkgconfig/sdl2.pc
  112. %dir %{_libdir}/cmake/SDL2
  113. %{_libdir}/cmake/SDL2/sdl2-config.cmake
  114. %{_includedir}/SDL2
  115. %{_datadir}/aclocal/*
  116. %changelog
  117. * Sat Apr 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.5-1
  118. - initial build for Vine Linux
  119. * Wed Nov 18 2015 Ding-Yi Chen <dchen@redhat.com> - 2.0.3-9
  120. - Use bcond instead
  121. * Tue Aug 11 2015 Ding-Yi Chen <dchen@redhat.com> - 2.0.3-8
  122. - Remove wayland support for Requires.
  123. * Thu Aug 06 2015 Ding-Yi Chen <dchen@redhat.com> - 2.0.3-7
  124. - Remove wayland support.
  125. * Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-6
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  127. * Tue Jun 2 2015 Tom Callaway <spot@fedoraproject.org> - 2.0.3-5
  128. - remove code preventing builds with ancient gcc
  129. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-4
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  131. * Wed Jun 11 2014 Karsten Hopp <karsten@redhat.com> 2.0.3-3
  132. - fix filename of SDL_config.h for ppc64le
  133. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  135. * Wed Mar 19 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.3-1
  136. - 2.0.3 upstream release
  137. * Sat Mar 08 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.2-1
  138. - 2.0.2 upstream release
  139. - Enable wayland backend
  140. * Tue Dec 10 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.1-2
  141. - Add libXinerama, libudev, libXcursor support (RHBZ #1039702)
  142. * Thu Oct 24 2013 Tom Callaway <spot@fedoraproject.org> - 2.0.1-1
  143. - update to 2.0.1
  144. * Sat Aug 24 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-3
  145. - Fix multilib issues
  146. * Tue Aug 13 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-2
  147. - SDL2 is released. Announce:
  148. - http://lists.libsdl.org/pipermail/sdl-libsdl.org/2013-August/089854.html
  149. * Sat Aug 10 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc4
  150. - Update to latest SDL2 (08.08.2013)
  151. * Tue Jul 30 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc3
  152. - Fix Licenses
  153. - some cleanups in spec
  154. * Tue Jul 30 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc2
  155. - Delete -static package
  156. - Fix License tag
  157. - Fix end-of-line in documents
  158. - Remove all spike-nails EL-specify (if someone will want to do - 'patches are welcome')
  159. - Change Release tag to .rcX%%{?dist} (maintainer has changed released tarballs)
  160. * Mon Jul 29 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 2.0.0-1.rc1
  161. - Some fixes in spec and cleanup
  162. * Mon Jul 29 2013 Jon Ciesla <limburgher@gmail.com> - 2.0.0-1
  163. - Ported from SDL 1.2.15-10