cdparanoia-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: cdparanoia
  3. Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
  4. Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
  5. Version: 10.2
  6. Release: 3%{?_dist_release}
  7. Group: Applications/Multimedia
  8. License: GPLv2 and LGPLv2
  9. URL: http://www.xiph.org/paranoia/index.html
  10. Source: http://www.xiph.org/paranoia/download/%{name}-III-%{version}.src.tgz
  11. Patch0: cdparanoia-fPIC.patch
  12. # Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
  13. # https://trac.xiph.org/changeset/15338
  14. # https://bugzilla.redhat.com/show_bug.cgi?id=463009
  15. Patch1: cdparanoia-10.2-#463009.patch
  16. #Patch1: cdparanoia-gcc4-build.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. %description
  19. Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
  20. writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
  21. PCM format. Cdparanoia doesn't contain any extra features (like the ones
  22. included in the cdda2wav sampling utility). Instead, cdparanoia's strength
  23. lies in its ability to handle a variety of hardware, including inexpensive
  24. drives prone to misalignment, frame jitter and loss of streaming during
  25. atomic reads. Cdparanoia is also good at reading and repairing data from
  26. damaged CDs.
  27. %package devel
  28. Summary: Development tools for libcdda_paranoia (Paranoia III).
  29. Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
  30. Group: Development/Libraries
  31. License: LGPLv2
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. The cdparanoia-devel package contains the static libraries and header
  35. files needed for developing applications to read CD Digital Audio disks.
  36. # compat32
  37. %package -n compat32-%{name}
  38. Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
  39. Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
  40. Group: Applications/Multimedia
  41. Requires: %{name} = %{version}-%{release}
  42. %description -n compat32-%{name}
  43. Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
  44. writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
  45. PCM format. Cdparanoia doesn't contain any extra features (like the ones
  46. included in the cdda2wav sampling utility). Instead, cdparanoia's strength
  47. lies in its ability to handle a variety of hardware, including inexpensive
  48. drives prone to misalignment, frame jitter and loss of streaming during
  49. atomic reads. Cdparanoia is also good at reading and repairing data from
  50. damaged CDs.
  51. %package -n compat32-%{name}-devel
  52. Summary: Development tools for libcdda_paranoia (Paranoia III).
  53. Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
  54. Group: Development/Libraries
  55. Requires: compat32-%{name} = %{version}-%{release}
  56. Requires: %{name}-devel = %{version}-%{release}
  57. %description -n compat32-%{name}-devel
  58. The cdparanoia-devel package contains the static libraries and header
  59. files needed for developing applications to read CD Digital Audio disks.
  60. %prep
  61. %setup -q -n %{name}-III-%{version}
  62. %patch1 -p3 -b .#463009
  63. %build
  64. export OPT="${CFLAGS:-%optflags} -O0 -Wno-pointer-sign -Wno-unused -Werror-implicit-function-declaration"
  65. %configure --includedir=%{_includedir}/cdda
  66. make OPT="$OPT"
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. install -d $RPM_BUILD_ROOT%{_bindir}
  70. install -d $RPM_BUILD_ROOT%{_includedir}/cdda
  71. install -d $RPM_BUILD_ROOT%{_libdir}
  72. install -d $RPM_BUILD_ROOT%{_mandir}/man1
  73. install -m 0755 cdparanoia $RPM_BUILD_ROOT%{_bindir}
  74. install -m 0644 cdparanoia.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  75. install -m 0644 utils.h paranoia/cdda_paranoia.h interface/cdda_interface.h \
  76. $RPM_BUILD_ROOT%{_includedir}/cdda
  77. install -m 0755 paranoia/libcdda_paranoia.so.0.10.? \
  78. interface/libcdda_interface.so.0.10.? \
  79. $RPM_BUILD_ROOT%{_libdir}
  80. install -m 0755 paranoia/libcdda_paranoia.a interface/libcdda_interface.a \
  81. $RPM_BUILD_ROOT%{_libdir}
  82. install -d $RPM_BUILD_ROOT%{_mandir}/ja/man1
  83. install -m 0644 cdparanoia.1.jp $RPM_BUILD_ROOT%{_mandir}/ja/man1/cdparanoia.1
  84. /sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
  85. pushd $RPM_BUILD_ROOT%{_libdir}
  86. ln -s libcdda_paranoia.so.0.10.? libcdda_paranoia.so
  87. ln -s libcdda_interface.so.0.10.? libcdda_interface.so
  88. popd
  89. %post -p /sbin/ldconfig
  90. %postun -p /sbin/ldconfig
  91. %post -n compat32-%{name} -p /sbin/ldconfig
  92. %postun -n compat32-%{name} -p /sbin/ldconfig
  93. %clean
  94. [ "$RPM_BUILD_ROOT" != "/" -a -d "$RPM_BUILD_ROOT" ] && rm -rf "$RPM_BUILD_ROOT"
  95. %files
  96. %defattr(-,root,root)
  97. %doc README COPYING-GPL COPYING-LGPL
  98. %{_bindir}/*
  99. %{_libdir}/lib*.so.*
  100. %{_mandir}/man1/*
  101. %{_mandir}/ja/man1/*
  102. %files devel
  103. %defattr(-,root,root)
  104. %{_includedir}/cdda
  105. %{_libdir}/lib*.so
  106. %{_libdir}/*.a
  107. # compat32
  108. %if %{build_compat32}
  109. %files -n compat32-%{name}
  110. %defattr(-, root, root)
  111. %{_libdir}/*.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr(-, root, root)
  114. %{_libdir}/*.so
  115. %endif
  116. %changelog
  117. * Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2-3
  118. - create compat32 sub packages
  119. * Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-2
  120. - rebuilt with new toolchain
  121. - added Japanese summary
  122. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-1
  123. - new upstream release
  124. - added Requires: cdparanoia to devel package
  125. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> alpha9.8-9vl5
  126. - applied new versioning policy
  127. * Tue Jul 3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> alpha9.8-8vl6
  128. - add Patch1
  129. * Tue Oct 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> alpha9.8-8vl5
  130. - added fPIC.patch fix a problem on x86_64 archtecture
  131. * Fri Dec 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> alpha9.8-8vl4
  132. - rebuild with new toolchain
  133. * Sun Mar 16 2003 IWAI Masaharu <iwai@alib.jp> alpha9.8-8vl3
  134. - rebuild with new toolchain
  135. * Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  136. - alpha9.8-8vl2
  137. - rebuild on VineSeed
  138. * Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  139. - alpha9.8-8vl1
  140. - included japanese manual
  141. * Tue Feb 27 2001 Karsten Hopp <karsten@redhat.de>
  142. - fix spelling error in description
  143. * Thu Dec 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
  144. - rebuild for new tree
  145. * Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
  146. - use %%{_tmppath}
  147. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  148. - automatic rebuild
  149. * Wed Jun 06 2000 Preston Brown <pbrown@redhat.com>
  150. - revert name change
  151. - use new rpm macro paths
  152. * Wed Apr 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  153. - Switched spec file from the one used in Red Hat Linux 6.2, which
  154. also changes the name
  155. - gzip man page
  156. * Thu Dec 23 1999 Peter Jones <pjones@redhat.com>
  157. - update package to provide cdparanoia-alpha9.7-2.*.rpm and
  158. cdparanoia-devel-alpha9.7-2.*.rpm. Also, URLs point at xiph.org
  159. like they should.
  160. * Wed Dec 22 1999 Peter Jones <pjones@redhat.com>
  161. - updated package for alpha9.7, based on input from:
  162. Monty <xiphmont@xiph.org>
  163. David Philippi <david@torangan.saar.de>
  164. * Mon Apr 12 1999 Michael Maher <mike@redhat.com>
  165. - updated pacakge
  166. * Tue Oct 06 1998 Michael Maher <mike@redhat.com>
  167. - updated package
  168. * Mon Jun 29 1998 Michael Maher <mike@redhat.com>
  169. - built package