check-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. Summary: A unit test framework for C
  2. Summary(ja): C 言語用単体テストフレームワーク
  3. Name: check
  4. Version: 0.9.14
  5. Release: 1%{?_dist_release}
  6. License: LGPL
  7. Group: System Environment/Libraries
  8. URL: http://check.sourceforge.net/
  9. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. Patch0: %{name}-examples-bootstrap.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: docbook-utils
  13. BuildRequires: texinfo
  14. Requires(post,preun): /sbin/install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
  18. %description
  19. Check is a unit test framework for C. It features a simple interface
  20. for defining unit tests, putting little in the way of the developer.
  21. Tests are run in a separate address space, so Check can catch both
  22. assertion failures and code errors that cause segmentation faults or
  23. other signals. The output from unit tests can be used within source
  24. code editors and IDEs.
  25. %package devel
  26. Summary: Libraries and headers for developing programs with check
  27. Summary(ja): Check を使ったプログラム開発用ライブラリとヘッダファイル
  28. Group: Development/Libraries
  29. Requires: pkgconfig
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. Libraries and headers for developing programs with check
  33. %package tools
  34. Summary: The tools for %{name}
  35. Summary(ja): Check 用のツール
  36. Group: Development/Tools
  37. Requires: %{name} = %{version}-%{release}
  38. %description tools
  39. This package contains check tool "chkckmk".
  40. checkmk, a tool for reducing "boilerplate coding" when writing unit tests with check.
  41. %prep
  42. %setup -q
  43. %patch0 -p1
  44. %build
  45. %configure --disable-static
  46. make %{?_smp_mflags}
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. %makeinstall
  50. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  51. rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
  52. rm -rf example
  53. cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
  54. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
  55. %clean
  56. rm -rf $RPM_BUILD_ROOT
  57. %post
  58. /sbin/ldconfig
  59. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  60. %postun -p /sbin/ldconfig
  61. %preun
  62. if [ $1 = 0 ]; then
  63. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
  64. fi
  65. %files
  66. %defattr(-,root,root)
  67. %doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
  68. %{_libdir}/libcheck.so.*
  69. %{_infodir}/check.info*
  70. %files devel
  71. %defattr(-,root,root)
  72. %doc example
  73. %{_includedir}/check.h
  74. %{_includedir}/check_stdint.h
  75. %{_libdir}/libcheck.so
  76. %{_libdir}/pkgconfig/check.pc
  77. %{_datadir}/aclocal/check.m4
  78. %files tools
  79. %defattr(-,root,root)
  80. %{_bindir}/checkmk
  81. %{_mandir}/man1/checkmk.1.gz
  82. %changelog
  83. * Thu Nov 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.14-1
  84. - new upstream release
  85. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.12-1
  86. - new upstream release
  87. * Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
  88. - new upstream release
  89. - create %{name}-tools sub package
  90. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  91. - rebuilt with rpm-4.8.1 for pkg-config
  92. * Sat Apr 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.8-1
  93. - new upstream release
  94. - dropt Patch1
  95. * Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
  96. - spec in UTF-8
  97. - split devel subpackage
  98. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
  99. - new upstream release
  100. - updated Patch1
  101. * Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
  102. - enable -fPIC to build gstreamer on x86_64
  103. * Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
  104. - upstream release
  105. - add BuildRequires: docbook-utils instead of lyx
  106. * Fri Aug 1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
  107. - Rebuild for new Vine.
  108. * Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
  109. - Initial build.