colord-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283
  1. %bcond_with firstbuild
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: Color daemon
  4. Name: colord
  5. Version: 1.1.8
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Daemons
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://gitorious.org/colord
  10. Source0: http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: dbus-devel
  13. BuildRequires: docbook-utils
  14. BuildRequires: gettext
  15. BuildRequires: glib2-devel
  16. BuildRequires: intltool
  17. BuildRequires: lcms2-devel
  18. BuildRequires: libgudev1-devel
  19. BuildRequires: libgusb-devel
  20. BuildRequires: polkit-devel
  21. BuildRequires: sqlite3-devel
  22. BuildRequires: bash-completion
  23. %{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
  24. Requires: shared-color-profiles
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: Takemikaduchi
  28. %description
  29. colord is a low level system activated daemon that maps color devices
  30. to color profiles in the system context.
  31. %package devel
  32. Summary: Development package for %{name}
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Requires: glib2-devel
  36. Requires: dbus-devel
  37. Requires: lcms2-devel
  38. %description devel
  39. Files for development with %{name}.
  40. # compat32
  41. %package -n compat32-%{name}
  42. Summary: Color daemon
  43. Group: System Environment/Daemons
  44. Requires: %{name} = %{version}-%{release}
  45. %description -n compat32-%{name}
  46. colord is a low level system activated daemon that maps color devices
  47. to color profiles in the system context.
  48. %package -n compat32-%{name}-devel
  49. Summary: Development package for %{name}
  50. Group: Development/Libraries
  51. Requires: compat32-%{name} = %{version}-%{release}
  52. %description -n compat32-%{name}-devel
  53. Files for development with %{name}.
  54. %prep
  55. %setup -q
  56. %build
  57. %configure \
  58. --disable-static \
  59. --disable-rpath \
  60. --disable-examples \
  61. --disable-dependency-tracking \
  62. --disable-systemd-login
  63. make %{?_smp_mflags}
  64. %install
  65. make install DESTDIR=$RPM_BUILD_ROOT
  66. # Remove static libs and libtool archives.
  67. find %{buildroot} -name '*.la' -exec rm -f {} ';'
  68. find %{buildroot} -name '*.a' -exec rm -f {} ';'
  69. # databases
  70. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
  71. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
  72. %find_lang %{name}
  73. %post -p /sbin/ldconfig
  74. %postun
  75. /sbin/ldconfig
  76. if [ $1 -eq 0 ]; then
  77. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  78. fi
  79. %posttrans
  80. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  81. %post -n compat32-%{name} -p /sbin/ldconfig
  82. %postun -n compat32-%{name} -p /sbin/ldconfig
  83. %files -f %{name}.lang
  84. %defattr(-,root,root,-)
  85. %doc AUTHORS COPYING NEWS README.md
  86. %{_libexecdir}/colord
  87. %{_libexecdir}/colord-session
  88. %dir %{_localstatedir}/lib/colord
  89. %{_bindir}/*
  90. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
  91. %{_datadir}/bash-completion/completions/colormgr
  92. %{_datadir}/color
  93. %{_datadir}/colord
  94. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
  95. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
  96. %{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
  97. %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
  98. %{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
  99. %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
  100. %{_datadir}/man/man1/*.1.gz
  101. %{_libdir}/libcolord.so.*
  102. %{_libdir}/libcolordprivate.so.*
  103. %{_libdir}/libcolorhug.so.*
  104. %{_libdir}/colord-plugins/libcd_plugin_camera.so
  105. %{_libdir}/colord-plugins/libcd_plugin_scanner.so
  106. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
  107. %{!?with_firstbuild:%{_libdir}/girepository-1.0/ColorHug-1.0.typelib}
  108. /lib/udev/rules.d/*.rules
  109. %{_libdir}/colord-sensors
  110. %ghost %{_localstatedir}/lib/colord/*.db
  111. %files devel
  112. %defattr(-,root,root,-)
  113. %{_includedir}/colord-1
  114. %{_libdir}/libcolord.so
  115. %{_libdir}/libcolordprivate.so
  116. %{_libdir}/libcolorhug.so
  117. %{_libdir}/pkgconfig/colord.pc
  118. %{_libdir}/pkgconfig/colorhug.pc
  119. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
  120. %{!?with_firstbuild:%{_datadir}/gir-1.0/ColorHug-1.0.gir}
  121. # compat32
  122. %if %{build_compat32}
  123. %files -n compat32-%{name}
  124. %defattr(-,root,root,-)
  125. %{_libdir}/libcolord.so.*
  126. %{_libdir}/libcolordprivate.so.*
  127. %{_libdir}/libcolorhug.so.*
  128. %files -n compat32-%{name}-devel
  129. %defattr(-,root,root,-)
  130. %{_libdir}/libcolord.so
  131. %{_libdir}/libcolordprivate.so
  132. %{_libdir}/libcolorhug.so
  133. %endif
  134. %changelog
  135. * Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.8-2
  136. - added libcolordprivate and libcolorhug to compat32-* subpackages
  137. * Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.8-1
  138. - new upstream release
  139. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-1
  140. - update to 1.1.7
  141. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  142. - new upstream release
  143. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  144. - new upstream release
  145. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  146. - new upstream release
  147. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  148. - new upstream release
  149. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  150. - new upstream release
  151. - add BuildRequires: bash-completion
  152. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
  153. - new upstream release
  154. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
  155. - new upstream release
  156. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
  157. - new upstream release
  158. - remove BuildRequires: sane-devel
  159. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
  160. - new upstream release
  161. - change BuildRequires: libgusb-devel instead of libusb1-devel
  162. - add BuildRequires: gobject-introspection-devel
  163. * Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
  164. - new upstream release
  165. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
  166. - new upstream release
  167. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
  168. - new upstream release
  169. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
  170. - new upstream release
  171. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
  172. - new upstream release
  173. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
  174. - new upstream release
  175. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
  176. - new upstream release
  177. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
  178. - new upstream release
  179. - create compat32 sub packages
  180. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
  181. - initial build for Vine Linux
  182. * Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
  183. - New upstream version
  184. * Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
  185. - New upstream version
  186. * Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
  187. - New upstream version
  188. - Add a webcam device kind
  189. - Add a timestamp when making profiles default
  190. - Add support for reading and writing ICC profile metadata
  191. - Allow the client to pass file descriptors out of band to CreateProfile
  192. - Prettify the device vendor and model names
  193. - Split out the sensors into runtime-loadable shared objects
  194. - Provide some GIO async variants for the methods in CdClient
  195. - Ensure GPhoto2 devices get added to the device list
  196. * Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
  197. - New upstream version.
  198. - Create /var/lib/colord at buildtime not runtime for SELinux
  199. - Ensure profiles with embedded profile checksums are parsed correctly
  200. - Move the colorimeter rules to be run before 70-acl.rules
  201. - Stop watching the client when the sensor is finalized
  202. - Ensure the source is destroyed when we unref CdUsb to prevent a crash
  203. - Only enable the volume mount tracking when searching volumes
  204. * Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
  205. - Own /var/lib/colord and /var/lib/colord/*.db
  206. * Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
  207. - New upstream version.
  208. * Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
  209. - New upstream version.
  210. * Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
  211. - New upstream version.
  212. * Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
  213. - New upstream version.
  214. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
  215. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  216. * Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
  217. - Rebuild in the vain hope koji isn't broken today.
  218. * Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
  219. - New upstream version.
  220. * Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
  221. - Initial version for Fedora package review.