curl-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %if %{?_dist_release} != "vl6"
  3. %global with_http2 1
  4. %endif
  5. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  6. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  7. Name: curl
  8. Version: 7.54.0
  9. Release: 1%{?_dist_release}
  10. License: MIT
  11. Group: Applications/Internet
  12. URL: http://curl.haxx.se/
  13. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
  14. # patch making libcurl multilib ready
  15. Patch101: 0101-curl-7.32.0-multilib.patch
  16. # prevent configure script from discarding -g in CFLAGS (#496778)
  17. Patch102: 0102-curl-7.36.0-debug.patch
  18. # use localhost6 instead of ip6-localhost in the curl test-suite
  19. Patch104: 0104-curl-7.19.7-localhost6.patch
  20. # work around valgrind bug (#678518)
  21. Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: openssl-devel libidn-devel zlib-devel
  24. BuildRequires: openldap-devel gnutls-devel
  25. BuildRequires: openssh-server
  26. BuildRequires: openssh-clients
  27. BuildRequires: pkgconfig
  28. %if "%{?_dist_release}" != "vl6"
  29. BuildRequires: libssh2-devel
  30. %endif
  31. %if 0%{?with_http2}
  32. BuildRequires: libnghttp2-devel
  33. %endif
  34. Requires: ca-certificates
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: daisuke
  38. %description
  39. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  40. Dict servers, using any of the supported protocols. cURL is designed
  41. to work without user interaction or any kind of interactivity. cURL
  42. offers many useful capabilities, like proxy support, user
  43. authentication, FTP upload, HTTP post, and file transfer resume.
  44. %package devel
  45. Summary: Files needed for building applications with libcurl.
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: openssl-devel libidn-devel zlib-devel
  49. %description devel
  50. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  51. Dict servers, using any of the supported protocols. The curl-devel
  52. package includes files needed for developing applications which can
  53. use cURL's capabilities internally.
  54. #'
  55. ## to build compat32 for x86_64 architecture support
  56. %package -n compat32-%{name}
  57. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  58. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  59. Group: System Environment/Libraries
  60. %description -n compat32-%{name}
  61. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  62. Dict servers, using any of the supported protocols. cURL is designed
  63. to work without user interaction or any kind of interactivity. cURL
  64. offers many useful capabilities, like proxy support, user
  65. authentication, FTP upload, HTTP post, and file transfer resume.
  66. %package -n compat32-%{name}-devel
  67. Summary: Files needed for building applications with libcurl.
  68. Group: Development/Libraries
  69. %description -n compat32-%{name}-devel
  70. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  71. Dict servers, using any of the supported protocols. The curl-devel
  72. package includes files needed for developing applications which can
  73. use cURL's capabilities internally.
  74. #'
  75. %prep
  76. %setup -q
  77. # Fedora patches
  78. %patch101 -p1
  79. %patch102 -p1
  80. %patch104 -p1
  81. %patch107 -p1
  82. %build
  83. %configure \
  84. --with-ssl=%{_prefix} \
  85. --with-gnutls \
  86. --with-libidn \
  87. --enable-ipv6 \
  88. --enable-threaded-resolver \
  89. --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  90. %if "%{?_dist_release}" != "vl6"
  91. --with-libssh2 \
  92. %endif
  93. %if 0%{?with_http2}
  94. --with-nghttp2 \
  95. %endif
  96. --enable-ldaps \
  97. --disable-static \
  98. --enable-hidden-symbols
  99. make %{?_smp_mflags}
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. make DESTDIR=$RPM_BUILD_ROOT install
  103. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %post -p /sbin/ldconfig
  107. %postun -p /sbin/ldconfig
  108. %files
  109. %defattr(-,root,root)
  110. %{!?_licensedir:%global license %%doc}
  111. %license COPYING
  112. %doc CHANGES README
  113. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  114. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  115. %doc docs/TheArtOfHttpScripting docs/TODO
  116. %{_bindir}/curl
  117. #{_datadir}/curl/*
  118. %{_libdir}/*.so.*
  119. %{_mandir}/man1/*.1*
  120. %files devel
  121. %defattr(-,root,root)
  122. %{_bindir}/curl-config
  123. %{_includedir}/curl
  124. %{_libdir}/*.so
  125. %{_libdir}/pkgconfig/*.pc
  126. %{_mandir}/man1/curl-config.1*
  127. %{_mandir}/man3/*
  128. %{_datadir}/aclocal/libcurl.m4
  129. ## to build compat32 for x86_64 architecture support
  130. %if %{build_compat32}
  131. %files -n compat32-%{name}
  132. %defattr(-,root,root)
  133. %{_libdir}/*.so.*
  134. %files -n compat32-%{name}-devel
  135. %defattr(-,root,root)
  136. %{_libdir}/*.so
  137. %{_libdir}/pkgconfig/*.pc
  138. %endif
  139. %changelog
  140. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  141. - new upstream release.
  142. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  143. - new upstream release.
  144. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  145. - new upstream release.
  146. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  147. - new upstream release.
  148. - disabled HTTP/2 on Vine6.
  149. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  150. - added HTTP/2 support.
  151. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  152. - new upstream release with security fix.
  153. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  154. - new upstream release.
  155. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  156. - new upstream release
  157. - built with openssl 1.0.2g
  158. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  159. - new upstream release with security fix .
  160. - removed Patch108 (fixed in upstream).
  161. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  162. - new upstream release with security fix
  163. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  164. - new upstream release
  165. - add libcurl.m4 to -devel package
  166. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  167. - new upstream release
  168. - import upstream/fedora patches
  169. - disable libssh2 on Vine Linux 6
  170. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  171. - new upstream reelase
  172. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  173. - update to 7.28.0
  174. - add configure options
  175. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  176. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  177. - use ca-certificates package
  178. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  179. - R: ca-certificates
  180. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  181. - new upstream release
  182. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  183. - add patch100 for fix CVE-2011-2192 (gssapi)
  184. - add Vendor/Distri tags
  185. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  186. - rebuild with openssl-1.0.0c
  187. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  188. - rebuilt with rpm-4.8.1 for pkg-config
  189. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  190. - new upstream release
  191. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  192. - new upstream release with security fix
  193. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  194. - added compat32 subpackages
  195. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  196. - new upstream release
  197. - use "_smp_mflags" flag
  198. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  199. - rebuild with openldap-2.4.11
  200. - add BR: openldap-devel
  201. - remove static library
  202. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  203. - new upstream release with security fix (CVE-2009-0037)
  204. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  205. - new upstream release
  206. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  207. - new upstream release
  208. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  209. - new upstream release
  210. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  211. - new upstream release
  212. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  213. - new upstream release
  214. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  215. - rebuilt with openssl-0.9.8e
  216. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  217. - new upstream release
  218. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  219. - new upstream release
  220. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  221. - new upstream release
  222. - add pkgconfig file to devel package
  223. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  224. - new upstream release
  225. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  226. - new upstream release
  227. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  228. - new upstream release
  229. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  230. - added libidn, zlib in Requires
  231. - added libidn-devel, zlib-devel in BuildPrereq
  232. - added zlib-devel in curl-devel's Requires
  233. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  234. - added openssl-devel, libidn-devel in curl-devel's Requires
  235. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  236. - new upstream release
  237. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  238. - new upstream release
  239. - rebuild with openssl-0.9.7d
  240. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  241. - upstream release
  242. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  243. - add %%{_datadir}/curl/* to %%files section
  244. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  245. - source upgrade
  246. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  247. - source upgrade
  248. - add PreReq: ldconfig
  249. - add %%{_libdir}/*.la to %%files devel section
  250. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  251. - build for VineSeed
  252. - add Requires: openssl
  253. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  254. - automated rebuild
  255. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  256. - 7.9.2
  257. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  258. - include curl-config in curl-devel
  259. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  260. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  261. - added openssl-devel build req
  262. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  263. - built for the distro
  264. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  265. - upgrade to curl-7.7.2.
  266. - enable IPv6.
  267. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  268. - rebuilt against openssl-0.9.6-1
  269. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  270. - fixed mising ldconfigs
  271. - updated to 7.5.2, bug fixes
  272. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  273. - updated to 7.5.1
  274. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  275. - update to 7.4.1 to fix bug #20337, problems with curl -c
  276. - not using patch anymore, it's included in the new source. Keeping
  277. for reference
  278. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  279. - fix bogus req in -devel package
  280. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  281. - devel package needed defattr so that root owns the files
  282. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  283. - update to 7.3
  284. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  285. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  286. - enable SSL support
  287. - fix packager tag
  288. - move buildroot to %%{_tmppath}
  289. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  290. - fixed vendor tag for bug #15028
  291. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  292. - rebuilt
  293. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  294. - workaround alpha build problems with optimizations
  295. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  296. - rebuilt
  297. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  298. - put man pages in correct place
  299. - use %%makeinstall
  300. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  301. - updated to 6.5.2
  302. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  303. - updated sources to 6.2
  304. - gzip man page
  305. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  306. - changed group
  307. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  308. - changelog started
  309. - general cleanups, changed prefix to /usr, added manpage to files section
  310. - including in Powertools