123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176 |
- %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
- %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
- %define dbus_glib_version 0.70
- %define dbus_version 1.6
- %define pkg_release 1%{?_dist_release}
- Name: dbus-python
- Summary: D-Bus Python Bindings
- Summary(ja): D-Bus Python バインディング
- Version: 1.2.0
- Release: %{pkg_release}
- Group: System Environment/Libraries
- License: MIT
- URL: http://www.freedesktop.org/software/dbus/
- Source0: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: dbus-devel >= %{dbus_version}
- BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
- BuildRequires: python-devel
- %description
- D-Bus python bindings for use with python programs.
- %description -l ja
- D-Bus を python プログラムから使う為のバインディングです。
- %package devel
- Summary: Libraries and headers for dbus-python
- Summary(ja): dbus-python のライブラリ及びヘッダファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- Headers and static libraries for hooking up custom mainloops to the dbus python
- bindings.
- %description devel -l ja
- dbus-python バインディング用のカスタム・メインループをフックする為の
- ヘッダファイルとスタティック・ライブラリです。
- %prep
- %setup -q
- %build
- %configure
- %{__make} %{?_smp_mflags}
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__make} install DESTDIR=${RPM_BUILD_ROOT}
- # remove unnecessary *.la files
- find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
- %clean
- rm -rf ${RPM_BUILD_ROOT}
- %files
- %defattr(-,root,root)
- %doc COPYING ChangeLog README NEWS TODO
- %doc doc/API_CHANGES.txt doc/HACKING.txt doc/tutorial.txt
- %exclude %{_datadir}/doc/dbus-python
- %dir %{python_sitelib}/dbus
- %dir %{python_sitelib}/dbus/mainloop
- %{python_sitearch}/*.so
- %{python_sitelib}/dbus/*.py*
- %{python_sitelib}/dbus/mainloop/*.py*
- %files devel
- %defattr(-,root,root)
- %{_includedir}/dbus-1.0/dbus/dbus-python.h
- %{_libdir}/pkgconfig/dbus-python.pc
- %changelog
- * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
- - update to 1.2.0
- * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.83.2-2
- - rebuild with python-2.7.2
- * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.83.2-1
- - new upstream release
- * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.83.1-1
- - new upstream release
- - dropt Patch0 (merged into upstream)
- - built with rpm-4.8.1 for pkg-config
- * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-4
- - rebuilt with gcc-4.4.3-3 on ppc
- * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-3
- - rebuilt with rpm-4.8.0-3 (on ppc)
- * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.83.0-2
- - rebuild with python-2.6
- * Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.83.0-1
- - initital build for Vine Linux based on fedora package
- * Tue Sep 16 2008 Marco Pesenti Gritti - 0.83.0-3
- - Add patch for https://bugs.freedesktop.org/show_bug.cgi?id=17551
- * Tue Aug 05 2008 Huang Peng <phuang@redhat.com> - 0.83.0-2
- - Update to 0.83.0.
- * Wed Jul 16 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.82.4-3
- - fix license tag
- * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.82.4-2
- - Autorebuild for GCC 4.3
- * Sun Jan 20 2008 Matthias Clasen <mclasen@redhat.com> - 0.82.4-1
- - Update to 0.82.4
- * Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-3
- - Rebuild against new dbus-glib
- * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.82.0-2
- - Rebuild for selinux ppc32 issue.
- * Fri Jun 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-1
- - Update to 0.82.0
- - Put all docs in the usual place
- * Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-3
- - Rebuild
- * Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-2
- - Don't examine args for functions declared METH_NOARGS (#235017)
- * Tue Feb 13 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.2-1
- - upgrade to 0.80.2 which fixes some memleaks
- * Wed Jan 24 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.1-1
- - upgrade to 0.80.1
- - remove dependency on Pyrex and libxml2
- - some API breakage,
- please see http://dbus.freedesktop.org/doc/dbus-python/NEWS.html
- for notes on changes
- * Wed Jan 3 2007 David Zeuthen <davidz@redhat.com> - 0.70-9%{?dist}
- - rebuild against new Pyrex
- * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 0.70-8
- - rebuild against python 2.5
- * Tue Nov 7 2006 Matthias Clasen <mclasen@redhat.com> - 0.70-7
- - Fix a typo in the spec file
- * Fri Aug 18 2006 Karsten Hopp <karsten@redhat.com> - 0.70-6
- - require libxml2-python for site-packages/dbus/introspect_parser.py
- * Thu Jul 20 2006 Jesse Keating <jkeating@redhat.com> - 0.70-5
- - Remove unnecessary obsoletes
- * Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-4
- - Try python_sitearch this time
- * Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-3
- - Add a BR on dbus-devel
- * Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-2
- - Spec file cleanups
- - Add PKG_CONFIG_PATH
- * Mon Jul 17 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-1
- - Initial package import
|