evolution-webcal-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. %define libsoup_version 2.3.0
  2. %define eds_version 2.32.0
  3. %define gettext_package evolution-webcal
  4. Name: evolution-webcal
  5. Summary: A handler for webcal URIs
  6. Version: 2.32.0
  7. Release: 3%{?_dist_release}
  8. License: GPL
  9. Group: Applications/Internet
  10. Source0: %{name}-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: glib2-devel >= 2.8.0
  13. BuildRequires: gtk2-devel >= 2.4.0
  14. BuildRequires: libsoup-devel >= %{libsoup_version}
  15. BuildRequires: evolution-data-server-devel >= %{eds_version}
  16. Requires: libsoup >= %{libsoup_version}
  17. Requires: evolution-data-server >= %{eds_version}
  18. Requires(post): GConf2
  19. Requires(pre): GConf2
  20. Requires(preun): GConf2
  21. %description
  22. evolution-webcal is a small helper application that can be run when webcal URIs are clicked in web browsers.
  23. It adds the calendar to your evolution-data-server, which will make the calendar appear in Evolution and in the gnome-panel's calendar.
  24. %prep
  25. %setup -q
  26. %build
  27. %configure --disable-schemas-install
  28. make
  29. %install
  30. rm -rf %{buildroot}
  31. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  32. make DESTDIR=$RPM_BUILD_ROOT install
  33. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  34. %find_lang %{gettext_package}
  35. grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
  36. %clean
  37. rm -rf %{buildroot}
  38. %post
  39. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  40. SCHEMAS="evolution-webcal.schemas"
  41. for S in $SCHEMAS; do
  42. gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
  43. done
  44. %pre
  45. if [ "$1" -gt 1 ]; then
  46. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  47. SCHEMAS="evolution-webcal.schemas"
  48. for S in $SCHEMAS; do
  49. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  50. done
  51. fi
  52. %preun
  53. if [ "$1" -eq 0 ]; then
  54. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  55. SCHEMAS="evolution-webcal.schemas"
  56. for S in $SCHEMAS; do
  57. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  58. done
  59. fi
  60. %files -f %{gettext_package}.lang
  61. %defattr(-,root,root)
  62. %{_sysconfdir}/gconf/schemas/evolution-webcal.schemas
  63. %{_libexecdir}/evolution-webcal
  64. %changelog
  65. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.32.0-3
  66. - rebuild with evolution-data-server-3.1.90
  67. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.32.0-2
  68. - rebuild with evolution-data-server-3.1.4
  69. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.32.0-1
  70. - new upstream release
  71. * Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.28.1-1
  72. - new upstream release
  73. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.28.0-1
  74. - new upstream release
  75. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
  76. - new upstream release
  77. - applied new versioning policy
  78. - built with evolution-data-server 2.24.2, libsoup 2.24.3
  79. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.1-1vl2
  80. - rebuild with gnutls-1.4.1
  81. * Wed Nov 9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.4.1-1vl1
  82. - rebuild for Vine Linux
  83. * Tue Oct 18 2005 David Malcolm <dmalcolm@redhat.com> - 2.4.1-1
  84. - 2.4.1
  85. * Thu Sep 15 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0.1-2
  86. - rebuild for new e-d-s
  87. * Wed Sep 7 2005 David Malcolm <dmalcolm@redhat.com> - 2.4.0.1-1
  88. - 2.4.0.1
  89. * Mon Aug 22 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.91-3
  90. - rebuild
  91. * Mon Aug 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.91-2
  92. - rebuild
  93. * Tue Aug 9 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.91-1
  94. - 2.3.91
  95. * Mon Aug 8 2005 Tomas Mraz <tmraz@redhat.com> - 2.3.90-2
  96. - rebuild with new gnutls
  97. * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.90-1
  98. - 2.3.90
  99. * Wed Mar 9 2005 David Malcolm <dmalcolm@redhat.com> - 2.2.0-1
  100. - updated from 2.1.92 to 2.2.0
  101. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.92-1
  102. - updated from 2.1.91 to 2.1.92
  103. * Wed Feb 9 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.91-1
  104. - updated from 2.1.4 to 2.1.91
  105. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.4-2
  106. - Exclude ppc64 build since mozilla is not supported, hence e-d-s is not supported
  107. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.4-1
  108. - updated from 1.0.10 to 2.1.3
  109. - removed evolution-webcal.applications; this was removed in version 2.1.1
  110. - updated e-d-s requirement from 0.0.91 to 1.1.0
  111. * Fri Oct 29 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.10-2
  112. - added missing requirements on libgnomeui (#137554)
  113. * Wed Sep 1 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.10-1
  114. - updated from 1.0.9 to 1.0.10
  115. * Mon Aug 30 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.9-2
  116. - Converted dashes to underscores in version defines; usage should now match up with definition
  117. * Thu Aug 26 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.9-1
  118. - Initial build.