flac-vl.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: flac
  3. Summary: FLAC - Free Lossless Audio Codec
  4. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  5. Version: 1.3.1
  6. Release: 3%{?_dist_release}
  7. Group: Applications/Multimedia
  8. License: BSD and GPLv2+
  9. URL: http://flac.sourceforge.net/
  10. Source: http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libogg-devel
  13. BuildRequires: automake autoconf libtool gettext-devel
  14. %ifarch %ix86
  15. # 2.0 supports symbol visibility
  16. BuildRequires: nasm >= 2.0
  17. %endif
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  22. similar to MP3, but lossless.
  23. The FLAC project consists of:
  24. * the stream format
  25. * libFLAC - reference encoders and decoders in library form
  26. * flac - a command-line program to encode and decode FLAC files
  27. * metaflac - a command-line metadata editor for FLAC files
  28. %description -l ja
  29. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  30. MP3 に似ていますが、音質が劣化しません。
  31. FLAC プロジェクトは以下により構成されています。
  32. * ストリーム形式
  33. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  34. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  35. プログラム。
  36. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  37. %package devel
  38. Summary: Development libraries and header files from FLAC
  39. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}
  42. Requires: pkgconfig
  43. %description devel
  44. This package contains all the files needed to develop applications that
  45. will use the Free Lossless Audio Codec (FLAC).
  46. %description -l ja devel
  47. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  48. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  49. # compat32
  50. %package -n compat32-%{name}
  51. Summary: FLAC - Free Lossless Audio Codec
  52. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  53. Group: System Environment/Libraries
  54. %description -n compat32-%{name}
  55. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  56. similar to MP3, but lossless.
  57. The FLAC project consists of:
  58. * the stream format
  59. * libFLAC - reference encoders and decoders in library form
  60. * flac - a command-line program to encode and decode FLAC files
  61. * metaflac - a command-line metadata editor for FLAC files
  62. %description -n compat32-%{name} -l ja
  63. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  64. MP3 に似ていますが、音質が劣化しません。
  65. FLAC プロジェクトは以下により構成されています。
  66. * ストリーム形式
  67. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  68. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  69. プログラム。
  70. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  71. %package -n compat32-%{name}-devel
  72. Summary: Development libraries and header files from FLAC
  73. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  74. Group: Development/Libraries
  75. Requires: %{name}-devel = %{version}-%{release}
  76. Requires: compat32-%{name} = %{version}-%{release}
  77. Requires: compat32-pkgconfig
  78. %description -n compat32-%{name}-devel
  79. This package contains all the files needed to develop applications that
  80. will use the Free Lossless Audio Codec (FLAC).
  81. %description -n compat32-%{name}-devel -l ja
  82. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  83. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  84. %prep
  85. %define srcver %{version}%{?extraver:-%extraver}
  86. %setup -q -n %{name}-%{srcver}
  87. %build
  88. ./autogen.sh -V
  89. %configure \
  90. --disable-static \
  91. --disable-xmms-plugin \
  92. %ifarch ppc
  93. --disable-asm-optimizations \
  94. %endif
  95. --disable-thorough-tests
  96. make %{?_smp_mflags}
  97. %install
  98. %__rm -rf %{buildroot}
  99. make install DESTDIR=%{buildroot}
  100. # remove unneeded files
  101. %{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
  102. %{_bindir}/find doc/ -name "Makefile*" -exec %__rm -f "{}" \;
  103. %check
  104. make -C test check &> /dev/null
  105. %clean
  106. %__rm -rf %{buildroot}
  107. %post -p %{_syssbindir}/ldconfig
  108. %postun -p %{_syssbindir}/ldconfig
  109. %post -n compat32-%{name} -p /sbin/ldconfig
  110. %postun -n compat32-%{name} -p /sbin/ldconfig
  111. %files
  112. %defattr(-,root,root)
  113. %doc AUTHORS COPYING.* README
  114. %{_bindir}/*
  115. %{_libdir}/*.so.*
  116. %{_mandir}/*/*
  117. %files devel
  118. %defattr(-,root,root)
  119. %doc doc/html COPYING.*
  120. %{_includedir}/*
  121. %{_libdir}/*.so
  122. %{_libdir}/pkgconfig/*.pc
  123. %{_datadir}/aclocal/*.m4
  124. # compat32
  125. %if %{build_compat32}
  126. %files -n compat32-%{name}
  127. %defattr(-,root,root)
  128. %doc AUTHORS COPYING.* README
  129. %{_libdir}/*.so.*
  130. %files -n compat32-%{name}-devel
  131. %defattr(-,root,root,-)
  132. %{_libdir}/*.so
  133. %{_libdir}/pkgconfig/*.pc
  134. %endif
  135. %changelog
  136. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-3
  137. - rebuilt with new toolchain.
  138. * Sat May 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.1-2
  139. - added compat32 subpackages
  140. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
  141. - new upstream release
  142. - remove old patches
  143. * Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
  144. - new upstream release
  145. - remove Patch1-6
  146. - add Patch1,2 from Fedora
  147. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
  148. - rebuilt with rpm-4.8.1 for pkg-config
  149. - added Patch1-6 from Fedora
  150. * Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  151. - applied new versioning policy
  152. - spec in UTF-8
  153. * Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
  154. - new upstream release
  155. - drop bmp-plugin.patch (patch1)
  156. - disable xmms plugin
  157. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  158. - new upsteram release
  159. - dropped Patch2 (merged into upstream)
  160. - do not build beepmp plugin
  161. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
  162. - rebuilt with new toolchain
  163. * Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
  164. - add '--disable-static' option to %%configure
  165. - remove *.la
  166. * Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
  167. - rebuild
  168. * Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
  169. - --disable-asm-optimizations on ppc
  170. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
  171. - rebuild
  172. * Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
  173. - initialize flac_cfg.stream with NULL to avoid crashing (patch2)
  174. * Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
  175. - upstream release
  176. - update bmp-plugin.patch
  177. * Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
  178. - upstream release
  179. - update bmp-plugin.patch
  180. * Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
  181. - fix typo
  182. * Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
  183. - move html docs to devel package
  184. * Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
  185. - add input plugin for beepmp based on for xmms (patch1)
  186. - BuildRequires: beepmp-devel >= 0.9.7
  187. - define build_*_plugin macros to build input plugin sub-packages
  188. - update description
  189. * Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
  190. - drop BuildRequires: zlib-devel (was required to build with id3lib)
  191. * Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
  192. - upstream release
  193. - drop (Build)Requires: id3lib(-devel)
  194. * Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
  195. - 1.1.1-beta1
  196. - add BuildRequires: gtk+-devel, zlib-devel
  197. * Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
  198. - xmms-flac
  199. - enable to convert charset from/to EUC-JP-MS (Patch0)
  200. - Requires: glibc >= 2.3.3
  201. * Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
  202. - fix docs
  203. * Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
  204. - first build for Vine Linux
  205. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  206. - Rebuilt for Red Hat Linux 9.
  207. - Exclude .la files.
  208. - Updated description.
  209. * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  210. - Fix nasm dep to be only for ix86.
  211. * Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  212. - Update to 1.1.0.
  213. * Sun Jan 5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  214. - Rebuilt against the latest id3lib for the xmms plugin.
  215. * Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  216. - Fixed location of include files, doh!
  217. * Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  218. - Rebuilt for Red Hat Linux 8.0.
  219. * Wed Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  220. - Update to 1.0.4.
  221. - Removed obsolete build patch, the xmms plugin builds cleanly at last!
  222. * Thu Jul 4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  223. - Update to 1.0.3.
  224. * Tue Apr 23 2002 Daniel Resare <noa@resare.com>
  225. - Fixed plugin build when flac is not already installed
  226. * Mon Apr 8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  227. - Replaced the hard-coded xmms input path with an expansion.
  228. - Fixed spec (License tag and redundant Group for devel package).
  229. - Fixed defattr for the xmms plugin.
  230. * Sat Apr 6 2002 Daniel Resare <noa@resare.com>
  231. - Update to 1.0.2.
  232. - Splitted out xmms plugin to a separate subpackage.
  233. * Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  234. - Update to 1.0.1.
  235. * Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  236. - Rebuilt for Red Hat 7.2 and added xmms dependency.
  237. * Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  238. - Initial RPM release.
  239. - You cannot rebuild this SRPM easily if you want the xmms plugin.