freeciv-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442
  1. # include fallback defs for _ggz_config, _ggz_datadir macros
  2. # feel free to drop when ggz-client-lib including these is deployed everywhere
  3. %{!?_ggz_config:%define _ggz_config %{_bindir}/ggz-config}
  4. %{!?_ggz_datadir:%define _ggz_datadir %(%{_ggz_config} --datadir >& /dev/null ||:)}
  5. Name: freeciv
  6. Version: 2.2.5
  7. Release: 3%{?_dist_release}
  8. Summary: A multi-player strategy game
  9. Summary(ja): 多人数戦略ゲーム
  10. Group: Applications/Games
  11. License: GPLv2+
  12. URL: http://freeciv.wikia.com/index.php/Freeciv
  13. Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  14. Source1: freeciv-2.2.5-fixed-tutorial_ja.po
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  16. ##Fix DSO patch
  17. Patch10: freeciv-client-fix-DSO.patch
  18. BuildRequires: gtk2-devel
  19. BuildRequires: readline-devel
  20. BuildRequires: zlib-devel
  21. BuildRequires: SDL_mixer-devel
  22. BuildRequires: ncurses-devel
  23. BuildRequires: ggz-client-libs-devel
  24. BuildRequires: desktop-file-utils
  25. BuildRequires: gettext
  26. Requires(post): ggz-client-libs
  27. Requires(preun): ggz-client-libs
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: iwaim
  31. %description
  32. Freeciv is a turn-based, multi-player, X based strategy game. Freeciv
  33. is generally comparable to, and has compatible rules with, the
  34. Civilization II(R) game by Microprose(R). In Freeciv, each player is
  35. the leader of a civilization, and is competing with the other players
  36. in order to become the leader of the greatest civilization.
  37. %prep
  38. %setup -q -n %{name}-%{version}
  39. %patch10 -p0
  40. %__rm -f po/ja.{po,gmo}
  41. %__cp -p %{SOURCE1} po/ja.po
  42. %build
  43. %configure --enable-client=gtk --disable-static
  44. make %{?_smp_mflags}
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. make install DESTDIR=$RPM_BUILD_ROOT
  48. %find_lang %{name}
  49. desktop-file-install --vendor vine --delete-original \
  50. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  51. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  52. desktop-file-install --vendor vine --delete-original \
  53. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  54. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}-server.desktop
  55. # Remove civmanual
  56. rm $RPM_BUILD_ROOT%{_bindir}/civmanual
  57. # ggz config
  58. # omit ggz.modules, to register at install, not build, time.
  59. if [ -e $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules ]; then
  60. rm $RPM_BUILD_ROOT%{_sysconfdir}/ggz.modules
  61. fi
  62. # include .dsc files
  63. install -p -D -m644 data/civclient.dsc $RPM_BUILD_ROOT%{_ggz_datadir}/civclient.dsc
  64. find $RPM_BUILD_ROOT -name '*.la' -delete
  65. find $RPM_BUILD_ROOT -name '*.a' -delete
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %post
  69. %{_ggz_config} --install --force --modfile=%{_ggz_datadir}/civclient.dsc || :
  70. touch --no-create %{_datadir}/icons/hicolor
  71. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  72. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  73. fi
  74. %preun
  75. if [ $1 -eq 0 ]; then
  76. %{_ggz_config} --remove --modfile=%{_ggz_datadir}/civclient.dsc || :
  77. fi
  78. %postun
  79. touch --no-create %{_datadir}/icons/hicolor
  80. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  81. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  82. fi
  83. %files -f %{name}.lang
  84. %defattr(-,root,root)
  85. %doc COPYING NEWS doc/BUGS doc/HOWTOPLAY doc/README
  86. %doc doc/README.AI doc/README.agents doc/README.attributes doc/README.cma
  87. %doc doc/README.delta doc/README.effects doc/README.ftwl doc/HACKING
  88. %doc doc/README.scorelog doc/TODO
  89. %doc doc/README.graphics doc/README.sound
  90. %{_bindir}/freeciv-server
  91. %{_bindir}/freeciv-gtk2
  92. %{_datadir}/%{name}/
  93. %{_datadir}/applications/vine-*.desktop
  94. %{_datadir}/icons/hicolor/*/apps/*.png
  95. %{_datadir}/pixmaps/%{name}-client.png
  96. %{_mandir}/man6/freeciv*6*
  97. %{_ggz_datadir}/civclient.dsc
  98. %changelog
  99. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.5-3
  100. - rebuild with readline-6.3
  101. - remove BuildRequires: esound-devel
  102. * Sun Nov 2 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.5-2
  103. - moved to Applications/Games
  104. * Thu Apr 7 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.5-1
  105. - new upstream release
  106. - update ja.po (Source1): fixed upstream ja.po bug
  107. * Tue Dec 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.3-2
  108. - rebuild with SDL_mixer-1.2.11-2
  109. * Fri Sep 17 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.3-1
  110. - new upstream release
  111. - update ja.po (Source1): fixed upstream ja.po
  112. * Wed Sep 1 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
  113. - build for Vine Linux: from Fedora 2.2.2-1
  114. - change BuildRequires: ggz-gtk-client-devel to gz-client-libs-devel
  115. - add ja.po (Source1) from http://loda.jp/freeciv/?id=81
  116. * Mon Aug 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.2-1
  117. - security fix https://www.redhat.com/security/data/cve/CVE-2010-2445.html
  118. - fixes #612296
  119. * Sun Jun 06 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-2
  120. - security fix http://gna.org/bugs/?15624
  121. - #600742 #600743 #600744
  122. * Tue Mar 02 2010 Thomas Janssen <thomasj@fedoraproject.org> 2.2.0-1
  123. - New upstream source 2.2.0
  124. * Fri Jan 29 2010 Brian Pepple <bpepple@fedoraproject.org> - 2.1.11-1
  125. - Update to 2.1.11.
  126. * Fri Dec 11 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.10-1
  127. - Update to 2.1.10.
  128. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.9-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  130. * Sun Apr 5 2009 Brian Pepple <bpepple@fedoraproject.org> - 2.1.9-1
  131. - Update to 2.1.9.
  132. * Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 2.1.8-3
  133. - drop bind-devel BuildReq, it is not needed
  134. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.8-2
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  136. * Thu Dec 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.8-1
  137. - Update to 2.1.8.
  138. * Wed Nov 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.7-1
  139. - Update to 2.1.7.
  140. * Sat Nov 22 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-2
  141. - Simplify summary.
  142. * Sat Aug 23 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.6-1
  143. - Update to 2.1.6.
  144. * Thu Jun 19 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.5-1
  145. - Update to 2.1.5.
  146. * Tue Apr 29 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.4-1
  147. - Update to 2.1.4.
  148. * Sat Feb 9 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 2.1.3-4
  149. - Fix up typo.
  150. * Fri Feb 8 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.3-3
  151. - fixup ggz integration (#431726)
  152. * Mon Feb 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-2
  153. - Add ggz gaming support.
  154. * Sat Jan 26 2008 Brian Pepple <bpepple@fedoraproject.org> - 2.1.3-1
  155. - Update to 2.1.3.
  156. * Tue Dec 25 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.2-1
  157. - Update to 2.1.2.
  158. * Thu Nov 29 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.1-1
  159. - Update to 2.1.1.
  160. - Drop buffer overflow patch. fixed upstream.
  161. - Drop open file patch. fixed upstream.
  162. * Sat Nov 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-2
  163. - Add patch to fix buffer overflow. (#397531)
  164. * Sun Oct 28 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.1.0-1
  165. - Update to 2.1.0.
  166. - Update urls.
  167. - Update aifill & open patches.
  168. - Remove old freeciv pixmap.
  169. - Remove desktop patch.
  170. * Sun Sep 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-4
  171. - Add patch to fix open function build bug.
  172. * Tue Aug 21 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-3
  173. - Rebuild.
  174. * Thu Aug 2 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-2
  175. - Update license tag.
  176. * Tue Feb 13 2007 Brian Pepple <bpepple@fedoraproject.org> - 2.0.9-1
  177. - Update to 2.0.9.
  178. - Drop button patch, fixed upstream.
  179. - Drop security patch, fixed upstream.
  180. - Drop X-Fedora category from desktop files.
  181. * Thu Sep 7 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-7
  182. - Rebuild for FC6.
  183. * Wed Aug 2 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-6
  184. - Update security patch.
  185. - Add patch to fix turn done buttons style.
  186. * Tue Aug 1 2006 Brian Pepple <bpepple@fedoraproject.org> - 2.0.8-5
  187. - Add patch to fix CVE-2006-3913 vulnerability. (#200545)
  188. - Replace desktop file category 'Strategy' with 'StrategyGame'. (#198086)
  189. * Mon Mar 6 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.8-2
  190. - Update to 2.0.8.
  191. * Thu Feb 16 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-6
  192. - Remove unnecessary BR (alsa-lib-devel & SDL-devel).
  193. * Mon Feb 13 2006 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-5
  194. - rebuilt for new gcc4.1 snapshot and glibc changes
  195. * Sun Dec 4 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-4
  196. - Rebuild for new bind.
  197. * Sun Nov 6 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.7-3
  198. - Update to 2.0.7.
  199. - Modify desktop patch for upstream fixes.
  200. - Drop the %%config from .desktop files.
  201. * Mon Sep 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.6-3
  202. - Update to 2.0.6.
  203. * Fri Sep 2 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.5-3
  204. - Update to 2.0.5.
  205. - Enable debug info.
  206. * Tue Aug 16 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-4
  207. - Rebuild for cairo dep.
  208. * Thu Jul 28 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.4-2
  209. - Update to 2.0.4.
  210. - Use new stdsounds.
  211. * Fri Jul 15 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-2
  212. - Bump release.
  213. * Thu Jul 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.3-1
  214. - Update to 2.0.3.
  215. * Tue Jun 14 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.2-1
  216. - Update to 2.0.2.
  217. - Add dist tag.
  218. * Tue Apr 26 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.1-1.fc4
  219. - Update to 2.0.1.
  220. * Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-3.fc4
  221. - Re-add patch to set aifill to 5 on new servers to get some opponents.
  222. * Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-2.fc4
  223. - remove redundant --dir* options in %%configure & %%makeinstall.
  224. * Mon Apr 18 2005 Brian Pepple <bdpepple@ameritech.net> - 2.0.0-1.fc4
  225. - Update to 2.0.0.
  226. - Drop 1.14 patches.
  227. - Add new BR's for 2.0.0.
  228. * Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-7
  229. - Fixed typos.
  230. * Sat Mar 26 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-6
  231. - Added more macros.
  232. - Replaced BuildPrereq with BuildRequires.
  233. - Drop version of gtk2-devel, since FC3 & later meet minimum needed.
  234. * Wed Mar 23 2005 Brian Pepple <bdpepple@ameritech.net> - 1.14.2-5
  235. - Changed X-Red-Hat-Extra to X-Fedora.
  236. - Added URL.
  237. - Changed BuildRoot to preferred value.
  238. - Removed period from summary.
  239. * Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> 1.14.2-4
  240. - Rebuilt for new readline.
  241. * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.14.2-3
  242. - [136921] Try a little harder to run as nobody
  243. * Mon Oct 25 2004 Daniel Reed <djr@redhat.com> 1.14.2-2
  244. - [136921] Provide the user with the opportunity to run FreeCiv as root if unable to su to nobody, and throw up an error message if everything fails
  245. * Mon Sep 13 2004 Karsten Hopp <karsten@redhat.de> 1.14.2-1
  246. - update to latest stable version
  247. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  248. - rebuilt
  249. * Mon Feb 23 2004 Karsten Hopp <karsten@redhat.de> 1.14.1-3
  250. - rebuild with new chown syntax
  251. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
  252. - Use ':' instead of '.' as separator for chown.
  253. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  254. - rebuilt
  255. * Wed Dec 03 2003 Karsten Hopp <karsten@redhat.de> 1.14.1-1
  256. - update to bugfix release 1.14.1
  257. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  258. - rebuilt
  259. * Thu May 08 2003 Karsten Hopp <karsten@redhat.de> 1.14.0-1
  260. - update
  261. * Thu Feb 20 2003 Karsten Hopp <karsten@redhat.de> 1.13.0-6
  262. - remove last patch (obsolete)
  263. * Wed Feb 19 2003 Karsten Hopp <karsten@redhat.de>
  264. - fix message translation (#84599)
  265. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  266. - rebuilt
  267. * Thu Nov 07 2002 Karsten Hopp <karsten@redhat.de>
  268. - spelling fix (#75021)
  269. - set aifill to 5 on new servers to get some opponents (#72586)
  270. * Thu Aug 01 2002 Karsten Hopp <karsten@redhat.de>
  271. - desktop fixes (#69391)
  272. * Wed Jul 24 2002 Karsten Hopp <karsten@redhat.de>
  273. - 0.1.13
  274. - s/Games/Game in desktop-file-install
  275. - fix URL
  276. - add standard sounds
  277. * Wed Jul 17 2002 Karsten Hopp <karsten@redhat.de> 1.12.0-6
  278. - fix path to datafiles if FREECIV_PATH is not set (#67922)
  279. - fix desktop files (#67920)
  280. - use desktop-file-install
  281. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  282. - automated rebuild
  283. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  284. - automated rebuild
  285. * Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-2
  286. - Rebuild in current environment
  287. * Thu Aug 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.12.0-1
  288. - 1.12.0 (non-beta)
  289. * Tue Jul 31 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-9
  290. - Rebuild - the fix for #49442 didn't seem to get in last time.
  291. * Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.11.4-8
  292. - Fix up demographics (#50119)
  293. * Wed Jun 27 2001 Than Ngo <than@redhat.com>
  294. - support new gettext
  295. - add patch to build against new libtool
  296. * Tue Mar 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  297. - use gtk-config instead of glib-config
  298. * Sun Feb 25 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  299. - Fix up civclient-wrapper so it doesn't fail silently when started as
  300. potentially harmful user (Bug #28928)
  301. * Tue Aug 1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  302. - Fix warning in civclient-wrapper (Bug 14860)
  303. * Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
  304. - 1.11.4
  305. - move to /usr/bin and /usr/share/freeciv (no more /usr/games)
  306. * Wed Jul 12 2000 Trond Eivind Glomsrød <teg@redhat.com>
  307. - remove icon, glint is obsoleted
  308. - don't use find to build file lists, it claimed to own
  309. lots of directories
  310. - use %%{_tmppath}
  311. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  312. - automatic rebuild
  313. * Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  314. - 1.11.0 (Bug #13610)
  315. - Add .desktop files (Bug #13610)
  316. - Add BuildPrereq: lines
  317. - fix build
  318. * Thu Jun 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  319. - move to dist
  320. - update
  321. - clean up the spec file
  322. - fix build with gcc 2.96
  323. - make the gtk client default; it's better than the Xaw one by now.
  324. * Thu Feb 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  325. - 1.10.0
  326. * Fri Feb 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  327. - 1.9.2
  328. - use the configure macro
  329. * Sun Nov 7 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  330. - redo RPM for 1.9.0 (many changes to build/install procedure)