gnome-shell-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356
  1. %define pkg_version 3.20.3
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Summary(ja): GNOME 上でウィンドウの管理及びアプリケーションの起動を行うインターフェース
  5. Name: gnome-shell
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
  9. # settings for Vine
  10. Patch101: gnome-shell-3.14.1-vine-settings.patch
  11. Patch102: gnome-shell-3.16.0-revert-loginManager.patch
  12. Patch103: gnome-shell-3.16.2-disable-packagekit.patch
  13. Patch104: gnome-shell-3.20.3-vine-themes.patch
  14. License: GPLv2+
  15. Group: User Interface/Desktops
  16. URL: http://live.gnome.org/GnomeShell
  17. Requires: mutter
  18. Requires: caribou
  19. Requires: ca-certificates
  20. Requires: at-spi2-atk
  21. Requires: telepathy-logger
  22. Requires: network-manager-applet
  23. Requires: gnome-tweak-tool
  24. BuildRequires: gnome-common
  25. BuildRequires: libtool
  26. BuildRequires: automake
  27. BuildRequires: autoconf
  28. BuildRequires: pkgconfig
  29. BuildRequires: gtk2-devel
  30. BuildRequires: clutter-devel
  31. BuildRequires: mutter-devel
  32. BuildRequires: gjs-devel
  33. BuildRequires: gnome-desktop3-devel
  34. BuildRequires: gnome-menus-devel
  35. BuildRequires: libSM-devel
  36. BuildRequires: libffi-devel
  37. BuildRequires: startup-notification-devel
  38. BuildRequires: gnome-doc-utils
  39. BuildRequires: desktop-file-utils
  40. BuildRequires: libcroco-devel
  41. BuildRequires: librsvg2-devel
  42. BuildRequires: gobject-introspection-devel
  43. BuildRequires: control-center-devel
  44. BuildRequires: gcr-devel
  45. BuildRequires: gstreamer-devel
  46. BuildRequires: dbus-glib-devel
  47. BuildRequires: telepathy-logger-devel
  48. BuildRequires: polkit-devel
  49. BuildRequires: pulseaudio-libs-devel
  50. BuildRequires: evolution-data-server-devel
  51. BuildRequires: folks-devel
  52. BuildRequires: NetworkManager-glib-devel
  53. BuildRequires: libnm-gtk-devel
  54. BuildRequires: libgudev1-devel
  55. BuildRequires: libcanberra-gtk3-devel
  56. BuildRequires: caribou-devel
  57. BuildRequires: ca-certificates
  58. BuildRequires: python3-devel
  59. BuildRequires: intltool
  60. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  61. Vendor: Project Vine
  62. Distribution: Vine Linux
  63. Packager: Takemikaduchi
  64. %description
  65. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  66. It provides core interface functions like switching to windows and launching
  67. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  68. hardware and introduces innovative user interface concepts to provide a delightful
  69. and easy to use experience.
  70. %package docs
  71. Summary: Documentation for %{name}
  72. Summary(ja): %{name} 用のドキュメント
  73. Group: Documentation
  74. Requires: %{name} = %{version}-%{release}
  75. BuildArch: noarch
  76. %description docs
  77. This package contains documentation for %{name}.
  78. %prep
  79. %setup -q
  80. #%patch101 -p1 -b .vine
  81. %patch102 -p1 -b .vine
  82. %patch103 -p1 -b .vine
  83. %patch104 -p1 -b .vine
  84. %build
  85. %configure \
  86. --disable-static \
  87. --disable-systemd
  88. %{__make} %{?_smp_mflags} V=1
  89. %install
  90. %{__rm} -rf ${RPM_BUILD_ROOT}
  91. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  92. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  93. %find_lang %{name}
  94. %clean
  95. %{__rm} -rf ${RPM_BUILD_ROOT}
  96. %post
  97. /sbin/ldconfig
  98. touch --no-create %{_datadir}/icons/hicolor
  99. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  100. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  101. fi
  102. %postun
  103. /sbin/ldconfig
  104. touch --no-create %{_datadir}/icons/hicolor
  105. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  106. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  107. fi
  108. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  109. %posttrans
  110. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  111. %files -f %{name}.lang
  112. %defattr(-,root,root,-)
  113. %doc COPYING NEWS README
  114. %{_bindir}/gnome-shell
  115. %{_bindir}/gnome-shell-extension-tool
  116. %{_bindir}/gnome-shell-extension-prefs
  117. %{_bindir}/gnome-shell-perf-tool
  118. %{_libdir}/%{name}/*
  119. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  120. %{_libexecdir}/gnome-shell-calendar-server
  121. %{_libexecdir}/gnome-shell-hotplug-sniffer
  122. %{_libexecdir}/gnome-shell-perf-helper
  123. %{_libexecdir}/gnome-shell-portal-helper
  124. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  125. %{_datadir}/applications/org.gnome.Shell.desktop
  126. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  127. %{_datadir}/applications/evolution-calendar.desktop
  128. %{_datadir}/applications/org.gnome.Shell.PortalHelper.desktop
  129. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  130. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
  131. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
  132. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
  133. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  134. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  135. %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
  136. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  137. %{_datadir}/%{name}/*
  138. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  139. %{_mandir}/man1/%{name}.1.gz
  140. %files docs
  141. %defattr(-,root,root,-)
  142. %{_datadir}/gtk-doc/html/shell
  143. %{_datadir}/gtk-doc/html/st
  144. %changelog
  145. * Sun Jul 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-2
  146. - new upstream release
  147. - add Patch104 (gnome-shell-3.20.3-vine-themes.patch)
  148. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
  149. - new upstream release
  150. - update Patch104 (gnome-shell-3.20.0-vine-themes.patch)
  151. * Fri Nov 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
  152. - new upstream release
  153. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  154. - new upstream release
  155. * Thu Nov 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  156. - new upstream release
  157. - update Patch104 (gnome-shell-3.18.1-vine-themes.patch)
  158. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  159. - new upstream release
  160. * Sun Jun 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  161. - add Patch104 (gnome-shell-3.16.2-vine-themes.patch)
  162. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  163. - add Patch103 (gnome-shell-3.16.2-disable-packagekit.patch)
  164. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  165. - new upstream release
  166. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  167. - new upstream release
  168. * Thu Apr 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  169. - new upstream release
  170. - add BuildRequires: python3-devel
  171. - update Patch102 (gnome-shell-3.16.0-revert-loginManager.patch)
  172. * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.3-2
  173. - rebuilt with libical 1.0.1
  174. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
  175. - new upstream release
  176. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  177. - new upstream release
  178. * Sat Nov 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1.5-1
  179. - new upstream release
  180. - update Patch101 (gnome-shell-3.14.1-vine-settings.patch)
  181. - add Patch102 (gnome-shell-3.14.1.5-revert-loginManager.patch)
  182. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  183. - new upstream release
  184. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  185. - new upstream release
  186. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  187. - new upstream release
  188. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  189. - new upstream release
  190. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2.1-1
  191. - new upstream release
  192. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  193. - new upstream release
  194. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  195. - new upstream release
  196. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  197. - new upstream release
  198. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  199. - new upstream release
  200. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  201. - new upstream release
  202. - update Patch101 (gnome-shell-vine-settings.patch)
  203. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  204. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  205. - create %%{name}-docs subpackage
  206. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  207. - new upstream release
  208. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  209. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  210. - new upstream release
  211. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  212. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  213. - new upstream release
  214. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  215. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  216. - rebuild with telepathy-logger-0.6.0
  217. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  218. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  219. - new upstream release
  220. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  221. - new upstream release
  222. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  223. - update Patch101 (gnome-shell-vine-settings.patch)
  224. - change BuildRequires: ca-certificates instead of openssl
  225. - add BuildRequires: libcanberra-gtl3-devel
  226. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  227. - new upstream release
  228. - remove Patch103 (gnome-shell-ja.po-date.patch)
  229. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  230. - new upstream release
  231. - update Patch101,103
  232. - remove Patch0,102
  233. - add BuildRequires: gcr-devel
  234. - remove BuildRequires: GConf2-devel
  235. - add Requires: at-spi2-atk
  236. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  237. - new upstream release
  238. - remove Patch1
  239. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  240. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  241. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  242. - rename Patch103 (gnome-shell-ja.po-date.patch)
  243. - drop Patch102
  244. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  245. - new upstream release
  246. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  247. - new upstream release
  248. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  249. - new upstream release
  250. - update Patch101
  251. - update Patch102
  252. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  253. - add BuildRequires: libgudev1-devel, openssl
  254. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  255. - new upstream release
  256. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  257. - add Requires: caribou
  258. - remove Patch0
  259. - update Patch101
  260. - update Patch102
  261. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  262. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  263. - rebuild with gnome-menus-3.1.5
  264. - add Patch0 (gnome-shell-git20110821.patch)
  265. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  266. - new upstream release
  267. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  268. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  269. - remove BuildRequires: xulrunner-devel
  270. - add Patch101 (gnome-shell-vine-settings.patch)
  271. - add Patch102 (gnome-shell-vine-customize.patch)
  272. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  273. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  274. - add Requires: mutter
  275. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  276. - new upstream release
  277. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  278. - initial build for Vine Linux