inkscape-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. Name: inkscape
  2. Summary: A Vector Drawing Application
  3. Summary(ja): ベクター描画アプリケーション
  4. Version: 0.91
  5. Release: 3%{?_dist_release}
  6. Group: Applications/Graphics
  7. License: GPLv2+
  8. URL: https://launchpad.net/inkscape
  9. Source0: https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: gtk2-devel >= 2.8.0
  12. BuildRequires: gnome-vfs2-devel >= 2.0
  13. BuildRequires: libxml2-devel >= 2.6.11
  14. BuildRequires: libxslt-devel >= 1.0.15
  15. BuildRequires: gc-devel >= 6.4
  16. BuildRequires: dbus-glib-devel
  17. BuildRequires: libsigc++-devel >= 2.0.12
  18. BuildRequires: gtkmm2-devel >= 2.8.0
  19. BuildRequires: libpng-devel >= 1.2.0
  20. BuildRequires: libwpg-devel
  21. BuildRequires: libexif-devel
  22. BuildRequires: libjpeg-turbo-devel
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: lcms2-devel
  25. BuildRequires: poppler-devel >= 0.14.2
  26. BuildRequires: pango-devel, cairo-devel
  27. BuildRequires: gsl-devel
  28. BuildRequires: libboost-devel
  29. BuildRequires: popt-devel
  30. BuildRequires: ImageMagick-c++-devel
  31. BuildRequires: dos2unix
  32. BuildRequires: automake autoconf
  33. Requires: python-lxml
  34. Requires: perl-XML-RegExp
  35. Requires: perl-XML-DOM
  36. Requires: perl-XML-XQL
  37. # the package requires libperl.so, so it also has to require this:
  38. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  39. # Filter out perl requires and provides
  40. # XXX: For now _all_
  41. %global __perl_provides %{nil}
  42. %global __perl_requires %{nil}
  43. Vendor: Project Vine
  44. Distribution: Vine Linux
  45. %description
  46. Inkscape is a SVG based generic vector-drawing program for
  47. Linux/Unix/Windows/Mac.
  48. %description -l ja
  49. Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
  50. Linux/Unix/Windows/Mac で動作します。
  51. %prep
  52. %setup -q -n %{name}-%{version}
  53. # https://bugs.launchpad.net/inkscape/+bug/314381
  54. # A couple of files have executable bits set,
  55. # despite not being executable
  56. find . -name '*.cpp' | xargs chmod -x
  57. find . -name '*.h' | xargs chmod -x
  58. find share/extensions -name '*.py' | xargs chmod -x
  59. # Fix end of line encodings
  60. dos2unix -k -q share/extensions/*.py
  61. %build
  62. export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
  63. %configure \
  64. --with-python \
  65. --with-gnome-vfs \
  66. --with-inkjar \
  67. --enable-lcms2 \
  68. --enable-poppler-cairo \
  69. --disable-strict-build
  70. make %{?_smp_mflags}
  71. %install
  72. rm -rf %{buildroot}
  73. make install DESTDIR=$RPM_BUILD_ROOT
  74. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  75. %find_lang %{name}
  76. %clean
  77. rm -rf %{buildroot}
  78. %post
  79. /sbin/ldconfig
  80. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  81. %postun
  82. if [ $1 -eq 0 ] ; then
  83. update-desktop-database -q &> /dev/null
  84. touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
  85. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  86. fi
  87. %posttrans
  88. update-desktop-database -q &> /dev/null
  89. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  90. %files -f %{name}.lang
  91. %defattr(-, root, root)
  92. %doc AUTHORS COPYING ChangeLog NEWS README
  93. %{_bindir}/inkscape
  94. %{_bindir}/inkview
  95. %{_datadir}/applications/*.desktop
  96. %{_datadir}/icons/hicolor/*
  97. %{_datadir}/inkscape
  98. %{_mandir}/man1/*
  99. %{_mandir}/*/man1/*
  100. %changelog
  101. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
  102. - rebuild with gcc-5.4.0
  103. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
  104. - rebuild with poppler-0.43.0
  105. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
  106. - update to 0.91
  107. - remove old patches
  108. - add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
  109. * Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
  110. - rebuild with ImageMagick-6.9.1.1
  111. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
  112. - rebuilt with libwpd 0.3.0
  113. - added Patch14 to build with libwpd 0.3.0
  114. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
  115. - rebuild with poppler-0.26.2
  116. * Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
  117. - new upstream release
  118. - add BuildRequires: libwpg-devel
  119. - remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  120. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
  121. - rebuild with poppler-0.24.5
  122. - add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  123. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
  124. - rebuild with ImageMagick-6.8.7.5
  125. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
  126. - rebuild with poppler-0.24.2
  127. * Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
  128. - rebuild with ImageMagick-6.8.6.8
  129. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
  130. - new upstream release
  131. - remove Patch0 (inkscape-0.48.2-poppler_020.patch)
  132. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
  133. - rebuild with poppler-0.20.4
  134. - add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
  135. - change BuildRequires: lcms2-devel instead of lcms-devel
  136. * Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
  137. - new upstream release
  138. * Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
  139. - rebuild with ImageMagick-6.7.5.10
  140. * Sat Feb 4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
  141. - new upstream release
  142. * Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
  143. - add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
  144. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
  145. - new upstream release
  146. - built with poppler-0.16.3
  147. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
  148. - rebuild with poppler-0.14.2
  149. - add BuildRequires: popt-devel, ImageMagick-c++-devel
  150. * Sun Oct 3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
  151. - new upstream release
  152. - rebuilt with ImageMagick-6.6.4.8
  153. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
  154. - added Patch0 for building with poppler-0.12.2+
  155. - rebuilt with new toolchain and ImageMagick-6.6.1.5
  156. - removed BR: libgnomeprint-devel, libgnomeprintui-devel
  157. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
  158. - rebuild with poppler-0.12.1
  159. * Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
  160. - new upstream release
  161. - add BR: libboost-devel
  162. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
  163. - update to 0.47pre2
  164. - drop obsolete patches
  165. - add BR: gsl-devel
  166. * Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
  167. - rebuild with poppler-0.10.2
  168. * Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
  169. - add Patch[1-6]
  170. * Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
  171. - added inkscape-0.46-poppler-0.8.3.patch
  172. - spec in utf-8
  173. - added option %%{?_smp_mflags} at make
  174. * Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
  175. - new upstream release
  176. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
  177. - rebuild with new environment/toolchain
  178. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
  179. - new upstream release
  180. * Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
  181. - add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
  182. - update required version of gtk2-devel
  183. * Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
  184. - new upstream release
  185. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
  186. - new upstream release
  187. * Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
  188. - new upstream release
  189. * Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
  190. - new upstream release
  191. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
  192. - new upstream release
  193. * Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
  194. - new upstream release
  195. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
  196. - new upstream release
  197. - add Japanese summary and description
  198. - fixed dependancy of libsigc++12 to libsigc++ >= 2.0
  199. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
  200. - fixed dependancy of libsigc++ to libsigc++12
  201. - fixed %files section
  202. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
  203. - rebuild for Vine Linux
  204. - s/Copyright/License/
  205. - added Requires and BuildRequires
  206. * Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
  207. - Removing _libdir and TODO, updating description
  208. * Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
  209. - Fix up the spec file for current release
  210. * Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
  211. - Update to 0.2.6
  212. * Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
  213. - Update to 0.2.5
  214. - Changed SPEC to benefit from macros