lua-rex-vl.spec 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. %define luaver %(pkg-config --variable=V lua || echo missing)
  2. %define lualibdir %{_libdir}/lua/%{luaver}
  3. Name: lua-rex
  4. Version: 2.4.0
  5. Release: 6%{?_dist_release}
  6. Summary: Regular expression handling library for Lua
  7. Summary(ja): 正規表現を扱うための Lua ライブラリ
  8. Group: Development/Libraries
  9. License: MIT
  10. URL: http://lrexlib.luaforge.net/
  11. Source0: http://luaforge.net/frs/download.php/3599/lrexlib-2.4.0.zip
  12. Patch0: lrexlib-2.4.0-pmake.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: oniguruma-devel
  15. BuildRequires: pcre-devel
  16. BuildRequires: lua-devel
  17. BuildRequires: pkgconfig
  18. BuildRequires: unzip
  19. Requires: lua = %{luaver}
  20. Provides: lrexlib = %{version}
  21. %description
  22. Lrexlib are bindings of three regular expression library APIs (POSIX, PCRE
  23. and Oniguruma) to Lua.
  24. %prep
  25. %setup -q -n lrexlib-%{version}
  26. %patch0 -p1 -b .pmake
  27. %build
  28. make %{?_smp_mflags} LD=cc MYCFLAGS="%{optflags} -fPIC %(pcre-config --cflags)" build
  29. %install
  30. rm -rf $RPM_BUILD_ROOT
  31. install -d $RPM_BUILD_ROOT%{lualibdir}
  32. cp -P */*/rex_{onig,pcre,posix}.so* $RPM_BUILD_ROOT%{lualibdir}
  33. %check
  34. make %{?_smp_mflags} test
  35. %clean
  36. rm -rf $RPM_BUILD_ROOT
  37. %files
  38. %defattr(-,root,root,-)
  39. %{lualibdir}/*
  40. %doc ChangeLog LICENSE NEWS README doc
  41. %changelog
  42. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-6
  43. - rebuild with pcre-8.31
  44. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.4.0-5
  45. - rebuilt with rpm-4.8.1-3
  46. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-4
  47. - rebuilt with gcc-4.4.3-3 on ppc
  48. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-3
  49. - rebuilt with rpm-4.8.0-3 (on ppc)
  50. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-2
  51. - added BR: unzip
  52. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  53. - initial build for Vine Linux
  54. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-5
  55. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  56. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-4
  57. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  58. * Thu Dec 23 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-3
  59. - Compile shared library as PIC
  60. * Wed Dec 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-2
  61. - Add doc directory to documentation
  62. - Allow parallel make runs
  63. * Tue Dec 16 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-1
  64. - Initial packaging