libldb-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. %define talloc_version 2.1.9
  4. %define tdb_version 1.3.14
  5. %define tevent_version 0.9.32
  6. Name: libldb
  7. Summary: A schema-less, ldap like, API and database
  8. Version: 1.1.31
  9. Release: 1%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: LGPLv3+
  12. URL: http://ldb.samba.org/
  13. Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
  14. # Patches
  15. Patch1001: FED01-fix-tevent-check.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libtalloc-devel >= %{talloc_version}
  18. BuildRequires: libtdb-devel >= %{tdb_version}
  19. BuildRequires: libtevent-devel >= %{tevent_version}
  20. BuildRequires: popt-devel
  21. BuildRequires: autoconf
  22. BuildRequires: libxslt
  23. BuildRequires: docbook-style-xsl
  24. BuildRequires: python-devel
  25. BuildRequires: python-tdb
  26. BuildRequires: pytalloc-devel
  27. BuildRequires: python-tevent
  28. BuildRequires: doxygen
  29. Requires: libtalloc >= %{talloc_version}
  30. Requires: libtdb >= %{tdb_version}
  31. Requires: libtevent >= %{tevent_version}
  32. Provides: bundled(libreplace)
  33. Provides: bundled(libtdb_compat)
  34. Provides: bundled(libccan)
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: tomop
  38. %description
  39. An extensible library that implements an LDAP like API to access remote LDAP
  40. servers, or use local tdb databases.
  41. %package -n ldb-tools
  42. Group: Applications/System
  43. Summary: Tools to manage LDB files
  44. Requires: libldb = %{version}-%{release}
  45. %description -n ldb-tools
  46. Tools to manage LDB files
  47. %package devel
  48. Group: Development/Libraries
  49. Summary: Developer tools for the LDB library
  50. Requires: libldb = %{version}-%{release}
  51. Requires: libtdb-devel >= %{tdb_version}
  52. Requires: libtalloc-devel >= %{talloc_version}
  53. Requires: libtevent-devel >= %{tevent_version}
  54. Requires: pkgconfig
  55. %description devel
  56. Header files needed to develop programs that link against the LDB library.
  57. %package -n pyldb
  58. Group: System Environment/Libraries
  59. Summary: Python bindings for the LDB library
  60. Requires: libldb = %{version}-%{release}
  61. Requires: python-tdb >= %{tdb_version}
  62. %description -n pyldb
  63. Python bindings for the LDB library
  64. %package -n pyldb-devel
  65. Group: Development/Libraries
  66. Summary: Development files for the Python bindings for the LDB library
  67. Requires: pyldb = %{version}-%{release}
  68. %description -n pyldb-devel
  69. Development files for the Python bindings for the LDB library
  70. %if %build_compat32
  71. %package -n compat32-%{name}
  72. Summary: A schema-less, ldap like, API and database
  73. Group: System Environment/Libraries
  74. %description -n compat32-%{name}
  75. An extensible library that implements an LDAP like API to access remote LDAP
  76. servers, or use local tdb databases.
  77. %endif
  78. %prep
  79. %setup -q -n ldb-%{version}
  80. %patch1001 -p1
  81. %build
  82. # tdb_compat and ccan have no upstream releases to link against yet and their
  83. # API is in flux. It is unsafe to make them public and shared at this time.
  84. %configure --disable-rpath \
  85. --disable-rpath-install \
  86. --bundled-libraries=cmocka \
  87. --builtin-libraries=tdb_compat,ccan,replace \
  88. --with-modulesdir=%{_libdir}/ldb/modules \
  89. --with-privatelibdir=%{_libdir}/ldb
  90. make V=1 %{?_smp_mflags}
  91. doxygen Doxyfile
  92. %install
  93. make install DESTDIR=%{buildroot}
  94. rm -f %{buildroot}%{_libdir}/libldb.a
  95. # Remove _tevent.so (it's managed by python-tevent)
  96. #rm -f %{buildroot}/%{python_sitearch}/_tevent.so
  97. # Shared libraries need to be marked executable for
  98. # rpmbuild to strip them and include them in debuginfo
  99. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  100. # Install API docs
  101. cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
  102. # drop garbages
  103. rm -f %{buildroot}%{_mandir}/man3/_home_vbuilder_rpm_BUILD_ldb-*_include_.3*
  104. rm -f %{buildroot}%{_mandir}/man3/ldif_read_file_state.3*
  105. %clean
  106. rm -rf %{buildroot}
  107. %post
  108. /sbin/ldconfig
  109. %postun
  110. /sbin/ldconfig
  111. %post -n pyldb
  112. /sbin/ldconfig
  113. %postun -n pyldb
  114. /sbin/ldconfig
  115. %if %build_compat32
  116. %post -n compat32-%{name}
  117. /sbin/ldconfig
  118. %postun -n compat32-%{name}
  119. /sbin/ldconfig
  120. %endif
  121. %files
  122. %defattr(-,root,root,-)
  123. %dir %{_libdir}/ldb
  124. %{_libdir}/libldb.so.*
  125. %dir %{_libdir}/ldb/modules
  126. %dir %{_libdir}/ldb/modules/ldb
  127. %{_libdir}/ldb/libldb-cmdline.so
  128. %{_libdir}/ldb/libcmocka-ldb.so
  129. %{_libdir}/ldb/modules/ldb/*.so
  130. %files -n ldb-tools
  131. %defattr(-,root,root,-)
  132. %{_bindir}/ldbadd
  133. %{_bindir}/ldbdel
  134. %{_bindir}/ldbedit
  135. %{_bindir}/ldbmodify
  136. %{_bindir}/ldbrename
  137. %{_bindir}/ldbsearch
  138. %{_mandir}/man1/ldbadd.1.*
  139. %{_mandir}/man1/ldbdel.1.*
  140. %{_mandir}/man1/ldbedit.1.*
  141. %{_mandir}/man1/ldbmodify.1.*
  142. %{_mandir}/man1/ldbrename.1.*
  143. %{_mandir}/man1/ldbsearch.1.*
  144. %files devel
  145. %defattr(-,root,root,-)
  146. %{_includedir}/ldb_module.h
  147. %{_includedir}/ldb_handlers.h
  148. %{_includedir}/ldb_errors.h
  149. %{_includedir}/ldb_version.h
  150. %{_includedir}/ldb.h
  151. %{_libdir}/libldb.so
  152. %{_libdir}/pkgconfig/ldb.pc
  153. %{_mandir}/man3/ldb*.gz
  154. %files -n pyldb
  155. %defattr(-,root,root,-)
  156. %{python_sitearch}/ldb.so
  157. %{python_sitearch}/_ldb_text.*
  158. %{_libdir}/libpyldb-util.so.1*
  159. %files -n pyldb-devel
  160. %defattr(-,root,root,-)
  161. %{_includedir}/pyldb.h
  162. %{_libdir}/libpyldb-util.so
  163. %{_libdir}/pkgconfig/pyldb-util.pc
  164. %{_mandir}/man*/Py*.gz
  165. %if %build_compat32
  166. %files -n compat32-%{name}
  167. %defattr(-,root,root,-)
  168. %dir %{_libdir}/ldb
  169. %{_libdir}/libldb.so.*
  170. %dir %{_libdir}/ldb/modules
  171. %dir %{_libdir}/ldb/modules/ldb
  172. %{_libdir}/ldb/libldb-cmdline.so
  173. %{_libdir}/ldb/libcmocka-ldb.so
  174. %{_libdir}/ldb/modules/ldb/*.so
  175. %endif
  176. %changelog
  177. * Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.31-1
  178. - new upstream release.
  179. * Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
  180. - new upstream release.
  181. * Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.26-1
  182. - new upstream release.
  183. * Fri Dec 18 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.25-1
  184. - new upstream release.
  185. * Thu Dec 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.24-1
  186. - new upstream release.
  187. * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.23-1
  188. - new upstream release.
  189. * Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
  190. - new upstream release.
  191. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
  192. - added compat32 package.
  193. * Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
  194. - new upstream release.
  195. * Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
  196. - new upstream release.
  197. * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
  198. - new upstream release.
  199. * Fri Oct 3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
  200. - moved libldb and pyldb to System Environment/Libraries Group
  201. - moved ldb-tool to Applications/System Group
  202. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
  203. - new upstream release.
  204. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
  205. - rebuilt with current environment.
  206. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
  207. - new upstream release.
  208. * Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
  209. - new upstream release.
  210. * Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
  211. - moved libldb-cmdline.so to main package.
  212. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
  213. - fixed dependency.
  214. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
  215. - new upstream release.
  216. - initial build for Vine Linux.
  217. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
  218. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  219. * Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
  220. - New upstream release
  221. - Add ldb_module_error() routine
  222. - Fedora: work around unreliable configure check for pytevent
  223. - Drop patch to ignore --disable-silent-rules (included in tarball)
  224. * Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
  225. - Add patch to ignore --disable-silent-rules
  226. * Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
  227. - Add explicit mention of the bundled libreplace
  228. - https://fedorahosted.org/fpc/ticket/120
  229. - Add explicit mention of bundled libtdb_compat and libccan
  230. - https://fedorahosted.org/fpc/ticket/119
  231. * Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
  232. - Build and install API documentation
  233. - Build tdb_compat and ccan statically. They have no upstream releases to
  234. link against yet and their API is in flux. It is unsafe to make them
  235. public and shared at this time.
  236. * Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
  237. - New upstream release
  238. - Required for building newer samba4 packages
  239. * Tue Aug 2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
  240. - Update to 1.1.0
  241. (dependency for samba4 alpha16 snapshot)
  242. * Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
  243. - Update to 1.0.2
  244. (dependency for samba4 alpha15 snapshot)
  245. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
  246. - Disable rpath
  247. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
  248. - New upstream release 1.0.0
  249. - SOname bump to account for module loading changes
  250. - Rename libldb-tools to ldb-tools to make upgrades easier
  251. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
  252. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  253. * Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
  254. - Fixes from package review
  255. - Change Requires: on tools subpackage to be the exact version/release
  256. - Remove unnecessary BuildRoot directive
  257. * Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
  258. - Update to 0.9.22 (first independent release of libldb upstream)