mlt-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502
  1. %bcond_without ruby
  2. %bcond_with php
  3. Summary: Toolkit for broadcasters, video editors, media players, transcoders
  4. Name: mlt
  5. Version: 6.2.0
  6. Release: 3%{?_dist_release}
  7. # mlt/src/win32/fnmatch.{c,h} are BSD-licensed.
  8. License: GPLv3 and LGPLv2+ and BSD
  9. URL: http://www.mltframework.org/twiki/bin/view/MLT/
  10. Group: System Environment/Libraries
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Source0: https://github.com/mltframework/mlt/archive/v%{version}/%{name}-%{version}.tar.gz
  14. BuildRequires: frei0r-devel
  15. BuildRequires: opencv-devel
  16. BuildRequires: qt5-qtsvg-devel
  17. BuildRequires: qt5-qt3d-devel
  18. BuildRequires: SDL-devel
  19. BuildRequires: SDL_image-devel
  20. BuildRequires: gtk2-devel
  21. BuildRequires: jack-audio-connection-kit-devel
  22. BuildRequires: libogg-devel
  23. #Deprecated dv, kino, and vorbis modules are not built.
  24. #https://github.com/mltframework/mlt/commit/9d082192a4d79157e963fd7f491da0f8abab683f
  25. #BuildRequires: libdv-devel
  26. #BuildRequires: libvorbis-devel
  27. BuildRequires: libsamplerate-devel
  28. BuildRequires: ladspa-devel
  29. BuildRequires: libxml2-devel
  30. BuildRequires: sox
  31. BuildRequires: sox-devel
  32. BuildRequires: swig
  33. BuildRequires: python-devel
  34. BuildRequires: freetype2-devel
  35. BuildRequires: libexif-devel
  36. BuildRequires: fftw3-devel
  37. BuildRequires: pulseaudio-libs-devel
  38. BuildRequires: alsa-lib-devel
  39. %if %{with ruby}
  40. BuildRequires: ruby-devel ruby
  41. %else
  42. Obsoletes: mlt-ruby < 0.8.8-5
  43. %endif
  44. %if %{with php}
  45. BuildRequires: php-devel
  46. %endif
  47. Requires: opencv-core
  48. %if %{with php}
  49. %global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{php_extdir}/.*\\.so$
  50. %endif
  51. %description
  52. MLT is an open source multimedia framework, designed and developed for
  53. television broadcasting.
  54. It provides a toolkit for broadcasters, video editors,media players,
  55. transcoders, web streamers and many more types of applications. The
  56. functionality of the system is provided via an assortment of ready to use
  57. tools, xml authoring components, and an extendible plug-in based API.
  58. %package devel
  59. Summary: Libraries, includes to develop applications with %{name}
  60. License: LGPLv2+
  61. Group: Development/Libraries
  62. Requires: pkgconfig
  63. Requires: %{name}%{?_isa} = %{version}-%{release}
  64. %package python
  65. Requires: python
  66. Requires: %{name}%{?_isa} = %{version}-%{release}
  67. Summary: Python package to work with MLT
  68. %package ruby
  69. Requires: %{name}%{_isa} = %{version}-%{release}
  70. Summary: Ruby package to work with MLT
  71. %package php
  72. Requires: php(zend-abi) = %{php_zend_api}
  73. Requires: php(api) = %{php_core_api}
  74. Requires: %{name}%{?_isa} = %{version}-%{release}
  75. Summary: PHP package to work with MLT
  76. %description devel
  77. The %{name}-devel package contains the header files and static libraries for
  78. building applications which use %{name}.
  79. %description python
  80. This module allows to work with MLT using python.
  81. %description ruby
  82. This module allows to work with MLT using ruby.
  83. %description php
  84. This module allows to work with MLT using PHP.
  85. %prep
  86. %setup -q
  87. chmod 644 src/modules/qt/kdenlivetitle_wrapper.cpp
  88. chmod 644 src/modules/kdenlive/filter_freeze.c
  89. chmod -x demo/demo
  90. # Don't overoptimize (breaks debugging)
  91. sed -i -e '/fomit-frame-pointer/d' configure
  92. sed -i -e '/ffast-math/d' configure
  93. %build
  94. #export STRIP=/bin/true
  95. %configure \
  96. --enable-gpl \
  97. --enable-gpl3 \
  98. --enable-motion-est \
  99. %ifnarch %{ix86} x86_64
  100. --disable-mmx \
  101. --disable-sse \
  102. --disable-xine \
  103. %endif
  104. --rename-melt=%{name}-melt \
  105. --swig-languages="python %{?with_php: php}%{?with_ruby: ruby}"
  106. make %{?_smp_mflags}
  107. %install
  108. make DESTDIR=%{buildroot} install
  109. # manually do what 'make install' skips
  110. install -D -pm 0644 src/swig/python/mlt.py %{buildroot}%{python_sitelib}/mlt.py
  111. install -D -pm 0755 src/swig/python/_mlt.so %{buildroot}%{python_sitearch}/_mlt.so
  112. %if %{with ruby}
  113. install -D -pm 0755 src/swig/ruby/play.rb %{buildroot}%{ruby_vendorlibdir}/play.rb
  114. install -D -pm 0755 src/swig/ruby/thumbs.rb %{buildroot}%{ruby_vendorlibdir}/thumbs.rb
  115. install -D -pm 0755 src/swig/ruby/mlt.so %{buildroot}%{ruby_vendorarchdir}/mlt.so
  116. %endif
  117. %if %{with php}
  118. install -D -pm 0755 src/swig/php/mlt.so %{buildroot}%{php_extdir}/mlt.so
  119. install -d %{buildroot}%{_sysconfdir}/php.d
  120. cat > %{buildroot}%{_sysconfdir}/php.d/mlt.ini << 'EOF'
  121. ; Enable mlt extension module
  122. extension=mlt.so
  123. EOF
  124. %endif
  125. mv src/modules/motion_est/README README.motion_est
  126. %check
  127. # verify pkg-config version sanity
  128. export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
  129. test "$(pkg-config --modversion mlt-framework)" = "%{version}"
  130. test "$(pkg-config --modversion mlt++)" = "%{version}"
  131. %post
  132. /sbin/ldconfig
  133. %postun
  134. /sbin/ldconfig
  135. %files
  136. %doc AUTHORS ChangeLog NEWS README*
  137. %license COPYING GPL
  138. %{_bindir}/mlt-melt
  139. %{_libdir}/mlt/
  140. %{_libdir}/libmlt++.so.*
  141. %{_libdir}/libmlt.so.*
  142. %{_datadir}/mlt/
  143. %files python
  144. %{python_sitelib}/mlt.py*
  145. %{python_sitearch}/_mlt.so
  146. %if %{with ruby}
  147. %files ruby
  148. %{ruby_vendorlibdir}/play.rb
  149. %{ruby_vendorlibdir}/thumbs.rb
  150. %{ruby_vendorarchdir}/mlt.so
  151. %endif
  152. %if %{with php}
  153. %files php
  154. %config(noreplace) %{_sysconfdir}/php.d/mlt.ini
  155. %{php_extdir}/mlt.so
  156. %endif
  157. %files devel
  158. %doc docs/* demo/
  159. %{_libdir}/pkgconfig/mlt-framework.pc
  160. %{_libdir}/pkgconfig/mlt++.pc
  161. %{_libdir}/libmlt.so
  162. %{_libdir}/libmlt++.so
  163. %{_includedir}/mlt/
  164. %{_includedir}/mlt++/
  165. %changelog
  166. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
  167. - initial build for Vine Linux.
  168. * Thu Jun 30 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-2
  169. - Disable the php extension, for now, the PHP 7 landed in rawhide
  170. * Wed May 25 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-1
  171. - Initial MLT spec on Fedora.
  172. * Tue Mar 29 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-3
  173. - Use upstream patch to compile Ruby bindings
  174. * Sun Feb 21 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-2
  175. - Add license tag.
  176. - More spec modernizations and rpmlint fixes.
  177. - Configure conditional build for Ruby.
  178. - Remove old BuilRequires that aren't needed anymore.
  179. - Remove old config options (avformat-swscale and qimage-libdir) that no longer
  180. exist in configure.
  181. - Fix Ruby build.
  182. * Fri Feb 19 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-1
  183. - Update 6.0.0 (This is a bugfix and minor enhancement release. Note that our
  184. release versioning scheme has changed. We were approaching 1.0 but decided to
  185. synchronize release version with the C library ABI version, which is currently
  186. at v6)
  187. - Switch to qt5 to fix rfbz #3810 and copy some BRs from Debian package.
  188. * Wed Nov 18 2015 Sérgio Basto <sergio@serjux.com> - 0.9.8-1
  189. - Update MLT to 0.9.8
  190. * Mon May 11 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-2
  191. - Workaround #3523
  192. * Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-1
  193. - Update mlt to 0.9.6 .
  194. - Added BuildRequires of libexif-devel .
  195. * Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.2-4
  196. - Added BuildRequires of opencv-devel, rfbz #3523 .
  197. * Mon Oct 20 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-3
  198. - Rebuilt for FFmpeg 2.4.3
  199. * Fri Sep 26 2014 Nicolas Chauvet <kwizart@gmail.com> - 0.9.2-2
  200. - Rebuilt for FFmpeg 2.4.x
  201. * Mon Sep 15 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-1
  202. - New upstream release.
  203. * Thu Aug 07 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-6
  204. - Rebuilt for ffmpeg-2.3
  205. * Sat Jul 26 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-5
  206. - Rebuild for new php, need by mlt-php
  207. * Sun Mar 30 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-4
  208. - Rebuilt for ffmpeg-2.2 and fix for freetype2 changes.
  209. * Wed Dec 04 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-3
  210. - Update License tag .
  211. * Wed Nov 20 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-2
  212. - Enable gplv3 as asked in rfbz #3040
  213. - Fix a changelog date.
  214. - Fix Ruby warning with rpmbuild "Use RbConfig instead of obsolete and deprecated Config".
  215. - Remove obsolete tag %%clean and rm -rf
  216. * Mon Oct 07 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-1
  217. - Update to 0.9.0
  218. * Wed Oct 02 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-7
  219. - Rebuilt
  220. * Thu Aug 15 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-6
  221. - Rebuilt for FFmpeg 2.0.x
  222. * Mon Jun 10 2013 Rex Dieter <rdieter@fedoraproject.org> 0.8.8-5
  223. - mlt-ruby FTBFS, omit until fixed (#2816)
  224. * Sun May 26 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-4
  225. - Rebuilt for x264/FFmpeg
  226. * Sun Apr 28 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-3
  227. - https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  228. * Fri Feb 1 2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
  229. - Fix ABI requirement to Ruby 1.9
  230. * Fri Feb 1 2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
  231. - Update to 0.8.8
  232. * Wed Jan 30 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-2
  233. - Rebuilt for ffmpeg
  234. * Sun Dec 30 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-1
  235. - Update to 0.8.6
  236. * Sat Nov 24 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-3
  237. - Rebuilt for FFmpeg 1.0
  238. * Tue Jun 26 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-2
  239. - Rebuilt for FFmpeg
  240. * Tue Jun 19 2012 Richard Shaw <hobbes1069@gmail.com> - 0.8.0-1
  241. - Update to latest upstream release.
  242. * Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-3
  243. - fix filter
  244. * Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-2
  245. - update PHP requirement for PHP Guildelines
  246. - add php extension configuration file
  247. - filter php private shared so
  248. * Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.8-1
  249. - 0.7.8
  250. * Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-8
  251. - rebuild (sox)
  252. * Fri Mar 02 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-7
  253. - Rebuilt for c++ ABI breakage
  254. * Tue Feb 28 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-6
  255. - Rebuilt for x264/FFmpeg
  256. * Fri Jan 27 2012 Ryan Rix <ry@n.rix.si> 0.7.6-5
  257. - Include patch to fix building on gcc47 (upstreaming)
  258. * Wed Jan 25 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-4
  259. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  260. * Thu Dec 29 2011 Ryan Rix <ry@n.rix.si> 0.7.6-3
  261. - s/%%[?_isa}/%%{?_isa}
  262. * Tue Nov 15 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-2
  263. - rebuild
  264. * Fri Nov 11 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-1
  265. - 0.7.6
  266. - track files/sonames closer
  267. - tighten subpkg deps via %%{?_isa}
  268. - drop dup'd %%doc items
  269. * Mon Sep 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.7.4-2
  270. - Rebuilt for ffmpeg-0.8
  271. * Thu Jul 21 2011 Ryan Rix <ry@n.rix.si> - 0.7.4-1
  272. - New upstream
  273. * Sun Apr 10 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-2
  274. - Add SDL_image-devel BR per Kdenlive wiki page
  275. * Thu Apr 7 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-1
  276. - New upstream
  277. * Tue Dec 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-2
  278. - Fix build, needed a patch from mlt's git repo.
  279. * Sat Nov 20 2010 Nicolas Chauvet <kwizart@gmail.com> - 0.5.4-1.1
  280. - rebuilt - was missing in repo
  281. * Wed Apr 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-1
  282. - New upstream version to fix reported crashes against Kdenlive
  283. * Fri Feb 19 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-2
  284. - disabled xine module for PPC arch.
  285. * Thu Feb 18 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-1
  286. - new version
  287. * Wed Dec 09 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.10-1
  288. - new version
  289. - added subpackage for ruby
  290. * Wed Oct 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.6-1
  291. - new version
  292. - added subpackages for: python, PHP
  293. * Mon Sep 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.4-1
  294. - new version
  295. - renamed melt binary to mlt-melt
  296. * Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.2-1
  297. - new version
  298. - removed obsolete patches
  299. * Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-3
  300. - added linker and license patches
  301. - set license of MLT devel subpackage to LGPLv2+
  302. * Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-2
  303. - some PPC clearing
  304. * Mon May 18 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-1
  305. - update to 0.4.0
  306. * Wed May 13 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-2
  307. - spec cleaning
  308. * Mon May 11 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-1
  309. - new release
  310. - MLT++ is now a part of this package
  311. * Fri May 8 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-3
  312. - unused-direct-shlib-dependency fix
  313. * Fri Apr 17 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-2
  314. - spec clearing
  315. - added patches for resolving broken lqt-config, lib64 and execstack
  316. * Wed Apr 15 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-1
  317. - New release
  318. * Thu Apr 9 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-3
  319. - Enabled MMX support (not for PPC & PPC64)
  320. - include demo files
  321. - some spec cosmetics
  322. * Thu Mar 12 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-2
  323. - Change URL address
  324. - devel Requires: pkgconfig
  325. * Fri Feb 20 2009 Levente Farkas <lfarkas@lfarkas.org> - 0.3.6-1
  326. - Update to 0.3.6
  327. * Wed Nov 5 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.1-0.1.svn1180
  328. - update to upstream r1180
  329. - add --avformat-swscale configure option
  330. * Tue Nov 4 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.0-5
  331. - rebuilt with proper qt4 paths
  332. * Mon Oct 13 2008 jeff <moe@blagblagblag.org> - 0.3.0-4
  333. - Build without fomit-frame-pointer ffmath
  334. - Add BuildRequires: prelink
  335. - clear-execstack libmltgtk2.so
  336. - Don't strip binaries
  337. - Group: Development/Libraries
  338. - Prefix albino, humperdink, and miracle binaries with mlt-
  339. * Sun Oct 5 2008 jeff <moe@blagblagblag.org> - 0.3.0-3
  340. - License: GPLv2+ and LGPLv2+
  341. - Group: Development/Tools
  342. - ExcludeArch: x86_64 s390 s390x ppc ppc64
  343. - %%defattr(-,root,root)
  344. - %%doc docs/
  345. - %%{_libdir}/%%{name} to main package
  346. * Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-2
  347. - Change BuildRoot:
  348. - Full source URL
  349. - ExcludeArch: x86_64
  350. - -devel Requires: pkgconfig, Requires: %%{name} = %%{version}-%%{release}
  351. * Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-1
  352. - Update to 0.3.0
  353. - --enable-gpl
  354. - mlt-filehandler.patch
  355. * Tue Jul 8 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f10
  356. - Build for blaghead
  357. * Mon Jul 7 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f9
  358. - Update to svn r1155
  359. - Remove sox-st.h.patch
  360. - Add configure --disable-sox as it breaks build
  361. * Sun Nov 11 2007 jeff <moe@blagblagblag.org> - 0.2.4-0blag.f7
  362. - Update to 0.2.4
  363. - Clean up spec
  364. * Sat Jun 23 2007 jeff <moe@blagblagblag.org> - 0.2.3-0blag.f7
  365. - Update to 0.2.3
  366. * Sat Dec 30 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc6
  367. - Rebuild for 60k
  368. - Remove --disable-sox
  369. - Add mlt-0.2.2-sox-st.h.patch
  370. * Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc5
  371. - Update to 0.2.2
  372. * Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.1-0blag.fc5
  373. - BLAG'd
  374. - Removed "olib" from path, name, etc.
  375. - Add changelog
  376. - Update summary/description