nasm-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %define nasm_version 2.11.08
  2. %define download http://www.nasm.us/pub/nasm/releasebuilds
  3. Summary: The Netwide Assembler, a portable x86 assembler with Intel-like syntax
  4. Summary(ja): Netwide アセンブラ: Intel ライクなシンタックスのポータブル x86 アセンブラ
  5. Name: nasm
  6. Version: %{nasm_version}
  7. Release: 1%{?_dist_release}
  8. License: BSD
  9. Group: Development/Languages
  10. URL: http://nasm.sourceforge.net/
  11. Source0: %{download}/%{nasm_version}/nasm-%{nasm_version}.tar.xz
  12. Source1: %{download}/%{nasm_version}/nasm-%{nasm_version}-xdoc.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: ghostscript
  15. BuildRequires: perl
  16. BuildRequires: texinfo
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: owa
  20. %package doc
  21. Summary: Extensive documentation for NASM
  22. SUmmary(ja): NASM のドキュメント
  23. Group: Applications/Documentation
  24. Requires(post): install-info
  25. Requires(preun): install-info
  26. %package rdoff
  27. Summary: Tools for the RDOFF binary format, sometimes used with NASM.
  28. Summary(ja): NASM で使われる RDOFF バイナリフォーマット用ツール
  29. Group: Development/Tools
  30. %description
  31. NASM is the Netwide Assembler, a free portable assembler for the Intel
  32. 80x86 microprocessor series, using primarily the traditional Intel
  33. instruction mnemonics and syntax.
  34. %description -l ja
  35. NASM は Netwide アセンブラです。Intel 80x86 プロセッサシリーズ用の
  36. フリーでポータブルなアセンブラで、基本的に伝統的な Intel インストラクション
  37. ニーモニックと文法を使います。
  38. %description doc
  39. Extensive documentation for the Netwide Assembler, NASM, in HTML,
  40. info, PostScript and text formats.
  41. %description doc -l ja
  42. Netwide アセンブラ NASM のドキュメントです。
  43. HTML、Info、ポストスクリプト、テキスト形式です。
  44. %description rdoff
  45. Tools for the operating-system independent RDOFF binary format, which
  46. is sometimes used with the Netwide Assembler (NASM). These tools
  47. include linker, library manager, loader, and information dump.
  48. %description rdoff -l ja
  49. RDOFF バイナリフォーマットの OS 用のツールで、NASM が使います。
  50. ここには、リンカ、ライブラリマネージャ、ローダ、ダンプが入っています。
  51. %prep
  52. %setup -q -n nasm-%{nasm_version} -b 1
  53. %build
  54. LDFLAGS=-s %configure
  55. ## don't use _smp_mflags (at 2.07.00)
  56. #make %{?_smp_mflags} everything
  57. make everything
  58. %install
  59. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  60. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  61. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  62. mkdir -p $RPM_BUILD_ROOT%{_infodir}
  63. make INSTALLROOT="$RPM_BUILD_ROOT" docdir=%{_docdir}/nasm-doc install_everything
  64. mkdir -p included-docs
  65. cp -pr $RPM_BUILD_ROOT%{_docdir}/nasm-doc/* included-docs/
  66. rm -rf $RPM_BUILD_ROOT%{_docdir}/nasm-doc
  67. %clean
  68. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  69. %post doc
  70. /sbin/install-info %{_infodir}/nasm.info.gz %{_infodir}/dir
  71. %preun doc
  72. if [ $1 = 0 ]; then
  73. /sbin/install-info --delete %{_infodir}/nasm.info.gz %{_infodir}/dir
  74. fi
  75. %files
  76. %defattr(-,root,root)
  77. %doc AUTHORS CHANGES ChangeLog INSTALL LICENSE README TODO
  78. %{_bindir}/nasm
  79. %{_bindir}/ndisasm
  80. %{_mandir}/man1/*.1.gz
  81. %files doc
  82. %defattr(-,root,root)
  83. %doc included-docs/*
  84. %{_infodir}/nasm.info*
  85. %files rdoff
  86. %defattr(-,root,root)
  87. %doc rdoff/README
  88. %{_bindir}/ldrdf
  89. %{_bindir}/rdf2bin
  90. %{_bindir}/rdf2com
  91. %{_bindir}/rdf2ihx
  92. %{_bindir}/rdf2ith
  93. %{_bindir}/rdf2srec
  94. %{_bindir}/rdfdump
  95. %{_bindir}/rdflib
  96. %{_bindir}/rdx
  97. %changelog
  98. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> nasm-2.11.08-1
  99. - updated nasm to nasm-2.11.08
  100. - updated xdoc to nasm-2.11.08-xdoc
  101. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> nasm-2.11.05-1
  102. - updated nasm to nasm-2.11.05
  103. - updated xdoc to nasm-2.11.05-xdoc
  104. - updated License to BSD (see, LICENSE)
  105. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> nasm-2.09.08-1
  106. - updated nasm to nasm-2.09.08
  107. - updated xdoc to nasm-2.09.08-xdoc
  108. * Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09.03-1
  109. - updated nasm to nasm-2.09.03
  110. - updated xdoc to nasm-2.09.03-xdoc
  111. * Wed Sep 08 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09.01-1
  112. - updated nasm to nasm-2.09.01
  113. - updated xdoc to nasm-2.09.01-xdoc
  114. * Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.09-1
  115. - updated nasm to nasm-2.09
  116. - updated xdoc to nasm-2.09-xdoc
  117. * Tue Mar 16 2010 Shu KONNO <owa@bg.wakwak.com> nasm-2.08.01-1
  118. - updated nasm to nasm-2.08.01
  119. - updated xdoc to nasm-2.08.01-xdoc
  120. * Sat Sep 05 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.07.00-1
  121. - updated nasm to nasm-2.07
  122. * Mon Jul 13 2009 Shu KONNO <owa@bg.wakwak.com> nasm-2.06.00-1
  123. - updated nasm to nasm-2.06
  124. - added nasm-2.06-xdoc
  125. - changed download url
  126. * Tue Sep 30 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.04.00-1vl5
  127. - updated nasm to nasm-2.04
  128. - fixed typo of changelog version
  129. * Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.03.00-1vl5
  130. - updated nasm to nasm-2.03
  131. - applied new versioning policy and spec in utf-8
  132. * Fri Feb 22 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.02.00-0vl1
  133. - updated nasm to nasm-2.02
  134. * Mon Jan 28 2008 Shu KONNO <owa@bg.wakwak.com> nasm-2.01.00-0vl1
  135. - updated nasm to nasm-2.01
  136. * Thu Nov 29 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0.0-0vl1
  137. - updated nasm to nasm-2.00
  138. * Sun Nov 25 2007 Shu KONNO <owa@bg.wakwak.com> nasm-2.0-0vl0rc1
  139. - updated nasm to nasm-2.00rc1
  140. * Sun Aug 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.98.39-0vl2
  141. - drop stupid macros
  142. - fix dependencies
  143. - add BuildRequires: texinfo
  144. - add BuildRequires: ghostscript instead of /usr/bin/ps2pdf
  145. - doc: add PreReq: install-info instead of /sbin/install-info
  146. - chande doc's group to Applications/Documentation
  147. * Sat Jun 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.39-0vl1
  148. - new upstream release
  149. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.38-0vl1
  150. - updated to 0.98.38
  151. - fixed %doc of nasm-doc
  152. * Thu Jul 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl3
  153. - fixed nasm-doc Group: Documentation
  154. - changed URL:
  155. - s/Copyright/License/
  156. * Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl2
  157. - merged Vine Plus spec file and Vine Seed Plus spec file (sorry....)
  158. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.98.36-0vl1
  159. - update 0.98.36 based on sourceforge
  160. - change licence to LGPL
  161. - change URL
  162. - add BuildPrereq: perl
  163. * Tue Jan 27 2003 Masaki Shinomiya <shino@pos.to> 0.98.35-0vl1
  164. - source upstream, new URL, doc files
  165. * Sat Apr 14 2001 Shoji Matsumoto <shom@vinelinux.org> 0.98-0vl2
  166. - add ja desc
  167. - modify %files
  168. - use %configure
  169. - build for Seed
  170. * Fri Dec 15 2000 Hirotaka Mizutani
  171. - 0.98-0vl1
  172. - updated for VineLinux2.1