openbabel-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. %define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
  2. %define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
  3. Name: openbabel
  4. Version: 2.3.2
  5. Release: 5%{?_dist_release}
  6. Summary: Chemistry software file format converter
  7. Summary(ja): 化学ソフトデータファイル変換プログラム
  8. License: GPLv2
  9. Group: Applications/Edutainment
  10. URL: http://openbabel.sourceforge.net/
  11. Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
  12. # fron fedora
  13. Patch0: openbabel-2.3.1-gcc47-darwin.patch
  14. Patch1: openbabel-rpm.patch
  15. Patch2: openbabel-2.3.2-cmake.patch
  16. Patch3: openbabel-2.3.1-ruby19-vendorarch.patch
  17. Patch4: openbabel-2.3.1-ruby22-remove-deprecated-usage.patch
  18. Patch10: openbabel-2.3.2-gcc5.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: inchi-devel
  21. BuildRequires: libtool
  22. BuildRequires: libxml2-devel
  23. BuildRequires: perl
  24. BuildRequires: python
  25. BuildRequires: python-devel
  26. BuildRequires: ruby
  27. BuildRequires: ruby-devel
  28. BuildRequires: swig
  29. BuildRequires: wxGTK-devel
  30. BuildRequires: zlib-devel
  31. BuildRequires: cmake
  32. BuildRequires: eigen2-devel
  33. Distribution: Vine Linux
  34. Vendor: Project Vine
  35. Packager: inagaki
  36. %description
  37. Open Babel is a free, open-source version of the Babel chemistry file
  38. translation program. Open Babel is a project designed to pick up where
  39. Babel left off, as a cross-platform program and library designed to
  40. interconvert between many file formats used in molecular modeling,
  41. computational chemistry, and many related areas.
  42. Open Babel includes two components, a command-line utility and a C++
  43. library. The command-line utility is intended to be used as a replacement
  44. for the original babel program, to translate between various chemical file
  45. formats. The C++ library includes all of the file-translation code as well
  46. as a wide variety of utilities to foster development of other open source
  47. scientific software.
  48. %package devel
  49. Summary: Development tools for programs which will use the Open Babel library
  50. Summary(ja): %{name} の開発用ヘッダファイル
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: pkgconfig
  54. %description devel
  55. The %{name}-devel package includes the header files and libraries
  56. necessary for developing programs using the Open Babel library.
  57. If you are going to develop programs which will use this library
  58. you should install %{name}-devel. You'll also need to have the
  59. %{name} package installed.
  60. %description devel -l ja
  61. %{name}の開発用ヘッダファイル
  62. %package -n perl-%{name}
  63. Summary: Perl wrapper for the Open Babel library
  64. Summary(ja): Open Babel ライブラリの Perl ラッパー
  65. Group: Development/Libraries
  66. Requires: perl > %(eval "`%{__perl} -V:version`"; echo $version)
  67. Obsoletes: %{name}-perl < 2.2.0
  68. Provides: %{name}-perl = %{version}-%{release}
  69. %description -n perl-%{name}
  70. Perl wrapper for the Open Babel library.
  71. %description -n perl-%{name} -l ja
  72. Open Babel ライブラリの Perl ラッパーです.
  73. %package -n python-%{name}
  74. Group: Development/Libraries
  75. Summary: Python wrapper for the Open Babel library
  76. Summary(ja): Open Babel ライブラリの Python ラッパー
  77. Obsoletes: %{name}-python < 2.2.0
  78. Provides: %{name}-python = %{version}-%{release}
  79. %description -n python-%{name}
  80. Python wrapper for the Open Babel library.
  81. %description -n python-%{name} -l ja
  82. Open Babel ライブラリの Python ラッパー
  83. %package -n ruby-%{name}
  84. Summary: Ruby wrapper for the Open Babel library
  85. Summary(ja): Open Babel ライブラリの Ruby ラッパー
  86. Group: Development/Libraries
  87. Requires: ruby >= 1.8
  88. Requires: %{name} = %{version}-%{release}
  89. %description -n ruby-%{name}
  90. Open Babel ライブラリの Ruby ラッパー
  91. %prep
  92. %setup -q
  93. %patch0 -p1 -b .gcc47
  94. %patch1 -p1 -b .rpm
  95. %patch2 -p1 -b .cmake
  96. %patch3 -p1 -b .ruby_vendor
  97. %patch4 -p1 -b .rbconfig
  98. %patch10 -p1 -b .gcc5
  99. chmod 644 src/formats/{mmcif,fchk}format.cpp
  100. %build
  101. %cmake \
  102. -DOPENBABEL_USE_SYSTEM_INCHI=true \
  103. -DPYTHON_BINDINGS:BOOL=ON \
  104. -DRUBY_BINDINGS:BOOL=ON \
  105. -DPERL_BINDINGS:BOOL=ON \
  106. .
  107. make %{?_smp_mflags}
  108. %install
  109. rm -rf $RPM_BUILD_ROOT
  110. make install DESTDIR=$RPM_BUILD_ROOT
  111. rm -f $RPM_BUILD_ROOT%{_libdir}{,/%{name}}/*.la
  112. mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
  113. mv $RPM_BUILD_ROOT%{_libdir}/_openbabel.so \
  114. $RPM_BUILD_ROOT%{_libdir}/openbabel.py \
  115. $RPM_BUILD_ROOT%{_libdir}/pybel.py \
  116. $RPM_BUILD_ROOT%{python_sitearch}
  117. rm -rf $RPM_BUILD_ROOT%{_libdir}/cmake/openbabel2
  118. rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/*/*/perllocal.pod
  119. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/.packlist
  120. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.bs
  121. %clean
  122. rm -rf $RPM_BUILD_ROOT
  123. %post -p /sbin/ldconfig
  124. %postun -p /sbin/ldconfig
  125. %files
  126. %defattr(-,root,root,-)
  127. %doc AUTHORS COPYING ChangeLog README THANKS
  128. %doc doc/*.html
  129. #doc doc/README* doc/babel*.inc doc/dioxin.*
  130. %doc doc/README* doc/dioxin.*
  131. %{_bindir}/*
  132. %{_mandir}/man1/*
  133. %{_datadir}/%{name}
  134. %{_libdir}/libopenbabel.so.*
  135. %{_libdir}/%{name}
  136. %files devel
  137. %defattr(-,root,root,-)
  138. %{_includedir}/%{name}-2.0
  139. %{_libdir}/libopenbabel.so
  140. %{_libdir}/pkgconfig/*.pc
  141. %files -n perl-%{name}
  142. %defattr(-,root,root,-)
  143. %{perl_vendorarch}/Chemistry/OpenBabel.pm
  144. %dir %{perl_vendorarch}/*/Chemistry/OpenBabel
  145. %{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
  146. %files -n python-%{name}
  147. %defattr(-,root,root,-)
  148. %{python_sitearch}/_openbabel.so
  149. %{python_sitearch}/openbabel.py*
  150. %{python_sitearch}/pybel.py*
  151. %files -n ruby-%{name}
  152. %defattr(-,root,root,-)
  153. %{ruby_vendorarchdir}/openbabel.so
  154. %changelog
  155. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-5
  156. - rebuild with gcc-5.4.0
  157. - add Patch10 (openbabel-2.3.2-gcc5.patch)
  158. * Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-4
  159. - rebuild with ruby-2.2.3
  160. - add Patch4 (openbabel-2.3.1-ruby22-remove-deprecated-usage.patch) from fedora
  161. * Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-3
  162. - add BuildRequires: wxGTK-devel, eigen2-devel
  163. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  164. - rebuilt with ruby 2.1.5 and perl 5.16.3
  165. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-1
  166. - new upstream release
  167. - add BuildRequires: cmake
  168. - add Patch0,1,2,3 from fedora
  169. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-4
  170. - rebuilt with rpm-4.8.1 for pkg-config
  171. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3
  172. - rebuild with python-2.6
  173. * Fri Nov 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.3-2
  174. - <BTS:0789> ruby binding install path changed to Config::CONFIG["archdir"]
  175. * Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  176. - applied new versioning policy, spec in UTF-8
  177. - using system inchi package
  178. - added ruby-%{name} package
  179. * Mon May 14 2007 Susumu Tanimura <arumiant@gmail.com> 2.1.0-0vl1
  180. - Updated to 2.1.0
  181. * Tue May 1 2007 Susumu Tanimura <arumiant@gmail.com> 2.0.2-5vl1
  182. - built for VineLinux
  183. * Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
  184. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  185. * Wed Sep 20 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-4
  186. - .pyo files no longer ghosted
  187. - fix chicken-and-egg problem when building perl and python bindings
  188. * Tue Aug 29 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-3
  189. - simplified autotools invocation
  190. - mass rebuild
  191. * Mon Aug 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-2
  192. - simplified file lists and permissions
  193. - removed weird character from inchi summary and description
  194. - added missing pkgconfig Req: for -devel
  195. * Sat Aug 05 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-1
  196. - updated to 2.0.2
  197. - dropped GCC4 fix (upstream'd)
  198. - split off inchi package
  199. - added python and perl bindings packages
  200. * Sat Jan 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.0-1
  201. - updated to 2.0.0
  202. - fix compilation with GCC4
  203. - FE compliance
  204. * Thu Feb 10 2005 Dominik Mierzejewski <rpm@greysector.net> 1.100.2-1
  205. - rebuilt for Fedora 3
  206. * Tue Jan 18 2005 ALT QA Team Robot <qa-robot@altlinux.org> 1.100.2-alt1.1
  207. - Rebuilt with libstdc++.so.6.
  208. * Wed Mar 03 2004 Michael Shigorin <mike@altlinux.ru> 1.100.2-alt1
  209. - 1.100.2
  210. * Wed Dec 17 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt2
  211. - removed *.la
  212. - don't package static library by default
  213. * Mon Sep 22 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt1
  214. - 1.100.1
  215. - #2994 fixed; thanks to Alex Ott (ott@) for a pointer
  216. - spec cleanup (underlibification fixup)
  217. * Mon Jun 30 2003 Michael Shigorin <mike@altlinux.ru> 1.100.0-alt1
  218. - built for ALT Linux
  219. - based on Mandrake Cooker spec by:
  220. * Lenny Cartier <lenny@mandrakesoft.com>
  221. * Austin Acton <aacton@yorku.ca>
  222. - spec cleanup