perl-DBD-SQLite-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. %define module DBD-SQLite
  2. %define name perl-%{module}
  3. %define version 1.42
  4. %define release 1%{_dist_release}
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Summary: Self Contained RDBMS in a DBI Driver
  9. License: Artistic or GPL+
  10. Group: Development/Libraries
  11. URL: http://search.cpan.org/dist/%{module}/
  12. Source: ftp://ftp.perl.org/pub/CPAN/modules/by-module/DBD/%{module}-%{version}.tar.gz
  13. Buildroot: %{_tmppath}/%{name}-%{version}
  14. BuildRequires: perl(DBI) >= 1.57
  15. BuildRequires: sqlite3-devel
  16. Requires: perl(DBI) >= 1.57
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. SQLite is a small fast embedded SQL database engine.
  22. DBD::SQLite embeds that database engine into a DBD driver, so
  23. if you want a relational database for your project, but don't
  24. want to install a large RDBMS system like MySQL or PostgreSQL,
  25. then DBD::SQLite may be just what you need.
  26. It supports quite a lot of features, such as transactions (atomic
  27. commit and rollback), indexes, DBA-free operation, a large subset
  28. of SQL92 supported, and more.
  29. #'
  30. %prep
  31. %setup -q -n %{module}-%{version}
  32. %build
  33. CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor"
  34. make %{?_smp_mflags}
  35. %check
  36. make test
  37. %install
  38. rm -rf %{buildroot}
  39. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  40. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  41. find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
  42. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  43. chmod -R u+w %{buildroot}/*
  44. %clean
  45. rm -rf %{buildroot}
  46. %files
  47. %defattr(-,root,root)
  48. %doc README* Changes
  49. %{perl_vendorarch}/DBD
  50. %{perl_vendorarch}/auto/DBD
  51. %{_mandir}/*/*
  52. %changelog
  53. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.42-1
  54. - new upstream release
  55. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.31-2
  56. - build with Perl 5.16
  57. - add Requires: MODULE_COMPAT_*
  58. * Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.31-1
  59. - new upstream release
  60. - update {Build,}Requires: perl-DBI version: sync upstream
  61. * Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-1vl5
  62. - rebuild with perl 5.10
  63. - new versioning policy
  64. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl1
  65. - rebuild for VineSeed
  66. - disable test
  67. * Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.43
  68. - add Requires: perl(DBI) >= 1.03
  69. * Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.42
  70. - new upstream release
  71. - built for Vine 4.2 testing
  72. * Sun Dec 17 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-2mdv2007.0
  73. + Revision: 98263
  74. - fix build dependencies
  75. * Sat Dec 16 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-1mdv2007.1
  76. + Revision: 98198
  77. - new version
  78. * Mon Aug 07 2006 Olivier Thauvin <nanardon@mandriva.org> 1.12-2mdv2007.0
  79. + Revision: 53730
  80. - rebuild
  81. - Import perl-DBD-SQLite
  82. * Thu Apr 13 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.12-1mdk
  83. - New release 1.12
  84. - better source URL
  85. - better buildrequires syntax
  86. * Tue Dec 20 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.11-1mdk
  87. - new version
  88. - fix directory ownership
  89. * Mon Sep 26 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.09-2mdk
  90. - rebuild to link against external library
  91. - spec cleanup
  92. - %%mkrel
  93. * Tue Jun 21 2005 Rafael Garcia-Suarez <rgarciasuarez@mandriva.com> 1.09-1mdk
  94. - 1.09
  95. - spec cleanups
  96. * Mon Mar 14 2005 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.08-1mdk
  97. - new veresion 1.08
  98. * Mon Nov 15 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-2mdk
  99. - rebuild for new perl
  100. - remove README.urpmi
  101. * Thu Oct 14 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-1mdk
  102. - 1.07.
  103. * Tue Aug 10 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.03-1mdk
  104. - 1.03.
  105. - Remove patch 1.
  106. * Wed Jul 28 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.00-1mdk
  107. - 1.00, incompatible format with previous versions.
  108. - Remove MANIFEST, add README.update.urpmi.
  109. - Patch to prevent interactivity in Makefile.PL
  110. * Mon May 17 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-2mdk
  111. - Fix compile FLAGS
  112. * Fri Nov 01 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-1mdk
  113. - first version of rpm.