perl-Mail-DKIM-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. #
  2. # - Mail::DKIM -
  3. # This spec file was automatically generated by cpan2rpm [ver: 2.028]
  4. # The following arguments were used:
  5. # Mail::DKIM
  6. # For more information on cpan2rpm please visit: http://perl.arix.com/
  7. #
  8. %define pkgname Mail-DKIM
  9. %define filelist %{pkgname}-%{version}-filelist
  10. %define NVR %{pkgname}-%{version}-%{release}
  11. %define maketest 1
  12. Name: perl-Mail-DKIM
  13. Summary: Mail-DKIM - Signs/verifies Internet mail with DKIM/DomainKey signatures
  14. Version: 0.40
  15. Release: 3%{?_dist_release}
  16. License: Artistic
  17. Group: Development/Libraries
  18. URL: http://search.cpan.org/~jaslong/Mail-DKIM/
  19. Source: http://search.cpan.org//CPAN/authors/id/J/JA/JASLONG/Mail-DKIM-%{version}.tar.gz
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildArch: noarch
  22. BuildRequires: perl(Crypt::OpenSSL::RSA)
  23. BuildRequires: perl(Mail::Address)
  24. BuildRequires: perl(Net::DNS)
  25. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: tomop
  29. %description
  30. This module implements the various components of the DKIM and
  31. DomainKeys message-signing and verifying standards for Internet mail.
  32. It currently tries to implement these specifications:
  33. =over
  34. =item RFC4871, for DKIM
  35. =item RFC4870, for DomainKeys
  36. =back
  37. The module uses an object-oriented interface. You use one of
  38. two different classes, depending on whether you are signing or verifying
  39. a message. To sign, use the L<Mail::DKIM::Signer> class. To verify, use
  40. the L<Mail::DKIM::Verifier> class. Simple, eh?
  41. #
  42. # This package was generated automatically with the cpan2rpm
  43. # utility. To get this software or for more information
  44. # please visit: http://perl.arix.com/
  45. #
  46. %prep
  47. %setup -q -n %{pkgname}-%{version}
  48. chmod -R u+w %{_builddir}/%{pkgname}-%{version}
  49. %build
  50. grep -rsl '^#!.*perl' . |
  51. grep -v '.bak$' |xargs --no-run-if-empty \
  52. %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
  53. CFLAGS="$RPM_OPT_FLAGS"
  54. %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLDIRS=vendor
  55. %{__make}
  56. %if %maketest
  57. %{__make} test
  58. %endif
  59. %install
  60. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  61. %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
  62. cmd=/usr/share/spec-helper/compress_files
  63. [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
  64. [ -x $cmd ] && $cmd
  65. # SuSE Linux
  66. if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
  67. then
  68. %{__mkdir_p} %{buildroot}/var/adm/perl-modules
  69. %{__cat} `find %{buildroot} -name "perllocal.pod"` \
  70. | %{__sed} -e s+%{buildroot}++g \
  71. > %{buildroot}/var/adm/perl-modules/%{name}
  72. fi
  73. # remove special files
  74. find %{buildroot} -name "perllocal.pod" \
  75. -o -name ".packlist" \
  76. -o -name "*.bs" \
  77. |xargs -i rm -f {}
  78. # no empty directories
  79. find %{buildroot}%{_prefix} \
  80. -type d -depth \
  81. -exec rmdir {} \; 2>/dev/null
  82. %{__perl} -MFile::Find -le '
  83. find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
  84. print "%doc TODO scripts Changes README";
  85. for my $x (sort @dirs, @files) {
  86. push @ret, $x unless indirs($x);
  87. }
  88. print join "\n", sort @ret;
  89. sub wanted {
  90. return if /auto$/;
  91. local $_ = $File::Find::name;
  92. my $f = $_; s|^\Q%{buildroot}\E||;
  93. return unless length;
  94. return $files[@files] = $_ if -f $f;
  95. $d = $_;
  96. /\Q$d\E/ && return for reverse sort @INC;
  97. $d =~ /\Q$_\E/ && return
  98. for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
  99. $dirs[@dirs] = $_;
  100. }
  101. sub indirs {
  102. my $x = shift;
  103. $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
  104. }
  105. ' > %filelist
  106. [ -z %filelist ] && {
  107. echo "ERROR: empty %files listing"
  108. exit -1
  109. }
  110. %clean
  111. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  112. %files -f %filelist
  113. %defattr(-,root,root)
  114. %changelog
  115. * Thu Feb 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.40-3
  116. - added BR: perl(Crypt::OpenSSL::RSA), perl(Net::DNS)
  117. - moved to Development/Libraries
  118. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-2
  119. - rebuilt with perl-5.16.3.
  120. * Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-1
  121. - new upstream release.
  122. * Fri Dec 02 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.39-1
  123. - Initial build.