perl-PPI-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-PPI
  4. Version: 1.215
  5. Release: 3%{?_dist_release}
  6. Summary: Parse, Analyze and Manipulate Perl
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/PPI/
  10. Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/PPI-%{version}.tar.gz
  11. Patch0: PPI-1.215-UTF8.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. BuildRequires: perl(List::Util) >= 1.20
  16. BuildRequires: perl(Storable) >= 2.17
  17. BuildRequires: perl(Clone) >= 0.30
  18. BuildRequires: perl(Digest::MD5) >= 2.35
  19. BuildRequires: perl(File::Remove) >= 1.42
  20. BuildRequires: perl(IO::String) >= 1.07
  21. BuildRequires: perl(List::MoreUtils) >= 0.16
  22. BuildRequires: perl(Params::Util) >= 1.00
  23. BuildRequires: perl(Task::Weaken)
  24. BuildRequires: perl(Test::More) >= 0.86
  25. BuildRequires: perl(Test::NoWarnings) >= 0.084
  26. BuildRequires: perl(Test::Object) >= 0.07
  27. BuildRequires: perl(Test::SubCalls) >= 1.07
  28. BuildRequires: perl(Class::Inspector) >= 1.25
  29. # Circular dependencies in release tests, so don't do them when bootstrapping:
  30. # Perl::MinimumVersion -> PPI
  31. %if 0%{!?perl_bootstrap:1}
  32. BuildRequires: perl(File::Find::Rule) >= 0.32
  33. BuildRequires: perl(File::Find::Rule::Perl) >= 1.09
  34. BuildRequires: perl(Perl::MinimumVersion) >= 1.20
  35. BuildRequires: perl(Test::ClassAPI) >= 1.03
  36. BuildRequires: perl(Test::CPAN::Meta)
  37. BuildRequires: perl(Test::MinimumVersion) >= 0.101080
  38. BuildRequires: perl(Test::Pod) >= 1.00
  39. %endif
  40. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  41. Vendor: Project Vine
  42. Distribution: Vine Linux
  43. Packager: shaolin
  44. %description
  45. Parse, analyze and manipulate Perl (without perl).
  46. %prep
  47. %setup -q -n PPI-%{version}
  48. # Re-code docs as UTF-8
  49. %patch0 -p1
  50. # Filter out redundant unversioned provides
  51. %if %{_dist_release} > "vl6"
  52. %global __provides_exclude ^perl\\(PPI::.+\\)$
  53. %else
  54. cat << \EOF > %{name}-prov
  55. #!/bin/sh
  56. %{__perl_provides} $* |\
  57. sed -e '/^perl(PPI::.\+)$/d'
  58. EOF
  59. %global __perl_provides %{_builddir}/PPI-%{version}/%{name}-prov
  60. chmod +x %{__perl_provides}
  61. %endif
  62. %build
  63. perl Makefile.PL INSTALLDIRS=vendor
  64. make %{?_smp_mflags}
  65. %install
  66. make pure_install DESTDIR=%{buildroot}
  67. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  68. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  69. %{_fixperms} %{buildroot}
  70. %check
  71. make test
  72. %if 0%{!?perl_bootstrap:1}
  73. make test TEST_FILES="xt/*.t" RELEASE_TESTING=1
  74. %endif
  75. %files
  76. %doc Changes LICENSE README inline2test.conf inline2test.tpl
  77. %{perl_vendorlib}/PPI/
  78. %{perl_vendorlib}/PPI.pm
  79. %{_mandir}/man3/PPI*.3pm*
  80. %changelog
  81. * Sat Nov 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.215-3
  82. - rebuilt with perl 5.16.3
  83. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-2
  84. - rebuild
  85. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-1
  86. - initial build for Vine Linux
  87. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.215-4
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  89. * Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 1.215-3
  90. - always run test suite but don't run release tests when bootstrapping
  91. - nobody else likes macros for commands
  92. - clean up for modern rpm:
  93. - drop explicit buildroot tag
  94. - drop buildroot cleaning
  95. - drop %%defattr
  96. - use native provides filtering
  97. - use a patch rather than scripting iconv to fix character encoding
  98. - upstream file permissions no longer need fixing
  99. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.215-2
  100. - rebuild with Perl 5.14.1
  101. - use perl_bootstrap macro
  102. * Sun Mar 27 2011 Paul Howarth <paul@city-fan.org> - 1.215-1
  103. - update to 1.215 (general fix release):
  104. - index_locations on an empty document no longer warns
  105. - Corrected a bug in line-spanning attribute support
  106. - Regression test for line-spanning attribute support
  107. - return { foo => 1 } should parse curlys as hash constructor, not block
  108. (CPAN RT#61305)
  109. - Fixed bug with map and regexp confusing PPI (CPAN RT#63943)
  110. - Updated copyright year to 2011
  111. - Fix bless {} probably contains a hash constructor (CPAN RT#64247)
  112. - Backed out glob fix
  113. - Fix cast can trump braces in PPI::Token::Symbol->symbol (CPAN RT#65199)
  114. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.213-3
  115. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  116. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.213-2
  117. - rebuild to fix problems with vendorarch/lib (#661697)
  118. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.213-1
  119. - update to 1.213 (targeted bug fix, no changes to parsing or normal usage)
  120. - Updated to Module::Install 1.00
  121. - Updated module dependencies in xt author tests
  122. - Fixed extremely broken PPI::Token::Pod::merge and added test case
  123. - bump perl(Perl::MinimumVersion) requirement to 1.25
  124. - bump perl(Test::CPAN::Meta) requirement to 0.17
  125. - bump perl(Test::Pod) requirement to 1.44
  126. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.212-1
  127. - update to 1.212 (experimental/development support and bugfixes)
  128. - Fixed bug in ForLoop back-compatibility warning (CPAN RT#48819)
  129. - Added support for $ENV{X_TOKENIZER} --> $PPI::Lexer::X_TOKENIZER
  130. - Upgraded to Module::Install 0.93
  131. - Added support for $PPI::Lexer::X_TOKENIZER, for alternate tokenizers
  132. - Added an extra test case to validate we handle byte order marks properly
  133. - Moved author tests from t to xt
  134. - Fixed CPAN RT#26082: scalar { %%x } is misparsed
  135. - Fixed CPAN RT#26591: VMS patch for PPI 1.118
  136. - Fixed CPAN RT#44862: PPI cannot parse "package Foo::100;" correctly
  137. - Fixed CPAN RT#54208: PPI::Token::Quote::Literal::literal missing
  138. - run release tests as well as regular test suite
  139. - BR: perl(File::Find::Rule) >= 0.32, perl(File::Find::Rule::Perl) >= 1.09,
  140. perl(Perl::MinimumVersion) >= 1.24 and perl(Test::MinimumVersion) >= 0.101080
  141. for release tests
  142. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.210-1
  143. - update to 1.210 (packaging fixes)
  144. - use RELEASE_TESTING rather than AUTOMATED_TESTING for better test coverage
  145. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.209-1
  146. - update to 1.209 (small optimisation release, no functional changes)
  147. * Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.208-1
  148. - update to 1.208
  149. - don't assign '' to $^W, it generates a warning on Gentoo
  150. - added missing PPI::Token::Regexp fix to Changes file
  151. - updating Copyright to the new year
  152. - fixed #50309: literal() wrong result on "qw (a b c)"
  153. - PPI::Dumper no longer causes Elements to flush location data
  154. - PPI::Dumper no longer disables location information for non-Documents
  155. - +{ package => 1 } doesn't create a PPI::Statement::Package
  156. - extra methods in PPI::Token::Regexp and PPI::Token::QuoteLike::Regexp
  157. - use %%{_fixperms} macro instead of our own chmod incantation
  158. * Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.206-6
  159. - BR: perl(Task::Weaken) and perl(Test::CPAN::Meta) for improved test coverage
  160. - enable AUTOMATED_TESTING
  161. - use DESTDIR rather than PERL_INSTALL_ROOT
  162. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.206-5
  163. - Mass rebuild with perl-5.12.0
  164. * Thu Feb 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-4
  165. - fix filtering, provide versioned provides
  166. * Wed Feb 10 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-3
  167. - make rpmlint happy
  168. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-2
  169. - rebuild against perl 5.10.1
  170. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-1
  171. - new upstream version
  172. - update build requires
  173. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-3
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  175. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-2
  176. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  177. * Tue Sep 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.203-1
  178. - update to 1.203
  179. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-3
  180. - Rebuild for perl 5.10 (again)
  181. * Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-2
  182. - rebuild for new perl
  183. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-1
  184. - bump to 1.201
  185. * Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.118-1
  186. - Update to 1.118.
  187. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.117-1
  188. - Update to 1.117.
  189. * Sun Jun 4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-2
  190. - Removed the perl(IO::Scalar) build requirement.
  191. * Sun Jun 4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-1
  192. - Update to 1.115.
  193. * Wed May 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.113-1
  194. - Update to 1.113.
  195. * Tue Apr 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.112-1
  196. - Update to 1.112.
  197. * Sat Apr 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.111-1
  198. - First build.