python-funcparserlib-vl.spec 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. %define ver 0.3.5
  2. %define rel 3
  3. Summary: Recursive descent parsing library for Python based on functional combinators
  4. Name: python-funcparserlib
  5. Version: %{ver}
  6. Release: %{rel}%{?_dist_release}
  7. License: MIT License
  8. Group: Development/Libraries
  9. URL: http://code.google.com/p/funcparserlib/
  10. Source0:http://pypi.python.org/packages/source/f/funcparserlib/funcparserlib-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  12. BuildArch: noarch
  13. BuildRequires: python-devel
  14. Requires: python
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. Parser combinators are just higher-order functions that take parsers as
  19. their arguments and return them as result values. Parser combinators are:
  20. - First-class values
  21. - Extremely composable
  22. - Tend to make the code quite compact
  23. - Resemble the readable notation of xBNF grammars
  24. Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
  25. that it's very easy to write them without thinking about look-aheads and
  26. all that hardcore parsing stuff. But the recursive descent parsing is a
  27. rather slow method compared to LL(k) or LR(k) algorithms.
  28. So the primary domain for funcparserlib is parsing little languages or
  29. external DSLs (domain specific languages).
  30. %prep
  31. %setup -q -n funcparserlib-%{ver}
  32. %build
  33. %__python setup.py build
  34. %install
  35. %__rm -rf %{buildroot}
  36. %__python setup.py install --skip-build --root %{buildroot}
  37. %clean
  38. %__rm -rf %{buildroot}
  39. %files
  40. %defattr(-,root,root,-)
  41. %doc CHANGES LICENSE README doc examples
  42. %{python_sitelib}/funcparserlib-%{ver}-py*.egg-info
  43. %{python_sitelib}/funcparserlib
  44. %changelog
  45. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-3
  46. - rebuild with VineSeed environment
  47. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-2
  48. - rebuild with python-2.7.2
  49. * Mon May 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.3.5-1
  50. - Initial build.