python-pycurl-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Name: python-pycurl
  3. Version: 7.19.0
  4. Release: 5%{?_dist_release}
  5. Summary: A Python interface to libcurl
  6. Summary(ja): libcurl の Python インタフェース
  7. Group: Development/Languages
  8. License: LGPLv2+
  9. URL: http://pycurl.sourceforge.net/
  10. Source0: http://pycurl.sourceforge.net/download/pycurl-%{version}.tar.gz
  11. Patch0: python-pycurl-no-static-libs.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildRequires: python-devel
  14. BuildRequires: curl-devel >= 7.19.0
  15. BuildRequires: openssl-devel
  16. BuildRequires: openldap-devel
  17. # During its initialization, PycURL checks that the actual libcurl version
  18. # is not lower than the one used when PycURL was built.
  19. # Yes, that should be handled by library versioning (which would then get
  20. # automatically reflected by rpm).
  21. # For now, we have to reflect that dependency.
  22. %define libcurl_sed '/^#define LIBCURL_VERSION "/!d;s/"[^"]*$//;s/.*"//;q'
  23. %define curlver_h /usr/include/curl/curlver.h
  24. %define libcurl_ver %(sed %{libcurl_sed} %{curlver_h} 2>/dev/null || echo 0)
  25. Requires: curl >= %{libcurl_ver}
  26. Provides: pycurl = %{version}-%{release}
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %description
  30. PycURL is a Python interface to libcurl. PycURL can be used to fetch
  31. objects identified by a URL from a Python program, similar to the
  32. urllib Python module. PycURL is mature, very fast, and supports a lot
  33. of features.
  34. %prep
  35. %setup0 -q -n pycurl-%{version}
  36. %patch0 -p0
  37. chmod a-x examples/*
  38. %build
  39. CFLAGS="$RPM_OPT_FLAGS -DHAVE_CURL_OPENSSL" %{__python} setup.py build
  40. %check
  41. export PYTHONPATH=$PWD/build/lib*
  42. %{__python} tests/test_internals.py -q
  43. %install
  44. rm -rf %{buildroot}
  45. %{__python} setup.py install -O1 --skip-build --root %{buildroot}
  46. rm -rf %{buildroot}%{_datadir}/doc/pycurl
  47. %clean
  48. rm -rf %{buildroot}
  49. %files
  50. %defattr(-,root,root,-)
  51. %doc COPYING ChangeLog README TODO examples doc tests
  52. %{python_sitearch}/*
  53. %changelog
  54. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-5
  55. - rebuild with VineSeed environment
  56. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-4
  57. - rebuild with python-2.7.2
  58. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 7.19.0-3
  59. - rebuild with python-2.6
  60. * Sat Aug 8 2009 Shu KONNO <owa@bg.wakwak.com> - 7.19.0-2
  61. - spec in utf-8
  62. - added BR: openldap-devel
  63. * Thu Aug 6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 7.19.0-1
  64. - initial build for VineSeed
  65. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-4
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  67. * Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-3
  68. - fix typo in the previous change
  69. * Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-2
  70. - add a require to reflect a dependency on libcurl version (#496308)
  71. * Thu Mar 5 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.19.0-1
  72. - Update to 7.19.0
  73. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.18.2-3
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  75. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 7.18.2-2
  76. - Rebuild for Python 2.6
  77. * Thu Jul 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.2-1
  78. - Update to 7.18.2
  79. - Thanks to Ville Skytt辰 re-enable the tests and fix a minor problem
  80. with the setup.py. (Bug # 45400)
  81. * Thu Jun 5 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.1-1
  82. - Update to 7.18.1
  83. - Disable tests because it's not testing the built library, it's trying to
  84. test an installed library.
  85. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.16.4-3
  86. - Autorebuild for GCC 4.3
  87. * Thu Jan 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-2
  88. - BR openssl-devel
  89. * Wed Aug 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-1
  90. - Update to 7.16.4
  91. - Update license tag.
  92. * Sat Jun 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.2.1-1
  93. - Update to released version.
  94. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.0-0.1.20061207
  95. - Update to a CVS snapshot since development has a newer version of curl than is in FC <= 6
  96. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-4
  97. - Add -DHAVE_CURL_OPENSSL to fix PPC build problem.
  98. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-3
  99. - Don't forget to Provide: pycurl!!!
  100. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-2
  101. - Remove INSTALL from the list of documentation
  102. - Use python_sitearch for all of the files
  103. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-1
  104. - First version for Fedora Extras