qt5-qt3d-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237
  1. %global qt_module qt3d
  2. %define docs 1
  3. #define prerelease
  4. %global qt5_minorver 5.6
  5. %global qt5_version 5.6.1
  6. %global qt5_patchlevel 1
  7. Summary: Qt5 - Qt3D QML bindings and C++ APIs
  8. Name: qt5-%{qt_module}
  9. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  10. Release: 1%{?_dist_release}
  11. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  12. # See also http://doc.qt.io/qt-5/licensing.html
  13. License: LGPLv2 with exceptions or GPLv3 with exceptions
  14. Url: http://www.qt.io
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  18. BuildRequires: cmake
  19. BuildRequires: qt5-qtbase-static >= %{version}
  20. BuildRequires: pkgconfig(Qt5Quick)
  21. BuildRequires: pkgconfig(Qt5XmlPatterns)
  22. BuildRequires: pkgconfig(Qt5Qml)
  23. BuildRequires: pkgconfig(Qt5Network)
  24. BuildRequires: pkgconfig(Qt5Core)
  25. BuildRequires: pkgconfig(Qt5XmlPatterns)
  26. BuildRequires: pkgconfig(Qt5OpenGL)
  27. BuildRequires: pkgconfig(assimp)
  28. Requires: qt5-qtimageformats%{?_isa} >= %{version}
  29. %{?_qt5:Requires: %{_qt5}%{?_isa} >= %{_qt5_version}}
  30. %description
  31. Qt 3D provides functionality for near-realtime simulation systems with
  32. support for 2D and 3D rendering in both Qt C++ and Qt Quick applications).
  33. %package devel
  34. Summary: Development files for %{name}
  35. Requires: %{name}%{?_isa} = %{version}-%{release}
  36. Requires: qt5-qtbase-devel%{?_isa}
  37. %description devel
  38. %{summary}.
  39. %if 0%{?docs}
  40. %package doc
  41. Summary: API documentation for %{name}
  42. License: GFDL
  43. Requires: %{name} = %{version}-%{release}
  44. BuildRequires: qt5-qdoc
  45. BuildRequires: qt5-qhelpgenerator
  46. BuildArch: noarch
  47. %description doc
  48. %{summary}.
  49. %endif
  50. %package examples
  51. Summary: Programming examples for %{name}
  52. Requires: %{name}%{?_isa} = %{version}-%{release}
  53. %description examples
  54. %{summary}.
  55. %prep
  56. %setup -q -n %{qt_module}-opensource-src-%{qt5_version}
  57. %build
  58. mkdir %{_target_platform}
  59. pushd %{_target_platform}
  60. %{qmake_qt5} ..
  61. make %{?_smp_mflags}
  62. %if 0%{?docs}
  63. # HACK to avoid multilib conflicts in noarch content
  64. # see also https://bugreports.qt-project.org/browse/QTBUG-42071
  65. QT_HASH_SEED=0; export QT_HASH_SEED
  66. make %{?_smp_mflags} docs
  67. %endif
  68. popd
  69. %install
  70. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  71. %if 0%{?docs}
  72. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  73. %endif
  74. ## .prl/.la file love
  75. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  76. pushd %{buildroot}%{_qt5_libdir}
  77. for prl_file in libQt5*.prl ; do
  78. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  79. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  80. rm -fv "$(basename ${prl_file} .prl).la"
  81. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  82. fi
  83. done
  84. popd
  85. %post -p /sbin/ldconfig
  86. %postun -p /sbin/ldconfig
  87. %files
  88. %license LICENSE.GPL* LICENSE.LGPL*
  89. %{_qt5_libdir}/libQt53DQuick.so.5*
  90. %{_qt5_libdir}/libQt53DInput.so.5*
  91. %{_qt5_libdir}/libQt53DQuickRender.so.5*
  92. %{_qt5_libdir}/libQt53DRender.so.5*
  93. %{_qt5_libdir}/libQt53DCore.so.5*
  94. %{_qt5_libdir}/libQt53DLogic.so.5*
  95. %{_qt5_libdir}/libQt53DQuickInput.so.5*
  96. %{_qt5_archdatadir}/qml/Qt3D/
  97. %{_qt5_archdatadir}/qml/QtQuick/Scene3D
  98. %{_qt5_plugindir}/sceneparsers/libassimpsceneparser.so
  99. %{_qt5_plugindir}/sceneparsers/libgltfsceneparser.so
  100. %files devel
  101. %{_qt5_bindir}/qgltf
  102. %{_qt5_libdir}/libQt53DQuick.so
  103. %{_qt5_libdir}/libQt53DQuick.prl
  104. %{_qt5_libdir}/cmake/Qt53DQuick
  105. %{_qt5_headerdir}/Qt3DQuick
  106. %{_qt5_libdir}/pkgconfig/Qt53DQuick.pc
  107. %{_qt5_libdir}/libQt53DInput.so
  108. %{_qt5_libdir}/libQt53DInput.prl
  109. %{_qt5_libdir}/cmake/Qt53DInput
  110. %{_qt5_headerdir}/Qt3DInput/
  111. %{_qt5_libdir}/pkgconfig/Qt53DInput.pc
  112. %{_qt5_libdir}/libQt53DCore.so
  113. %{_qt5_libdir}/libQt53DCore.prl
  114. %{_qt5_libdir}/cmake/Qt53DCore/
  115. %{_qt5_headerdir}/Qt3DCore/
  116. %{_qt5_libdir}/pkgconfig/Qt53DCore.pc
  117. %{_qt5_libdir}/libQt53DQuickRender.so
  118. %{_qt5_libdir}/libQt53DQuickRender.prl
  119. %{_qt5_libdir}/cmake/Qt53DQuickRender/
  120. %{_qt5_headerdir}/Qt3DQuickRender/
  121. %{_qt5_libdir}/pkgconfig/Qt53DQuickRender.pc
  122. %{_qt5_libdir}/libQt53DRender.so
  123. %{_qt5_libdir}/libQt53DRender.prl
  124. %{_qt5_libdir}/cmake/Qt53DRender/
  125. %{_qt5_headerdir}/Qt3DRender/
  126. %{_qt5_libdir}/pkgconfig/Qt53DRender.pc
  127. %{_qt5_archdatadir}/mkspecs/modules/*.pri
  128. %{_qt5_libdir}/libQt53DLogic.so
  129. %{_qt5_libdir}/libQt53DLogic.prl
  130. %{_qt5_headerdir}/Qt3DLogic/
  131. %{_qt5_libdir}/cmake/Qt53DLogic
  132. %{_qt5_libdir}/pkgconfig/Qt53DLogic.pc
  133. %{_qt5_libdir}/libQt53DQuickInput.so
  134. %{_qt5_libdir}/libQt53DQuickInput.prl
  135. %{_qt5_headerdir}/Qt3DQuickInput/
  136. %{_qt5_libdir}/cmake/Qt53DQuickInput
  137. %{_qt5_libdir}/pkgconfig/Qt53DQuickInput.pc
  138. %if 0%{?docs}
  139. %files doc
  140. %{_qt5_docdir}/*
  141. %endif
  142. %if 0%{?_qt5_examplesdir:1}
  143. %files examples
  144. %{_qt5_examplesdir}/
  145. %endif
  146. %changelog
  147. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  148. - new upstream release.
  149. - initial build for Vine Linux.
  150. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  151. - Update to 5.6.1
  152. * Wed May 25 2016 Rich Mattes <richmattes@gmail.com> - 5.6.0-3
  153. - Rebuild for assimp-3.2.0
  154. * Tue Mar 22 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  155. - rebuild
  156. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  157. - 5.6.0 final release
  158. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.9.rc
  159. - Update to final RC
  160. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8
  161. - Update RC release
  162. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.7.beta
  163. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  164. * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
  165. - use %%license, update Source URL, BR: cmake
  166. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
  167. - Update to final beta release
  168. * Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.4
  169. - -doc: BR: qt5-qdoc qt5-qhelpgenerator
  170. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
  171. - Official beta release
  172. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
  173. - Official beta release
  174. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  175. - Start to implement 5.6.0 beta
  176. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  177. - Start to implement 5.6.0 beta
  178. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  179. - Update to final release 5.5.1
  180. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  181. - Update to Qt 5.5.1 RC1
  182. * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
  183. - New final upstream release Qt 5.5.0
  184. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  185. - Update for official RC1 released packages
  186. * Wed Jun 17 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
  187. - Qt 5.5.0 RC1 (initial version)