subversion-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555
  1. %define neon_version 0.25.5
  2. %define swig_version 3.0.0
  3. %define apache_version 2.4
  4. %define apache_dir /usr
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.8.17
  12. Release: 1%{?_dist_release}
  13. License: ASL 2.0
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: iwaim, daisuke
  19. SOURCE0: subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch3: subversion-1.7.0-rpath.patch
  24. BuildRequires: apache2-devel >= %{apache_version}
  25. BuildRequires: apr-devel, apr-util-devel
  26. BuildRequires: autoconf >= 2.53
  27. BuildRequires: libdb-devel
  28. BuildRequires: expat-devel
  29. BuildRequires: gdbm-devel
  30. BuildRequires: libtool >= 1.4.2
  31. BuildRequires: neon-devel >= %{neon_version}
  32. BuildRequires: openssl-devel
  33. BuildRequires: python
  34. BuildRequires: python-devel
  35. BuildRequires: swig >= %{swig_version}
  36. BuildRequires: texinfo
  37. BuildRequires: zlib-devel
  38. BuildRequires: openldap-devel
  39. BuildRequires: ruby >= 2.2.3
  40. BuildRequires: ruby-devel >= 2.2.3
  41. BuildRequires: perl >= 5.8.0
  42. BuildRequires: sqlite3-devel
  43. BuildRequires: krb5-devel
  44. BuildRequires: keyutils-libs-devel
  45. BuildRequires: dbus-devel
  46. BuildRequires: libgnome-keyring-devel
  47. BuildRequires: libserf-devel
  48. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  49. %define __perllib_requires %{SOURCE3}
  50. %description
  51. Subversion is a concurrent version control system which enables one
  52. or more users to collaborate in developing and maintaining a
  53. hierarchy of files and directories while keeping a history of all
  54. changes. Subversion only stores the differences between versions,
  55. instead of every complete file. Subversion is intended to be a
  56. compelling replacement for CVS.
  57. %package devel
  58. Group: Development/Libraries
  59. Summary: Development package for Subversion developers.
  60. Requires: subversion = %{version}-%{release}
  61. Requires: apr-devel, apr-util-devel
  62. %description devel
  63. The subversion-devel package includes the static libraries and include files
  64. for developers interacting with the subversion package.
  65. %package mod_dav_svn
  66. Group: System Environment/Daemons
  67. Summary: Apache server module for Subversion server.
  68. Requires: apache2 >= %{apache_version}
  69. Requires: subversion = %{version}-%{release}
  70. %description mod_dav_svn
  71. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  72. the Apache directories and configuration.
  73. %package tools
  74. Group: Development/Tools
  75. Summary: Tools for Subversion
  76. BuildRequires: perl >= 5.8.0
  77. Requires: perl >= 5.8.0
  78. Requires: subversion = %{version}-%{release}
  79. %description tools
  80. Tools for Subversion.
  81. %package perl
  82. Group: Development/Libraries
  83. Summary: Perl bindings to the Subversion libraries
  84. Requires: subversion = %{version}-%{release}
  85. Requires: perl >= 5.8.0
  86. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  87. %description perl
  88. This package includes the Perl bindings to the Subversion libraries.
  89. %package ruby
  90. Group: Development/Libraries
  91. Summary: Ruby bindings to the Subversion libraries
  92. Requires: subversion = %{version}-%{release}
  93. Requires: ruby >= 2.0
  94. %description ruby
  95. This package includes the Ruby bindings to the Subversion libraries.
  96. %package python
  97. Group: Development/Libraries
  98. Summary: Python bindings to the Subversion libraries
  99. Requires: subversion = %{version}-%{release}, python
  100. %description python
  101. This package includes the Python bindings to the Subversion libraries.
  102. %prep
  103. %setup -q
  104. %patch3 -p1 -b .rpath
  105. %build
  106. PATH=/usr/bin:$PATH ./autogen.sh --release
  107. # fix shebang lines, #111498
  108. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  109. # override weird -shrext from ruby
  110. export svn_cv_ruby_link="%{__cc} -shared"
  111. export svn_cv_ruby_sitedir_libsuffix=""
  112. export svn_cv_ruby_sitedir_archsuffix=""
  113. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
  114. export LIBTOOL=/usr/bin/libtool
  115. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  116. --with-swig --with-serf=%{_prefix} \
  117. --with-ruby-sitedir=%{rarchdir} \
  118. --with-apxs=%{_bindir}/apxs \
  119. --disable-mod-activation \
  120. --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
  121. --with-gnome-keyring \
  122. --with-berkeley-db \
  123. --disable-mod-activation \
  124. --disable-static
  125. make %{?_smp_mflags} all tools
  126. make swig-py swig-py-lib %{swigdirs}
  127. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  128. %install
  129. echo %{rarchdir}
  130. rm -rf $RPM_BUILD_ROOT
  131. make install \
  132. install-swig-py \
  133. install-swig-pl-lib \
  134. install-swig-rb \
  135. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  136. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  137. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  138. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  139. install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
  140. # Add subversion.conf configuration file into apache2/conf.d directory.
  141. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  142. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  143. # Remove unpackaged files
  144. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  145. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  146. $RPM_BUILD_ROOT%{_libdir}/*.la
  147. # The SVN build system is broken w.r.t. DSO support; it treats
  148. # normal libraries as DSOs and puts them in $libdir, whereas they
  149. # should go in some subdir somewhere, and be linked using -module,
  150. # etc. So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
  151. # since nothing should ever link against them directly.
  152. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
  153. # remove stuff produced with Perl modules
  154. find $RPM_BUILD_ROOT -type f \
  155. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  156. -print0 | xargs -0 rm -f
  157. # make Perl modules writable so they get stripped
  158. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  159. xargs -0 chmod 755
  160. # unnecessary libraries for swig bindings
  161. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  162. # Remove unnecessary ruby libraries
  163. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  164. # Trim what goes in docdir
  165. rm -rf tools/*/*.in tools/test-scripts
  166. # Rename authz_svn INSTALL doc for docdir
  167. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  168. # Install bash completion
  169. install -Dpm 644 tools/client-side/bash_completion \
  170. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
  171. for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
  172. ln -s svn \
  173. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
  174. done
  175. # Install tools ex diff*
  176. make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
  177. rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
  178. for f in svn-populate-node-origins-index svn-rep-sharing-stats \
  179. svnauthz-validate svnmucc svnraisetreeconflict; do
  180. echo %{_bindir}/$f
  181. done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
  182. %find_lang %{name}
  183. cat %{name}.lang exclude.tools.files >> %{name}.files
  184. %clean
  185. rm -rf $RPM_BUILD_ROOT
  186. %post -p /sbin/ldconfig
  187. %postun -p /sbin/ldconfig
  188. %post perl -p /sbin/ldconfig
  189. %postun perl -p /sbin/ldconfig
  190. %post ruby -p /sbin/ldconfig
  191. %postun ruby -p /sbin/ldconfig
  192. %post python -p /sbin/ldconfig
  193. %postun python -p /sbin/ldconfig
  194. %post tools -p /sbin/ldconfig
  195. %postun tools -p /sbin/ldconfig
  196. %files
  197. %defattr(-,root,root)
  198. %doc BUGS CHANGES COMMITTERS LICENSE NOTICE INSTALL README
  199. %doc subversion/LICENSE
  200. %{_bindir}/*
  201. %{_libdir}/libsvn_*.so.*
  202. %{_localedir}/*/*/subversion.mo
  203. %{_mandir}/man*/*
  204. %{_datadir}/bash-completion/completions/*
  205. %dir %{_sysconfdir}/subversion
  206. %exclude %{_mandir}/man*/*::*
  207. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  208. %exclude %{_libdir}/libsvn_swig_py*.so.*
  209. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  210. %files devel
  211. %defattr(-,root,root)
  212. %{_includedir}/subversion-1
  213. %{_libdir}/libsvn*.so
  214. %exclude %{_libdir}/libsvn_swig_perl*
  215. %exclude %{_libdir}/libsvn_swig_py*
  216. %exclude %{_libdir}/libsvn_swig_ruby*
  217. %files mod_dav_svn
  218. %defattr(-,root,root)
  219. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  220. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  221. %files tools -f tools.files
  222. %defattr(-,root,root)
  223. %files perl
  224. %defattr(-,root,root,-)
  225. %{perl_vendorarch}/auto/SVN
  226. %{perl_vendorarch}/SVN
  227. %{_libdir}/libsvn_swig_perl*
  228. %{_mandir}/man*/*::*
  229. %files ruby
  230. %defattr(-,root,root,-)
  231. %{_libdir}/libsvn_swig_ruby*
  232. %{rarchdir}/svn
  233. %files python
  234. %defattr(-,root,root,-)
  235. %{_libdir}/libsvn_swig_py*
  236. %{python_sitearch}/libsvn
  237. %{python_sitearch}/svn
  238. %changelog
  239. * Wed May 31 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.17-1
  240. - update to 1.8.17
  241. * Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
  242. - rebuild with ruby-2.2.3
  243. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
  244. - build with Perl 5.16
  245. - using %%__perllib_requires
  246. * Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
  247. - rebuild with ruby-2.1.2-6
  248. * Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
  249. - update to 1.8.9
  250. - remove unneeded explisit dependency
  251. - add BR: apache2-devel >= 2.4
  252. - add BR: libdb-devel instead of db4-devel
  253. - add R: apache2 > 2.4 to mod_dav_svn
  254. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  255. - update to 1.8.8
  256. - add BR: libserf-devel to handle http* scheme
  257. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
  258. - update to 1.7.7
  259. - rebuild with ruby-1.9.3
  260. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  261. - new upstream release
  262. - update License
  263. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  264. - drop deplibs patch (Patch1)
  265. - drop obsolete patch files: Patch6, 10
  266. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  267. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  268. - add configure option with-gnome-keyring
  269. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  270. - fix Packager name
  271. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  272. - build with perl 5.12.3
  273. - add Requires: perl(:MODULE_COMPAT_...)
  274. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  275. - new upstream release with security fix
  276. - add Vendor/Distri tags
  277. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  278. - new upstream release
  279. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  280. - fix <BTS:VineLinux:941>
  281. - using rpm macro: rarchdir
  282. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  283. - using rpm macros: perl_vendorarch and python_sitearch
  284. - add BuildRequires: sqlite3-devel krb5-devel
  285. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  286. - new upstream release
  287. - update URL
  288. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  289. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  290. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  291. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  292. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  293. - new upstream release
  294. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  295. - new upstream release
  296. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  297. - rebuilt with python-2.5.2
  298. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  299. - new upstream release
  300. - rebuild with neon-0.28.2
  301. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  302. - added Patch6, 8, 9, 10 from Fedora Core
  303. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  304. - Correct install location of java stuff (#433295)
  305. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  306. - fix build with new glibc open()-as-macro
  307. - build all swig code in %%build, not %%install
  308. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  309. - build /usr/bin/* as PIEs
  310. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  311. - rebuild with expat-2.0.1
  312. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  313. - new upstream release
  314. - add Patch10 to build with neon.
  315. 1.3.2-0vl5 does not support neon..
  316. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  317. - rebuild with new neon
  318. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  319. - rebuilt with new toolchain and db4-4.3.x
  320. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  321. - modified %%files section for lib64 architecture
  322. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  323. - new upstream release
  324. - rebuild with new openldap-2.3.24
  325. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  326. - new upstream release
  327. - change Group to Develoment/Tools
  328. - build with apr-1.2.7/apr-util-1.2.7
  329. - require apr/apr-util instead of apache2-apr
  330. - build with swig-1.3.29
  331. - split {perl,python,ruby} related files to subpackage.
  332. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  333. - new upstream release
  334. - add noreplace option for config file
  335. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  336. - fix Requires and BuildPreReq.
  337. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  338. - new upstream release.
  339. - add swig-runtime to 'BuildPreReq:'.
  340. - fix %%files.
  341. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  342. - require neon version 0.24.7 for ra_dav
  343. - add BuildPreReq: openldap-devel
  344. - replace BuildPreReq: httpd to BuildPreReq: apache2
  345. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  346. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  347. - new upstream release
  348. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  349. - new upstream release
  350. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  351. - new upstream release
  352. - clean up specfile.
  353. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  354. - new upstream release
  355. - build with apache2-2.0.47
  356. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  357. - build Vine Linux
  358. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  359. - Enabled RA_DAV checking.
  360. Now requires httpd package to build because of RA_DAV tests.
  361. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  362. - Created tools package to hold the tools.
  363. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  364. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  365. version of APR/APR-UTILS as of 2003.01.15.
  366. - Added svnversion command.
  367. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  368. - Create a svnadmin.static which is copied to svnadmin-version-release
  369. when the package is erased, so users can still dump/load their repositories
  370. even after they have upgraded the RPM package.
  371. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  372. - SWIG now builds so we can use cvs2svn.
  373. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  374. - Made cvs2svn conditional (at least until we can get it to build consistently
  375. and work).
  376. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  377. - Added SWIG dependencies to add cvs2svn capabilities.
  378. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  379. - Now requires neon-0.22.0.
  380. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  381. - Took out loading mod_dav_svn from subversion.spec file and put it in
  382. subversion.conf file which goes into the apache conf directory.
  383. - Simplify what gets put into httpd.conf to only the include for the
  384. subversion.conf file.
  385. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  386. me to do this).
  387. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  388. - Updated to APR/APR-UTIL 2002-08-08.
  389. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  390. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  391. - Previous version had a few problems because of missing apache error/ files.
  392. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  393. - Updated to apache-2.0.40-0.3.
  394. - Updated to subversion-0.13.1-2318.
  395. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  396. - Updated for RedHat 7.3 (autoconf253).
  397. - Added a bunch of pre-requisites I didn't know were needed because I built a
  398. new machine that didn't have them already installed.
  399. - Fixed installation of man and info documentation pages.
  400. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  401. - Back to apache-libapr* stuff, hopefully to stay.
  402. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  403. - Fixed expat.patch to not have to make so many changes by writing a small
  404. shell script that changes libexpat to -lexpat.
  405. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  406. - Updated to neon-0.19.2.
  407. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  408. - Back to using apr and apr-util separately from apache.
  409. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  410. - Updated to APR and APR-UTIL 2002.02.11.
  411. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  412. - Took out a (now non-existant) documentation file.
  413. - Moved SPEC file changelog to after all package definitions.
  414. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  415. - Updated to neon-0.18.5.
  416. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  417. apache-apr-utils, and apache-apr-utils-devel.
  418. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  419. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  420. - Now builds without the separate APR package as it is built into and
  421. "exported" from apache-2.0.31-0.3.
  422. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  423. - Took out patches to install procedure now not required because of fixes
  424. in rev 1130.
  425. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  426. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  427. program was added.
  428. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  429. - Release M5-r340: Added the subversion-server package.
  430. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  431. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  432. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  433. - Release M3-r117: Initial Version.