sudo-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. Summary: Allows command execution as root for specified users
  2. Summary(ja): スーパーユーザ権限でのコマンドの実行
  3. Name: sudo
  4. Version: 1.8.17p1
  5. Release: 1%{?_dist_release}
  6. License: ISC-style
  7. Group: Applications/System
  8. URL: http://www.sudo.ws/sudo/
  9. Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
  10. Source1: sudo-sudoers-vine
  11. # don't strip
  12. Patch1: sudo-1.6.7p5-strip.patch
  13. # Patch to read ldap.conf more closely to nss_ldap
  14. Patch2: sudo-1.8.14p1-ldapconfpatch.patch
  15. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: pam-devel
  17. BuildRequires: groff
  18. BuildRequires: flex
  19. BuildRequires: bison
  20. BuildRequires: openldap-devel
  21. BuildRequires: automake autoconf libtool
  22. BuildRequires: libcap-devel
  23. BuildRequires: zlib-devel
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. Sudo (superuser do) allows a system administrator to give certain users
  28. (or groups of users) the ability to run some (or all) commands as root while
  29. logging all commands and arguments. Sudo operates on a per-command basis,
  30. it is not a replacement for the shell.
  31. %description -l ja
  32. sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
  33. いくつかのコマンド操作を行うことを許可するためのプログラムです。
  34. %prep
  35. %setup -q
  36. %patch1 -p1 -b .strip
  37. %patch2 -p1 -b .ldapconfpatch
  38. rm -rf zlib/
  39. %build
  40. autoreconf -I m4 -fv --install
  41. F_PIE=-fpie
  42. export CFLAGS="$RPM_OPT_FLAGS $F_PIE" LDFLAGS="-pie -Wl,-z,relro -Wl,-z,now"
  43. %configure \
  44. --prefix=%{_prefix} \
  45. --sbindir=%{_sbindir} \
  46. --libdir=%{_libdir} \
  47. --sysconfdir=%{_sysconfdir} \
  48. --docdir=%{_datadir}/doc/%{name}-%{version} \
  49. --with-iologdir=/var/log/sudo-io \
  50. --with-pam \
  51. --with-pam-login \
  52. --with-logging=syslog \
  53. --with-logfac=authpriv \
  54. --with-tty-tickets \
  55. --with-ignore-dot \
  56. --with-editor=/bin/vi \
  57. --with-env-editor \
  58. --with-ldap \
  59. --with-passprompt="[sudo] password for %p: " \
  60. --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
  61. --without-interfaces \
  62. --without-selinux
  63. make %{?_smp_mflags}
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. mkdir $RPM_BUILD_ROOT
  67. make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
  68. chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
  69. install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
  70. install -p -d -m 700 $RPM_BUILD_ROOT/var/db/sudo/lectured
  71. install -p -d -m 700 $RPM_BUILD_ROOT/var/log/sudo-io
  72. install -p -d -m 750 $RPM_BUILD_ROOT/etc/sudoers.d
  73. install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
  74. chmod +x $RPM_BUILD_ROOT%{_libexecdir}/sudo/*.so # for stripping, reset in %%files
  75. # Remove execute permission on this script so we don't pull in perl deps
  76. chmod -x $RPM_BUILD_ROOT%{_docdir}/sudo-*/sudoers2ldif
  77. mv -f %{buildroot}%{_docdir}/sudo-%{version} docdir
  78. #Remove all .la files
  79. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  80. %find_lang sudo
  81. %find_lang sudoers
  82. cat sudo.lang sudoers.lang > sudo_all.lang
  83. rm sudo.lang sudoers.lang
  84. mkdir -p $RPM_BUILD_ROOT/etc/pam.d
  85. cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
  86. #%PAM-1.0
  87. auth include system-auth
  88. account include system-auth
  89. password include system-auth
  90. session optional pam_keyinit.so revoke
  91. session required pam_limits.so
  92. session include system-auth
  93. EOF
  94. cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
  95. #%PAM-1.0
  96. auth include sudo
  97. account include sudo
  98. password include sudo
  99. session optional pam_keyinit.so force revoke
  100. session include sudo
  101. EOF
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %files -f sudo_all.lang
  105. %defattr(-,root,root)
  106. %doc plugins/sample/sample_plugin.c
  107. %doc docdir/*
  108. %attr(0440,root,root) %config(noreplace) /etc/sudoers
  109. %attr(0750,root,root) %dir /etc/sudoers.d/
  110. %config(noreplace) /etc/pam.d/sudo
  111. %config(noreplace) /etc/pam.d/sudo-i
  112. %dir /var/run/sudo
  113. %dir /var/db/sudo
  114. %dir /var/db/sudo/lectured
  115. %attr(0750,root,root) %dir /var/log/sudo-io
  116. %attr(4111,root,root) %{_bindir}/sudo
  117. %{_bindir}/sudoedit
  118. %attr(0111,root,root) %{_bindir}/sudoreplay
  119. %attr(0755,root,root) %{_sbindir}/visudo
  120. %dir %{_libexecdir}/sudo
  121. %attr(0644,root,root) %{_libexecdir}/sudo/sudo_noexec.so
  122. %attr(0644,root,root) %{_libexecdir}/sudo/sudoers.so
  123. %attr(0644,root,root) %{_libexecdir}/sudo/group_file.so
  124. %attr(0644,root,root) %{_libexecdir}/sudo/system_group.so
  125. %attr(0644,root,root) %{_libexecdir}/sudo/libsudo_util.so.?.?.?
  126. %{_libexecdir}/sudo/libsudo_util.so.?
  127. %{_libexecdir}/sudo/libsudo_util.so
  128. %{_mandir}/man5/sudoers*.5*
  129. %{_mandir}/man5/sudo.conf.5*
  130. %{_mandir}/man8/sudo.8*
  131. %{_mandir}/man8/sudoedit.8*
  132. %{_mandir}/man8/sudoreplay.8*
  133. %{_mandir}/man8/visudo.8*
  134. # should be splitted to -devel?
  135. %{_includedir}/sudo_plugin.h
  136. %{_mandir}/man8/sudo_plugin.8*
  137. %post
  138. /bin/chmod 0440 /etc/sudoers || :
  139. %changelog
  140. * Sat Jul 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.17p1-1
  141. - updated to 1.8.17p1.
  142. - added Patch2.
  143. - dropped Patch4.
  144. * Mon Feb 3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.6p8-1
  145. - update to 1.8.6p8
  146. * Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-3
  147. - fix permission of sudoreplay
  148. * Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-2
  149. - add /var/log/sudo-io
  150. - add some comments to default sudoers
  151. * Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-1
  152. - update to 1.8.6p7
  153. - drop unneeded patches.
  154. * Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
  155. - add patch120 for fix CVE-2012-2337 (netmask match)
  156. * Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
  157. - update sudoers
  158. - enable "%wheel ALL=(ALL) ALL" by default.
  159. * Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
  160. - add patch110,111 for fix CVE-2011-0010 ("-g" option)
  161. * Wed Sep 8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
  162. - add Patch100 for fix CVE-2010-2956 (sudo Runas)
  163. - add _smp_mflags flag into make section
  164. - fix doc filelist (no longer exist BUGS, CHANGSE)
  165. * Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
  166. - new upstream release with security fix (CVE-2010-1646)
  167. - change specfile name (-vl)
  168. * Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
  169. - new upstream release with security fix (CVE-2010-1163)
  170. - add sudoers.ldap.5 into files section
  171. * Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
  172. - new upstream release with security fix (CVE-2010-0426)
  173. - update Patch3
  174. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
  175. - new upstream release
  176. * Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
  177. - new upstream release
  178. - update patches
  179. - disable "Defaults requiretty"
  180. * Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
  181. - rebuilt with openldap-2.4.11
  182. * Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
  183. - new upstream release with security fix (CVE 2009-0034)
  184. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
  185. - new upstream release
  186. - merge some changes from fedoraproject
  187. - include [sudo] in password prompt
  188. - compiled with secure path
  189. - also use getgrouplist() to determine group membership
  190. - add sudoers file
  191. - add command aliases, default environment config
  192. - build with openldap
  193. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
  194. - applied new versioning policy, spec in utf-8
  195. * Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
  196. - change PAM configuration to use system-auth
  197. - add --with-ignore-dot, --with-editor and --with-env-editor to
  198. configure option.
  199. * Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
  200. - new upstream release (included security fix)
  201. - add patch1 for fix CVE-2006-0151
  202. * Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
  203. - new upstream release
  204. - use macros
  205. - build with pam
  206. * Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
  207. - new upstream release
  208. * Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
  209. - SECURITY FIX: new upstream release
  210. - update rpmnonroot.patch ( Patch0 )
  211. - add new man page: sudoedit(8)
  212. * Wed Sep 1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
  213. - new upstream release
  214. - update rpmnonroot.patch ( Patch0 )
  215. - change Copyrigh tag to License tag
  216. - update License
  217. - update URL and Source0: official web site moved.
  218. - new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
  219. * Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
  220. - upstream release
  221. * Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
  222. - fixed changelog
  223. -- don't expand macros in changelog ;P
  224. * Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
  225. - changed to use configure in build section
  226. (can't build on sparc)
  227. * Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
  228. - upstream release
  229. - fix security hole : buffer over flow
  230. * Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
  231. - upstream release
  232. - updated sudo.rpmnonroot.diff
  233. * Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
  234. - upstream release
  235. - added configure script option '--disable-root-mailer'
  236. * Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
  237. - upstream release
  238. - eliminated FAQ from %doc
  239. * Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
  240. - upstream release
  241. - added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
  242. - updated sudo.rpmnonroot.diff
  243. * Wed May 09 2001 <sagami@vinelinux.org>
  244. - 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
  245. * Fri Mar 02 2001 sagami@vinelinux.org
  246. - 1.6.3p7-0vl1
  247. - use better macros
  248. * Thu Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
  249. - 1.6.3p6-0vl1
  250. - changed sudo.rpmnonroot.diff for 1.6.3p6
  251. * Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  252. - 1.6.1-2vl5
  253. - patch -p1 -> patch -p0
  254. * Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
  255. - 1.6.1-2vl4
  256. - fix uid/gid to root.root
  257. - add sudo.rpmnonroot.diff to built by non-root users
  258. * Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
  259. - 1.6.1-2vl3
  260. - fix attr
  261. * Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
  262. - 1.6.1-2vl2
  263. - enable to build by non-root useres
  264. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  265. - 1.6.1-2vl1
  266. - modified %files section to handle compressed man page(s)
  267. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  268. - change group
  269. * Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
  270. - version 1.6.1
  271. - build for Vine Linux 2.0
  272. * Fri May 14 1999 Takeda Eiji <keda@flatout.org>
  273. - sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
  274. * Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
  275. - Initial Release