xorg-x11-drv-intel-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate1 20130611
  4. %define gputoolsdate2 20110817
  5. %if "%{?_dist_release}" >= "vl7"
  6. %define accel sna
  7. #%define gputoolsdate 20130611
  8. %define gputoolsdate 1.14
  9. %else
  10. %define accel sna
  11. %define gputoolsdate 20110817
  12. %endif
  13. Summary: Xorg X11 Intel video driver
  14. Summary(ja): Xorg X11 Intel ビデオドライバ
  15. Name: xorg-x11-drv-intel
  16. Epoch: 1
  17. Version: 2.99.917
  18. Release: 3%{?_dist_release}
  19. URL: http://intellinuxgraphics.org/
  20. License: MIT
  21. Group: User Interface/X Hardware Support
  22. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  23. Source2: intel.xinf
  24. Source3: intel-gpu-tools-%{gputoolsdate}.tar.bz2
  25. # vine patch
  26. Patch0: xf86-video-intel-2.99.917-git20160430.patch
  27. ExclusiveArch: %{ix86} x86_64 ia64
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: autoconf, automake, libtool
  30. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  31. BuildRequires: libXvMC-devel
  32. BuildRequires: libXfont-devel
  33. BuildRequires: libGL-devel >= 7.10
  34. BuildRequires: libdrm-devel >= 2.4.25
  35. BuildRequires: kernel-headers >= 2.6.33
  36. BuildRequires: eudev-libudev-devel
  37. BuildRequires: libxcb-devel >= 1.5
  38. BuildRequires: xcb-util-devel
  39. BuildRequires: cairo-devel
  40. Requires: hwdata
  41. Requires: xorg-x11-server-Xorg
  42. Requires: xcb-util
  43. Obsoletes: xorg-x11-drv-i810
  44. Provides: xorg-x11-drv-i810
  45. #Conflicts: kudzu < 1.2.42-1
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: daisuke
  49. %description
  50. X.Org X11 Intel video driver.
  51. %package devel
  52. Summary: Xorg X11 Intel video driver XvMC development package
  53. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  54. Group: Development/System
  55. Requires: %{name} = %{epoch}:%{version}-%{release}
  56. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  57. %description devel
  58. X.Org X11 Intel video driver XvMC development package.
  59. %package -n intel-gpu-tools
  60. Summary: Debugging tools for Intel graphics chips
  61. Group: Development/Tools
  62. %description -n intel-gpu-tools
  63. Debugging tools for Intel graphics chips
  64. %prep
  65. %setup -q -n xf86-video-intel-%{version} -b3
  66. %patch0 -p1
  67. %build
  68. autoreconf -vi
  69. %if "%{?_dist_release}" < "vl7"
  70. export CFLAGS="-I/usr/include/X11/dri"
  71. %endif
  72. %configure \
  73. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  74. --enable-dri --enable-xvmc \
  75. --enable-sna --enable-uxa \
  76. --with-default-accel=%{accel} \
  77. --enable-xaa=no
  78. make
  79. pushd ../intel-gpu-tools-%{gputoolsdate}
  80. #autoreconf -v --install
  81. %configure \
  82. --disable-nouveau \
  83. --disable-dumper \
  84. --disable-gtkdoc \
  85. --without-libunwind
  86. make
  87. popd
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. make install DESTDIR=$RPM_BUILD_ROOT
  91. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  92. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  93. pushd ../intel-gpu-tools-%{gputoolsdate}
  94. make install DESTDIR=$RPM_BUILD_ROOT
  95. popd
  96. rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/intel-gpu-tools
  97. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %triggerpostun -- XOrg < 7.0
  101. if (grep -q i810 /etc/X11/xorg.conf)
  102. then
  103. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  104. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  105. fi ||:
  106. %files
  107. %defattr(-,root,root,-)
  108. %{driverdir}/intel_drv.so
  109. %{_datadir}/hwdata/videoaliases/intel.xinf
  110. %{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
  111. %{_libdir}/libI810XvMC.so.*
  112. %{_libdir}/libIntelXvMC.so.*
  113. %{_libexecdir}/xf86-video-intel-backlight-helper
  114. %{_mandir}/man4/i*
  115. %files devel
  116. %defattr(-,root,root,-)
  117. %{_libdir}/libI810XvMC.so
  118. %{_libdir}/libIntelXvMC.so
  119. %files -n intel-gpu-tools
  120. %defattr(-,root,root,-)
  121. %{_bindir}/*
  122. %{_libdir}/intel_aubdump.so
  123. %{_libexecdir}/intel-gpu-tools/
  124. %{_datadir}/intel-gpu-tools/
  125. %{_mandir}/man1/intel_*.1*
  126. %changelog
  127. * Thu May 05 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-3
  128. - update Source3 (intel-gpu-tools-1.14.tar.bz2)
  129. - update Patch0 (xf86-video-intel-2.99.917-git20160430.patch)
  130. - add BuildRequires: libXfont-devel
  131. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-2
  132. - update Source3 (intel-gpu-tools-1.12.tar.bz2)
  133. - update Patch0 (xf86-video-intel-2.99.917-git20151019.patch)
  134. - remove Patch1 (intel-gpu-tools-1.10-git20150410.patch)
  135. - remove Source4 (intel-gpu-tools-20110817.tar.bz2)
  136. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-1
  137. - update to 2.99.917
  138. - update Patch0 (xf86-video-intel-2.99.917-git20150409.patch)
  139. - update Patch1 (intel-gpu-tools-1.10-git20150410.patch)
  140. - update Source3 (intel-gpu-tools-1.10.tar.bz2)
  141. * Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
  142. - add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
  143. - update Source3 (intel-gpu-tools-1.8.tar.bz2)
  144. * Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
  145. - update to 2.99.916
  146. * Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
  147. - update to 2.99.912
  148. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
  149. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  150. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
  151. - rebuild with VineSeed environment
  152. * Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
  153. - new upstream release
  154. * Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
  155. - new upstream release
  156. - change default accel method to sna.
  157. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
  158. - new upstream release
  159. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
  160. - new upstream release
  161. * Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
  162. - new upstream release
  163. * Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
  164. - new upstream release
  165. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
  166. - new upstream release
  167. * Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
  168. - new upstream release
  169. * Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
  170. - new upstream release
  171. * Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
  172. - new upstream release
  173. * Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  174. - new upstream release
  175. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
  176. - new upstream release
  177. * Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
  178. - rebuild with xcb-util-0.3.9
  179. * Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
  180. - disable sna, enable uxa
  181. * Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
  182. - new upstream release
  183. * Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
  184. - rebuild with xserver-1.12.0
  185. * Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  186. - new upstream release
  187. - enable sna
  188. * Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
  189. - disable sna/vmap
  190. * Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  191. - new upstram release
  192. - disable copy-fb patch
  193. * Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
  194. - rebuild with xserver-1.11.1.902
  195. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  196. - add --enable-sna --enable-vmap
  197. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  198. - new upstream release
  199. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  200. - rebuild with xcb-util-0.3.8
  201. - drop Patch200
  202. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  203. - update to disable copy_fb on sandybridge/ivybridge
  204. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  205. - update intel.xinf
  206. - add patch10 from fedora
  207. - Clamp VGA pixel clock to 250MHz,
  208. anything higher's going to look awful anyway. (#559426)
  209. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  210. - drop patch1-3 and replaced with new patch1 from git master
  211. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  212. - update intel-gpu-tools
  213. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  214. - add Patch1-3 from upstream
  215. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  216. - new upstream release
  217. - drop upstream patches: 107-115
  218. - temporary disabled patch101
  219. - BR: libdrm >= 2.4.25
  220. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  221. - add Patch101-115 from ubuntu/debian package
  222. - Patch101: Plymouth integration patch
  223. - Patch107: Check null return from uxa_acquire_solid()
  224. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  225. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  226. - Patch110,114: Cherry picks to fix a large number of build warnings.
  227. - Patch111: Fix clipped window plane offset
  228. - Patch112: Fix issue where vertical green line and strange colors
  229. shows up when playing gstreamer with certain videos,
  230. when dragged. (LP 460677)
  231. - Patch113: Fixes GPU lockup during login with
  232. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  233. error messages listed in the gpu dump text. (LP 710321)
  234. - Patch115: Don't fill up Xorg.0.log with
  235. "get vblank counter failed: Invalid argument" warnings.
  236. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  237. - rebuild with xserver-1.10.0
  238. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  239. - new upstream release
  240. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  241. - new upstream release
  242. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  243. - rebuild with xserver-1.9.2
  244. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  245. - new upstream release
  246. - add Patch40: fix uxa planemask (backported)
  247. - add Patch61: add support for backlight on macbooks
  248. - add Patch62: disable page flipping for stability
  249. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  250. - new upstream release
  251. - drop patch70
  252. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  253. - rebuild again with xserver-1.8rc
  254. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  255. - add intel-gpu-tools as sub-package
  256. - rebuild with libdrm-2.4.18
  257. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  258. - new upstream release
  259. - import Patch1,2,60,70 from fedora
  260. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  261. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  262. - add BR; libudev-devel and autoreconf for Patch60
  263. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  264. - rebuild with libdrm-2.4.17
  265. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  266. - new upstream release
  267. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  268. - new upstream release (hopefully fixes severe issues w/ efifb)
  269. - drop all patches already upstreamed; import Patch20/21 from Fedora
  270. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  271. - import Patch121,122 from ubuntu
  272. - build with libdrm-2.4.12 which fixes vt switch crash
  273. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  274. - apply patch114 to fix Xv with non-GEM kernel
  275. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  276. - update to 2.6.3
  277. - add patch106,107,115,118,119,120 from ubuntu
  278. - add Patch106: remove triple buffering
  279. - add Patch107: remove page flipping
  280. - add Patch115: fix crash Xv overlay
  281. - add Patch118: drop legacy3d
  282. - add Patch119: fix crashes in drm bo
  283. - add Patch120: fix vt switch
  284. - add patch130-134 from upstream git
  285. - add Patch130: fix another vt switch leak
  286. - add Patch131: Create known output configuration at EnterVT time
  287. - add Patch132: fix leak of some 965 render state on VT switch
  288. - add Patch133: fix crash with fake bufmgr and UXA
  289. - add Patch134: fix EnterVT/LeaveVT
  290. - add Patch135: add new chip supoprt
  291. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  292. - revert to 2.6.1, add Epoch
  293. - add Patch103-121 from ubuntu
  294. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  295. - new upstream release
  296. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  297. - new upstream release
  298. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  299. - new upstream release
  300. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  301. - add Patch5 - Dont die on irq handler failure
  302. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  303. - new upstream release
  304. - add BR: libdrm-devel >= 2.4.0-3
  305. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  306. - import Patch10,11,12 from ubuntu
  307. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  308. - new upstream release
  309. - add triggerpostun script to replace i810 driver to intel driver
  310. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  311. - new upstream release
  312. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  313. - new upstream release
  314. - rename i810.xinf to intel.xinf
  315. - update intel.xinf (add Intel 4 series)
  316. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  317. - rebuild with new xserver
  318. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  319. - new upstream release
  320. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  321. - new upstream release
  322. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  323. - new upstream release
  324. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  325. - initial build for Vine Linux
  326. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  327. - Rebuild for new server ABI.
  328. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  329. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  330. - hook up ch7017 (bz#408471)
  331. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  332. - xf86-video-intel 2.2.0
  333. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  334. - xf86-video-intel 2.1.99.
  335. - Drop the i810 driver. Time to move on.
  336. - Require xserver 1.4.99.1
  337. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  338. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  339. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  340. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  341. for textured Xv to use as an offscreen pixmap so xv actually works under
  342. compiz - granted it may be unusably slow but at least stuff shows up.
  343. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  344. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  345. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  346. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  347. - intel-2.1.1-quirk-update.patch - update quirks from master
  348. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  349. - i810.xinf: Flip everything over to -intel by default now. Still install
  350. i810 driver just in case.
  351. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  352. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  353. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  354. - xf86-video-intel 2.1.1.
  355. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  356. - xf86-video-intel 2.1.0.
  357. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  358. - Update Requires and BuildRequires.
  359. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  360. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  361. 965GME, G33, Q33, and Q35 chips.
  362. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  363. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  364. DRI clients are active, for better battery life.
  365. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  366. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  367. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  368. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  369. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  370. rename this at some point.
  371. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  372. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  373. 915GM.
  374. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  375. - i810.xinf: More intel whitelisting (#214011, #234877)
  376. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  377. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  378. - i810.xinf: Point 965GM support at the intel driver since it's not present
  379. in old i810.
  380. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  381. - xf86-video-intel-1.9.93 (RC3).
  382. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  383. - fix typo with 945GM pci id from my laptop
  384. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  385. - xf86-video-intel 1.9.92 (RC2).
  386. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  387. - Updated modesetting driver to one that will actually work with a 1.3 server.
  388. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  389. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  390. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  391. code anywhere
  392. - Disown the module
  393. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  394. - update modesetting driver to git snapshot from today
  395. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  396. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  397. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  398. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  399. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  400. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  401. actually require kudzu to run.
  402. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  403. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  404. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  405. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  406. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  407. driver match the corresponding terrible heuristic in the server.
  408. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  409. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  410. correctly distinguish between Mac Mini and Macbook Pro.
  411. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  412. - i810.xinf: PCI IDs for i965.
  413. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  414. - i810.xinf: Uppercase PCI IDs.
  415. * Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  416. - Update i810 to 1.6.5, should fix DRI.
  417. - Add kuzdu requires.
  418. - i810.xinf: Start whitelisting devices over to intel.
  419. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  420. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  421. you know, load.
  422. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  423. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  424. LFP special casing in favor of the blacklist.
  425. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  426. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  427. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  428. and is selected with Driver "intel" in xorg.conf. Individual devices will
  429. whitelist over to "intel" until that branch gets merged into head.
  430. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  431. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  432. the BIOS is known to lie.
  433. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  434. - Today's snapshot: I2C bus creation fix.
  435. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  436. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  437. clock when computing the modes list.
  438. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  439. in centimeters as the size of the display in pixels.
  440. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  441. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  442. probing.
  443. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  444. - Update again for a mode comparison bugfix.
  445. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  446. - Update to today's git; crash fixes, better pre-915 support, slightly better
  447. autoconfigurability.
  448. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  449. - rebuild
  450. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  451. - Fix Revision number to match naming policy.
  452. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  453. - Add back modesetting changes.
  454. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  455. - Roll back modesetting changes and build for fc5 aiglx repo.
  456. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  457. - Snapshot of the git modesetting branch.
  458. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  459. - Update i810.xinf to include entries for E7221 and 945GM.
  460. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  461. - Add with_dri macro to spec file, and conditionalize build time DRI support
  462. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  463. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  464. to pick up proto-devel as well.
  465. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  466. - Rebuild for 7.1 ABI fix.
  467. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  468. - Bump for fc5-bling build.
  469. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  470. - Update to 1.6.0 from 7.1RC1.
  471. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  472. - Add patch to add missing #include's, specifically assert.h.
  473. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  474. - Update to CVS snapshot of 20060322.
  475. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  476. - rebuilt for new gcc4.1 snapshot and glibc changes
  477. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  478. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  479. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  480. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  481. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  482. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  483. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  484. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  485. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  486. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  487. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  488. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  489. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  490. - Fix *.la file removal.
  491. - Added 'devel' subpackage for XvMC .so
  492. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  493. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  494. - Update BuildRoot to use Fedora Packaging Guidelines.
  495. - Deglob file manifest.
  496. - Limit "ExclusiveArch" to x86, x86_64, ia64
  497. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  498. - Initial spec file for i810 video driver generated automatically
  499. by my xorg-driverspecgen script.