dbus-python3-vl.spec 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. %{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  2. %{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  3. %define dbus_glib_version 0.70
  4. %define dbus_version 1.6
  5. %define pkg_release 3%{?_dist_release}
  6. Name: dbus-python3
  7. Summary: D-Bus Python3 Bindings
  8. Summary(ja): D-Bus Python3 バインディング
  9. Version: 1.2.0
  10. Release: %{pkg_release}
  11. Group: System Environment/Libraries
  12. License: MIT
  13. URL: http://www.freedesktop.org/software/dbus/
  14. Source0: http://dbus.freedesktop.org/releases/dbus-python/dbus-python-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: dbus-devel >= %{dbus_version}
  17. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  18. BuildRequires: python3-devel
  19. Requires: python3
  20. %description
  21. D-Bus python3 bindings for use with python programs.
  22. %description -l ja
  23. D-Bus を python3 プログラムから使う為のバインディングです。
  24. %prep
  25. %setup -q -n dbus-python-%{version}
  26. %build
  27. %configure PYTHON=/usr/bin/python3
  28. %{__make} %{?_smp_mflags}
  29. %install
  30. %{__rm} -rf ${RPM_BUILD_ROOT}
  31. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  32. # remove unnecessary *.la files
  33. find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
  34. # remove conflict files with dbus-python
  35. rm -f ${RPM_BUILD_ROOT}%{_includedir}/dbus-1.0/dbus/dbus-python.h
  36. rm -f ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/dbus-python.pc
  37. rm -f ${RPM_BUILD_ROOT}%{_docdir}/dbus-python/*
  38. %clean
  39. rm -rf ${RPM_BUILD_ROOT}
  40. %files
  41. %defattr(-,root,root)
  42. %doc COPYING ChangeLog README NEWS
  43. %{python3_sitearch}/*.so
  44. %{python3_sitelib}/dbus/*.py*
  45. %{python3_sitelib}/dbus/mainloop/*.py*
  46. %changelog
  47. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-3
  48. - rebuild with python3-3.5.2
  49. * Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
  50. - rebuild with python3-3.4.3
  51. * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  52. - initial build