WebKit-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit
  15. Version: 1.2.3
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi
  25. Source0: http://www.webkitgtk.org/webkit-%{version}.tar.gz
  26. # upstream patch
  27. Patch100: WebKit-icu44-36381.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: bison
  30. BuildRequires: flex
  31. BuildRequires: gperf
  32. BuildRequires: gtk2-devel
  33. BuildRequires: libicu-devel
  34. BuildRequires: libjpeg-devel
  35. BuildRequires: libtool
  36. BuildRequires: libxslt-devel
  37. BuildRequires: libXt-devel
  38. BuildRequires: pcre-devel
  39. BuildRequires: sqlite3-devel
  40. BuildRequires: geoclue-devel
  41. BuildRequires: gnome-keyring-devel
  42. BuildRequires: gstreamer-devel
  43. BuildRequires: gstreamer-plugins-base-devel
  44. BuildRequires: enchant-devel
  45. %if %{with pango}
  46. BuildRequires: pango-devel
  47. %else
  48. BuildRequires: cairo-devel
  49. BuildRequires: fontconfig-devel
  50. BuildRequires: freetype2-devel
  51. %endif
  52. BuildRequires: libsoup-devel >= 2.28.2
  53. %description
  54. WebKit is an open source web browser engine.
  55. %package gtk
  56. Summary: GTK+ port of WebKit
  57. Summary(ja): WebKit の GTK+ ポート
  58. Group: Development/Libraries
  59. %description gtk
  60. %{name} is an open-source Web content engine library. This package contains
  61. the shared libraries for the WebKit GTK+ port as well as the sample
  62. GtkLauncher tool.
  63. %package gtk-devel
  64. Summary: Development package for %{name}
  65. Summary(ja): %{name} の開発パッケージ
  66. Group: Development/Libraries
  67. Requires: %{name}-gtk = %{version}-%{release}
  68. Requires: pkgconfig
  69. Requires: gtk2-devel
  70. Requires: libsoup-devel >= 2.28.2
  71. %description gtk-devel
  72. The %{name}-gtk-devel package contains libraries, build data, and header
  73. files for developing applications that use %{name}-gtk.
  74. Please note that the WebKit/GTK+ API is not yet stable. This should
  75. only be used as a "preview" rather than a stable platform library.
  76. %package doc
  77. Summary: Documentation for %{name}
  78. Summary(ja): %{name} のドキュメント
  79. Group: Documentation
  80. %description doc
  81. %{name} is an open-source Web content engine library. This package contains
  82. the documentation for %{name}, including various LICENSE, README, and
  83. AUTHORS files.
  84. %prep
  85. %setup -q -n webkit-%{version}
  86. # upstream
  87. ## %patch100 -p0
  88. %build
  89. %configure \
  90. --enable-icon-database \
  91. --enable-geolocation \
  92. %{?with_coverage: --enable-coverage } \
  93. %{?with_pango: --with-font-backend=pango } \
  94. %{?with_wml: --enable-wml }
  95. make %{?_smp_mflags}
  96. # workaround for bug 488112
  97. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  98. touch JavaScriptCore/AllInOneFile.cpp
  99. make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  100. %install
  101. rm -rf %{buildroot}
  102. make install DESTDIR=%{buildroot}
  103. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  104. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  105. ## Finally, copy over and rename the various files for %%doc inclusion.
  106. rm -f docfiles.list
  107. %add_to_doc_files JavaScriptCore/COPYING.LIB
  108. %add_to_doc_files JavaScriptCore/icu/LICENSE
  109. %add_to_doc_files WebKit/LICENSE
  110. %add_to_doc_files WebCore/LICENSE-APPLE
  111. %add_to_doc_files WebCore/LICENSE-LGPL-2
  112. %add_to_doc_files WebCore/LICENSE-LGPL-2.1
  113. %add_to_doc_files WebCore/icu/LICENSE
  114. %add_to_doc_files JavaScriptCore/AUTHORS
  115. %add_to_doc_files JavaScriptCore/pcre/AUTHORS
  116. %add_to_doc_files JavaScriptCore/THANKS
  117. %find_lang webkit
  118. %clean
  119. rm -rf %{buildroot}
  120. %post gtk -p /sbin/ldconfig
  121. %postun gtk -p /sbin/ldconfig
  122. %files -f webkit.lang gtk
  123. %defattr(-,root,root,-)
  124. %doc
  125. %{_libdir}/libwebkit-1.0.so.*
  126. %{_libexecdir}/WebKit/
  127. %{_bindir}/jsc
  128. %files gtk-devel
  129. %defattr(-,root,root,-)
  130. %exclude %{_libdir}/*.la
  131. %{_includedir}/webkit-1.0
  132. %{_datadir}/webkit-1.0
  133. %{_libdir}/libwebkit-1.0.so
  134. %{_libdir}/pkgconfig/webkit-1.0.pc
  135. %files doc -f docfiles.list
  136. %defattr(-,root,root,-)
  137. %changelog
  138. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
  139. - new upstream release
  140. - add Requires: libsoup-devel (devel package)
  141. - fix configure (remove unrecognized option)
  142. - drop Patch100
  143. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  144. - rebuilt again on ppc
  145. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  146. - new upstream release
  147. - rebuilt with libicu-4.4
  148. - added Patch100 for compiling with libicu-4.4
  149. - s/sqlite-devel/sqlite3-devel/
  150. - s/freetype-devel/freetype2-devel/
  151. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  152. - updated to 1.1.18
  153. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  154. - change BR from libsoup to libsoup-devel
  155. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  156. - new upstream release.
  157. - add Vendor, Distribution and Packager.
  158. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  159. - update to webkit-1.1.10 release version
  160. - added BuildRequires: enchant-devel
  161. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  162. - update to webkit-1.1.6 release version
  163. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  164. - update to new upstream snapshot (svn r41944)
  165. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  166. - update to new upstream snapshot (svn r40471)
  167. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  168. - update to new upstream snapshot (svn r37056)
  169. - disable html5video by default
  170. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  171. - update to new upstream snapshot (svn r36882)
  172. - build with gnome-2.24
  173. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  174. - build without pango by default.
  175. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  176. - update to new upstream snapshot (svn r36053)
  177. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  178. - update to new upstream snapshot (svn r34655)
  179. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  180. - initial build for Vine Linux
  181. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  182. - rebuild for new icu
  183. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  184. - Update to new upstream snapshot (SVN 34279) anyway
  185. - Add BR: libXt-devel
  186. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  187. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  188. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  189. subdirectories either.)
  190. - Reference: bug 442200 (RFE: WebKit Migration)
  191. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  192. tree).
  193. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  194. - Update to new upstream snapshot (SVN 32531).
  195. - Fix bug 443048 and hopefully fix bug 444445
  196. - Modify the process of building GTK+ port a bit
  197. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  198. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  199. - Update to new upstream snapshot (SVN 31787).
  200. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  201. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  202. - Switch to using autotools for building the GTK+ port.
  203. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  204. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  205. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  206. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  207. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  208. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  209. file location mismatch)
  210. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  211. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  212. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  213. - Update to new upstream snapshot (SVN 30667)
  214. - Add some build fixes for GCC 4.3:
  215. + gcc43.patch
  216. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  217. - Autorebuild for GCC 4.3
  218. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  219. - Update to new upstream snapshot (SVN 29336).
  220. - Drop TCSpinLock pthread workaround (fixed upstream):
  221. - TCSpinLock-use-pthread-stubs.patch
  222. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  223. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  224. - Add patch to forcibly build the TCSpinLock code using the pthread
  225. implementation:
  226. + TCSpinLock-use-pthread-stubs.patch
  227. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  228. - Package renamed from WebKitGtk.
  229. - Update to SVN 28482.
  230. - Build both the GTK and Qt ports, putting each into their own respective
  231. subpackages.
  232. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  233. the build-webkit script from upstream.
  234. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  235. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  236. - Initial packaging for Fedora.