neon-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: neon
  3. Summary: An HTTP and WebDAV client library.
  4. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  5. Version: 0.29.3
  6. Release: 2%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.webdav.org/neon/
  10. Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: expat
  13. Requires: zlib >= 1.1.4
  14. Requires: krb5-libs
  15. BuildRequires: expat-devel
  16. BuildRequires: gnutls-devel
  17. BuildRequires: krb5-devel
  18. BuildRequires: libxml2-devel
  19. #BuildRequires: openssl-devel
  20. BuildRequires: sed
  21. BuildRequires: zlib-devel
  22. BuildRequires: keyutils-libs-devel
  23. %description
  24. neon is an HTTP and WebDAV client library, with a C interface;
  25. providing a high-level interface to HTTP and WebDAV methods along
  26. with a low-level interface for HTTP request handling. neon
  27. supports persistent connections, proxy servers, basic, digest and
  28. Kerberos authentication, and has complete SSL support.
  29. %package devel
  30. Summary: Development libraries and C header files for the neon library
  31. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}
  34. Requires: zlib-devel
  35. #Requires: openssl-devel
  36. Requires: expat-devel
  37. Requires: gnutls-devel
  38. Requires: krb5-devel
  39. Requires: keyutils-libs-devel
  40. %description devel
  41. The development library for the C language HTTP and WebDAV client library.
  42. %description devel -l ja
  43. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-%{name}
  46. Summary: C language HTTP and WebDAV client library.
  47. Group: System Environment/Libraries
  48. Requires: expat
  49. Requires: zlib >= 1.1.4
  50. %description -n compat32-%{name}
  51. A C language HTTP and WebDAV client library.
  52. %package -n compat32-%{name}-devel
  53. Summary: A C language HTTP and WebDAV client library.
  54. Group: Development/Libraries
  55. Requires: compat32-%{name} = %{version}
  56. Requires: compat32-zlib-devel
  57. #Requires: compat32-openssl-devel
  58. Requires: compat32-expat-devel
  59. Requires: compat32-keyutils-libs-devel
  60. Requires: compat32-krb5-devel
  61. %description -n compat32-%{name}-devel
  62. The development library for the C language HTTP and WebDAV client library.
  63. %prep
  64. %setup -q
  65. %build
  66. %configure \
  67. --with-expat \
  68. --with-ssl=gnutls \
  69. --enable-threadsafe-ssl=posix \
  70. --enable-shared \
  71. --disable-static \
  72. --with-force-ssl
  73. %__make %{?_smp_mflags}
  74. %install
  75. %__rm -rf %{buildroot}
  76. %makeinstall
  77. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  78. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  79. %find_lang %{name}
  80. ## remove unuse files
  81. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post -p /sbin/ldconfig
  85. %postun -p /sbin/ldconfig
  86. %post -n compat32-%{name} -p /sbin/ldconfig
  87. %postun -n compat32-%{name} -p /sbin/ldconfig
  88. %files -f %{name}.lang
  89. %defattr(-,root,root)
  90. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
  91. %doc doc/html
  92. %{_libdir}/*.so.*
  93. %files devel
  94. %defattr(-,root,root)
  95. %{_bindir}/*
  96. %{_includedir}/*
  97. %{_mandir}/man1/*
  98. %{_mandir}/man3/*
  99. #{_libdir}/*.a
  100. #{_libdir}/*.la
  101. %{_libdir}/*.so
  102. %{_libdir}/pkgconfig/*.pc
  103. %if %{build_compat32}
  104. %files -n compat32-%{name}
  105. %defattr(-,root,root)
  106. %{_libdir}/*.so.*
  107. %files -n compat32-%{name}-devel
  108. %defattr(-,root,root)
  109. #{_libdir}/*.a
  110. #{_libdir}/*.la
  111. %{_libdir}/pkgconfig/*.pc
  112. %endif
  113. %changelog
  114. * Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
  115. - add BuildRequires: keyutils-libs-devel
  116. - add Requires: krb5-devel, keyutils-libs-devel (-devel package)
  117. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
  118. - new upstream release
  119. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
  120. - rebuilt with krb5-libs-1.8.2
  121. - removed BR: openssl-devel
  122. - removed static library from devel package
  123. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
  124. - rebuilt with rpm-4.8.1 for pkg-config
  125. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  126. - new upstream release with security fix (CVE-2009-2473, 2474)
  127. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  128. - rebuild with gnutls-2.6.3
  129. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  130. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  131. - add _smp_mflags into make section
  132. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  133. - new upstream release with security fix (CVE-2008-3746)
  134. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  135. - removed *.la
  136. - spec in utf-8
  137. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  138. - added --with-ssl=gnutls --enable-threadsafe-ssl
  139. - added BuildRequires: gnutls-devel
  140. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  141. - new upstream release
  142. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  143. - removed %%if !%%{build_compat32} case condition
  144. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  145. - rebuild with expat-2.0.1
  146. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  147. - new upstream release
  148. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  149. - add Requires: zlib-devel, openssl-devel, expat-devel
  150. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  151. - move %%configure from %%prep to %%build
  152. - remove unneeded locales.patch (for neon-0.26.x or later)
  153. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  154. - new upstream release
  155. - drop doc.patch (patch0)
  156. - use more macros
  157. - drop BuildRequires: autoconf, automake
  158. - add *.pc to -devel (and compat32's) package
  159. - change group
  160. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  161. - add doc/html instead of doc/* to %%doc
  162. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  163. - run ldconfig in %%post,postun
  164. - add locales.patch (patch0)
  165. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  166. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  167. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  168. - added compat32- packages for x86_64 architecture support
  169. - added --libdir=%{_libdir} option to configure
  170. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  171. - new upstream release
  172. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  173. - upstream release
  174. - update URL and Source0 tag: valid URL
  175. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  176. - upstream release
  177. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  178. - add Japanese Summary and %%description
  179. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  180. - build VineLinux
  181. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  182. - Updated to 0.23.5.
  183. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  184. - Upgraded to 0.23.2.
  185. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  186. - Upgraded to 0.22.0.
  187. - Fixed compilation from CVS.
  188. - Took out man pages until I can figure out xmlto program.
  189. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  190. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  191. to RedHat 7.3 versions and fixing bug in spec file.
  192. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  193. work.
  194. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  195. - Fixed file ownership problems. Made them owned by root.
  196. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  197. - Updated to neon 0.21.3.
  198. * Tue Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  199. - Updated to neon 0.21.2.
  200. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  201. - Updated to neon 0.21.1.
  202. - Now requires zlib >= 1.1.4.
  203. - Broke into zlib and zlib-devel.
  204. - Now builds shared library.
  205. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  206. - Updated to neon 0.19.4.
  207. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  208. - Updated to neon 0.19.2.
  209. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  210. - Updated to neon 0.18.2.
  211. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  212. - Took out dependency on libxml and w3c-libwww packages.
  213. - Added dependency on expat.
  214. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  215. - Release 0.17.2-1: Updated neon.
  216. * Thu Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  217. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  218. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  219. - Release 2001-10-20: Initial Version.