123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272 |
- # Copyright (c) 2000-2007, JPackage Project
- # All rights reserved.
- #
- # Redistribution and use in source and binary forms, with or without
- # modification, are permitted provided that the following conditions
- # are met:
- #
- # 1. Redistributions of source code must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- # 2. Redistributions in binary form must reproduce the above copyright
- # notice, this list of conditions and the following disclaimer in the
- # documentation and/or other materials provided with the
- # distribution.
- # 3. Neither the name of the JPackage Project nor the names of its
- # contributors may be used to endorse or promote products derived
- # from this software without specific prior written permission.
- #
- # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
- # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
- # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
- # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
- # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
- # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
- # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
- # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- #
- Name: bcel
- Version: 5.2
- Release: 8%{?_dist_release}
- Summary: Byte Code Engineering Library
- License: ASL 2.0
- Group: Development/Libraries
- URL: http://commons.apache.org/proper/commons-bcel/
- Source0: %{name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- Requires: regexp
- #Requires(post): javapackages-tools >= 1.7.2
- #Requires(postun): javapackages-tools >= 1.7.2
- %description
- The Byte Code Engineering Library (formerly known as JavaClass) is
- intended to give users a convenient possibility to analyze, create, and
- manipulate (binary) Java class files (those ending with .class). Classes
- are represented by objects which contain all the symbolic information of
- the given class: methods, fields and byte code instructions, in
- particular. Such objects can be read from an existing file, be
- transformed by a program (e.g. a class loader at run-time) and dumped to
- a file again. An even more interesting application is the creation of
- classes from scratch at run-time. The Byte Code Engineering Library
- (BCEL) may be also useful if you want to learn about the Java Virtual
- Machine (JVM) and the format of Java .class files. BCEL is already
- being used successfully in several projects such as compilers,
- optimizers, obsfuscators and analysis tools, the most popular probably
- being the Xalan XSLT processor at Apache.
- %package javadoc
- Summary: Javadoc for %{name}
- Summary(ja): %{name} の Javadoc
- Group: Documentation
- %description javadoc
- %{summary}.
- %package manual
- Summary: Manual for %{name}
- Summary(ja): %{name} のマニュアル
- Group: Documentation
- %description manual
- %{summary}.
- %prep
- %setup -q
- #cat <<EOT
- #
- # This is initial build for Vine Linux.
- # Binary archive is provided.
- #
- #EOT
- # fix wrong-file-end-of-line-encoding
- #sed -i 's/\r//' docs/verifier/V_API_SD.eps docs/eps/classloader.fig
- %build
- # nothing to do
- %install
- rm -rf %{buildroot}
- # jars
- mkdir -p %{buildroot}%{_javadir}
- install -m 0644 %{name}-%{version}.jar \
- %{buildroot}%{_javadir}/%{name}-%{version}.jar
- (
- cd %{buildroot}%{_javadir}
- for jar in *-%{version}*; do
- ln -s ${jar} `echo $jar | %{__sed} "s|-%{version}||g"`
- done
- )
- # javadoc
- mkdir -p %{buildroot}%{_javadocdir}/%{name}-%{version}
- cp -pr docs/apidocs/* %{buildroot}%{_javadocdir}/%{name}-%{version}
- rm -rf docs/apidocs
- ln -s %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
- # manual
- mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}
- cp -pr docs/* %{buildroot}%{_docdir}/%{name}-%{version}
- #cp -p LICENSE.txt %{buildroot}%{_docdir}/%{name}-%{version}
- %clean
- rm -rf %{buildroot}
- %files
- %defattr(0644,root,root,0755)
- %doc LICENSE.txt
- #doc %{_docdir}/%{name}-%{version}
- #doc %{_docdir}/%{name}-%{version}/LICENSE.txt
- %{_javadir}/*
- #{_datadir}/maven2/poms/*
- #{_mavendepmapfragdir}
- %files javadoc
- %defattr(0644,root,root,0755)
- %{_javadocdir}/%{name}-%{version}
- %doc %{_javadocdir}/%{name}
- %files manual
- %defattr(0644,root,root,0755)
- %doc %{_docdir}/%{name}-%{version}
- %changelog
- * Fri Mar 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.2-8
- - Initial build for Vine Linux
- * Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0:5.2-7.2
- - Rebuilt for RHEL 6
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:5.2-7.1
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:5.2-6.1
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Thu Dec 04 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-5.1
- - Do not install poms in /usr/share/maven2/default_poms
- * Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:5.2-5
- - drop repotag
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:5.2-4jpp.2
- - Autorebuild for GCC 4.3
- * Tue Jan 22 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-3jpp.1
- - Merge with upstream
- * Mon Jan 07 2008 Permaine Cheung <pcheung at redhat.com> 0:5.2-2jpp.2
- - Fixed unowned directory (Bugzilla 246185)
- * Fri Nov 16 2007 Ralph Apel <r.apel@r-apel.de> 0:5.2-3jpp
- - Install poms unconditionally
- - Add pom in ./maven2/default_poms
- - Add org.apache.bcel:bcel depmap frag
- * Wed Sep 19 2007 Permaine Cheung <pcheung at redhat.com> 0:5.2-2jpp.1
- - Update to 5.2 in Fedora
- * Mon Sep 4 2007 Jason Corley <jason.corley@gmail.com> 0:5.2-2jpp
- - use official 5.2 release tarballs and location
- - change vendor and distribution to macros
- - add missing requires on and maven-plugin-test, maven-plugins-base, and
- maven-plugin-xdoc
- - macro bracket fixes
- - remove demo subpackage (examples are not included in the distribution tarball)
- - build in mock
- * Wed Jun 27 2007 Ralph Apel <r.apel@r-apel.de> 0:5.2-1jpp
- - Upgrade to 5.2
- - Drop bootstrap option: not necessary any more
- - Add pom and depmap frags
- * Fri Feb 09 2007 Ralph Apel <r.apel@r-apel.de> 0:5.1-10jpp
- - Fix empty-%%post and empty-%%postun
- - Fix no-cleaning-of-buildroot
- * Fri Feb 09 2007 Ralph Apel <r.apel@r-apel.de> 0:5.1-9jpp
- - Optionally build without maven
- - Add bootstrap option
- * Thu Aug 10 2006 Matt Wringe <mwringe at redhat.com> 0:5.1-8jpp
- - Add missing requires for Javadoc task
- * Sun Jul 23 2006 Matt Wringe <mwringe at redhat.com> 0:5.1-7jpp
- - Add conditional native compilation
- - Change spec file encoding from ISO-8859-1 to UTF-8
- - Add missing BR werken.xpath and ant-apache-regexp
- * Tue Apr 11 2006 Ralph Apel <r.apel@r-apel.de> 0:5.1-6jpp
- - First JPP-1.7 release
- - Use tidyed sources from svn
- - Add resources to build the manual
- - Add examples to -demo subpackage
- - Build with maven by default
- - Add option to build with straight ant
- * Fri Nov 19 2004 David Walluck <david@jpackage.org> 0:5.1-5jpp
- - rebuild to fix packager
- * Sat Nov 06 2004 David Walluck <david@jpackage.org> 0:5.1-4jpp
- - rebuild with javac 1.4.2
- * Sat Oct 16 2004 David Walluck <david@jpackage.org> 0:5.1-3jpp
- - rebuild for JPackage 1.6
- * Fri Aug 20 2004 Ralph Apel <r.apel at r-apel.de> 0:5.1-2jpp
- - Build with ant-1.6.2
- * Sun May 11 2003 David Walluck <david@anti-microsoft.org> 0:5.1-1jpp
- - 5.1
- - update for JPackage 1.5
- * Mon Mar 24 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 5.0-6jpp
- - For jpackage-utils 1.5
- * Tue Feb 25 2003 Ville Skyttä <ville.skytta at iki.fi> - 5.0-5jpp
- - Rebuild to get docdir right on modern distros.
- - Fix License tag and source file perms.
- - Built with IBM's 1.3.1SR3 (doesn't build with Sun's 1.4.1_01).
- * Tue Jun 11 2002 Henri Gomez <hgomez@slib.fr> 5.0-4jpp
- - use sed instead of bash 2.x extension in link area to make spec compatible
- with distro using bash 1.1x
- * Tue May 07 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 5.0-3jpp
- - vendor, distribution, group tags
- * Wed Jan 23 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 5.0-2jpp
- - section macro
- - no dependencies for manual and javadoc package
- * Tue Jan 22 2002 Henri Gomez <hgomez@slib.fr> 5.0-1jpp
- - bcel is now a jakarta apache project
- - dependency on jakarta-regexp instead of gnu.regexp
- - created manual package
- * Sat Dec 8 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.1-2jpp
- - javadoc into javadoc package
- - Requires: and BuildRequires: gnu.regexp
- * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 4.4.1-1jpp
- - removed packager tag
- - new jpp extension
- - 4.4.1
- * Thu Oct 11 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.0-2jpp
- - first unified release
- - used lower case for name
- - used original tarball
- - s/jPackage/JPackage
- * Mon Aug 27 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 4.4.0-1mdk
- - first Mandrake release
|