mplayer-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510
  1. %define with_vaapi 1
  2. %define with_libvpx 1
  3. %define name mplayer
  4. %define version 1.0
  5. %define extver rc4
  6. %define release 42%{?extver:.%{extver}}%{?_dist_release}
  7. %define svndate 20100709
  8. #% define release 40.%{svndate}%{?_dist_release}
  9. # define dvbappver 0.95
  10. %define ttfontdir /usr/share/fonts
  11. %define ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  12. TrueType-sazanami-gothic/sazanami-gothic
  13. Summary: The Movie Player
  14. Summary(ja): 動画プレイヤー
  15. Name: %{name}
  16. Version: %{version}
  17. Release: %{release}
  18. Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  19. #Source0: mplayer-export-%{svndate}.tar.bz2
  20. Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
  21. Source10: mplayer-snapshot-vine.sh
  22. ## DVB app.
  23. ## 0.9.5
  24. # Source100: http://2sen.dip.jp/cgi-bin/dtvup/source/up0624.zip
  25. ## 0.9.5 -> 0.9.6
  26. # Source101: http://2sen.dip.jp/cgi-bin/dtvup/source/up0658.zip
  27. #Patch2: %{name}-config.patch
  28. Patch2: %{name}-config-20100709-vine.patch
  29. Patch8: %{name}-manlinks.patch
  30. Patch14: %{name}-nodvdcss.patch
  31. ## Vine
  32. Patch50: mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  33. # Patch101: mplayer-1.0rc4-0001-makes-ffdec_aac-more-robust-against-erroneous-irregu.patch
  34. # Patch102: mplayer-1.0rc4-0002-add-support-for-audio-channel-reconfiguration.patch
  35. # Patch103: mplayer-1.0rc4-0003-add-support-for-dual-mono-auto-selection-and-switchi.patch
  36. # Patch106: mplayer-1.0rc4-0006-add-support-for-S2API-tuning-with-a-new-channels.con.patch
  37. # Patch107: mplayer-1.0rc4-0007-add-BCAS-descrambling-feature.patch
  38. # Patch111: mplayer-1.0rc4-ffmpeg-0001-makes-ffdec_aac-more-robust-against-erroneous-irregu.patch
  39. # Patch113: mplayer-1.0rc4-ffmpeg-0003-add-dual-mono-support-to-ffdec_aac.patch
  40. License: GPLv2+
  41. Group: Applications/Multimedia
  42. URL: http://www.mplayerhq.hu/
  43. BuildRequires: SDL-devel
  44. BuildRequires: aalib-devel
  45. BuildRequires: alsa-lib-devel
  46. BuildRequires: cdparanoia-devel
  47. BuildRequires: desktop-file-utils
  48. BuildRequires: enca-devel
  49. BuildRequires: freetype2-devel >= 2.0.9
  50. BuildRequires: fribidi-devel
  51. BuildRequires: fontconfig-devel
  52. BuildRequires: giflib-devel
  53. BuildRequires: gtk2-devel
  54. BuildRequires: mesa-libGL-devel
  55. BuildRequires: libXinerama-devel
  56. BuildRequires: libXScrnSaver-devel
  57. BuildRequires: libXv-devel
  58. BuildRequires: libXvMC-devel
  59. BuildRequires: libXxf86dga-devel
  60. BuildRequires: libXxf86vm-devel
  61. BuildRequires: libass-devel
  62. BuildRequires: libpng-devel
  63. BuildRequires: libjpeg-devel
  64. BuildRequires: libdvdread
  65. BuildRequires: libmpcdec-devel >= 1.2.1
  66. BuildRequires: librtmp-devel >= 2.3
  67. BuildRequires: speex-devel >= 1.1
  68. %if %{?_dist_release} != "vl5"
  69. %{?with_vaapi:BuildRequires:libva-devel}
  70. %endif
  71. BuildRequires: libvdpau-devel
  72. BuildRequires: libvorbis-devel
  73. %if %{?_dist_release} != "vl5"
  74. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.1}
  75. %endif
  76. BuildRequires: lzo-devel >= 2
  77. BuildRequires: pulseaudio-lib-devel
  78. BuildRequires: speex-devel >= 1.1
  79. BuildRequires: twolame-devel
  80. BuildRequires: xorg-x11-devel
  81. BuildRequires: yasm
  82. BuildRequires: zlib-devel
  83. # *-devel packages provided by other self-build-* should only be listed
  84. # in self-build-%{name}.spec as PreReq.
  85. ##Requires: self-build-mplayer-codecs
  86. ##BuildRequires: self-build-libdvdcss
  87. ##BuildRequires: self-build-libdvdnav
  88. ##BuildRequires: self-build-faac
  89. ##BuildRequires: self-build-lame
  90. ##BuildRequires: self-build-libdca
  91. ##BuildRequires: self-build-x264 >= 0.0.0-15.20110322
  92. ##BuildRequires: self-build-xvidcore >= 0.9.2
  93. ##BuildRequires: self-build-faad2 >= 2.6
  94. ##BuildRequires: self-build-libmad
  95. ##BuildRequires: self-build-libmpeg2
  96. Requires: TrueType-vlgothic
  97. Requires: mesa-libGL
  98. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  99. %description
  100. MPlayer can play most standard video formats out of the box and almost
  101. all others with the help of external codecs.
  102. MPlayer currently works best from the command line, but visual feedback
  103. for many functions is available from its onscreen status display (OSD),
  104. which is also used for displaying subtitles.
  105. MPlayer also has a GUI with skin support and several unofficial alternative
  106. graphical frontends are available.
  107. MEncoder is a command line video encoder for advanced users that can
  108. be built from the MPlayer source tree. Unofficial graphical frontends
  109. exist but arenot included.
  110. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  111. support for some newer codecs are not yet inpmlemented.
  112. You should install mplayer-codecs package if you want to play videos
  113. using those new codecs.
  114. %description -l ja
  115. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  116. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用することで再生できます。
  117. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  118. 多くの操作は字幕と同様に、
  119. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  120. MPlayer には スキンを変更できる GUI も用意されていますし、
  121. また複数の非公式なフロントエンドも利用できます。
  122. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  123. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  124. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  125. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  126. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  127. をインストールする必要があります。
  128. %prep
  129. %setup -q -n MPlayer-%{version}%{extver}
  130. #%setup -q -n mplayer-export-%{svndate}
  131. %patch2 -p1 -b .config
  132. %patch8 -p1 -b .manlinks
  133. %patch14 -p1 -b .nodvdcss
  134. %patch50 -p1 -b .x11
  135. # ## apply the DVB app. patches
  136. # unzip %{SOURCE100}
  137. # cat>ffmpeg<<EOF
  138. # Subproject commit 4f84e728dad84a366a2d183da03b7d92cb20fb23
  139. # EOF
  140. # %patch101 -p1 -b .vine
  141. # %patch102 -p1 -b .vine
  142. # %patch103 -p1 -b .vine
  143. # patch -p1 < mplayer-patches-%{dvbappver}/0004-improved-stream-selection-by-limiting-the-switch-wit.patch || exit 1
  144. # patch -p1 < mplayer-patches-%{dvbappver}/0005-extended-DVB-options-to-support-more-cards-and-speci.patch || exit 1
  145. # %patch106 -p1 -b .vine
  146. # %patch107 -p1 -b .vine
  147. # patch -p1 < mplayer-patches-%{dvbappver}/0008-supports-PMT-contents-change.patch || exit 1
  148. # patch -p1 < mplayer-patches-%{dvbappver}/0009-supports-video-frame-size-change.patch || exit 1
  149. # %patch111 -p1 -b .vine
  150. # patch -p1 < mplayer-patches-%{dvbappver}/ffmpeg/0002-add-support-for-audio-channel-reconfiguration.patch || exit 1
  151. # %patch113 -p1 -b .vine
  152. # patch -p1 < mplayer-patches-%{dvbappver}/ffmpeg/0004-fixed-sample-rate-calculation-in-SBR-AAC-HE_AAC.patch || exit 1
  153. %build
  154. ./configure \
  155. --prefix=%{_prefix} \
  156. --confdir=%{_sysconfdir}/mplayer \
  157. --enable-runtime-cpudetection \
  158. --extra-cflags="$RPM_OPT_FLAGS" \
  159. --disable-libdvdcss-internal \
  160. --disable-dvdread-internal \
  161. --enable-dvdread \
  162. --enable-dvdnav \
  163. \
  164. --disable-faac-lavc \
  165. --disable-mp3lame-lavc \
  166. --disable-x264-lavc \
  167. \
  168. --disable-faad-internal \
  169. \
  170. --disable-libopenjpeg \
  171. \
  172. --enable-vdpau \
  173. \
  174. --disable-bitmap-font \
  175. --disable-termcap \
  176. --enable-xvmc \
  177. --with-xvmclib=XvMCW \
  178. \
  179. --enable-largefiles \
  180. --enable-menu \
  181. --enable-gui \
  182. --language=ja,en \
  183. ;
  184. %{__make} %{?_smp_mflags}
  185. %install
  186. %{__rm} -rf ${RPM_BUILD_ROOT}
  187. %{__make} install INSTALLSTRIP= \
  188. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  189. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  190. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  191. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  192. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  193. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  194. ;
  195. ## install some default config files
  196. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  197. %{__install} -pm 644 etc/example.conf \
  198. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  199. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  200. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  201. # install default skin
  202. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  203. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  204. %{__tar} xjf %{SOURCE1}
  205. %{__ln_s} Blue default
  206. popd
  207. # make sybolic link to ttf font for subtitle
  208. for i in %{ttfontlist}; do
  209. if [ -e %{ttfontdir}/$i.ttf ];then
  210. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  211. break;
  212. fi;
  213. done
  214. ## install TOOLS
  215. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  216. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  217. done
  218. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  219. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  220. done
  221. for file in vobshift.py ; do
  222. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  223. done
  224. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  225. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  226. %clean
  227. %{__rm} -rf ${RPM_BUILD_ROOT}
  228. %files
  229. %defattr(-,root,root)
  230. %doc AUTHORS Changelog Copyright LICENSE README
  231. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  232. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  233. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  234. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  235. %{_bindir}/mplayer
  236. %{_bindir}/gmplayer
  237. %{_bindir}/mencoder
  238. %{_datadir}/mplayer/skins/Blue
  239. %{_datadir}/mplayer/skins/default
  240. %{_datadir}/mplayer/subfont.ttf
  241. %{_datadir}/applications/mplayer.desktop
  242. %{_datadir}/pixmaps/mplayer.xpm
  243. %{_mandir}/man1/mplayer.1*
  244. %{_mandir}/man1/mencoder.1*
  245. ## TOOLS
  246. %{_bindir}/aconvert
  247. %{_bindir}/calcbpp
  248. %{_bindir}/countquant
  249. %{_bindir}/divx2svcd
  250. %{_bindir}/dvd2divxscript
  251. %{_bindir}/mencvcd
  252. %{_bindir}/midentify
  253. %{_bindir}/mpconsole
  254. %{_bindir}/qepdvcd
  255. %{_bindir}/subsearch
  256. %{_bindir}/vobshift
  257. %{_datadir}/mplayer/*.fp
  258. %changelog
  259. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  260. - dropped BuildRequires: esound-devel
  261. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  262. - new upstream release
  263. - ready for Vine Linux 6
  264. - revived support for Vine Linux 5
  265. - added BuildRequires:
  266. - libass-devel
  267. - librtmp-devel >= 2.3
  268. - speex-devel >= 1.1
  269. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  270. - added BuildRequires:
  271. - aalib-devel
  272. - enca-devel
  273. - lzo-devel
  274. - speex-devel
  275. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  276. - updated fixed %{name}-config.patch
  277. - applied %{name}-config-20100709-vine.patch
  278. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  279. - change release to sync with self-build-mplayer
  280. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  281. - updated source snapshot 20100709
  282. - renamed %%Source10 to mplayer-snapshot-vine.sh
  283. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  284. - added BuildRequires: libvpx-devel >= 0.9.1
  285. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  286. - updated source snapshot 20100621
  287. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  288. - updated source snapshot 20100615
  289. - added BuildRequires: libXinerama-devel
  290. - dropped vl4 support
  291. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  292. - updated source snapshot 20100410
  293. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  294. - updated source snapshot 20100401
  295. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  296. - updated source snapshot 20100326
  297. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  298. - updated source snapshot 20100317
  299. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  300. - updated source snapshot 20100216
  301. - moved scripts from TOOLS
  302. - added --disable-libopenjpeg in configure options
  303. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  304. - updated source snapshot 20100201
  305. - dropped obsolete patches
  306. - added BuildRequires:
  307. - libvdpau-devel
  308. - libXScrnSaver-devel
  309. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  310. - update mplayer-config-20091215-vine.patch
  311. - update mplayer-20091215-x86_32-compile.patch
  312. - added --enable-runtime-cpudetection in configure options
  313. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  314. - source snapshot 20091031
  315. - updated mplayer-20091031-x86_32-compile.patch
  316. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  317. - source snapshot 20091003
  318. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  319. - change release to sync with self-build-mplayer
  320. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  321. - source snapshot 20090905
  322. - added settings for vl6
  323. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  324. - source snapshot 20090821
  325. - replaced BR: libungif-devel with BR: giflib-devel
  326. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  327. - source snapshot 20090722
  328. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  329. - source snapshot 20090702
  330. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  331. - source snapshot 20090611
  332. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  333. - added Requires: TrueType-vlgothic
  334. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  335. - source snapshot 20090522
  336. - build with x264 >= 0.0.0-9.20090522
  337. - updated mplayer-20090522-nodvdcss.patch
  338. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  339. - change release to sync with self-build-mplayer
  340. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  341. - source snapshot 20090502
  342. - updated mplayer-20090503-x86_32-compile.patch
  343. - updated mplayer-20090502-nodvdcss.patch
  344. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  345. - applied mplayer-config-vine.patch
  346. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  347. - source snapshot 20090327
  348. - updated mplayer-20090327-x86_32-compile.patch
  349. - updated mplayer-20090325-nodvdcss.patch
  350. - dropped gmplayer-about-vine.patch
  351. - install some default config files
  352. - added configure options:
  353. - --disable-termcap
  354. - --enable-xvmc
  355. - --with-xvmclib=XvMCW
  356. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  357. - fixed %%files for *.conf
  358. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  359. - source snapshot 20090305
  360. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  361. - source snapshot 20090227
  362. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  363. - source snapshot 20090216
  364. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  365. - source snapshot 20090206
  366. - dropped mplayer-man-zh_CN.patch
  367. - updated mplayer-20090206-nodvdcss.patch
  368. - changed to PreReq: self-build-faad2 from faad2-devel
  369. - added PreReq: self-build-libmad
  370. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  371. - source snapshot 20090131
  372. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  373. - change release to sync with self-build-mplayer
  374. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  375. - source snapshot
  376. - update mplayer-20090122-nodvdcss.patch
  377. - added BuildRequires:
  378. - faad2-devel
  379. - libmpcdec-devel
  380. - twolame-devel
  381. - yasm
  382. - faac-devel (as PreReq in self-build-%{name})
  383. - lame-devel (as PreReq in self-build-%{name})
  384. - libdca-devel (as PreReq in self-build-%{name})
  385. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  386. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  387. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  388. - source snapshot
  389. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  390. --disable-faad-internal in configure options
  391. - dropped gmplayer-add-flv-extension.patch
  392. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  393. - source snapshot
  394. - fixed License
  395. - added some patches from RPM Fusion
  396. - updated gmplayer-about-vine.patch for 20081001 snapshot
  397. - added BuildRequires: libdvdread
  398. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  399. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  400. in configure options
  401. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  402. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  403. - fixed License
  404. - added some devel packages to support OpenGL
  405. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  406. - spec in utf8
  407. - fix sybolic link of subfont for vl5
  408. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  409. - add "Patch105: CVE-2008-1558.patch".
  410. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  411. - build with new versioning policy.
  412. - fix Source[01] URLs.
  413. - add "Patch200: gmplayer-about-vine.patch".
  414. - add "Patch201: gmplayer-add-flv-extension.patch".
  415. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  416. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  417. CVE-2008-0629, CVE-2008-0630)
  418. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  419. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  420. - change source download URL. <BTS:VineLinux:603>
  421. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  422. - fix CONFDIR for make install. <BTS:wishes:33>
  423. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  424. - initial build for Vine Linux