ModemManager-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240
  1. #%define snapshot .git20100720
  2. %define snapshot %{nil}
  3. %define ppp_version 2.4.4
  4. Summary: Mobile broadband modem management service
  5. Summary(ja): Mobile broadband modem management service
  6. Name: ModemManager
  7. Version: 0.4
  8. Release: 1%{?snapshot}%{?_dist_release}
  9. License: GPLv2+
  10. Group: System Environment/Base
  11. URL: http://www.gnome.org/projects/NetworkManager/
  12. #
  13. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  14. # tarball built with:
  15. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  16. # make distcheck
  17. #
  18. Source: %{name}-%{version}%{?snapshot}.tar.bz2
  19. Patch1: %{name}-0.3-jp-modems.patch
  20. Patch20: %{name}-0.4-git20100720.patch
  21. Patch21: %{name}-0.4-glib2-2.25.12.patch
  22. Patch22: %{name}-0.4-dbus-glib-property-access-bug.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. Requires: dbus-glib
  25. Requires: glib2
  26. BuildRequires: glib2-devel >= 2.26.1
  27. BuildRequires: dbus-glib-devel >= 0.92
  28. BuildRequires: libgudev-devel >= 143
  29. BuildRequires: ppp = %{ppp_version}
  30. BuildRequires: ppp-devel = %{ppp_version}
  31. BuildRequires: polkit-devel
  32. BuildRequires: automake autoconf intltool libtool
  33. # for xsltproc
  34. BuildRequires: libxslt
  35. %description
  36. The ModemManager service provides a consistent API to operate many different
  37. modems, including mobile broadband (3G) devices.
  38. %prep
  39. %setup -q
  40. %patch1 -p1 -b .jp-modems
  41. %patch20 -p1 -b .git20100720
  42. %patch21 -p1 -b .glib2
  43. %patch22 -p1 -b .dbus-glib
  44. %build
  45. autoreconf -i
  46. pppddir=`ls -1d %{_libdir}/pppd/2*`
  47. %configure \
  48. --enable-more-warnings=yes \
  49. --with-udev-base-dir=/lib/udev \
  50. --with-tests=yes \
  51. --with-docs=yes \
  52. --disable-static \
  53. --with-pppd-plugin-dir=$pppddir \
  54. --with-polkit=no
  55. make %{?_smp_mflags}
  56. %check
  57. make check
  58. %install
  59. make install DESTDIR=$RPM_BUILD_ROOT
  60. rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  61. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
  62. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  63. %post
  64. /sbin/ldconfig
  65. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  66. %postun
  67. /sbin/ldconfig
  68. if [ $1 -eq 0 ]; then
  69. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  70. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  71. fi
  72. %posttrans
  73. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  74. %files
  75. %defattr(0644, root, root, 0755)
  76. %doc COPYING README
  77. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
  78. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
  79. %attr(0755,root,root) %{_sbindir}/modem-manager
  80. %dir %{_libdir}/%{name}
  81. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  82. /lib/udev/rules.d/*
  83. %{_datadir}/polkit-1/actions/*.policy
  84. %{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
  85. %changelog
  86. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  87. - update to 0.4
  88. - add Patch20 (ModemManager-0.4-git20100720.patch)
  89. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  90. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  91. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  92. - initial build for Vine Linux
  93. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  94. - core: ignore some failures on disconnect (rh #578280)
  95. - core: add support for platform serial devices
  96. - gsm: better Blackberry DUN support
  97. - gsm: periodically poll access technology
  98. - cdma: prevent crash on modem removal (rh #571921)
  99. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  100. - novatel: better signal strength reporting on CDMA cards
  101. - novatel: add access technology and mode preference support on GSM cards
  102. - zte: fix mode preference retrieval
  103. - longcheer: add support for Zoom modems (4595, 4596, etc)
  104. - longcheer: add access technology and mode preference support
  105. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  106. - Silence %%post
  107. - Update scripts
  108. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  109. - gsm: fix parsing Blackberry supported character sets response
  110. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  111. - mbm: fix retrieval of current allowed mode
  112. - gsm: fix initialization issues with some devices (like Blackberries)
  113. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  114. - core: fix detection of some generic devices (rh #579247)
  115. - core: fix detection regression of some Huawei devices in 0.3-5
  116. - cdma: periodically poll registration state and signal quality
  117. - cdma: really fix registration detection on various devices (rh #569067)
  118. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  119. - core: fix PPC/SPARC/etc builds
  120. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  121. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  122. - cdma: handle signal quality requests while connected for more devices
  123. - cdma: handle serving system requests while connected for more devices
  124. - gsm: determine current access technology earlier
  125. - huawei: work around automatic registration issues on some devices
  126. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  127. - core: ensure enabled modems are disabled when MM stops
  128. - core: better capability detection for Blackberry devices (rh #573510)
  129. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  130. - gsm: don't block modem when it requires PIN2
  131. - option: fix access technology updates
  132. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  133. - mbm: add device IDs for C3607w
  134. - mbm: fail earlier during connection failures
  135. - mbm: fix username/password authentication when checked by the network
  136. - hso: implement asynchronous signal quality updates
  137. - option: implement asynchronous signal quality updates
  138. - novatel: correctly handle CDMA signal quality
  139. - core: basic PolicyKit support
  140. - core: fix direct GSM registration information requests
  141. - core: general GSM PIN/PUK unlock fixes
  142. - core: poll GSM registration state internally for quicker status updates
  143. - core: implement GSM 2G/3G preference
  144. - core: implement GSM roaming allowed/disallowed preference
  145. - core: emit signals on access technology changes
  146. - core: better handling of disconnections
  147. - core: fix simple CDMA status requests
  148. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  149. - core: startup speed improvements
  150. - core: GSM PIN checking improvements
  151. - huawei: fix EVDO-only connections on various devices (rh #553199)
  152. - longcheer: add support for more devices
  153. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  154. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  155. - core: fix crashes when devices are unplugged during operation (rh #553953)
  156. - cdma: prefer primary port for status/registration queries
  157. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  158. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  159. - gsm: fix Nokia N80 network scan parsing
  160. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  161. - core: fix apparent hangs by limiting retried serial writes
  162. - gsm: ensure modem state is reset when disabled
  163. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  164. - sierra: fix CDMA registration detection in some cases (rh #547513)
  165. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  166. - sierra: ensure CDMA device is powered up when trying to use it
  167. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  168. - zte: handle unsolicited messages better during probing
  169. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  170. - cdma: fix signal strength reporting on some devices
  171. - cdma: better registration state detection when dialing (ex Sierra 5275)
  172. - option: always use the correct tty for dialing commands
  173. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  174. - core: fix reconnect after manual disconnect (rh #541314)
  175. - core: fix various segfaults during registration
  176. - core: fix probing of various modems on big-endian architectures (ie PPC)
  177. - core: implement modem states to avoid duplicate operations
  178. - hso: fix authentication for Icera-based devices like iCON 505
  179. - zte: use correct port for new devices
  180. - nozomi: fix detection
  181. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  182. - Update to latest git
  183. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  184. - cdma: wait for network registration before trying to connect
  185. - gsm: add cell access technology reporting
  186. - gsm: allow longer-running network scans
  187. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  188. - nokia: don't power down phones on disconnect
  189. - hso: fix disconnection/disable
  190. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  191. - Fixes for Motorola and Ericsson devices
  192. - Fixes for CDMA "serving-system" command parsing
  193. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  194. - Fix a typo in one of the udev rules files
  195. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  196. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  197. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  198. - Fix source repo location
  199. - Fix directory ownership
  200. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  201. - Initial version