acl-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322
  1. Name: acl
  2. Summary: Access control list utilities
  3. Version: 2.2.49
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Base
  6. License: GPLv2+
  7. URL: http://oss.sgi.com/projects/xfs/
  8. Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
  9. Patch1: acl-2.2.39-build.patch
  10. # bz #488674
  11. Patch2: acl-2.2.49-setfacl-walk.patch
  12. # bz #467936
  13. Patch3: acl-2.2.49-bz467936.patch
  14. # prepare the test-suite for SELinux and arbitrary umask
  15. Patch4: acl-2.2.49-tests.patch
  16. # bz #576550
  17. Patch5: acl-2.2.49-setfacl-restore.patch
  18. # fix typos in setfacl(1) man page (#675451)
  19. Patch6: acl-2.2.49-bz675451.patch
  20. # add function acl_extended_file_nofollow() (#692982)
  21. Patch7: acl-2.2.49-bz692982.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: gawk
  24. BuildRequires: gettext
  25. BuildRequires: libattr-devel >= 2.4.1
  26. BuildRequires: libtool
  27. Requires: libacl = %{version}-%{release}
  28. %description
  29. This package contains the getfacl and setfacl utilities needed for
  30. manipulating access control lists.
  31. %package -n libacl
  32. Summary: Dynamic library for access control list support
  33. License: LGPLv2+
  34. Group: System Environment/Libraries
  35. Requires(post): /sbin/ldconfig
  36. Requires(postun): /sbin/ldconfig
  37. %description -n libacl
  38. This package contains the libacl.so dynamic library which contains
  39. the POSIX 1003.1e draft standard 17 functions for manipulating access
  40. control lists.
  41. %package -n libacl-devel
  42. Summary: Access control list static libraries and headers.
  43. License: LGPLv2+
  44. Group: Development/Libraries
  45. Requires: libacl = %{version}-%{release}
  46. Requires: libattr-devel
  47. %description -n libacl-devel
  48. This package contains static libraries and header files needed to develop
  49. programs which make use of the access control list programming interface
  50. defined in POSIX 1003.1e draft standard 17.
  51. %prep
  52. %setup -q
  53. %patch1 -p1
  54. %patch2 -p1
  55. %patch3 -p1
  56. %patch4 -p1
  57. %patch5 -p1
  58. %patch6 -p1
  59. %patch7 -p1
  60. %build
  61. touch .census
  62. # acl abuses libexecdir
  63. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  64. make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. make install DESTDIR=$RPM_BUILD_ROOT
  68. make install-dev DESTDIR=$RPM_BUILD_ROOT
  69. make install-lib DESTDIR=$RPM_BUILD_ROOT
  70. # get rid of libacl.a and libacl.la
  71. rm -f $RPM_BUILD_ROOT/%{_lib}/libacl.a
  72. rm -f $RPM_BUILD_ROOT/%{_lib}/libacl.la
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.a
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.la
  75. # fix links to shared libs and permissions
  76. rm -f $RPM_BUILD_ROOT/%{_libdir}/libacl.so
  77. ln -sf ../../%{_lib}/libacl.so $RPM_BUILD_ROOT/%{_libdir}/libacl.so
  78. chmod 0755 $RPM_BUILD_ROOT/%{_lib}/libacl.so.*.*.*
  79. %find_lang %{name}
  80. %check
  81. if ./setfacl/setfacl -m u:`id -u`:rwx .; then
  82. make tests || exit $?
  83. if test 0 = `id -u`; then
  84. make root-tests || exit $?
  85. fi
  86. else
  87. echo '*** ACLs are probably not supported by the file system,' \
  88. 'the test-suite will NOT run ***'
  89. fi
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %post -n libacl -p /sbin/ldconfig
  93. %postun -n libacl -p /sbin/ldconfig
  94. %files -f %{name}.lang
  95. %defattr(-,root,root)
  96. %{_bindir}/chacl
  97. %{_bindir}/getfacl
  98. %{_bindir}/setfacl
  99. %{_datadir}/doc/acl-%{version}
  100. %{_mandir}/man1/chacl.1*
  101. %{_mandir}/man1/getfacl.1*
  102. %{_mandir}/man1/setfacl.1*
  103. %{_mandir}/man5/acl.5*
  104. %files -n libacl-devel
  105. %defattr(-,root,root)
  106. /%{_lib}/libacl.so
  107. %{_includedir}/acl
  108. %{_includedir}/sys/acl.h
  109. %{_libdir}/libacl.*
  110. %{_mandir}/man3/acl_*
  111. %files -n libacl
  112. %defattr(-,root,root)
  113. /%{_lib}/libacl.so.*
  114. %changelog
  115. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
  116. - updated to 2.2.49
  117. - added Patch2-7 from Fedora
  118. * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
  119. - add function acl_extended_file_nofollow() (#692982)
  120. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
  121. - fix typos in setfacl(1) man page (#675451)
  122. * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
  123. - remove dependency of libacl-devel on nfs-utils-lib and openldap
  124. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
  125. - let acl depend on the same version of libacl (#595674)
  126. * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
  127. - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
  128. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
  129. - initial build for Vine Linux
  130. * Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
  131. - new upstream version
  132. * Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
  133. - Fixed segfault when using only "--" as parameter
  134. - Resolves: #430458
  135. * Wed Nov 7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
  136. - Fixed setfacl exitcodes
  137. - Resolves: #368451
  138. * Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
  139. - New version
  140. - dropped walk patch
  141. * Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
  142. - Rewriten path_max patch to support long UTF8 names
  143. - Resolves #287701, #183181
  144. * Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
  145. - Removed NFS4 ACL patch since it was rejected by upstream.
  146. * Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
  147. - disable nfs patch; linking libacl against libs in /usr will lead to breakage
  148. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
  149. - Build Require gawk
  150. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
  151. - Rebuild for selinux ppc32 issue.
  152. * Mon Aug 27 2007 Steve Dickson <steved@redhat.com> 2.2.39-5
  153. - Added NFS v4 ACL support
  154. * Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
  155. - Updated man page for getfacl
  156. * Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
  157. - Added support fort short params to getfacl
  158. - Resolves: #204087
  159. * Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
  160. - new improved walk patch with fixed getfacl exit code (rhbz#232884)
  161. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
  162. - fix buildroot
  163. - remove trailing dot from summary
  164. - -devel requires same version of libacl
  165. - escape macro in changelog
  166. - make .so symlink relative
  167. * Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
  168. - Apply patch to make order consistent.
  169. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
  170. - rebuild
  171. * Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
  172. - new version 2.2.39
  173. - fixed usage of long UTF-8 filenames (#183181)
  174. Thanks to Andrey for the initial patch.
  175. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
  176. - rebuild for -devel deps
  177. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
  178. - bump again for double-long bug on ppc(64)
  179. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
  180. - rebuilt for new gcc4.1 snapshot and glibc changes
  181. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
  182. - new version 2.2.34
  183. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  184. - rebuilt
  185. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
  186. - fixed permissions of libacl
  187. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
  188. - spec file cleanup
  189. - mark po files as lang specific
  190. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  191. - 2.2.32
  192. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
  193. - update to 2.2.31
  194. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
  195. - get rid of *.la files
  196. - remove duplicate doc files
  197. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
  198. - Rebuild
  199. * Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
  200. - make the libs executable so that we find their dependencies (#132696)
  201. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
  202. - libacl-devel Requires: libattr-devel for libattr.la
  203. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
  204. - Requires libtool >= 1.5 for building
  205. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
  206. - Make libacl.so.* executable.
  207. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
  208. - Update to latest upstream version.
  209. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
  210. - Close bug #125300 (Steve Grubb: build requires libtool,gettext)
  211. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  212. - rebuilt
  213. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
  214. - Add missing %%defattr
  215. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
  216. - Add /usr/include/acl to files manifest
  217. - Fix location of doc files, add main doc dir to files manifest
  218. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  219. - rebuilt
  220. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  221. - rebuilt
  222. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
  223. - Fix libtool invocation
  224. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
  225. - Update to acl-2.2.7
  226. * Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
  227. - include patch from Jay Berkenbilt to print better error messages
  228. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
  229. - udpate/rebuild
  230. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
  231. - set execute bits on library so that requires are generated.
  232. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
  233. - Correct patch in previous fix so that shared libraries go in /lib*
  234. instead of /usr/lib*
  235. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
  236. - Fix multilibbing
  237. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
  238. - Added fix to install libs in correct directory on 64bit machine
  239. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
  240. - Made the package only own the one directory that is unique to it:
  241. /usr/include/acl
  242. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
  243. - Initial Red Hat package
  244. Made as few changes as possible relative to upstream packaging to
  245. make it easier to maintain long-term. This means that some of
  246. the techniques used here are definitely not standard Red Hat
  247. techniques. If you are looking for an example package to fit
  248. into Red Hat Linux transparently, this would not be the one to
  249. pick.
  250. - acl-devel -> libacl-devel