texlive-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857
  1. ## -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %define enable_sharedlib 1
  4. %if %{?_dist_release} == "vl5"
  5. %define enable_sharedlib 0
  6. %endif
  7. %define with_babel 1
  8. %define ptexlivever 20100711
  9. %define texlivesrcver 20091107
  10. %define texlivever 20091107
  11. ## we provides e-pTeX and upTeX
  12. %define with_uptex 0
  13. %define with_eptex 1
  14. %define uptexver 0.30
  15. %define uptex_fontver 0.30
  16. %define eptexver 100420
  17. %define tex_destdir %{_datadir}
  18. %define texmf %{tex_destdir}/texmf
  19. %define texlive_src %{tex_destdir}/texlive-sources
  20. %define build_tex_destdir %{buildroot}%{tex_destdir}
  21. %define build_texmf %{buildroot}%{texmf}
  22. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  23. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  24. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  25. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
  26. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  27. %define vartexfonts %{_var}/lib/texmf
  28. Autoreq: 0
  29. Summary: The TeX text formatting system
  30. Summary(ja): TeX 文書整形システム
  31. Name: texlive
  32. Version: 2009
  33. Release: 13%{?_dist_release}
  34. License: distributable
  35. Group: Applications/Publishing
  36. ## The TeX Live is located on http://www.tug.org/texlive/
  37. ## e-pTeX: http://eptex.sourceforge.jp/
  38. ## upTeX: http://homepage3.nifty.com/ttk/comp/tex/uptex.html
  39. URL: http://tutimura.ath.cx/ptexlive/
  40. ## original TeX Live sources
  41. Source: http://tutimura.ath.cx/~nob/tex/ptexlive/ptexlive-%{ptexlivever}.tar.gz
  42. ##Source1: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivesrcver}-source.tar.xz
  43. ##Source2: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivever}-texmf.tar.xz
  44. ##Source3: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivever}-extra.tar.xz
  45. ##Source4: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivever}-bin.tar.xz
  46. ##Source5: ftp://tug.org/historic/systems/texlive/2009/tlnet/install-tl-unx.tar.gz
  47. ## pxdvi
  48. Source10: pxdvi.desktop
  49. ## dvipdfmx
  50. #Source20:
  51. ## texdoc
  52. ## http://github.com/mpg/texdoc
  53. ## Downloaded mpg-texdoc-0.72-0-gfdb7657.tar.gz
  54. ## Renamed this archive:
  55. # $ tar zxf mpg-texdoc-0.72-0-gfdb7657.tar.gz
  56. # $ mv mpg-texdoc-b66e1e3 texdoc-0.72
  57. # $ tar zcf texdoc-0.72.tar.gz texdoc-0.72
  58. #Source90: texdoc-%{texdocver}.tar.gz
  59. ## Japanese ptex
  60. # ## Babel
  61. # ## See [texqa:37398] http://oku.edu.mie-u.ac.jp/~okumura/texfaq/qa/37398.html
  62. # Source40: http://www.ctan.org/tex-archive/obsolete/systems/win32/fptex/0.7/collection/tex-langother.zip
  63. # Source41: http://www.ctan.org/tex-archive/obsolete/systems/win32/fptex/0.7/package/texlive-base.zip
  64. ## e-pTeX, upTeX
  65. Source50: http://homepage3.nifty.com/ttk/comp/tex/uptex-%{uptexver}.tar.gz
  66. Source51: http://homepage3.nifty.com/ttk/comp/tex/uptex_font-%{uptex_fontver}.tar.gz
  67. Source52: http://sourceforge.jp/projects/eptex/downloads/43841/eptex-%{eptexver}.tar.bz2
  68. ## etc...
  69. Source100: texlive.cron
  70. Source101: dvi-to-ps.fpi
  71. Source102: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
  72. Source103: ps-morisawa.map
  73. Source104: ps-morisawa-noEmbed.map
  74. # ## do not provide any perl deps (#516350)
  75. # %define __perl_provides %{nil}
  76. ######
  77. # TeX patches
  78. ######
  79. ## vine
  80. Patch0: ptexlive-%{ptexlivever}-vine.patch
  81. Patch1: texlive-%{texlivesrcver}-set-selfautodir.patch
  82. ##Patch1: texlive-2009-texmfcnf-selfautodir-vine.patch
  83. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  84. ## (p)xdvik
  85. Patch10: ptexlive-%{ptexlivever}-pxdvik-vine.patch
  86. Patch11: texlive-%{texlivesrcver}-xdvik-vine.patch
  87. ## dvipdfmx
  88. Patch20: ptexlive-%{ptexlivever}-dvipdfmx-vine.patch
  89. ## e-pTeX + upTeX
  90. Patch50: eptex-100420-vine.patch
  91. Patch51: http://sourceforge.jp/projects/eptex/wiki/FrontPage/attach/eptex-100420-patch1.diff
  92. ## texdoc
  93. #Patch90: texdoc-0.72-support-zipped-vine.patch
  94. ## others
  95. ## libpoppler-0.12 from texlive-bin_2009-7.diff.gz
  96. Patch100: texlive-2009-pdftexdir-libpoppler-0.12.patch
  97. Patch101: texlive-2009-luatexdir-libpoppler-0.12.patch
  98. ## security
  99. ## from Debian
  100. #Patch1000: texlive-2009-CVE-2010-0739.patch
  101. Patch1001: texlive-2009-CVE-2010-0827.patch
  102. ## this overrides the incomplete fix for CVE-2010-0793
  103. Patch1002: texlive-2009-CVE-2010-1440.patch
  104. Requires: coreutils
  105. Requires: ed mktemp
  106. Requires: tmpwatch
  107. Requires: zlib
  108. Requires: libpng
  109. Requires: gd
  110. Requires: ncurses
  111. Requires: libjpeg
  112. Requires: t1lib
  113. Requires: freetype2
  114. Requires: openMotif
  115. Requires: poppler
  116. Requires: openssl
  117. Requires: libpaper
  118. Requires: fontconfig
  119. Requires: perl-Tk
  120. Requires: nkf
  121. Requires: ghostscript >= 8.63
  122. %if %{?_dist_release} == "vl6"
  123. Requires: libkpathsea = %{version}-%{release}
  124. Requires: libptexenc = %{version}-%{release}
  125. %endif
  126. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  127. %{!?with_firstbuild:Requires: texlive-macros = %{version}}
  128. %if %{?_dist_release} == "vl6"
  129. %{!?with_firstbuild:Requires: jvf >= 2.0-5}
  130. %endif
  131. %if %{?_dist_release} == "vl5"
  132. %{!?with_firstbuild:Requires: texlive-jvf >= 2.0-5}
  133. %endif
  134. Requires: fontconfig >= 2.6.0-2
  135. Requires(post,postun): fontconfig >= 2.6.0-2
  136. Requires(post): ed mktemp
  137. Requires(post): vutils >= 2.0.5
  138. %{!?with_firstbuild:BuildRequires: texlive-common = %{version}}
  139. BuildRequires: texlive-sources = %{version}
  140. BuildRequires: xz
  141. BuildRequires: unzip
  142. BuildRequires: bison flex
  143. BuildRequires: zlib-devel
  144. BuildRequires: libpng-devel
  145. BuildRequires: gd-devel
  146. BuildRequires: ncurses-devel
  147. BuildRequires: libjpeg-devel
  148. BuildRequires: t1lib-devel
  149. BuildRequires: XOrg-devel
  150. BuildRequires: freetype2-devel >= 2.1.10
  151. BuildRequires: autoconf >= 2.63
  152. BuildRequires: openMotif-devel
  153. BuildRequires: poppler-devel
  154. BuildRequires: openssl-devel
  155. BuildRequires: libpaper-devel
  156. BuildRequires: fontconfig-devel
  157. BuildRequires: nkf
  158. BuildRequires: t1utils
  159. Buildroot: %{_tmppath}/%{name}-%{version}-root
  160. Vendor: Project Vine
  161. Distribution: Vine Linux
  162. Packager: munepi
  163. %description
  164. The TeX Live software distribution offers a complete TeX system for a
  165. variety of Unix, Macintosh, Windows and other platforms. It
  166. encompasses programs for editing, typesetting, previewing and printing
  167. of TeX documents in many different languages, and a large collection
  168. of TeX macros and font libraries.
  169. The distribution includes extensive general documentation about TeX,
  170. as well as the documentation for the included software packages.
  171. This package provides a Japanese TeX environment
  172. based on ptexlive-%{ptexlivever}.
  173. %description -l ja
  174. TeX Live ソフトウェアディストリビューションは、
  175. さまざまな Unix, Macintosh, Windows、および
  176. 他のプラットホームに対して完全な TeX システムを提供します。
  177. 多くの異なった言語を含む TeX ドキュメントの
  178. 編集、組版、閲覧、印刷するためのプログラム、
  179. そして、TeX マクロやフォントライブラリの大きなコレクションを
  180. 同梱しています。
  181. このディストリビューションは
  182. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  183. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  184. このパッケージは ptexlive-%{ptexlivever} を元にした
  185. 日本語 TeX 環境を提供します。
  186. %package doc
  187. Summary: TeX Live: Documentation files of %{name}
  188. Group: Applications/Publishing
  189. Requires: %{name} = %{version}-%{release}
  190. %if %{?_dist_release} != "vl5"
  191. BuildArch: noarch
  192. %endif
  193. %description doc
  194. This package contains documentation files of %{name}.
  195. %if %{enable_sharedlib}
  196. %package -n libkpathsea
  197. Summary: path search library for the TeX Live
  198. Summary(ja): TeX Live 用パス検索ライブラリ
  199. Group: System Environment/Libraries
  200. %description -n libkpathsea
  201. This package includes runtime part of the Kpathsea library.
  202. %package -n libkpathsea-devel
  203. Summary: path search libary and header files for the TeX Live
  204. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  205. Group: Development/Libraries
  206. Requires: libkpathsea = %{version}-%{release}
  207. %description -n libkpathsea-devel
  208. This package includes static library and header files of the Kpathsea library.
  209. %package -n libptexenc
  210. Summary: Kanji code convert library for Japanese pTeX
  211. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  212. Group: System Environment/Libraries
  213. Requires: libkpathsea = %{version}-%{release}
  214. %description -n libptexenc
  215. This package includes runtime part of the ptexenc library.
  216. %package -n libptexenc-devel
  217. Summary: Kanji code convert library and header files for Japanese pTeX
  218. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  219. Group: Development/Libraries
  220. Requires: libptexenc = %{version}-%{release}
  221. %description -n libptexenc-devel
  222. This package includes header files of the ptexenc library.
  223. %endif
  224. %prep
  225. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  226. #% setup -q -n ptexlive-%{ptexlivever} -a 90
  227. %setup -q -n ptexlive-%{ptexlivever}
  228. ## extract texlive-source
  229. %__tar Jxf %{texlive_src}/source/%{name}-%{texlivesrcver}-source.tar.xz || exit 1
  230. ## move texlive-source to build/
  231. %__mkdir_p build && \
  232. %__mv %{name}-%{texlivesrcver}-source build/ || exit 1
  233. ## apply ptexlive
  234. %patch0 -p1 -b .orig
  235. ## fix $SELFAUTODIR to /usr/share
  236. %patch1 -p1 -b .orig
  237. %__cat <<EOF > ptexlive.cfg
  238. #KANJI_CODE=EUC
  239. KANJI_CODE=UTF8
  240. TEXLIVE_VERSION=2009
  241. ISO_DIR=%{texlive_src}
  242. TEXLIVE_DIR=%{texlive_src}
  243. ##SRC_DIR=%{_sourcedir}
  244. SRC_TAR=%{SOURCE0}
  245. ##PREFIX=%{tex_destdir}
  246. PREFIX=$(pwd)/Vine
  247. TMP_PREFIX=$(pwd)/build
  248. TEXSRC_EXTRACTED=$(pwd)/build/%{name}-%{texlivesrcver}-source
  249. ##SRC_TAR=%{SOURCE1}
  250. ##TEXMFDIST=$(pwd)/build/%{name}-%{texlivesrcver}-source/inst/texmf-dist
  251. TEXMFDIST=%{texlive_src}/texmf-dist
  252. XDVI=echo
  253. PSPDF=echo
  254. make_option vartexfonts=%{vartexfonts}
  255. conf_option --enable-luatex
  256. conf_option --enable-xetex
  257. conf_option --enable-xdv2pdf
  258. conf_option --enable-xdvipdfmx
  259. conf_option --with-xdvi-x-toolkit=motif
  260. # conf_option --without-x
  261. # conf_option --disable-xdvik
  262. # conf_option --disable-oxdvik
  263. # conf_option --disable-pxdvik
  264. conf_option --with-system-ncurses
  265. conf_option --with-system-zlib
  266. conf_option --with-system-pnglib
  267. conf_option --with-system-t1lib
  268. conf_option --with-system-xpdf
  269. conf_option --with-system-freetype
  270. conf_option --with-system-freetype2
  271. conf_option --with-freetype2-include=`freetype-config --cflags | sed -e 's/-I//' -e 's/ .*//'`
  272. conf_option --with-system-gd
  273. EOF
  274. ## For vl5, libkpathsea and libptexenc libraries are static link
  275. %if %{enable_sharedlib}
  276. %__cat <<EOF >> ptexlive.cfg
  277. conf_option --enable-shared
  278. EOF
  279. %endif
  280. %__cat <<EOF >> ptexlive.cfg
  281. conf_option --enable-kanji-iconv
  282. conf_option --disable-multiplatform
  283. make_option %{?_smp_mflags}
  284. EOF
  285. ## exec 2extract-src.sh
  286. %__make x
  287. ## texmf.cnf for Vine Linux
  288. %patch2 -p1 -b .orig
  289. ## (p)xdvik for Vine Linux
  290. %patch10 -p1 -b .orig
  291. %patch11 -p1 -b .orig
  292. ## dvipdfmx for Vine Linux
  293. %patch20 -p1 -b .orig
  294. ## eptex
  295. (cd ..
  296. %__tar jxf %{SOURCE52}
  297. cd eptex-%{eptexver}
  298. %patch50 -p1 -b .orig
  299. %patch51 -p1 -b .orig
  300. ## apply eptex: exec almost 0eptex.sh
  301. %if %with_eptex
  302. ./0eptex.sh
  303. %endif
  304. )
  305. ## texdoc
  306. #%patch90 -p0 -b .orig
  307. ## libpoppler-0.12
  308. %if %{?_dist_release} != "vl5"
  309. (cd build/%{name}-%{texlivesrcver}-source
  310. %patch100 -p1 -b .xpdf
  311. %patch101 -p1 -b .xpdf
  312. )
  313. %endif
  314. ## apply security patches
  315. (cd build/%{name}-%{texlivesrcver}-source
  316. #%patch1000
  317. %patch1001 -p1 -b .security
  318. %patch1002 -p1 -b .security
  319. )
  320. %build
  321. ## NOTE:
  322. ## In this setion,
  323. ## execute almostly 3make-install.sh
  324. set -x
  325. unset TEXINPUTS || :
  326. unset HOME || :
  327. . ./common.sh
  328. export CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LANG=C
  329. ##%__make c
  330. PREF=${TEXSRC_EXTRACTED}/inst
  331. %__mkdir_p ${PREF}/texmf
  332. %__mkdir_p ${PREF}/../Work
  333. pushd ${PREF}/../Work
  334. ../configure --host=%{_host} --build=%{_build} \
  335. --prefix=${PREF} \
  336. --datadir=${PREF} \
  337. \
  338. --disable-native-texlive-build \
  339. --enable-multiplatform \
  340. --disable-omfonts \
  341. --enable-compiler-warnings=max \
  342. --without-cxx-runtime-hack \
  343. --enable-kanji=$KANJI_CODE \
  344. --with-ptexenc=$KANJI_CODE \
  345. --disable-all-pkgs \
  346. --enable-web2c \
  347. --disable-luatex \
  348. --disable-xetex \
  349. --enable-mf \
  350. --enable-mf-nowin \
  351. --enable-mp \
  352. --enable-web-progs \
  353. --enable-dvipdfmx \
  354. --enable-dvipsk \
  355. --enable-pdvipsk \
  356. --enable-gsftopk \
  357. --enable-makeindexk \
  358. --enable-makejvf \
  359. --enable-mendexk \
  360. --enable-ps2pkm \
  361. --enable-xdvik \
  362. --enable-pxdvik \
  363. --enable-tetex \
  364. --enable-texlive \
  365. $CONF_OPTION
  366. (cd ..
  367. ## Avoid pollution from internal libraries.
  368. %__rm -rf ./libs/{expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,type1,t1lib,unzip,xpdf,zlib}
  369. ## XXX Hacks to avoid accidental version clashs with system libraries.
  370. hack_libs=(
  371. zlib
  372. libpng
  373. t1lib
  374. freetype
  375. freetype2
  376. gd
  377. xpdf
  378. )
  379. for i in "${hack_libs[@]}"; do
  380. %__mkdir_p ./libs/${i}
  381. touch ./libs/${i}/configure
  382. done
  383. )
  384. %__make world $MAKE_OPTION %{?_smp_mflags}
  385. popd
  386. %install
  387. ## prepare %%install session
  388. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  389. set -x
  390. unset TEXINPUTS || :
  391. unset HOME || :
  392. . ./common.sh
  393. PREF=${TEXSRC_EXTRACTED}/inst
  394. pushd ${PREF}/../Work
  395. ## the following two lines are useful for
  396. ## "rpmbuild -ba --short-circuit ~/rpm/SPECS/texlive-vl.spec"
  397. %__rm -rf ${PREF}
  398. %__make world $MAKE_OPTION
  399. popd
  400. ## execute almostly 4extract-texmf.sh
  401. %__mv ${PREF}/texmf-dist ${PREF}/texmf-dist.install || exit # never use
  402. %__mv ${PREF}/texmf ${PREF}/texmf.install || exit
  403. %__cp -r %{texlive_src}/texmf ${PREF}/ || exit
  404. %__cp -rf ${PREF}/texmf.install/* ${PREF}/texmf/ || exit
  405. ## copy almost compatible TeX system of teTeX-3.0
  406. ## NOTE: The size of texmf-dist is about 2GB below:
  407. # 890M doc
  408. # 660M fonts
  409. # 103M source
  410. #
  411. # 68M tex/latex
  412. # 46M tex/generic
  413. # 27M tex/context
  414. ##%__ln_s -f %{texlive_src}/texmf-dist ${PREF}/
  415. %__mkdir_p ${PREF}/texmf-dist
  416. ##!! [FAKE] copy all directries except doc, fonts, source, tex4ht in texmf-dist
  417. (cd %{texlive_src}/texmf-dist
  418. %__cp -r README metapost scripts bibtex dvips makeindex mft \
  419. tlpkg context metafont tex omega vtex \
  420. ${PREF}/texmf-dist/
  421. )
  422. ## copy some fonts (almost tetex + tetex-extra)
  423. ## NOTE: this part is in texlive-common since texlive-8vl6
  424. #### customize updmap.cfg for each font's map files
  425. %{!?with_firstbuild: \
  426. %__sed -i -e "s,^\(Map\|MixedMap\),#! \1,g" ${PREF}/texmf/web2c/updmap.cfg}
  427. ## make some fundamental texmf trees
  428. %__mkdir_p ${PREF}/texmf-config
  429. %__mkdir_p ${PREF}/texmf-var
  430. %__mkdir_p ${PREF}/texmf-local
  431. ## NOTE: need texmf-dist/tex/latex/ltxmisc url.sty
  432. ./4extract-texmf.sh %{?with_firstbuild: || :}%{!?with_firstbuild: || exit 1}
  433. ## post 0eptex.sh
  434. %if %with_eptex
  435. (cd ../eptex-%{eptexver}
  436. ## copying distfiles
  437. echo "[copying] eptex.src"
  438. %__mkdir -p ${TEXMF}/ptex/plain/base
  439. %__cp eptex.src ${TEXMF}/ptex/plain/base/ || exit 1
  440. echo "[copying] eptexdefs.lib"
  441. cp eptexdefs.lib $TEXMF/ptex/plain/base/ || exit 1
  442. echo "[copying] language.def"
  443. %__mkdir -p ${TEXMF}/ptex/generic/config
  444. %__cp language.def ${TEXMF}/ptex/generic/config/ || exit 1
  445. )
  446. %endif
  447. ##!! DO NOT execute 5macro.sh
  448. # ./5macro.sh clean default utf %{?with_firstbuild: || :}%{!?with_firstbuild: || exit 1}
  449. # ./5macro.sh otf %{?with_firstbuild: || :}%{!?with_firstbuild: || exit 1}
  450. ## execute 6babel.sh
  451. %if %with_babel
  452. # %__unzip -o -d babel %{SOURCE40}
  453. # %__unzip -o -d babel %{SOURCE41}
  454. # %__install -m0644 \
  455. # babel/texmf/tex/generic/hyphen/cathyph.tex \
  456. # babel/texmf/tex/generic/hyphen/cyhyph.tex \
  457. # ${TEXMF}/tex/generic/hyphen/ || exit 1
  458. %{!?with_firstbuild: ../eptex-%{eptexver}/6babel.sh || exit 1}
  459. ## check 6babel.sh
  460. %{!?with_firstbuild: [ -f ${PREF}/texmf/doc/japanese/sample.tex ] || exit 1}
  461. %endif
  462. # ## update texdoc
  463. # cd texdoc-%{texdocver} || exit 1
  464. # %__rm -rf ${PREF}/texmf/texdoc || exit 1
  465. # %__mkdir_p ${PREF}/texmf/texdoc
  466. # %__cp -fa texdoc.cnf ${PREF}/texmf/texdoc/ || exit 1
  467. # %__rm -rf ${PREF}/texmf/scripts/texdoc || exit 1
  468. # %__rm -f script/*.orig || exit 1
  469. # %__cp -ra script ${PREF}/texmf/scripts/texdoc || exit 1
  470. # %__chmod 755 ${PREF}/texmf/scripts/texdoc/* || exit 1
  471. # %__rm -rf ${PREF}/texmf/doc/texdoc || exit 1
  472. # %__cp -ra doc ${PREF}/texmf/doc/texdoc || exit 1
  473. # %__cp -a News Todo ${PREF}/texmf/doc/texdoc/ || exit 1
  474. # cd -
  475. # # TODO:
  476. # # %{!?with_firstbuild: \
  477. # # cd ${PREF}/texmf/doc/texdoc && %__make || exit 1}
  478. ## install
  479. %__mkdir_p %{buildroot}%{_prefix}
  480. (cd ${PREF}
  481. %__rm -f bin/man
  482. %__cp -r bin %{buildroot}%{_bindir}
  483. %__cp -r lib %{buildroot}%{_libdir}
  484. %__cp -r include %{buildroot}%{_includedir}
  485. ##NOTE: use man, info files from texlive-sources
  486. %__rm -rf texmf/doc/info
  487. %__rm -rf texmf/doc/man
  488. %__mkdir_p %{build_tex_destdir}
  489. ## NOTE: texmf-dist is contained in texlive-common package
  490. ##%__cp -r texmf{,-dist,-config,-var,-local} %{build_tex_destdir}/ || exit 1
  491. %__cp -r texmf{,-config,-var,-local} %{build_tex_destdir}/ || exit 1
  492. )
  493. %__mkdir_p %{build_texmf}/fonts/truetype
  494. %__mkdir_p %{build_texmf}/fonts/opentype
  495. ## dvipdfmx: our map file
  496. %__mkdir_p %{build_texmf}/fonts/map/dvipdfmx
  497. touch %{build_texmf}/fonts/map/dvipdfmx/vine.map
  498. ## delete useless files (conflict with jvf package)
  499. # rm -rf %{build_texmf}/fonts/vf/ptex
  500. # rm -rf %{build_texmf}/fonts/tfm/ptex/*[a-zA-Z].tfm
  501. %__rm %{build_texmf}/fonts/vf/ptex/{min,tmin,goth,tgoth}{5,6,7,8,9,10}.vf || exit 1
  502. ## install jtygm.sty
  503. %__install -m0644 %{SOURCE102} %{build_texmf}/ptex/platex/base/ || exit 1
  504. ## morisawa map files remaped PS Kanji (CIDFont) Name
  505. %__install -m 0644 %{SOURCE103} %{SOURCE104} \
  506. %{buildroot}%{texmf}/fonts/map/dvipdfm/ptexlive/
  507. ## remove asymptote directries, which provides asymptote package
  508. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  509. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  510. # ## remove xindy
  511. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  512. # ## remove tex4ht
  513. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  514. ## relocate binaries to %{_bindir} and fix relative symlinks
  515. pushd %{buildroot}%{_bindir}
  516. for i in `find . -type l`; do
  517. if [ "`readlink $i | grep '..' | wc -l`" == "1" ]; then
  518. l=`readlink $i | sed s,../,../share/,`
  519. %__ln_s -f $l $i
  520. fi
  521. done
  522. popd
  523. # ## compress pdf files in texmf/doc
  524. # find %{build_tex_destdir}/texmf/doc -name "*.pdf" -exec xz {} \;
  525. ## compress info files
  526. %__rm -f %{buildroot}%{_infodir}/dir
  527. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  528. ## desktop things
  529. %__mkdir_p %{buildroot}%{_datadir}/applications
  530. %__install -c %{SOURCE10} %{buildroot}%{_datadir}/applications/pxdvi.desktop
  531. # for created fonts
  532. %__mkdir_p %{buildroot}%{vartexfonts}
  533. %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  534. %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  535. ## set executable bit for the library
  536. %if %{enable_sharedlib}
  537. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  538. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  539. %endif
  540. ## remove unpackaging files
  541. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f
  542. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f
  543. ### Files list
  544. find %{buildroot} -type f -or -type l | \
  545. %__sed -e "s|%{buildroot}||g" | \
  546. %__grep -v -e "^%{_sysconfdir}" -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  547. %__grep -v "%{_includedir}" | \
  548. %__grep -v "%{_libdir}" | \
  549. %__grep -v "%{_infodir}" | \
  550. %__sed -e "s|.*\.\(cnf\|cfg\)$|%config(noreplace) &|" \
  551. -e "s|.*ls-R$|%ghost &|" \
  552. -e "s|^.*/updmap$|%config &|" \
  553. -e "s|%{texmf}*/dvips/config/\(psfonts.*\|ps2pk.*\|pdftex.*\|dvipdfm.*\|.*35\)\.map$|%ghost &|" \
  554. -e "s|%{texmf}*/web2c/.*\.\(fmt\|efmt\|log\|base\|mem\|oft\)$|%config &|" \
  555. -e "s|%{texmf}*/dvips/config/config\.\(generic\|pdf\|ps\|www\)$|%config &|" \
  556. -e "s|%{texmf}*/tex/generic/config/.*|%config &|" \
  557. -e "s|%{texmf}*/pdftex/config/pdftex.cfg$|%config &|" \
  558. -e "s|%{texmf}*/xdvi/vfontmap$|%config &|" \
  559. -e "s|%{texmf}*/xdvi/XDvi|%config &|" \
  560. -e "s|%{_mandir}/.*|&*|" \
  561. > filelist.full
  562. find %{buildroot}%{texmf} -type d | \
  563. %__sed -e "s|^%{buildroot}|%dir |" \
  564. -e "s|$|/|" >> filelist.full
  565. ## subpackages
  566. %__grep "/texmf/doc/" filelist.full > filelist.doc
  567. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  568. %__mv -f filelist.tmp filelist.full
  569. %clean
  570. %__rm -rf %{buildroot}
  571. %post
  572. ## dvipdfmx
  573. ## Create our own cid-x.map
  574. ( %{exec_upddeffont} ) ||:
  575. %{exec_texhash}
  576. %{exec_updmap} --enable KanjiMap vine.map >/dev/null 2>&1
  577. # echo -n " "
  578. # echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  579. # echo -n " "
  580. # echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  581. %preun
  582. %__rm -rf %{_var}/lib/texmf/*
  583. if [ "$1" = 0 ]; then
  584. ## dvipdfmx
  585. for i in %{texmf}/fonts/truetype/*
  586. do
  587. if [ -L "$i" ]; then
  588. %__rm -f "$i"
  589. fi
  590. done
  591. fi
  592. %if %{enable_sharedlib}
  593. %post -n libkpathsea
  594. /sbin/ldconfig
  595. # /sbin/install-info %{_infodir}/kpathsea.info.* %{_infodir}/dir
  596. %preun -n libkpathsea
  597. # if [ "$1" = 0 ]; then
  598. # /sbin/install-info --delete %{_infodir}/kpathsea.info.* %{_infodir}/dir
  599. # fi
  600. %postun -n libkpathsea
  601. /sbin/ldconfig
  602. %post -n libptexenc
  603. /sbin/ldconfig
  604. %postun -n libptexenc
  605. /sbin/ldconfig
  606. %endif
  607. %triggerin -- ghostscript
  608. %__rm -f %{texmf}/fonts/cmap/ghostscript
  609. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  610. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{texmf}/fonts/cmap/ghostscript
  611. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  612. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{texmf}/fonts/cmap/ghostscript
  613. fi
  614. %{exec_texhash}
  615. %files -f filelist.full
  616. %defattr(-,root,root)
  617. %attr(1777,root,root) %dir %{_var}/lib/texmf
  618. %config %{_sysconfdir}/cron.daily/texlive.cron
  619. %files doc -f filelist.doc
  620. %defattr(-,root,root)
  621. %if %{enable_sharedlib}
  622. %files -n libkpathsea
  623. %defattr(-,root,root)
  624. %{_libdir}/libkpathsea.so.*
  625. # %{_infodir}/kpathsea.info*
  626. %files -n libkpathsea-devel
  627. %defattr(-,root,root)
  628. %{_libdir}/libkpathsea.so
  629. %dir %{_includedir}/kpathsea
  630. %{_includedir}/kpathsea/*
  631. %files -n libptexenc
  632. %defattr(-,root,root)
  633. %{_libdir}/libptexenc.so.*
  634. %files -n libptexenc-devel
  635. %defattr(-,root,root)
  636. %{_libdir}/libptexenc.so
  637. %dir %{_includedir}/ptexenc
  638. %{_includedir}/ptexenc/*
  639. %endif
  640. %changelog
  641. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  642. - updated ptexlive-20100711-pxdvik-vine.patch
  643. and added texlive-20091107-xdvik-vine.patch
  644. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  645. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  646. - supported Vine Linux 5
  647. - for vl5, changed a requirement of Japanese VF package
  648. - added Requires: texlive-jvf = 2009 (vl5)
  649. - dropped dependencies of Provides:/Obsoletes: tags
  650. - merged these dependencies in texlive-common-vl.spec
  651. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  652. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  653. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  654. - applied some security patches from Debian
  655. - texlive-2009-CVE-2010-0827.patch
  656. - texlive-2009-CVE-2010-1440.patch
  657. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  658. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  659. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  660. - fixed some dependencies
  661. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  662. - added BuildArch: noarch in %%package doc
  663. - removed some comment-out sentences
  664. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  665. - separeted texmf-dist to texlive-common package
  666. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  667. - unpacked texlive-20091107-source.tar.xz
  668. - babel is available now
  669. - applied eptex-100420 and some patches:
  670. - eptex-100420-vine.patch
  671. - eptex-100420-patch1.diff
  672. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  673. - updated ptexlive-20100711
  674. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  675. - customized updmap.cfg to correspond installed fonts
  676. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  677. - fixed insttexfont()
  678. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  679. - added jvf of MORISAWA basic 5 fonts
  680. - added cm-super, mathdesign in fntlst
  681. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  682. - define insttexfont() in %%install
  683. - copy almost compatible tetex-3.0
  684. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  685. - ptexlive-20090322 + TeXLive 2009
  686. - added BuildRequires: openssl-devel
  687. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  688. - ptexlive-20091009 + TeXLive 2008