ldns-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276
  1. %{?!with_python: %global with_python 1}
  2. %if %{with_python}
  3. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. %endif
  6. Summary: Lowlevel DNS(SEC) library with API
  7. Name: ldns
  8. Version: 1.6.4
  9. Release: 2%{?dist}
  10. License: BSD
  11. Url: http://www.nlnetlabs.nl/%{name}/
  12. Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
  13. Group: System Environment/Libraries
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  15. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  16. BuildRequires: perl, libpcap-devel, openssl-devel
  17. Patch1: ldns-installfix-r3167.patch
  18. Patch2: ldns-rpathfix.patch
  19. %if %{with_python}
  20. BuildRequires: python-devel, swig
  21. %endif
  22. %description
  23. ldns is a library with the aim to simplify DNS programing in C. All
  24. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  25. level API which allows a programmer to (for instance) create or sign
  26. packets.
  27. %package devel
  28. Summary: Development package that includes the ldns header files
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The devel package contains the ldns library and the include files
  33. %if %{with_python}
  34. %package python
  35. Summary: Python extensions for ldns
  36. Group: Applications/System
  37. Requires: %{name} = %{version}-%{release}
  38. %description python
  39. Python extensions for ldns
  40. %endif
  41. %prep
  42. %setup -q
  43. %patch1
  44. %patch2
  45. # To built svn snapshots
  46. rm config.guess config.sub ltmain.sh
  47. aclocal
  48. libtoolize -c --install
  49. autoreconf --install
  50. %build
  51. %configure --disable-rpath --disable-static --with-sha2 \
  52. %if %{with_python}
  53. --with-pyldns
  54. %endif
  55. (cd drill ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
  56. (cd examples ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
  57. make %{?_smp_mflags}
  58. ( cd drill ; make %{?_smp_mflags} )
  59. ( cd examples ; make %{?_smp_mflags} )
  60. make %{?_smp_mflags} doc
  61. %install
  62. rm -rf %{buildroot}
  63. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  64. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  65. %if %{with_python}
  66. # remove execute perms from python files
  67. chmod a-x %{buildroot}%{python_sitelib}/*py
  68. %endif
  69. # don't package building script in doc
  70. rm doc/doxyparse.pl
  71. #remove doc stubs
  72. rm -rf doc/.svn
  73. #remove double set of man pages
  74. rm -rf doc/man
  75. # remove .la files
  76. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
  77. (cd drill ; make DESTDIR=%{buildroot} install)
  78. (cd examples; make DESTDIR=%{buildroot} install)
  79. %clean
  80. rm -rf %{buildroot}
  81. %files
  82. %defattr(-,root,root)
  83. %{_libdir}/libldns*so.*
  84. %{_bindir}/drill
  85. %{_bindir}/ldnsd
  86. #%{_bindir}/ldns-*
  87. %{_bindir}/ldns-chaos
  88. %{_bindir}/ldns-compare-zones
  89. %{_bindir}/ldns-[d-z]*
  90. %doc README LICENSE
  91. %{_mandir}/*/*
  92. %files devel
  93. %defattr(-,root,root,-)
  94. %{_libdir}/libldns*so
  95. %{_bindir}/ldns-config
  96. %dir %{_includedir}/ldns
  97. %{_includedir}/ldns/*.h
  98. %doc doc Changelog README
  99. %if %{with_python}
  100. %files python
  101. %defattr(-,root,root)
  102. %{python_sitelib}/*
  103. %endif
  104. %post -p /sbin/ldconfig
  105. %postun -p /sbin/ldconfig
  106. %changelog
  107. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  108. - Fix missing _ldns.so causing ldns-python to not work
  109. - Patch for installing ldns-python files
  110. - Patch for rpath in ldns-python
  111. - Don't install .a file for ldns-python
  112. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  113. - Upgraded to 1.6.4.
  114. - Added ldns-python sub package
  115. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  116. - Upgraded to 1.6.3, which has minor bugfixes
  117. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  118. - Upgraded to 1.6.2. This fixes various bugs.
  119. (upstream released mostly to default with sha2 for the imminent
  120. signed root, but we already enabled that in our builds)
  121. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  122. - rebuilt with new openssl
  123. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  124. - Added openssl dependancy back in, since we get more functionality
  125. when using openssl. Especially in 'drill'.
  126. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  127. - Updated to 1.6.1
  128. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  130. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  131. - Fixed the ssl patch so it can now compile --without-ssl
  132. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  133. - Added patch to compile with --without-ssl
  134. - Removed openssl dependancies
  135. - Recompiled with --without-ssl
  136. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  137. - Updated to 1.6.0
  138. - (did not yet compile with --without-ssl due to compile failures)
  139. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  140. - Updated to 1.6.0
  141. - Compile without openssl
  142. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  143. - Memory management bug when generating a sha256 key, see:
  144. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  145. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  147. * Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  148. - Updated to new version, 1.5.0 had a bug preventing
  149. zone signing.
  150. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  151. - Updated to new version
  152. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  153. - fixed configure flags
  154. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  155. - rebuild with new openssl
  156. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  157. - Updated to 1.4.0
  158. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  159. - enable SHA2 functionality
  160. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  161. - re-tag (don't do builds while renaming local repo dirs)
  162. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  163. - Updated to latest release
  164. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  165. - Autorebuild for GCC 4.3
  166. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  167. - Rebuild for new libcrypto
  168. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  169. - Upgraded to 1.2.2. Removed no longer needed race workaround
  170. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  171. - Try to fix racing ln -s statements in parallel builds
  172. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  173. - Added patch for ldns-read-zone that does not put @. in RRDATA
  174. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  175. - Use install -p to work around multilib conflicts for .h files
  176. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  177. - Updated to 1.2.1
  178. - Removed patches that got moved into upstream
  179. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  180. - Patch for ldns-key2ds to write to stdout
  181. - Again remove extra set of man pages from doc
  182. - own /usr/include/ldns (bug 233858)
  183. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  184. - Added sha256 DS record patch to ldns-key2ds
  185. - Minor tweaks for proper doc/man page installation.
  186. - Workaround for parallel builds
  187. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  188. - Own the /usr/include/ldns directory (bug #233858)
  189. - Removed obsoleted patch
  190. - Remove files form previous libtool run accidentally packages by upstream
  191. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  192. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  193. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  194. - Fixed changelog typo in date
  195. - Rebuild requested for PT_GNU_HASH support from gcc
  196. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  197. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  198. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  199. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  200. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  201. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  202. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  203. * Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  204. - added a make clean for 2.3.3 since .o files were left behind upstream,
  205. causing failure on ppc platform
  206. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  207. - minor cleanups
  208. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  209. - reworked for svn version
  210. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  211. - Initial version